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Copyright and Trademark Information
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All other trademarks are the property of their respective owners.
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available. NCR Voyix, therefore, reserves the right to change specifications without prior notice.
Not all features, functions and operations described herein are available in all parts of the world. In some 
instances, photographs are of equipment prototypes; therefore, before using this document, consult with your 
NCR Voyix representative or NCR Voyix office for the most current information.
© 2024 NCR Voyix
Atlanta
Georgia
USA
www.ncrvoyix.com
All Rights Reserved
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About Virtual Kitchen 

A virtual kitchen is a delivery only concept operating within the store front of the ‘host’ restaurant and 
partners with aggregators to deliver their product to their consumers. The solution has become 
increasingly popular in the restaurant industry due to the low cost of not operating a Front-of-House 
and maintaining a minimal overhead to increase the profit margin for the virtual kitchen to be 
successful. 

While some variations of a virtual kitchen describe the host restaurant allowing an area of their 
kitchen for use to an outside entrepreneur, this guide focuses on the host restaurant and the virtual 
kitchen being in the same company and sharing the same database of items. Companies of this kind 
develop and bring different concepts or brands to market, but use a limited menu. 

For example, a company called ‘Aloha Cafe.’ offers a wide variety of food categories, but also 
markets their Mexican items for delivery only under a different brand name called ‘TexMex.’ Although 
the two restaurants operate from the same physical location, the consumer has the perception they 
are two separate restaurants. 

Partnering with delivery aggregators is essential for the virtual kitchen as they provide the service of 
delivering the food to the consumer. Established aggregators may also design the website from 
which the consumer places an online order as a service. 

The Aloha® solution uses several NCR Voyix products and applications to support virtual kitchens. 
When the order is placed, it is submitted to Business Services Layer (BSL), and then injected into 
Aloha Takeout (ATO), and then to Aloha Kitchen (AK).  

Virtual Kitchen at a Glance

Core Product Aloha Takeout, Aloha Kitchen, Aloha POS

Complementary Products

Separate License Required? No

Other References Aloha Takeout and Aloha Kitchen Integration Guide, Aloha Takeout 
Implementation Guide, Aloha Takeout Reference Guide, Aloha Kitchen 
Reference Guide, Aloha Kitchen Implementation Guide

Important
Virtual Kitchen requires CFC v21.10+. If you are already provisioned to use BSL, the options for 
configuring concepts appear in Aloha Configuration Center. You can continue with the Virtual 
Kitchen configuration. If you are not already provisioned to use BSL, contact your NCR Voyix 
representative and initiate the BSL provisioning process to obtain the required credentials. .



 Virtual Kitchen
Configuring Virtual Kitchen

5

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Configuring Virtual Kitchen
This section details the configuration requirements within Aloha Configuration Center (CFC), Aloha 
Kitchen, and Aloha Takeout. If you are an experienced user, refer to Procedures at a Glance for 
abbreviated steps. If you prefer more detail, continue reading this document. 

Virtual Kitchen Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Select Maintenance > System Settings > Concepts to create a concept for each virtual and host 
kitchen. See page 6. 

2. Select Maintenance > System Settings > Revenue Centers to create a revenue center for each 
concept/aggregator combination. See page 7. 

3. Select Maintenance > Takeout Configuration > Takeout Settings > Panel Options tab and add 
the Aggregator column to the Pickup and All Orders panels. See page 8. 

4. Select Maintenance > Kitchen Configuration > Header and Footer Layout > Design tab and 
add the Aggregator element to a header and footer. See page 10. 

5. Select Maintenance > Kitchen Configuration > Label Design > Design tab and add the 
Aggregator element to a label. See page 11. 

6. Select Maintenance > Hardware > Print Designer Configuration > Print Designer and add the 
Aggregator element to a ‘Production chit’ or ‘Order taker chit’ design. See page 12. 

7. Select Utilities > Refresh POS Data and All Installed Products to refresh data. See page 13. 
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Configuring virtual kitchen concepts
Use the Concepts applet to represent different brands under the same company. For a virtual kitchen 
solution, add a concept for the host restaurant and each virtual kitchen in use. You then associate 
each concept with a revenue center in the Revenue Center function. 

To configure virtual kitchen concepts:

1. Select Maintenance > System Settings > Concepts. 

2. Click New. 
3. Under the ‘Settings’ group bar, type a name for the concept. 
4. Click Save. 
5. Repeat this procedure for each concept in the restaurant. 
6. Click Close to exit the Concepts function. 

Tip
Do not use the existing Concept (with a singular name) function. For this solution, always use the 
Concepts (with a plural name) function. 

Figure 1  Concepts Function
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Configuring revenue centers for use with virtual kitchen 
Create a revenue center for each concept/aggregator combination the virtual kitchen uses. Name the 
revenue center based on the combination, such as ‘TexMex-Take It Away,’ where Take it Away is the 
name of the aggregator. The system uses the name you assign the revenue center to represent the 
aggregator elements you configure in Aloha Takeout and Aloha Kitchen.

To configure a revenue center for use with virtual kitchen: 

1. Select Maintenance > System Settings > Revenue Centers.
2. Click New. 

3. Under the ‘Settings’ group bar, type a name for the revenue center that describes the 
combination of the concept and the aggregator. 

4. Select the concept you created in the previous procedure from the ‘Concept’ drop-down list. 
5. Configure the remaining options as you would for any other revenue center. 
6. Click Save. 
7. Repeat this procedure for each revenue center requiring a concept/aggregator combination. 
8. Click Close to exit the Revenue Center function. 

Figure 2  Revenue Center Function
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Configuring concept and aggregator columns to appear on Aloha Takeout panels
To allow ATO employees to sort delivery orders by the aggregator or concept, add the Aggregator 
Column to the Pickup and All Orders panels in Aloha Takeout. This enables ‘Concept’ and 
‘Aggregator’ columns to appear. 

To configure an aggregator column to appear on Aloha Takeout panels:

1. With ATO selected in the product panel, select Maintenance > Takeout Configuration > 
Takeout Settings. 

2. Select the Panel Options tab. 
3. Select the Pickup > Columns tab. 

4. Under the ‘Columns’ group bar, click the Add drop-down arrow, select Aggregator Column 
from the list that appears, and click OK. 

Figure 3  Takeout Settings - Panel Options Tab - Pickup Tab
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5. Select the All Orders > Columns tab. 

6. Under the ‘Columns’ group bar, click the Add drop-down arrow, select Aggregator Column 
from the list that appears, and click OK. 

7. Click Save and exit the Takeout Settings function. 

Figure 4  Takeout Settings - Panel Options Tab - All Orders Tab
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Configuring the concept and aggregator to appear in a header and footer layout
Add the Aggregator element to a header or footer layout in Aloha Kitchen to allow the kitchen 
employee to identify orders needed for delivery by the aggregator. Both the concept and aggregator 
appears in the header or footer of the video cell depending on the one you select. 

To configure the concept and aggregator to appear in a header and footer layout:

1. With AK selected in the product panel, select Maintenance > Kitchen Configuration > 
Header and Footer Layout. 

2. Select a layout from the drop-down list. 
3. Select the Design tab. 

4. Under the ‘Elements’ group bar, click the Add drop-down arrow, select Aggregator from the list 
that appears, and click OK. 

5. Click Save. 
6. Repeat this procedure for other header and footer layouts requiring the Aggregator element. 
7. Click Close to exit the Header and Footer Layout function. 

Figure 5  Header and Footer Layout - Design Tab
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Configuring the concept and aggregator to print on a label
Add the Aggregator element to a label in Aloha Kitchen to print a label to attach to the bag so the 
aggregator can easily identify and pick up for delivery. Both the concept and aggregator prints on the 
label. 

To configure the concept and aggregator to print on a label:

1. With AK selected in the product panel, select Maintenance > Kitchen Configuration > Label 
Layout. 

2. Select a label layout from the drop-down list. 
3. Select the Design tab.  

4. Under the ‘Layout Elements’ group bar, click the Add drop-down arrow, select Aggregator from 
the list that appears, and click OK. 

5. Click the Move Up and Move Down controls to move the element in the label layout. 
6. Click Save. 
7. Repeat this procedure for any other label layout requiring the Aggregator element. 
8. Click Close to exit the Label Layout function. 

Figure 6  Label Layout - Design Tab
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Configuring the concept and aggregator to print on a kitchen chit
Add the Aggregator element to a production or order taker chit in Aloha Kitchen to print the concept 
and aggregator on the kitchen chit. This enables the kitchen employee to easily identify which orders 
are for delivery. Some restaurants attach the printed kitchen chit on the bag for identification. Both 
the concept and aggregator print on the kitchen chit. 

To configure the concept and aggregator to print on a kitchen chit:

1. With AK selected in the product panel, select Maintenance > Hardware > Print Designer 
Configuration > Print Designer. 

2. Select a production chit or order taker chit layout from the drop-down list. 
3. Select the Design tab. 

4. Under the ‘Design’ group bar, click the Add drop-down arrow, select Aggregator from the list 
that appears, and click OK. 

5. Click Save. 
6. Repeat this procedure for any other print layout requiring the Aggregator element. 
7. Click Close to exit the Label Layout function. 

Figure 7  Print Designer - Design Tab
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Refreshing the data
After all settings are in place in Aloha Manager, you must select Utilities > POS > Refresh POS and 
All Installed Products to transfer the new information to the Front-of-House (FOH) terminals, or wait for 
the End-of-Day (EOD) process to accomplish the data refresh for you. If you run the refresh prior to 
the EOD process, select ‘Automatically restart all POS terminals’ and click OK to continue. After the 
data refresh is complete, all new settings become operational across the Aloha network. 

Caution
Refresh data with caution and never during peak hours of operation. All FOH terminals reboot 
during a refresh and are down for a short period of time.
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Using Virtual Kitchen
When the consumer accesses the ordering website of the virtual kitchen concept and places an 
online order for delivery, the order is submitted into the Order Service API of the Business Services 
Layer (BSL) cloud application. It is then injected into the in-store instance of Aloha Takeout and placed 
in the queue on the ATO Front-of-House. 

The Concept and Aggregator columns appear on the Pickup and All Orders panels so the ATO 
employee can sort orders by aggregator and concept, if necessary. 

Figure 8  Concept and Aggregator Columns on Pick Up Panel in Aloha Takeout
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ATO releases the order based on the promise time, and sends it to Aloha Kitchen. The order appears 
on the video screen with the name of the concept and aggregator in the header or footer of the video 
cell. 

The virtual kitchen employee prepares the order and bumps it from the video screen, The concept 
and aggregator print on the kitchen chit and kitchen label, if in use. The employee packages the 
order, attaches the necessary artifacts to the bag, and places the order in a designated location. 

During this process, the delivery driver is notified of the order submission, the address of the 
consumer, and the time at which the order is ready for pickup. Upon the arrival at the restaurant 
hosting the virtual kitchen concept, the delivery driver identifies the order from the designated 
location and delivers it to the consumer. 

Figure 9  Concept and Aggregator on Video Cell
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Reporting Virtual Kitchen
The concept and aggregator elements write to Trans.log as a check attribute, and report in the 
following files: 

● Gnd.dbf
● GndSale.dbf
● GndItem.dbf
● GndRev.dbf



© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Virtual Kitchen, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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