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Revision Record

Date Version # Description

Prior to 
06/03/2021

v1.0+ Introduced the Source and Destination feature available from the BOH 
Radiant.Hospitality.AlohaToGo.Configuration.UI utility.

CFC/AM 
v19.1+

Migrated the Source and Destination feature to Aloha Configuration Center 
and Aloha Manager.

v19.x Added the requirement to define a Source and Destination record to 
address all order sources leveraged by an online ordering solution, 
such as a store website and a delivery marketplace. This enables the 
online ordering solution to inject orders into ATO. If this record 
does not exist, order injection fails. See “Appendix A: Configuring 
Source and Destination for online ordering injection only” on page 18.

06/03/2021 Converted the document to use new templates.

01/06/2023 Updated the front cover and back page to reflect new NCR branding.

12/20/2023 Updated document to reflect NCR Voyix branding.
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About Source and Destination  

In the current world of hospitality, there are many different options for placing and receiving orders, 
from calling the order in, placing the order using an app on your phone, logging in and placing an 
order through a web site, speaking directly to an employee at the counter, and using a delivery 
marketplace to act as an intermediary between you and the restaurant.

There are also many options for how you receive an order. You can elect to pick up your order, dine 
in at the restaurant, have the order delivered to your address, and more. You can even have them 
bring the order out to your car, such as in a car-hop environment.

The Source and Destination feature in Aloha® Takeout (ATO) assists you in tracking how consumers 
submit and receive orders. When it comes to performance metrics, this is valuable data you can use 
to evaluate staffing needs, identify areas of the restaurant that are not profitable, and reconcile 
payments from delivery partners. Order source refers to how an order is placed, and order 
destination refers to how an order is received. When configured, the system prompts the ATO 

Source and Destination at a Glance

Core Product Aloha Takeout

Complementary Products

Separate License Required? No

Other References Aloha Takeout Implementation Guide

Figure 1  Source and Destination Screen
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employee to specify from which source the order originated and to which destination the consumer 
will receive the order. The restaurant can then run a Source and Destination report.  

The Source and Destination feature was available for configuration in the BOH 
Radiant.Hospitality.AlohaToGo.Configuration.UI prior to the migration of ATO into Aloha 
Configuration Center (CFC) and Aloha Manager (AM). You can now configure the Source and 
Destination feature using CFC or AM v19.1. Moving the configuration of Source and Destination to 
CFC/AM eliminates the need to perform extra steps to save and refresh data from the 
Radiant.Hospitality.AlohaToGo.Configuration.UI utility.  

Important:  As of ATO v19.x, you must define a Source and Destination record to address all order 
sources leveraged by an online ordering solution, such as a store website and a delivery market-
place. This enables the online ordering solution to inject orders into ATO. If this record does not 
exist, order injection fails. See “Appendix A: Configuring Source and Destination for online order-
ing injection only” on page 18.

Tip:  This document provides instructions for how to implement the Source and Destination feature 
within the configuration management tool. If you are not on a supported version of the configuration 
management tool, you must use the Radiant.Hospitality.AlohaToGo.Configuration.UI utility.
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Configuring Source and Destination
This section details the configuration requirements within Aloha Manager and Aloha Configuration 
Center (CFC) for Source and Destination. If you are an experienced user, refer to Procedures at a 
Glance for abbreviated steps. If you prefer more detail, continue reading this document. 

Enabling the Source and Destination feature
When you enable the Source and Destination feature, you also determine whether to prompt the ATO 
employee for the source and destination for every order mode or just for specific order modes. For 
example, you many want to prompt for an order source for a delivery order because it could originate 
from one of many delivery aggregators, but it may not make sense to prompt for an order source for 
a call-in order because a call-in order is always submitted by a phone call. If you select ‘Always 
prompt for source’ or ‘Always prompt for destination,’ the system always displays a prompt regardless 
of the selections made under the Order Modes group bar. 

Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Access Maintenance > Takeout Configuration > Source and Destination and enable the Source 
and Destination feature (page 6), add sources, (page 8), add destinations (page 8), and associate 
each source and destination with an order mode (page 9). 

2. Access Maintenance > Takeout Configuration > Takeout Settings > Panel Options and add 
Source and Destination action buttons to either the Dispatch List or Orders screen to allow you to 
change a source and destination, when needed. See page 10.

3. To easily view source and destination entries, access Maintenance > Takeout Configuration > 
Takeout Settings > Panel Options and add a Source and a Destination column to either the Pickup 
or Orders screen. See page 12

4. If you integrate Aloha Takeout and Aloha Kitchen, to display the source and destination on a video 
cell, access Maintenance > Kitchen Configuration > Header and Footer Layout and add ‘ATO 
order source’ and ‘ATO order destination’ to a header or footer layout. See page 13. 

5. Access Utilities > POS > Refresh POS & All Installed Products to update the information on the 
FOH terminals, or wait for the End-of-Day (EOD) process to accomplish the data refresh for you. See 
page 14. 

Note:  Aloha Takeout has preset order modes to which you align POS order modes in Maintenance 
> Takeout Configuration > Takeout Settings > Order Modes tab.
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To enable the Source and Destination feature: 

1. With Takeout selected in the product panel, select Maintenance > Takeout Configuration > 
Source and Destination. 

2. Select the Settings tab. 
3. Click New to create a new record. 

4. Under the ‘General Settings’ group bar, select Enable source and destination tracking to 
activate the Source and Destination feature and enable all options under the ‘General Settings’ 
tab.

5. Select Always prompt for source to prompt you for the source (how the order originated) every 
time you start a new order, regardless of the order mode.

6. Select Always prompt for destination to prompt for the destination (how the guest is to receive 
the order), every time you enter a new order, regardless of the order mode.

7. Select Commit on source and destination selection to enable you to select a source and 
destination without the need to touch OK to proceed. 

8. Under the ‘Order Modes’ group bar, select Always prompt for source to prompt for the source 
(how the order originated) only when you enter a new order for this order mode. 

9. Select Always prompt for destination to prompt for the destination (how the guest is to receive 
the order) only when you enter a new order for this order mode. 

10. Continue to the next procedure. 

Figure 2  Source and Destination - Settings Tab
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Adding order sources
You must add each order source required for indicating from where an order originates. If the order 
source you need is not available, you can add up to 20 custom order sources. For example, if you 
use a new delivery partner that is not in the list, enter the partner as a custom order source. 

To make order sources active:

1. Continuing from the previous procedure, select the Sources tab. 

2. Under the ‘Active Sources’ group bar, click the Add drop-down arrow, select an order source, 
and click OK. A new row appears. 

3. If needed, type a name to appear on the ATO FOH for the selected order source in ‘Display 
name.’ Typically, you keep the same name of the order source; however, if you are adding a 
custom order source that is not defined in Aloha Takeout, change the name to reflect the name of 
the order source. 

4. If needed, type a name to appear in the API call for the selected order source in ‘External name.’ 
Typically, this column is for an API user and used by external applications. 

5. Repeat steps 2 through 4 for any other order source you want to add. 
6. Continue to the next procedure. 

Adding destinations
You must add each destination required for indicating the supported methods by which you allow 
consumers to receive orders. If the destination you need is not available, you can add up to 20 
custom destinations. 

Figure 3  Source and Destination - Sources Tab
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To make order destinations active:

1. Continuing from the previous procedure, select the Destinations tab. 

2. Under the ‘Active Destinations’ group bar, click the New drop-down arrow, select a destination 
from the list, and click OK. A new row appears. 

3. If needed, type a name to appear on the ATO FOH for the selected destination in ‘Display name.’ 
Typically, you keep the same name of the destination; however, if you are adding a custom 
destination that is not defined in Aloha Takeout, change the name to reflect the name of the 
destination. 

4. If needed, type a name to appear in the API call for the selected destination in ‘External name.’ 
Typically, this column is for an API user and used by external applications. 

5. Repeat steps 2 through 4 for any other destination you want to add. 
6. Continue to the next procedure. 

Associating each source and destination with an order mode
On the Matrix tab, you associate each source and destination with an order mode. A single order 
mode may have one or more sources or destinations and you must have a default source and 
destination defined. 

Figure 4  Source and Destination - Destinations Tab
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To associate each source and destination with an order mode:

1. Continuing from the previous procedure, select the Matrix tab. 

2. Under the ‘Matrix’ group bar, click Add. A new row appears for edit. 
3. Select an order mode from the ‘Order Mode’ drop-down list. 
4. Select an order source from the ‘Source’ drop-down list. 
5. Select Default Source if this is the default source selection for the selected order mode. 
6. Select a destination from the ‘Destination’ drop-down list. 
7. Select Default Destination if this is the default destination for the selected order mode. 
8. Repeat steps 2 through 7 for each association to include in the matrix. 
9. Click Save and exit the Source and Destination function. 

Configuring the ability to change a source or destination
Sometimes it may be necessary to change the selected source or destination for an order. For 
example, you may have an order mode configured to not prompt for a source or destination during 
the initial entry, or you entered a wrong source or destination. To allow you to change a source or 
destination, add the Change Source and Change Destination action buttons to one or all of the 
following screens: Dispatch, Dispatch List, and Orders. 

Figure 5  Source and Destination - Matrix Tab
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To configure the ability to change a source or destination:

1. With Takeout selected in the product panel, select Maintenance > Takeout Configuration > 
Takeout Settings > Panel Options. 

2. Select the Dispatch > Actions tab or Dispatch List > Actions tab or All Orders > Actions tab. 
3. Click the Add drop-down arrow, select Change Source or Change Destination, and click OK. 

4. Click Move Up and Move Down to arrange the location of the action button to fit your needs. 
5. Repeat this procedure to add the Change Source or Change Destination action buttons to 

another screen. 
6. Continue to the next procedure. 

Figure 6  Panel Options - Dispatch List Tab - Actions Tab
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Configuring the source and destination to appear in ATO
You can add a Source column and Destination column on the FOH Pickup and the FOH Orders 
screen. This allows the ATO employee, such as a bagger, to easily see from which source the order 
originated and from which destination the consumer receives the order. 

To configure Source and Destination columns to appear in ATO: 

1. With Takeout selected in the product panel, select Maintenance > Takeout Configuration > 
Takeout Settings > Panel Options. 

2. Select the Pickup > Columns tab or All Orders > Columns tab. 

3. Click the Add drop-down arrow, select Source Column or Destination Column, and click OK. 
4. Click Move Up and Move Down to arrange the location of the column to fit your needs. 

Figure 7  FOH Order Screen - Source Column

Figure 8  Panel Options - Pickup Tab - Columns Tab
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5. Repeat this procedure to add the source and designation columns to another screen. 
6. Continue to the next procedure. 

Configuring the source and destination to appear in AK
When you integrate Aloha Takeout and Aloha Kitchen (AK), you can configure the source and 
destination to appear on the video cell in AK. You may use this to allow the kitchen staff to prioritize 
orders for delivery partners. 

To configure the source and destination to appear in AK:

1. With Aloha Kitchen selected in the product panel, select Maintenance > Kitchen 
Configuration > Header and Footer Layout. 

2. Select the layout on which to add the element from the drop-down list. 
3. Select the Design tab. 

4. Click the Add drop-down arrow, select ATO order source and click OK. 
5. Click the Add drop-down arrow, select ATO order destination, and click OK. 
6. Configure the line number, location, and style for the ‘ATO order source’ and ‘ATO order 

destination’ elements. 
7. Click Save. 

Reference:  You must integrate Aloha Takeout and Aloha Kitchen to configure the source and des-
tination to appear in AK. Otherwise, no value appears in Aloha Kitchen. You must also use Aloha 
Takeout v15.2, or later, and Aloha Kitchen v16.1, or later, to use this feature. Refer to the Aloha 
Takeout and Aloha Kitchen Integration Guide for information on integrating the two products.

Figure 9  Header and Footer Layout - Design Tab
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8. Repeat this procedure for other layouts for which you need to add the ‘ATO order source’ and 
‘ATO order destination’ elements. 

9. Exit the Header and Footer Layout function. 

Refreshing data
After all settings are in place in Aloha Manager, you must select Utilities > POS > Refresh POS & All 
Installed Products to transfer the new information to the FOH terminals, or you can wait for the the 
End-of-Day (EOD) process to refresh the data for you. If you refresh the data prior to the EOD 
process, select ‘Automatically restart all POS terminals’ and click OK to continue. After the data 
refresh operation completes, all new settings become operational across the Aloha network. 

Caution:  Refresh data with caution and never during peak hours of operation. All FOH ter-
minals reboot during a refresh and are down for a short period of time. 
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Using ATO Source and Destination
Depending on the order modes you configure to require a source and destination selection, the 
Select Source/Destination screen appears when you start a new order. 

1. Start an Aloha Takeout order for an order mode for which you require the selection of an order 
source or destination. The Select Source/Destination screen appears.  

2. Touch the order source from which the order originated, if available. 
3. Touch the destination for how the consumer will receive the order, if available. 
4. Touch OK to dismiss the screen, if required. The system may automatically dismiss the screen 

when you select an order source or destination. 
5. Complete the Aloha Takeout order, as normal. 

If you need to change the source or destination, touch the Change Source or Change Destination 
button from either the Dispatch, Dispatch List, or Order screen. The Select Source/Destination screen 
appears (Figure 10). Follow the same procedure for selecting a source or destination with a new 
order to override the previously selected order source or destination. 

Tip:  This section is not applicable to using the Source and Destination feature for an online order-
ing solution only. 

Figure 10  Select Source/Destination Screen



 Source and Destination
Reporting ATO Source and Destination

16

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Reporting ATO Source and Destination
At the time of this writing, the Source and Destination report is not available in the configuration 
management tool. Use the Radiant Report Viewer utility to run and view the report.  

Figure 11  Source and Destination Report

Column Description

Source The order source.

Destination The destination. 

Customer Name The name of the customer. 

Phone Number The phone number of the customer. 

Order Number The order number for the order. 

Total The check total of the order. 

Address The address of the customer. 

Order Mode The order mode associated with the order. 

Order State The current state of the order when the report was ran. 

Order Sub Total The check total of the order without taxes. 

Order Time The time the order was placed. 
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To run the Source and Destination report:

1. On the BOH site controller, launch Radiant.Aloha.Reports.Viewer.Tool.exe from the Aloha 
Takeout > Bin directory. The Radiant Report Viewer utility appears. 

2. Select Report > Source and Destination Reports > Source and Destination Report. 
3. Select a date range for the report. 
4. Under the ‘Sources’ section, select the sources to include in the report, or select All sources. 
5. Under the ‘Destinations’ section, select the destinations to include in the report, or select All 

destinations. 
6. Under the ‘Group Report by’ section, select either Day, Week, Month, or Year to group the 

data for the report. 
7. Select Show order detail to customize the columns to appear on the report. This option enables 

the ‘Selected report columns’ and ‘Available report columns’ sections. 
8. Select the columns in ‘Available report columns’ and click the up or down arrows to move the 

column to the ‘Selected report columns’ section. 
9. Click the Run the report command from the tool bar. The Source and Destination report 

appears. 
10. Select File > Exit to exit Radiant Report Viewer.

Time Closed The time the check was closed. 

Column Description
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Appendix A: Configuring Source and Destination for online 
ordering injection only

As of ATO v19.x, you must define a Source and Destination record to address all order sources 
leveraged by an online ordering solution, such as a store website and a delivery marketplace. This 
enables the online ordering solution to inject orders into ATO. If this record does not exist, order 
injection fails. 

This section details the configuration requirements within Aloha Manager and Aloha Configuration 
Center (CFC) for Source and Destination to address order modes leveraged by an online ordering 
solution only. If you need to configure Source and Destination for all order sources besides the ones 
leveraged by an online ordering solution, see “Configuring Source and Destination” on page 6.

Enabling the Source and Destination feature
To use Source and Destination for an online solution only, you need only to enable the feature on the 
Settings tab. 

To configure the Source and Destination feature for online solution only: 

1. With Takeout selected in the product panel, select Maintenance > Takeout Configuration > 
Source and Destination. 

2. Select the Settings tab. 
3. Click New to create a new record. 

4. Under the ‘General Settings’ group bar, select Enable source and destination tracking to 
activate the Source and Destination feature.

5. Leave all other options on the Settings tab as their default. 
6. Continue to the next procedure. 

Figure 12  Source and Destination - Settings Tab
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Adding order sources
You must add a source record for each order source from which an online order originates. In this 
example, the Web order source is selected from the Add drop-down list. If an order source you 
need, such as a new delivery partner, is not available in the drop-down list, enter the partner as a 
custom order source. 

To add an order source:

1. Continuing from the previous procedure, select the Sources tab. 

2. Click the Add drop-down arrow, select an order source, such as Web, and click OK. A new 
row appears. 

3. Under the ‘Active Sources’ group bar, leave the default value or type a name of your choice in 
‘Display name’ to indicate the type of order source, such as Web. 

4. If needed, type a name to appear in the API call for the selected order source in ‘External name.’ 
Typically, this column is for an API user and used by external applications. 

5. Repeat steps 2 through 4 for each order source you need to add. 
6. Continue to the next procedure. 

Note:  You can add up to 20 custom order sources. 

Figure 13  Source and Destination - Sources Tab
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Adding destinations
You must add a destination record for each method by which you allow consumers to receive an 
order. If the destination you need is not available in the drop-down list, enter the destination as a 
custom destination. 

To add a destination:

1. Continuing from the previous procedure, select the Destinations tab. 

2. Click the New drop-down arrow, select a destination from the list, and click OK. A new row 
appears. 

3. Under the ‘Active Destinations’ group bar, leave the Display name as the default, or type a 
display name of your choice. 

4. If needed, type a name to appear in the API call for the selected destination in ‘External name.’ 
Typically, this column is for an API user and is used by external applications. 

5. Repeat steps 2 through 4 for each destination you want to add. 
6. Continue to the next procedure. 

Note:  You can add up to 20 custom destinations. 

Figure 14  Source and Destination - Destinations Tab
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Associating each source and destination with an order mode
On the Matrix tab, you associate each source and destination with an order mode. A single order 
mode may have one or more sources or destinations, and you must have a default source and 
destination defined. 

To associate each source and destination with an order mode:

1. Continuing from the previous procedure, select the Matrix tab. 

2. Click Add. A new row appears for edit. 
3. Under the ‘Matrix’ group bar, select an order mode, such as Web, from the ‘Order Mode’ 

drop-down list. 
4. Select an order source, such as Web, from the ‘Source’ drop-down list. 
5. Select Default Source. 
6. Select a destination from the ‘Destination’ drop-down list. 
7. Select Default Destination for the most commonly used destination for this source; otherwise, 

leave this option cleared. 
8. Repeat steps 2 through 7 for each association to include in the matrix. 
9. Click Save and exit the Source and Destination function. 

Figure 15  Source and Destination - Matrix Tab
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Source and Destination, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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