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About Multi-Lane Drive-Thru 

At the time of this writing, the configuration for this enhancement is not in Aloha Configura-
tion Center or Aloha Manager. You must perform the configuration in AlohaKitchenOver-
lay.xml.

To expedite the picking up of food that was ordered outside the walls of the restaurant, such as with a 
mobile app, an online order, a third-party delivery aggregator, and more, restaurants have designed 
innovative solutions to segment customers who order onsite and pre-order online, to facilitate the 
delivery of food to customers in a timely manner. 

One such solution is a multi-lane drive-thru concept with separate, dedicated pull-up lanes for online 
orders and traditional drive-thru orders. A boom gate holds the vehicles in each lane. When an order 
is ready, the boom gate rises to let the vehicle progress to a single lane for pickup. This gives the 
restaurant more control over their drive-thru environment and ensures the vehicles align to the 
sequence of orders prepared in the kitchen. 

Multi-Lane Drive Thru  at a Glance

Core Product Aloha® Online Ordering, Aloha Takeout, Aloha Kitchen

Complementary Products

Separate License Required? No

Other References Aloha Online Ordering User Guide, Aloha Takeout and Aloha Kitchen 
Integration Guide, Aloha Takeout Implementation Guide, Aloha Takeout 
Reference Guide, Aloha Kitchen Reference Guide, Getting Started with 
Aloha Kitchen Guide, Customizing Aloha Kitchen Guide

Figure 1  Multi-Lane Drive-Thru Concept
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The solution

The solution spans across the Aloha® Online Ordering (AOO), Aloha Takeout (ATO), Aloha 
Point-of-Sale (POS), and Aloha Kitchen (AK) products, with each one playing an integral part to 
complete the implementation. For online orders, AOO generates a reference ID to represent the 
order number and passes it into ATO, which manages the sending of the order to AK. ATO and AK 
communicate with each other to send order statuses and notify the consumer when the order is ready 
for pickup. 

For traditional drive-thru orders, the order is entered directly into ATO along with a lane number to 
identify from which lane the vehicle pulls in, and in turn, determines which boom gate to raise to 
allow the vehicle to pass. Online orders also utilize lane numbers. 

Software and hardware requirements

The following are the software requirements for each product in the solution. 

● Aloha Online Ordering v18.12 or later
● Aloha Takeout v19.1.7 or later
● Aloha Kitchen v18.2 or later
● Aloha Configuration Center or Aloha Manager v19.3 or later
● Aloha POS v17.1 or later 

The following is the expected behavior for a multi-lane drive-thru environment: 

Online Ordering interaction:

1. The consumer places their order using a mobile ordering app or through Aloha Online Ordering. 
2. Upon submission and payment of the order, Aloha Online Ordering automatically generates and 

presents an order number (reference ID) to the consumer. 
3. Aloha Online Ordering passes the reference ID to Aloha Takeout.
4. During the progression of the order, the consumer receives communication regarding the status 

of the order. 

Onsite interaction:

1. The consumer arrives at the site. 

a. If the consumer pre-ordered, they select a lane designated for online orders and enter their 
order number at the kiosk device. In most cases, the lane number is pre-defined and captured 
in the Fingermark software. The vehicle is held in place by a ‘boom gate.’

Note
Fingermark supplies and installs the kiosk device and boom gate positioned at each lane. You must 
use Fingermark hardware and software and you must be in contact with Fingermark at 
http://fingermarkqsr.tech/ prior to implementing this solution.

http://fingermarkqsr.tech/
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b. If the consumer did not pre-order, they select a lane designated for traditional drive-thru 
orders and place their order at the kiosk device. The employee enters the order into ATO with 
the selected lane number. The vehicle is held in place by a ‘boom gate.’ 

2. Aloha Takeout passes the order to Aloha Kitchen. The reference ID and lane number appear in 
the header and/or footer on the video cell for visibility and verification. 

3. The production stations prepare the food and the order passes to the first expediter station for 
bagging. 

4. Upon bagging the order, the first expediter station performs a master bump which sends a 
message back to ATO with the associated lane number. 

5. ATO communicates the lane number to the Fingermark software. Fingermark then opens the 
corresponding boom gate associated with the lane. Upon release, the vehicle merges into a 
single drive-thru lane. 

6. The order passes to the second expediter. 
7. Upon reaching the pickup window, the employee delivers the food to the consumer. 
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Implementing Multi-Lane Drive-Thru in Aloha Online Ordering 
The section details the configuration requirements within Aloha Online Ordering for the multi-lane 
drive-thru solution. If you are an experienced user, refer to Procedures at a Glance for abbreviated 
steps. If you prefer more detail, continue reading this document. 

Configuring the generation of the reference ID
When placing an online order using Aloha Online Ordering, the order number is a string of random 
numbers and letters that could potentially be difficult for the consumer to retain and remember. By 
the time the consumer arrives to enter their order number at the kiosk device for a mulit-lane 
drive-thru concept, they often forget the string of numbers. To ease this pain point, the solution 
requires you to configure the system to generate a reference ID to use. 

Aloha Online Ordering automatically generates the reference ID. The number is six or more digits 
long and appears as ‘Ref ID nnnnnn,’ where nnnnnn is the order number. If an order number is not 
passed, the reference ID appears only as ‘Ref ID.’ 

In Web Admin, you must configure the ‘EnableRandomReferenceNumbers’ and 
‘PromiseTimeThresholdHours’ company settings. ‘PromiseTimeThresholdHours’ defines the number 
of hours past the promise time to allow the consumer to arrive and check in the order. 

To configure the generation of the reference ID: 

1. In Web Admin, select Configuration > Company Settings Setup.
2. Click Add Setting.

Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. In Web Admin, select Configuration > Company Settings Setup and set 
‘EnableRandomReferenceNumbers’ to True. You must also add the ‘PromiseTimeThresholdHours’ 
company setting and specify the number of hours past the promise time to allow the consumer to 
check in the order. See page 7. 

2. (Optional) If a site wants more control on the check-in process and does not want to automatically 
check in an order, select Configuration > Site Setup > Sites > Mobile Settings tab and clear 
‘Allow Check-in on Mobile App.’ See page 13.

Figure 2  EnableRandomReferenceNumbers Company Setting
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3. Type EnableRandomReferenceNumbers in ‘Setting’ and type True in ‘Value.’
4. Click Update. 
5. Click Add Setting. 

6. Type PromiseTimeThresholdHours in ‘Setting’ and type the number of hours past the promise 
time to allow the consumer to still check in the order in ‘Value.’ The default value is 0. 

7. Click Update and exit the Company Settings Setup function. 

‘EnableRandomReferenceNumbers’ generates the proper reference ID on the Calculate Tax and Total 
(CTT) call; however, you cannot override the reference ID value. Once you configure the system to 
generate the reference number, an API user can use the following calls to send the reference 
number: 

● Put v1/Orders{siteId} in Calculate Tax and Total (CTT)
● Post v1/Orders/{SiteId}/ReferenceNumber/{referenceNumber}/Checkin in Check-in Order by 

Reference Number 
● Get v1/Orders/{siteId}/ReferenceNumber/{referenceNumber} in Get Order by Reference 

Number 

Figure 3  PromiseTimeThresholdHours Company Setting
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Calculate Tax and Total (CTT) call examples

Use the following examples when making the Calculate Tax and Total (CTT) call.   

Figure 4  CTT Call Set to a Valid Number

Figure 5  CTT Call Set to a Null Value 
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Check-In Order by Reference Number request examples

Use the following examples when making the Check-In Order by Reference Number request:   

The next response example occurs only when two active orders with the same reference number are 
available during check-in. Since the system automatically generates the reference number, it is 
unlikely this will occur. To recreate this scenario, set ‘EnableRandomReferenceNumbers’ to True and 

Figure 6  Check-In Order by Reference Number Call with a Valid Reference Number

Figure 7  Check-In by Reference Number Call with Incorrect or Inactive Reference Number

Figure 8  Check-In by Reference Number with Same Reference Number Twice

Figure 9  Check-In by Reference Number when Order is Past Promise Time Threshold
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then send the CTT call. Then set ‘EnableRandomReferenceNumbers’ to False and copy and assign the 
reference number from the previous CTT response to the current CTT.  

Get Order by Reference Number examples

Use the following examples when making the Get Order by Reference Number call. When you have 
the same reference number for two different orders, where one order is active and the other is 
inactive, the call always gets the active order. For example, the same reference number was assigned 
to order number 10144 (active order) and order number 4571 (inactive order); therefore, the call 
returns order number 10144. 

Figure 10  Check-In by Reference Number with Same Number for Two Active Orders

Figure 11  Get Order by Reference Number with Duplicate Reference Number
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The following example shows the response when the reference number you enter is either inactive or 
wrong:

The following example shows the response when the Get Order by Reference Number call is 
v1/Orders/{siteId}/ReferenceNumber/12345 and the submitted reference number exists:

Figure 12  Get Order by Reference Number with Reference Number Inactive or Wrong

Figure 13  Get Order by Reference Number - Reference Number Exists
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The following example shows the response when the Get Order by Reference Number call is 
9999999 and the submitted reference number does not exist:  

Disabling mobile app check-in by site (optional)
By default, Aloha Online Ordering allows you to check in with your mobile app. If a site wants more 
control on the check-in process and does not want this functionality, you can disable the feature in 
Web Admin. You must use App version 18.9.1 or later. 

To disable mobile app check-in by site:

1. In Web Admin, select Configuration > Site Setup > Sites. 
2. Select the site for which to disable mobile app check-in and then click Edit Site. 

Figure 14  Get Order by Reference Number - Reference Number Does Not Exist

Figure 15  Site Setup - Allow Check-In on Mobile App
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3. Select the Mobile Settings tab. 
4. Clear Allow Check-In on Mobile App to disable this feature for this site. This option is selected 

by default. 
5. Click Update. 
6. Repeat this procedure for any other site for which to disable check-in using a mobile app. 
7. Exit the Site Setup function. 

For an API user, you can use the following calls to send the ‘Allow Check-In on Mobile App’ 
configuration in an API call. 

● Get Site (shown)
● Get Site by External Id
● Get Full Sites by Search Term
● Get Nearby Sites by Search Term
● Get Nearby Sites by Coordinates 

Figure 16  Allow Check-In on Mobile App Set to True
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Implementing Multi-Lane Drive-Thru in Aloha Takeout 
This section details the configuration requirements for implementing the multi-lane drive-thru solution 
in Aloha Takeout. If you are an experienced user, refer to Procedures at a Glance for abbreviated 
steps. If you prefer more detail, continue reading this section. 

Enabling kitchen integration in ATO
You must enable kitchen integration in Aloha Takeout to pass the required information to Aloha 
Kitchen and back. If you do not enable kitchen integration, the two products do not communicate with 
each other. 

To enable kitchen integration in ATO:

1. With Takeout selected in the product panel, select Maintenance > Aloha Takeout 
Configuration > Takeout Settings > Options tab. 

2. Select the Settings tab. 
3. Under the ‘Kitchen integration’ group bar, select Enable Kitchen Interface. 
4. Click Save and exit the Takeout Settings function. 

Defining the available lanes for each order mode
A lane represents a designated spot or area at the site used for a variety of reasons. For this solution, 
it is where a vehicle pulls up to enter their order number or order at a kiosk device. The order point 
for a traditional drive-thru is also considered a lane. 

You must define each lane you support in ATO and associate it with an order mode. This allows the 
employee to select the correct lane for each order for Fingermark to read. You can also configure if 
the selection of a lane is required or optional, per order mode, as well as if you want to assign a 
default lane designation. 

Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Enable kitchen integration in ATO to allow Aloha Takeout and Aloha Kitchen to communicate with 
each other. See page 15. 

2. Define the available lanes for each order mode. See page 15. 

3. Configure the system to bypass the ATO confirmation screen for lane assignment. See page 18.

4. Configure the ability to change the lane number. See page 19. 
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To define the available lanes: 

1. With Takeout selected in the product panel, select Maintenance > Takeout Configuration > 
Check-In Locations. 

2. Click New. 
3. Type a name for the lane, such as ‘Lane 1’ or ‘Lane A.’ 
4. Click Save. 
5. Repeat this procedure for each lane you support. 
6. Exit the Check-In Locations function. 

Once you configure your lanes, you associate them with an order mode. 

Figure 17  Check-I+n Locations
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To associate a lane with an order mode location: 

1. With Takeout selected in the product panel, select Maintenance > Takeout Configuration > 
Order Mode Locations. 

2. Click the New drop-down arrow, select an order mode from the ‘Select Order Mode Type’ list 
box, and click OK. 

3. Under the ‘Settings’ group bar, select Selection required to require the assignment of a lane for 
each order applied to this order mode. 

4. Under the ‘Check-in Location Assignments’ group bar, select a lane location created in the 
previous procedure from the ‘Available’ list and click >> to move the lane location to the 
‘Included’ list. 

5. Under the ‘Included’ group bar, optionally select Default to make the lane location the default for 
the selected order mode. Note: You can have only one default lane location for each order 
mode. 

6. If you have more than one lane location for the selected order mode, repeat steps 4 and 5. 
7. Click Save. 
8. Repeat this procedure to associate other lane locations with other order modes. 
9. Exit the Order Mode Locations function. 

Figure 18  Order Mode Locations
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Bypassing the ATO confirmation screen for lane assignment
In normal ATO operations, the order confirmation screen appears to allow the employee to review the 
order, promise time, and contact information, before finalizing the order and sending it to the 
kitchen. You can also press the Lane button from this screen to display the lane selection screen 
where you assign the lane from which a consumer pulled in. 

You can streamline this process by navigating directly to the lane selection screen, bypassing the 
order confirmation screen where you assign the lane and finalize the order. 

To bypass the ATO confirmation screen for lane assignment: 

1. With Takeout selected in the product panel, select Maintenance > Takeout Configuration > 
Takeout Settings. 

2. Select the Order Modes tab. 
3. Under the ‘Order Modes’ group bar, select the order mode for which you want to bypass the 

ATO confirmation screen. 
4. Select the Order Modes Properties tab. 

5. Under the ‘Settings’ group bar, select Use quick location selection. 
6. Click Save. 
7. Repeat this procedure for each order mode for which you want to bypass the ATO confirmation 

screen. 
8. Continue to the next procedure. 

Figure 19  Takeout Settings - Order Modes Tab
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Configuring the ability to change the lane location 
If an employee needs to change a lane designation after one has been assigned, you can add an Edit 
Location action button to the Pickup and All Orders screens. The action button displays the lane 
selection screen from which you can choose a different lane. 

To configure the ability to change the lane location: 

1. With Takeout selected in the product panel, select Maintenance > Takeout Configuration > 
Takeout Settings. 

2. Select the Panel Options > Pickup tab. 
3. Select the Actions tab. 
4. Under the ‘Actions’ group bar, click the Add drop-down arrow, select Edit Location, and click 

OK. The button is added to the list of actions. 

5. Click Move Up or Move Down to position the button in the order to appear on the Pickup 
screen. 

6. Click Save. 
7. Repeat this procedure to add the Edit Location button to the All Orders screen. 
8. Exit the Takeout Settings function. 

Figure 20  Edit Location Action Button
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Implementing Multi-Lane Drive-Thru in Aloha Kitchen 
This section details the configuration requirements for the multi-lane drive-thru solution in Aloha 
Kitchen. If you are an experienced user, refer to Procedures at a Glance for abbreviated steps. If you 
prefer more detail, continue reading this document.  

Adding reference ID and lane number to header/footer of video cell
To allow visibility to the reference ID and lane number, you can add these elements to a header or 
footer of a video cell in use. 

To add the reference ID and lane number to the header or footer of the video cell: 

1. Locate and open AlohaKitchenOverlay.xml. 
2. Type the following syntax. 

<AlohaKitchenOverlay>
...
<HeaderFooterLayoutElement>
<CellHeaderFooterLayoutId>1</CellHeaderFooterLayoutId>
<ElementId>1</ElementId>
<ElementType>67</ElementType>
...
</HeaderFooterLayoutElement>
...
</AlohaKitchenOverlay> 

3. Save and exit AlohaKitchenOverlay.xml.

Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Add reference ID and lane number on header/footer of video cell. See page 20

2. Customize the font and size of the reference ID and lane identifier (Optional). See page 21. 

3. Configure the reference ID and lane identifier to print on the chit. See page 22. 

4. Add the reference ID and lane identifier to a customer order display. See page 24. 

Note
At the time of this writing, the configuration for this enhancement is not in Aloha Configuration 
Center or Aloha Manager. You must perform the configuration in AlohaKitchenOverlay.xml.
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Customizing the font and color of the reference ID and lane number (optional)
If desired, you can customize the font and color of the reference ID text that appears on the header or 
footer of the video cell. 

To customize the font and color of the reference ID: 

1. Locate and open AlohaKitchenOverlay.xml. 
2. Type the following syntax. 

<AlohaKitchenOverlay>
...
<Skin>
...
<ReferenceIdColor>255</ReferenceIdColor>
<ReferenceIdFontName>Courier New</ReferenceIdFontName>
<ReferenceIdFontSize>50</ReferenceIdFontSize>
...
</Skin>
...
</AlohaKitchenOverlay>

3. Save and exit AlohaKitchenOverlay.xml.

Note
At the time of this writing, the configuration for this enhancement is not in Aloha Configuration 
Center or Aloha Manager. You must perform the configuration in AlohaKitchenOverlay.xml.
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Configuring reference ID and lane number to print
By default, the reference ID and lane number do not print on the chit. You must use a print designer 
layout and include the ‘Reference ID’ and ‘Lane number’ elements. You can add both or either 
element to the print layout. The following procedure assumes you have a production chit layout in 
use. 

To add the lane number to a print designer layout:

1. With Kitchen displayed in the product panel, select Maintenance > Hardware > Print 
Designer. 

2. Select a production chit in use from the drop-down list. 

3. Select the Design tab. 
4. Click the Add drop-down arrow, select Lane identifier from the list, and click OK. 
5. Click Move up and Move down to adjust the line positioning of the element on the production 

chit. 
6. Configure the print style settings as you would for any other print designer element. 
7. Click Save and exit the Print Designer function.

Figure 21  Print Designer
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To add the reference ID to a print designer layout:

1. Locate and open AlohaKitchenOverlay.xml. 
2. Type the following syntax. 

<AlohaKitchenOverlay>
...
<PrintLayoutElement>
<PrintLayoutId>1</PrintLayoutId>
<ElementId>1</ElementId>
<ElementType>62</ElementType>
...
</PrintLayoutElement>
...
</AlohaKitchenOverlay>

3. Save and exit AlohaKitchenOverlay.xml.

Note
At the time of this writing, the configuration for this enhancement is not in Aloha Configuration 
Center or Aloha Manager. You must perform the configuration in AlohaKitchenOverlay.xml.
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Adding reference ID and lane number to a customer order display
In this solution, a kitchen screen of the customer order display type is placed on top of the 
Fingermark kiosk device in each drive-thru lane. This is optional and allows the consumer to monitor 
the progress of their order, 

To add the lane identifier to a customer order display:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Kitchen 
Screen. 

2. Select a screen defined as a customer order display to edit from the drop-down list. 

3. Under the ‘Customer order display options’ group bar, select Show lane identifier. 
4. Click Save. 
5. Repeat this procedure for each customer order display screen type for which to add the lane 

identifier. 
6. Exit the Kitchen Screen function. 

Figure 22  Kitchen Screen



 Multi-Lane Drive-Thru
Implementing Multi-Lane Drive-Thru in Aloha Kitchen

25

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

To add the reference ID to a customer order display: 

1. Locate and open AlohaKitchenOverlay.xml. 
2. Type the following syntax. 

}<AlohaKitchenOverlay>
...
<KitchenScreen>
...
<CustomerOrderDisplayShowReferenceId>true</CustomerOrderDisplayShowReference
Id>
...
</KitchenScreen>
</AlohaKitchenOverlay>

3. Save and exit AlohaKitchenOverlay.xml.

Note
At the time of this writing, the configuration for this enhancement is not in Aloha Configuration 
Center or Aloha Manager. You must perform the configuration in AlohaKitchenOverlay.xml.
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Using Multi-Lane Drive-Thru 
In the environment discussed in this document, there are designated lanes for online customers and 
for traditional drive-thru customers at the restaurant. Each lane has a kiosk device supplied by 
Fingermark. Customers who order and pre-pay online through Aloha Online Ordering or a third-party 
app enter their designated lanes, and customers who do not pre-order enter the lanes designated for 
a traditional drive-thru environment. 

Arrival and ordering
Customers who pre-order online receive an order number (reference ID) at the time they place the 
order. Upon entering the designated lane, they enter their order number at the Fingermark kiosk; 
however, they can add to, or change, their order at the kiosk, if desired. The vehicle is held in place 
with a boom gate until the order is prepared. 

Customers who do not pre-order tell the employee their order and the employee enters the order and 
assigns a lane number using ATO. The vehicle is held in place with a boom gate until the order is 
prepared. 

To assign a lane designation to an order: 

1. Enter the order and navigate to Aloha Takeout, as normal. The Order Confirmation screen 
appears.  

Figure 23  Order Confirmation Screen
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2. Touch Lane. Note: Depending on the configuration, lane entry may be required or optional, and 
may also be pre-populated with a default lane number. The lane selection screen appears. 

3. Notice the lane the vehicle is in and select it on the screen. 
4. Confirm the order in ATO, as normal. 

If you need to change the lane after placing the order, touch the Lane action button. 

Figure 24  Lane Selection Screen

Figure 25  Lane Action Button. 
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Order preparation
As the kitchen prepares the order, the order appears on the customer order display screen placed 
above the Fingermark kiosk device for the customer to monitor. The identifier is the reference ID.  

The order appears on the appropriate production screens in the kitchen with the reference ID. 

Figure 26  Customer Order Display with Reference ID

Figure 27  Production Screen with Reference ID
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Order completion
1. The production employees finish cooking the order, bump the order from the screen, and the 

order moves to the expediter screen. 
2. The kitchen chit prints with the reference ID and/or lane number for further identification. 
3. An API call is sent to the Fingermark kiosk device and raises the boom gate to allow the vehicle 

to move forward into a single drive-thru lane. 

Order delivery
1. The vehicle arrives at the pickup window.
2. If the order is not yet tendered, the consumer provides payment.
3. Hand the order to the customer.
4. Close the check as normal.
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Troubleshooting Multi-Lane Drive-Thru
This section discusses troubleshooting steps for a multi-lane drive-thru solution. 

Searching for an order by reference ID 
In Web Admin, the Orders Review function enables you to search and review customer orders, and 
displays the status of a POS order in an on-screen report. You might retrieve an order to troubleshoot 
why an order did not release properly. Since the reference ID is different than the order number, you 
can filter orders by the reference ID using the ‘Human Readable Submit Order Number’ parameter. 

To search for an order by reference ID: 

1. In Web Admin, select Order Management > Orders Review. 

2. Enter the reference number in ‘Human Readable Submit Order Number’ at the left side of the 
screen and click Search. The orders matching the search criteria appear.

Figure 28  Human Readable Submit Order Number
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Multi-Lane Drive-Thru, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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