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Revision Record

Date

Prior to
07/07/2022

Version #

v6.7+

Description

Implemented support for Round It Up Integration.

v13.1

Revised list of zip files, and updated the Adding a
Button to Launch Round it Up America section.

v14.1

Added two new optional settings for the Custom tab.

v14.2

Added three new custom variables for the Custom tab.

RIUA plugin

Added support for Connected Payments in Round It
Up America.

v15.1+

Added manifest information due to least privilege.
Also added instructions for configuring feature in
Quick Service. Provided additional tips for when the
charity line does not print on the voucher.

07/07/2022

Converted document to use new templates.

01/12/2023

Updated front cover and back page to reflect new
NCR branding.

02/17/2023

As of this date, we only support Giving.exe v2.4.1.
Added the ability to round up the amount before
apply payment, using a new custom setting. With this
new setting, you can also use RIUA with cash
payments.

03/06/2023

Updated contact information for Round It Up America.

11/16/2023

Updated document to reflect NCR Voyix branding.
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About Round It Up America

Round It Up America at a Glance

Core Product Aloha Table Service, Aloha Quick Service

Supported Version Giving.exe v2.4.1+

Complementary Products None

Separate License Required? No

Other References Aloha Table Service Reference Guide, Aloha Table Service
Report Guide, Aloha Quick Service Reference Guide, Aloha
Quick Service Report Guide

The Round It Up America (RIUA) program is a simple program that invites restaurant patrons to
donate pocket change by rounding up their purchases to the nearest dollar, or a specified amount.
While the individual donations may be nominal, their collective sum is powerful. RIUA is designed to
serve as a platform to centralize company giving and supports both national and local non-profit
agencies. Today there are thousands of locations (Mission Partners) participating in the program. The
RIUA website http://rounditupamerica.org/ showcases the power of this initiative.

How does it work?

After signing a contract with the RIUA program, you must work with the Aloha® reseller partner or
account manager to obtain the necessary files and implement the solution. After implementation,
consumers write the amount they wish to donate on a designated line on the guest check or voucher,
which you enter on the Close screen. Donation totals are available on the employee checkout report
and the Aloha daily Sales Report to track Round It Up America obligations.

If you have any prospects or customers interested in participating, or have additional questions,
please contact Michelle McCarthy, Executive Director of Round It Up America, at 855-554-RIUA or
mmccarthy@rounditupamerica.org.

Note: This feature works with both Table Service and Quick Service; however, the configuration is
slightly different for each, as noted in the document.
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Configuring Round It Up America

This section details the configuration requirements within Aloha Configuration Center (CFC) and

Aloha Manager for Round It Up America. If you are an experienced user, refer to Procedures at a

Glance for abbreviated steps. If you prefer more detail, continue reading this document.

Round It Up America Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information
regarding the task.

1.

Get started with Round It Up America by performing the following:
e Copy the installation file to the Back-of-House (BOH) server and run the installer. See page 6.

e Access NCR Aloha RAL Site Admin Configuration screen and validate the encrypted RIUA file
is installed by RAL. See page 7.

Access Maintenance > Menu > ltems to create a ‘Charitable Giving’ open item. See page 8.

Access Maintenance > Business > Store > Custom tab to add custom variables to Round It Up
America. See page 10.

Add a button to launch the Charitable Giving screen.

e Locate and right-click TSButton.cfg in the Newdata folder, to add a button that launches Round It
Up America fo the Table Service Close screen. See page 13.

e Select Maintenance > Screen Designer > Quick Service Screen Designer to add a button to
the Quick Service tender screen. See page 14.

Access Maintenance > Messaging > Guest Check Message and create a message to add to the
guest check that offers an opportunity to donate, and another message to print on the credit card
voucher that provides instructions on how to contribute. (Optional) Note: If using Connected
Payments, the instructional message that prints on the voucher may not be beneficial. See

page 14.

Access Utilities > Refresh POS & All Products to refresh the data. See page 19.
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Installing Round It Up America

To get started with Round It Up America, you must perform the following:

e Install RIUA.
e Validate the encrypted RIUA file is installed on the Aloha Front-of-House (FOH) terminals by RAL.

Installing Giving.exe

Aloha reseller partners and direct offices have access to the necessary files for implementing Round It
Up America. Upon obtaining the installation file provided by your account representative, run the
installer on the BOH site controller.

To install Giving.exe:

Copy the Giving.exe installation file to the BOH server.

2. Rightclick on Giving.exe to run the installation. Once the installation is successful, verify the
following files are present in the Aloha/Bin directory.

(¢]

(¢]

(¢]

(e]

(e]

Giving.exe

Aloha.Giving.PLdll

Aloha.Giving.Pl.dll.config
Interop.Aloha.Giving.dll
Interop.INTERCEPTPRINTINGLib.Aloha.Giving.dll

3. Navigate to Control Panel > Programs and Features and verify Aloha Giving is listed.

9 Tip: You can also use this path to uninstall Aloha Giving, if needed.

. © 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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Validating the encrypted file is installed by RAL

Next, you need to validate if the encrypted file is installed on the FOH terminals by RAL. Depending
on the RAL version installed on your system, the button on the NCR Aloha RAL Site Admin
Configuration screen appears as ‘Manifests’ or ‘Package.’

To validate the encrypted file is installed by RAL:

1. Doubleclick the Aloha Admin Ul icon. The NCR Aloha RAL Site Admin Configuration
appears.

@ NCR Aloha RAL - 181101172

(#)

NCR Aloha RAL Site Admin Configuration

this PC

= Exchange
Wardests . = Help >
Sae La Poblanta
BOH Corthg Ter=wrai Cogy Termngl Servwes
Aoha Server ALOHADEVSS 190 184 58 199
1 Owcler Erdey T1 Kachen Fre 192 168 5 W A e sed e
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D 3 Owder Ernny T2 Back Kachen 152 168 5% 1) R Afo gererates user |
0 99) redece Server ADD INT SRY 127801 - Apogerersted uter
D 995 bied S ATO INT SRV Z7e0 Nto e a R
‘ - Ve {’-’ - e
- Cordgure
L Reloat &
. .

]

B sefser|
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Figure T NCR Aloha RAL Site Admin Configuration Screen

2. Click Manifests or Package, depending on the RAL version in use. The appropriate screen
appears.

3. Verify RoundltUpAmerica appears in the Active list for all terminals.
4. Click Exit to exit the Manifest Configuration screen.
5. Exit the NCR Aloha RAL Site Admin Configuration screen.

f| Reference: Refer to the NCR Aloha RAL v19.x User Guide for manifests or NCR Aloha RAL
20.x User Guide for Chocolately packages for more information.
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Creating a charitable giving open item

You must create an open item for use in RIUA. We suggest naming it ‘Charitable Giving.’ Later in the
configuration you associate this item ID with lines on the Custom tab in the Store function in Aloha
Manager or Aloha Configuration Center). See “Adding custom variables for Round It Up America”

on page 10.

To create a ‘Charitable Giving’ open item:

1. Select Maintenance > Menu > ltems.

2. Select the New drop-down arrow and select Standard.

E =
| Item | Modifier | Pricing!| General Settings| Print | Display Options| Quick Count| Dynamic Modifiers| sku ¢ »
B Settings =
Number 10002
Short name
Chit name Charity |
Chit name alternate
Long name Charitable Giving |
Long name alternate
Type Standard
Button image None >
Control name
Ask for description ! I
Cost 0.0000
8 Sold as Family Style item
Export Id 0

B Assignments
Tax group None v
Concept None v
Salesjretail category Food v v

Figure 2 Charitable Giving ltem

3. Accept the system assigned number or click the ellipsis button (...) next to ‘Number’ to
display the Number Assignment dialog box, from which you can choose an alternate number.

4. Type a Chit name. We recommend ‘Charity.’
5. Type a Long name. We recommend ‘Charitable Giving.’
6. Select Ask for description.
7. Do not select a tax group.
-OR-
NCR V:3YIX O e o Diclows Solo Purssant 1o Compary o
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Select a tax group with a zero percent tax.

@ Tip: Round It Up America does not function correctly if you configure the ‘Charitable Giving’
T item as taxable.

8. Select a sales or retail category.

9. Select the Pricing tab.

(=111 H110002 Charitable Giving Food 4=
Item| Modifier m General Settings | Print| Display Options| Quick Count| Dynamic Modifiers| ¢ »
B Pricing options
U Eligible for fixed pricing 0
Pricing method Ask for Price ]'
Minimum price 0.00
Maximurn price 999999,99

Figure 3 Charitable Giving Item Pricing

10. Select Ask for Price from the ‘Pricing method’ drop-down list.

o Tip: If ‘Ask for Price’ does not appear as a choice in the ‘Pricing method’ drop-down list, you

must select Maintenance > Business > Additional Features > and clear ‘Restrict price edit’
under the ‘Restriction settings’ group bar, to enable the method.

NCR V::YIX
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11. Select the General Settings tab.

11510002 Charitable Giving Food M=

Item| Modifier | Pricing | General Settings | Print | Display Options| Quick Count| Dynamic Modifiers| < »
B General
Revenue item
CX Refill

18 no gratuity

Guest count weight 1

Label
Product mix report multiplier

O 0O

Do not show when item
Do not show on summary cell when item

Do not show when modifier

Show modifier independently

Do not show on summary cell when modifier
(€8 show on tracking summary

O0000a0

Figure 4 Charitable Giving Revenue Item

12. Select Revenue item.

13. Click Save and exit the ltems function.

Adding custom variables for Round It Up America

In Aloha Manager or Aloha Configuration Center (CFC), access the Store function and add the
following custom variables. The system alphabetizes the list by ‘Setting name’ once saved.

Round It Up America uses the custom variables to:

e Replace the ‘Charity $’ default text on the credit card voucher with text of your choosing.
e Define the charity item to add to the guest check.

e Define the name to use for the charity item on the guest check.

e Define the maximum amount of contribution allowed.

e Define the maximum percentage of contribution allowed.

e (Optional) Designate how you want to process authorizations for Round It Up transactions. You
have two choices. 1) Create two authorizations, one for the original amount plus the tip, the other
for the original amount plus the tip plus the change given to charity. The processor settles the
second authorization only and drops the first authorization, at their discretion. This is the default

N C R V.".YI X © 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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behavior. 2) Create two authorizations, one for the original amount plus the tip, the other for the
change given to charity. The processor settles both authorizations.

e (Optional) Move the tip line above the charitable giving line on the printed credit card voucher.

e Allow the consumer to add the donation to the check prior to applying the payment. This is
beneficial for a Quick Service environment where the cashier can select the Round It Up America
button and apply the rounding before the consumer inserts their credit card. This also allows you
to collect donations with a cash payment, and you are not limited to paying with a credit card.

To add the Round It Up America custom variables to the Custom tab:

1. Select Maintenance > Business > Store.

2. Select the Custom tab.

|10 Aloha Café v

Location Information | Licensing tom | Store Settings| Aloha Manager |

| Setting name AlValue
| WINGSFORCEDREBOOT FALSE
—Ixcom_osaue FALSE
| ZEROCHECKTIPAUTH 0.00

| CHARITABLE_GIVING_OPENITEM_ID '

| CHARITABLE_GIVING_ONPRINT_TEXT  + Charity Donation
_| CHARITABLE_GIVING_OPENITEM_TEXT Charitable Giving
—I CHARITABLE_GIVING_MAX_AMOUNT  5.00
—| CHARITABLE_GIVING_MAX_PERCENT  10.0
—| ROUNDITUPNEWAUTH TRUE

| CHANGEGIVINGTEXTORDER TRUE
\léUPPRESSGWlNGAUTHPRINT TRUE j"

Figure 5 RIUA Custom Settings

3. Click Add and type CHARITABLE_GIVING_OPENITEM_ID in the ‘Setting name’ column,
followed by the number assigned to the Charitable Giving item you created earlier in the
‘Value' column. See “Creating a charitable giving open item” on page 8.

4. If you want to replace the ‘Charity $’ default text that prints on the credit card voucher with text of
your choosing, click Add and type CHARITABLE_GIVING_ONPRINT_TEXT in the ‘Setting
name’ column, followed by + Charity Donation: or custom text of your choosing in the
‘Value’ column. Type no more than 15 characters or the text will not align properly on the
printout.

N C R v.".YI X © 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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5. Click Add and type CHARITABLE_GIVING_OPENITEM_TEXT in the ‘Setting name’ column,
followed by Charitable Giving or custom text of your choosing to appear on the Point-of-Sale
(POS) terminal.

6. Click Add and type CHARITABLE_GIVING_MAX_AMOUNT in the ‘Setting name’ column,
followed by the maximum amount you allow consumers to contribute. For example, if you
configure '5.00’ for the maximum allowed amount, the consumer may contribute up to $5.00 on
the guest check.

7. Click Add and type CHARITABLE_GIVING_MAX_PERCENT in the ‘Setting name’ column,
followed by the maximum percentage you allow consumers to contribute. For example, if you
configure ‘10%’ for the maximum percentage, and the check total is $21.00, the consumer may
contribute up to $2.10 on the guest check.

8. If you want to create two authorizations, one for the original amount plus the tip, the other for the
change given to charity, and have the processor settle both authorizations, click Add and type
ROUNDITUPNEWAUTH in the ‘Setting name’ column, followed by TRUE in the ‘Value’
column; otherwise, the system uses the default behavior and it is not necessary to add this
variable.

9. If you want to move the tip line above the charitable giving line on the credit card voucher, click
Add and type CHANGEGIVINGTEXTORDER in the ‘Setting name’ column, followed by TRUE
in the ‘Value' column; otherwise, the system uses the default behavior and it is not necessary to
add this variable.

10. If you want to allow the consumer to add a donation to the check prior to applying a payment,
click Add and type APPLYGIVINGBEFOREPAYMENT in the ‘Setting name’ column, followed by
TRUE in the ‘Value’ column; otherwise, the system adds the donation after you apply the
payment. This is convenient for a Quick Service environment.

11. Click Save and exit the Store function.

N C R v.".YI X © 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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Adding a button to launch Round It Up America

You must add a button that launches Round It Up America to the tender panel. When you touch this
button, the system automatically rounds the amount to the next dollar. The configuration is different
depending on if you are using Aloha Table Service or Aloha Quick Service.

To add an RIUA button to the Table Service close screen:

You must use TSButton.cfg to add a button to the Close screen in Table Service. If TSButton.cfg does
not appear in the Data directory, you must create the file.

..’-] Reference: Refer to HKS1581 for more information on TSButton.cfg.

J—

Open Windows Explorer and locate the Data directory.

N

Right-click TSButton.cfg and select Open. The file opens in Windows® Notepad®.

@ Tip: If a 'Windows can't open this file’ message appears, use the Select a program for a list
~ of installed programs and click OK. Select Notepad and click OK.

3. Add the following line to TSButton.cfg:
2,0,19,Round It Up,c:\Bootdrv\Aloha\BIN\Giving.exe, 1
4. Save and close Notepad.
@ Tip: In the example above, 2 specifies the button is a Tender button on the Close Check

screen, O is static and is always O, and ‘19" denotes the position where the button appears on
the tender screen. Adjust as necessary, based on your existing tender screen layout.

Substitute c:\bootdrv\Aloha\BIN\Giving.exe,1 with the actual path to the folder to which you

copied Giving.exe. (Use must append *1’ to the end of this path so that the system passes the
required parameters to Giving.exe.)

You may also change the text that appears on the button by changing ‘Round It Up’ to text that
matches your operation and training.

To add an RIUA button to the Quick Service tender screen:

Select Maintenance > Screen Designer > Quick Service Screen Designer.
Select Work with Panels.

Select Panel > Open Panel. The Open Panels dialog box appears.

0w b~

Select a panel to edit, such as the panel from which you access your tenders, and click OK. The
panel appears.

5. Select Panel > New Button. A new button appears on the panel.

N C R V::::YI X © 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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6. Under the Function section of the Properties dialog box, select Run Application from the
‘Action’ drop-down list.

Type the path to Giving.exe in ‘Application.” For example, c:\AlohaQS\BIN\Giving.exe.
Select True from the ‘Pass Parameters’ drop-down list.
Select False from the ‘Continue Script Immediately’ drop-down list.

10. Under the ‘Appearance’ group bar, type Round It Up instead of Run Application in ‘Text.

11. Configure the remaining options on the Properties dialog box as you would for any other
button, such as text, font, and color.

12. Select File > Save and exit Screen Designer.

Defining guest check and voucher messages

You can optionally print a custom message on the bottom of the guest check, to offer an opportunity
to donate and define reasons for donations with Round It Up America. Once you create a custom
guest check message, you must use the Activation Schedule and Event Schedule functions to
establish when the guest check footer message prints.

You may also want to print another guest check message on the debit or credit card voucher to
provide instructions to the consumer on how to contribute. You define which guest check message to
print on credit card vouchers in ‘Print footer message on voucher’ under the ‘Voucher print settings’
group bar in Maintenance > Business > Store > Store Settings > Credit Card group.

@ Tip: If you use Connected Payments, printing a guest check message in the footer of the debit or
credit card voucher may not be beneficial, as the consumer has already completed the transaction at
the time they receive the voucher.

N C R v.".YI X © 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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To define a custom guest check message for offering an opportunity to donate:

1. Select Maintenance > Messaging > Guest Check Message.

2. Click New and accept the system assigned number, or click the ellipsis button {(...) next to
‘Number’ to display the Number Assignment dialog box from which you can choose an
alternate number.

Guest Check Message
10 RIUA Offering

B Settings 2

Number 10
| Name [RIUA Offering

& Header text

Line 1

Line 2
Barcode message Mone .
E Footer text

Line 1 We are saddened by the recent

Line 2 tragic event in our community.

Line 3 Please consider paying with a

Line 4 debit or credit card and

Line 5 making a charitable donation to 18
Line 6 Round It Up America.

Line 7

Line 8

Figure 6 Guest Check Message for Round It Up America Offering

3. Type a name for the guest check footer message. For example, ‘RIUA Offering.’

4. Under the ‘Footer text’ group bar, type the text to appear at the bottom of the guest check in
‘Line 1" through ‘Line 12." See Figure 11on page 1-22.

* Example: ‘We are saddened by the recent tragic event in our community. Please consider pay-
ing with a debit or credit card and making a charitable donation to Round It Up America.’

5. Click Save.

N C R V.".YI X © 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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To define a custom guest check message for providing instruction:

1. Click New and accept the system assigned number or click the ellipsis button (...) next to
‘Number’ to display the Number Assignment dialog box, from which you can choose an
alternate number.

Guest Check Message
26 RIUA Instructions =

B Settings =
Number 26 es
Name RIUA Instructions

B Header text
Line 1
Line 2
Barcode message None v

B Footer text
Line 1 When paying with a debit or credit card, in
Line 2 use the line above to round up your total
Line 3 to the nearest dollar and
Line 4 help our community.
Line S wiww.rounditupamerica.org
Line 6 v

Figure 7 Guest Check Message for Round it Up America Donation

2. Type a name for the guest check footer message. For example, ‘RIUA Instructions.’

3. Under the ‘Footer text’ group bar, type the text to appear at the bottom of the guest check in
‘Line 1" through ‘Line 12." As outlined in the Mission Partner agreement, and required by the
State Attorney General. the www.rounditupamerica.org address appears on all printed receipts,
See “Signed Voucher Including Charitable Donation” on page 22.

7 Example: ‘When paying with a debit or credit card, use the line above to round up your total
to the nearest dollar and help our community. www.rounditupamerica.org.’

4. Click Save and exit the Guest Check Message function.

N C R V.".YI X © 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
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To activate the guest check message for offering an opportunity to donate:

Analyze your existing activation schedules to determine if a schedule with the desired recurrence
interval for printing the custom guest check message already exists. If yes, use that activation
schedule to activate the custom guest check message; if not, create a new activation schedule with
the desired interval.

.!] Note: Refer to Activation Schedules in the Aloha Quick Service or Table Service Reference Guides
for more information.

To configure the example cited in the scenario, you need a daily activation schedule that is in effect
all day, so that the custom guest check message prints on every guest check. The POS system
provides a default ‘Daily’ activation schedule configured for start-of-day, which meets the frequency
needs of this requirement; there is no need to create a new activation schedule.

Add a ‘Set Guest Check Footer Message’ event type to an event schedule to establish the specific
custom guest check message to print, the activation schedule to use, and the dates on which you want
the message to start and end printing. Because the custom guest check message does not need to
stop printing before the End-of-Day runs, you do not need to add an event to disable the custom
guest check message; however, you can do this, if desired.

o Note: How you are using the Event Schedule function determines whether you add new events to
an existing event schedule or add them to a new event schedule you create. For the purposes of this
document, we assume you use one event schedule to which you add all events.

Select Maintenance > System Settings > Event Schedule.
Select the event schedule to edit from the drop-down list.
Select the Events tab.

M w0bd

Click the Add drop-down arrow, select Set Guest Check Footer Message as the event type,
and click OK.

5. Select Daily from the ‘Activation Schedule’ drop-down list. Because the Daily activation schedule
stipulates to begin at ‘start of day,” you cannot edit the ‘Start time’ in the event definition. This
information is read only.

6. Select the date for the event message to begin printing in ‘Start date.’
7. Select the date you no longer want the message to print in ‘End date.’
8. Select the custom message created for Round It Up America from the drop-down list.
9. Click Save and exit the Event Schedule function.
NCR V::YIX O e ol Sialont Sy Parsgant 6 Commpary Inroctons
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To print the instructional RIUA message on your credit card vouchers:

1. Select Maintenance > Business > Store.
2. Select the Store Settings fab.
3. Select the Credit Card group located at the bottom of the screen.

|10 Aloha Café -

Location Information | Lic

Signature not required for Manually Entered Cards
Require signature when transaction is approved offline

Signature not required if check total is less than this amount 0.00
Number of voucher copies to print 1 s
Text to print on first voucher copy Thanks! Come again

Text to print on second voucher copy

Text to print on third voucher copy

Text to print on Fourth voucher copy

Number of vouchers to print if check amount less than sign... None (0) v
Number of vouchers to print if check amount at or above 5... None (0) -
Print check at master terminal printer when voucher prints

Print check message on voucher

Print footer message on voucher RIUA Instructions
Print large text on voucher

Use custom text on sales voucher

Use custom text on refund voucher

Message to print For prepaid cards Mone -

| Chit Printing| Report Printing| User Interface | Security| System _ Gift CardjCertificate Sales| Quic 4 »

mjm

Oo0Oo po

[«

Figure 8 Credit Card Group - Voucher Print Settings

4. Under the ‘Voucher print seftings’ group bar, select the footer message you created earlier from
the ‘Print footer message on voucher’ drop-down list.

5. Click Save and exit the Store function.

N c R V.".YI X © 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
% o® Use and Disclose Solely Pursuant to Company Instructions

18



Round It Up America
Configuring Round It Up America

Refreshing the data

After all settings are in place in Aloha Manager, it is necessary to select Utilities > POS > Refresh POS
& All Installed Products to transfer the new information to the FOH terminals, or wait for the
End-of-Day (EOD) process to accomplish the data refresh for you. If you run the refresh prior to the
EOD process, select ‘Automatically restart all POS terminals’ and click OK to continue. After the data
refresh is complete, all new settings become operational across the Aloha network.

Caution: Refresh data with caution and never during peak hours of operation. All FOH ter-
minals reboot during a refresh and are down for a short period of time.
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Using Round It Up America

You can apply the donation before or after applying payment. Rounding up before payment is
convenient for a Quick Service environment; however; you should leverage the best method based
on your operation.

To apply a Round It Up America donation before payment:

1. If payment is not applied and you have the APPLYGIVEINGBEFOREPAYMENT custom setting
configured, as shown on page 11, navigate to either the Close screen for Table Service or, if
Quick Service, locate the panel where the Round It Up button is placed.

2. Touch the Round It Up button. The Charitable Giving screen appears. The amount defaults to the
nearest dollar; however, you can change this amount to whatever the consumer indicates on the

voucher.
Charitable Giving

[‘E‘ﬁu_é'o s

| 10 pe Nugget
Ghost Pep Ranch
o Amount: 0.70
MD Fries 0.35
SM Sprite
10 pe Nugget 0.00
Ghost Pep fanch 1 2 3
Sweet & Souwr
MO Fries 0.00
SM Sprite 000
coMno RAL} 4 5 6
D Priz Den Pub
MO Fries 0.30
LM Sprite
0 Priz Ben Pub 0.00 7 8 9
MO Fries 000
SM Sprite oo
Subtotal 1421 Back 0 OK
Tax ror
DINE IN Totsl 15.30

Clear Cancel

Halance Due 815.30 |

Figure 9 Charitable Giving Screen

3. Verify the amount is correct or enter a new amount, if needed, and touch OK. The charitable
amount is added to the check.

4. Apply the payment and tip, as normal.
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To apply a Round It Up donation after payment:

1. If the credit card payment is already applied and the APPLYGIVEINGBEFOREPAYMENT custom
setting is not configured, as shown on page 11, navigate to either the Close screen for Table
Service or, if Quick Service, locate the panel where the Round It Up button is placed.

2. Touch the Round It Up button. The Charitable Giving screen appears. The amount defaults to the
nearest dollar; however, you can change this amount to whatever the consumer indicates on the

voucher.

LG Fries
chil
5M Chac Frasty

Total hems 2
Tax

DINE iN Total

Visa IOO00000000KT 111
Auth:

EAE]
030
[E1]

148
0.26

s1.14

Charitable Giving
b4

Amount: 0.26
1 2 9
4 5 6
7 8 g
Back 0 OK

Clear Cancel

Figure 10 Charitable Giving Screen

3. Verify the amount is correct or enter a new amount, if needed, and touch OK.

4. If the consumer provides a tip, navigate and touch the Adjust Tip button, enter the tip amount,

and touch OK.

5. Close the check as normal and hand the receipt to the consumer.
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Environments where you print a credit card voucher, print and deliver the most updated guest check
to the guest and notify and encourage the consumer to make a charitable donation; the consumer
can make a donation of any amount or you can round up to the nearest dollar amount.

Server: EIl 08/14/2017
Table 2/1 11:44AM
Guests: 2 #10052
Chicken Tortilla Soup 8.95
Chopped Salad 7.95
Roast Beef Dip 11.65
Ahi Crunchy 14.95
Lemonade 3.45
Subtotal 46.95
Tax 3.64
Total 50.59
Balance Due 50.59 | The Round It Up America
offering opportunity to donate

We are saddened by the message appears on the
Recent tragic events in our community. [ guestcheck.

Please consider paying 5.

With a debit or credit card
And making a charitable donation to
Round It Up America

Figure 11 Guest Check Footer Message Offering Opportunity to Donate

Server: EIl 08/14/2017
Table 2/1 11:44AM
Guests: 2

#10052
AMEX 1048580
Card#o000000XX2398

Approval:003220

The consumer writes the
rounded amount in the

Amount: 5‘;59 | line provided.
Round Up For Charity: . 7 ¥
s 10,00
=Total: 67. 00

. Veranizca Mars

The Round It Up America

Use the line above to round up instructional message
your total to the nearest dollar when appears on the voucher.
paying with a debit or credit card and <

help our community.
www . roundi tupamerica.org

Figure 12 Signed Voucher Including Charitable Donation
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Reporting Round It Up America

The system calculates the Round It Up America donation on both the server checkout report and the

daily Sales report.

NCR V::YIX

* * * Checkout ***

Unit # 3 04/26/2010

CORPORATE ACCOUNTING (CORPORATE) 05:53 pm
SHIFT =1

REV: BAR

JOBCODE: MANAGER

* * *QAIEQ * * *
Faoik: 118.55 (+)
Bevs: 16.20 (+)
SALES: 1475
TOTAL 13475 (<)

* %k %k TAxES % %k %k
EXCLUSIVE:
FOOD: 9.8 (+)
EX Bev: 126 (+)
TOTAL 10.44
BROSS SALES: 165.8 (=)

* * *REV [TEMS SOLD ***

02 Charitable Giving A4

Figure 13 Checkout Report
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The daily Sales Report allows you to view the total Round It Up America donations for the day. Use this
amount to determine what you need to send.

WiyFaeCate gas o Sales Report
1234 Las Vegas Blvd Sout!
Las Vegas, NV89134 04/26/2010

Printed by: Seeded Administrator

Page 10f 2
04/26/10-08:15PM

Comps
Elizabeth Bennett 0.00
Walter Mitty 0.00
Amy March 0.00
Jack Reacher 0.00
Theo Lawrence 0.00
Emma Woodhouse 0.00
Total 0.00

GC/ Rev Items Sold

Gift Card\n Bckup 0.00
Deposit 0.00
Givex Card Activation 0.00
Givey Card n nn
Charitable Giving 371
ml CUUT IIP: V.UU
Gift Cert Promos 0.00

NCR V::YIX

Figure 14 Daily Sales Report
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Troubleshooting Round It Up America
The following are troubleshooting tips provided for TSButton.cfg.
If you experience an issue with TSButton.cfg, check the following:

e When you select a button created with TSButton.cfg, the command line issued by the button is
recorded in the Debugging-Output-File (debout) of the terminal. Use this information to verify
your command line is functioning properly.

e Test your command line using either a Windows command prompt or by selecting Start/Run,
typing the command line, and clicking OK. If the command line works using this method, it
should work with TSButton.cfg. If not, it will not work with TSButton.cfg.

e Verify you did not enable the extended command line variables via the CONTEXT field. These
variables can interfere with some applications, such as Notepad.

e Do not include a copy of TSButton.cfg in your Newdata folder, since it can overwrite the active
copy in the Data folder when you refresh the system.
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Round It Up America, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in
helping us improve our information products. Please contact us using the following email address:
Documentation. HSR@NCRVoyix.com
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