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Copyright and Trademark Information
The products described in this document are proprietary works of NCR Voyix.
NCR Voyix is a registered trademark of NCR Voyix.
Aloha is a registered trademark of NCR Voyix.
Microsoft and Windows are registered trademarks of Microsoft Corporation in the United States and/or other 
countries.
All other trademarks are the property of their respective owners.
It is the policy of NCR Voyix to improve products as technology, components, software, and firmware become 
available. NCR Voyix, therefore, reserves the right to change specifications without prior notice.
Not all features, functions and operations described herein are available in all parts of the world. In some 
instances, photographs are of equipment prototypes; therefore, before using this document, consult with your 
NCR Voyix representative or NCR Voyix office for the most current information.
© 2024 NCR Voyix
Atlanta
Georgia
USA
www.ncrvoyix.com
All Rights Reserved

https://www.ncrvoyix.com
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Revision Record

Date Version # Description

Prior to 
11/25/2022

Aloha QS and Aloha TS v6.7 Began development effort for Revenu Québec Fiscal 
Requirements. The feature is not fully developed in 
this version.

Aloha QS and Aloha TS v12.3+ Implemented support for Revenu Québec Fiscal 
Requirements.

Aloha QS and Aloha TS v19+ Removed support of Group Events feature.

11/25/2022 Converted document to use new templates.

01/12/2023 Updated front cover and back page to reflect new 
NCR branding.

11/29/2023 Updated document to reflect NCR Voyix branding.
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About Revenu Québec Fiscal Requirements
The Québec government has certain fiscal requirements in place to help ensure everyone pays the 
correct income tax, and that consumption taxes paid by consumers, such as in a restaurant 
establishment, are properly remitted to the government. If your restaurant establishment is registered 
for the Québec sales tax (QST), the law requires that your Aloha® Point-of-Sale (POS) terminal pass 
the sales data through a sales recording module (SRM) to provide SRM-generated receipts to your 
customers. When a transaction occurs, the SRM device intercepts the transaction and adds a fiscal 
transaction ID and bar code to the bottom of the receipt. Once you activate an SRM device, you must 
use it at all times to produce your receipts and you must submit a monthly periodic sales summary to 
the Québec government. 

Reference:  Refer to http://www.revenuquebec.ca/en/a-propos/evasion_fiscale/restauration/sec-
teur.aspx for more detailed information on supporting fiscal requirements for Revenu Québec.

Figure 1  Sales Recording Module (SRM) Intercepting Transaction Example
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Configuring Revenu Québec Fiscal Requirements
Configuring the fiscal requirements for Revenu Québec is a multi-step process. This section details 
the configuration requirements within Aloha Manager and Aloha Configuration Center (CFC) for 
Revenu Québec. If you are an experienced user, refer to Procedures at a Glance for abbreviated 
steps. If you prefer more detail, continue reading this document. 

Revenu Québec Fiscal Requirements Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Access Maintenance > Business > Store > Store Settings tab > Check Printing group > ‘Fiscal 
printer’ group bar and configure Revenu Québec as the fiscal printing agency. See page 6. 

2. Access Maintenance > Hardware > Printers to configure receipt printers to communicate with an 
SRM device. See page 7. 

3. Access Maintenance > Screen Designer > Table Service Screen Designer or Quick Service 
Screen Designer to create a button that allows you to access and reprint a check from the SRM. See 
page 8. 

4. Access Maintenance > Payments > Comps and configure a comp for adjusting the package deal 
price to zero. See page 9. You also need to access Maintenance > Screen Designer > Table 
Service Screen Designer or Quick Service Screen Designer and create a button for sending an 
identifier to the SRM when the sale is a package deal. See page 10. 

5. Access Utilities > POS > Refresh POS & All Installed Products to refresh your POS system. See 
page 12.
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Designating the fiscal printing agency
You must designate Revenu Québec as the governing body that drives fiscal printing for your store. 
Once enabled, information goes through the printer interface to the SRM device for auditing 
purposes. Other options also appear in the system to allow you to complete the configuration 
requirements.

To designate Revenu Québec as the fiscal printing agency:

1. Select Maintenance > Business > Store > Store Settings tab. 

2. Select the ‘Check Printing’ group located at the bottom of the screen.
3. Under the ‘Fiscal printer’ group bar, select Revenu Québec  from the ‘Fiscal printing agency’ 

drop-down list.
4. Click Save and exit the Store function.

Figure 2  Store Settings Tab - Check Printing Group
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Configuring printers to communicate with SRM
All receipt printers must communicate and receive data from an SRM. It is this communication that 
provides the Fiscal Transaction ID and bar code that prints on the receipt. 

To configure each receipt printer to communicate with an SRM:

1. Select Maintenance > Hardware > Printers. 

2. Select a receipt printer from the drop-down list.
3. Select the Options tab.
4. Under the ‘Option settings’ group bar, select Communicate to external device.
5. Click Save.
6. Repeat this procedure for each receipt printer.
7. Exit the Printers function.

Figure 3  Printers - Option Tab
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Creating a duplicate check button
When you integrate the Aloha POS system with Revenu Québec , you must create a button that allows 
you to create a duplicate copy of a check for the merchant to retain.

To create a button for printing a duplicate copy of a guest check:

1. Select Maintenance > Screen Designer > Table Service Screen Designer or Quick 
Service Screen Designer.

2. Select Work with Panels.
3. Select Panel > Open Panel, select an available order screen panel (TS) or button functions 

panel (QS) to which to add the button, and click OK.
4. Select an available button or create a new button. The Properties dialog box appears.

5. Under the ‘Function’ group bar, select Quebec Fiscal Printing from the ‘Action’ drop-down list. 
6. Select Duplicate guest check from the ‘Options’ drop-down list.
7. Under the ‘Appearance’ group bar, type Duplicate\nCheck in place of the default text Quebec 

Fiscal Printing in ‘Text.’
8. Configure the remaining options as you would for any other button function. 

Figure 4  Properties Dialog Box - Button: Duplicate Guest Check
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9. Select Panel > Save Panel.
10. Select File > Exit to exit Table Service Screen Designer or Quick Service Screen 

Designer.

Configuring a package deal
If you offer other services, such as catering, you may also need to configure the system to provide a 
means for entering the sale of a package deal. A sale is considered a package deal when you include 
a meal with a service. For example, if your establishment is a dinner theatre, the price of the meal is 
included in the cost of the theatre ticket, qualifying this sale as a package deal. A package deal 
receipt must include each food item or beverage included in the package, with or without the price, 
and the adjusted total of zero. Please note the only configuration available in the Aloha POS system 
includes the price of each item with an adjusted total of zero. In addition, you must also include the 
price of each food or beverage item not included in the package deal and adjust the total 
accordingly. To avoid having the sale recorded in both the accounting system and the Aloha POS 
system, you must configure: 

● A comp that brings the total of the items included in the package deal to a zero total.
● A Package Deal button that, when pressed, sends an identifier to the SRM device. 

To configure a comp for adjusting the package deal price to zero:

1. Select Maintenance > Payments > Comps.
2. Click New and accept the system assigned number or click the ellipsis button (...) next to 

‘Number’ to display the Number Assignment dialog box, from which you can choose an 
alternate number. 

Figure 5  Payments - Comps
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3. Under the ‘Settings’ group bar, type a descriptive name for the comp, such as ‘Package Deal.’
4. Select Active.
5. Type 100.00 in ‘Percent off.’
6. Select ‘Must select items’ 
7. Make other selections as you normally would.
8. Click Save and exit the Comps function. 

To create a button for sending a package deal identifier to the SRM device:

1. Select Maintenance > Screen Designer > Table Service Screen Designer or Quick 
Service Screen Designer.

2. Select Work with Panels.
3. Select Panel > Open Panel, select an available order screen panel (TS) or button functions 

panel (QS) to which to add the button, and click OK.
4. Select an available button or create a new button. The Properties dialog box appears.

5. Under the ‘Function’ group bar, select Quebec Fiscal Printing from the ‘Action’ drop-down list. 
6. Select Package deal from the ‘Options’ drop-down list.
7. Under the ‘Appearance’ group bar, type Package Deal in place of the default text Quebec Fiscal 

Printing in ‘Text.’
8. Configure the remaining options as you would for any other button function. 

Figure 6  Properties Dialog Box - Button: Package Deal
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9. Select Panel > Save Panel.
10. Select File > Exit to exit Table Service Screen Designer or Quick Service Screen 

Designer.

Refreshing the data
Once you configure the necessary features for Revenu Québec Fiscal Requirements, you must refresh 
the Aloha POS system.

Select Utilities > POS > Refresh POS & All Installed Products to transfer the new information to 
the Front-of-House (FOH) terminals, or wait for the End-of-Day (EOD) process to accomplish the data 
refresh for you. Note: If you run the refresh prior to the EOD process, select ‘Automatically restart all 
POS terminals’ and click OK to continue. After the data refresh is complete, all new settings become 
operational across the Aloha network. 

Caution:  Refresh data with caution and never during peak hours of operation. All FOH ter-
minals reboot during a refresh and are down for a short period of time.
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Using Revenu Québec Fiscal Requirements
Once your Aloha POS system is connected to and active with an SRM, all receipts print with a Fiscal 
Transaction ID and a bar code, provided by the SRM, on the receipt. 

Figure 7  Revenu Québec  Fiscal Printing Sample
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Reprinting a guest check
When you integrate the Aloha POS system with Revenu Québec , all standard methods for reprinting 
a check now also include the Fiscal Transaction ID and bar code that were added to the original 
check. The Reprint function located in Manager Functions displays a prompt to determine if you want 
to reprint the check, or print a duplicate of the check to retain for your records.

To access and print a duplicate guest check:

1. Recall the check to reprint from the Working with Tables/Tabs screen in Aloha Table Service or 
using the recall buttons in Aloha Quick Service. 

2. Touch the Duplicate Guest Check button. The guest check prints to the local receipt printer with 
the fiscal transaction ID. 

3. Exit the check, as normal.

Figure 8  Duplicate Guest Check
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Entering a sale for a package deal
When you enter a sale for a package deal, first add the items included in the package deal to the 
guest check, then apply the Package Deal comp to adjust the total to zero.

1. Start a check.
2. Add the items included in the package deal to the check, as normal. You can also add any 

items a guest purchases that are not included in the package deal, if applicable. 
3. Touch the Package Deal button to send the identifier to the SRM device. 
4. Touch Close to display the Comp screen (TS) or navigate to the panel containing your comps 

(QS) and touch the Package Deal comp button. The Select Items to Comp screen appears. 
5. Select the items included in the package deal from the guest check window and touch OK. The 

system applies the comp to the selected item(s) at 100% and adjusts the check total.
6. Tender any non-package deal items, as normal, if the check has a remaining balance. 

7. Close the check, as normal.

Figure 9  On-Screen Guest Check with Package Deal
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Revenu Québec Fiscal Requirements, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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