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Revision Record

Date Version # Description

Prior to 
01/23/2023

v12.3+ Implemented Print Designer for production chits, including expo, 
kitchen, order taker, tray chits, and guest checks.

AK v13.1+ Added support for the Pager Location within a Custom Line element. 

v14.1+ Incorporated Campaign Rulebook elements.

v19.3+ Added support for Custom line for label printing for exclusive use for 
NCR Sticky Media™.

AK v19.3+ Added support for the following enhancements:
● Group and print items based on categories. 
● Apply line attribute overrides, such as bold and italics, to menu items 

and modifiers on the kitchen chit. 
● Assign an image to each menu item, for printing on the kitchen chit.
● Assign an image to each modifier code, for printing on the kitchen chit. 
● Associate a production chit with each order mode.
● Rewards Member element.
● Customer Paid Line Text element.
● Override font and font sizes when using a Windows printer.
● Customer Name and Customer Name and First Initials elements. 

01/23/2023 Converted the document to use new templates. Updated front cover and 
back page to reflect new NCR branding.

09/22/2023 Added Aggregator element to production and order taker layouts. 

06/13/2024 Converted the document to NCR Voyix branding.

01/31/2025 Add support for the following enhancements:
● Label print sequence element.
● Pickup instructions element.
● Payment status element.
● Delivery partner name element.
● Delivery partner order number element.
● Loyalty customer name and image element.
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About Print Designer   

The Aloha® Point-of-Sale (POS) system provides a generic layout for the guest check and for chits that 
print in your restaurant. You can do limited customization to these layouts using options available in 
functions like Store Settings, Printers, and others. Print Designer provides the ability to create custom 
layouts with much more flexibility on what prints on a guest check or chit, as well as increased control 
over the positioning of the information. You can create as many custom layouts as needed to fit your 
business needs. 

Print Designer at a Glance

Core Product Aloha Quick Service and Aloha Table Service

Separate License Required? No

Other References Aloha Quick Service Reference Guide; Aloha Table Service 
Reference Guide

Figure 1  Print Designer Illustration

Tip
Print Designer does not affect the print attributes of items and modifiers on the chit or guest check. 
Additionally, you cannot use Print Designer to customize such things as credit card vouchers, 
clock-in chits, and more.
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You also use Print Designer to design printed vouchers for use with campaigns to drive traffic back 
into your restaurant. Use the Campaign Rulebook function to define the actual set of conditions under 
which a guest earns a voucher reward. 

Benefits of Print Designer:

Print Designer enables you to change the appearance of your chits, guest check, and campaign 
vouchers. With Print Designer you can:

● Use the Aloha generic chit layout as a template for designing a custom production chit layout for 
an expo chit, kitchen chit, tray chit, and more.

● Use the Aloha generic guest check layout as a template for designing a custom guest check 
layout.

● Use the Aloha generic general message layout as a template for designing a custom reward 
voucher.

● Define in what order the elements appear on a chit or guest check.
● Define the horizontal position (left, center, right) of elements.
● Define free text data elements to appear on the printed form.
● Define the location of static elements on the printed chit, such as surveys, bar codes, and more.
● Promote “green” printing by suppressing line feed to control paragraph spacing and reduce the 

number of blank lines.
● Define text and font styles.

Once you complete a custom layout, access Maintenance > System Settings > Event Schedule and 
use the Activate Layout Override event to notify the system to use the custom layout, and use Disable 
Layout Override to revert back to the default layout before the end-of-day, if necessary.

Layout types

When you create a new custom layout, it is easier to select the template that corresponds to the type 
of layout you want to create and make modifications, but you can click the down-arrow next to ‘New,’ 
select the type of layout you want to create, and start from scratch. Select from the following types:

Production chit provides the elements you need to design a custom chit to print in the kitchen, such 
as an expo chit, kitchen chit, and tray chit. You must include the Items and Training elements on a 
custom chit of this type to save the new layout. 

Guest check provides the elements you need to design a custom guest check. You must include the 
Items and Training elements on a custom guest check to save the new layout. 

Reference
Refer to the Campaign Rulebook Feature Focus Guide - HKS324 for more information on creating 
voucher rewards using Print Designer. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS324
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General message provides the elements required to design a printed voucher for use with 
campaigns. 

Order taker chit provides the same elements you need to design a custom chit to print in the kitchen 
(production chit) without the requirement of including the Items and Training elements. With this 
type, as long as you include one of the available elements in your design, you can save and use the 
new layout.

Layout alignment and elements
The Print Designer tool uses elements to build and design your layout, such as ‘Ordermode name,’ 
‘Day part,’ ‘Revenue center,’ and many more. Some of these elements are standard to all businesses 
and some are only required when you use a certain feature or interface with a complimentary 
product. For example, you would always include the ‘Current date’ element, and only include the 
‘eFrequency check total’ element if you use Aloha Insight.

Whether you create a layout for a chit or a guest check, you must be familiar with the divisions of the 
layout to properly create your design. Envision the layout in three vertical (top-down) areas, Header, 
Item, and Footer, and three horizontal positions, Left, Center, and Right. 

Figure 2  Layout Alignment
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Vertical areas
The vertical areas (Header, Item, and Footer) are defined sections of the layout for customization. 
With the exception of the Item area, they are unrestricted, meaning an element that is normally 
hard-coded for the Header area can easily be placed in the Footer area, with Print Designer. 
Additionally, there is no limit to the elements you can add to the Header or Footer area. 

● Header - The Header area is usually designated for store information, essential check 
requirements, such as employee name, time, check number, and anything else you deem as 
header information.  

● Item - The Items area is restricted, meaning you cannot make any design changes within the Print 
Designer tool. This area consists solely of the Items element, which is a required element in your 
design for the guest check. 

● Footer - The Footer area is usually designated for salutations, guest experience feedback, and 
anything else you deem as footer information. 

Horizontal positioning
The horizontal positions (Left, Center, and Right) provide the flexibility to align elements flush against 
the left or right sides, or directly in the center of the layout. Each element has a default alignment; 
however, you can change this alignment to your liking. For example, the default alignment for a guest 
count appears flush left; however, you can easily place it in the middle or flush right. 

Additionally, using the ‘Custom line’ element, you can assign up to three select elements to appear 
on a single line, to conserve space and provide unity. 

Guest: 5

Check: 10025

Item Area

Footer Area

Header Area

Item Area

Guest: 5

Check: 10025

Guest: 5 Guest: 5

Server: Suzie Table: 15 12:34 PM
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Required configuration for Print Designer
Printing configuration resides in several areas of the Aloha POS system, and each serves its own 
purpose. You can perform printing configuration in the following areas:

● Store Settings - Defines print configuration at the store level. 
● Printer Maintenance - Defines print configuration for a specific printer. 
● Item Maintenance - Defines print configuration for a specific item. 

With the inception of Print Designer, the system now uses the following hierarchy when determining 
the printing within the Aloha POS system (with 1 being the highest and 4 being the lowest): 

1. Print configuration in Item Maintenance.
2. Print configuration in Print Designer.
3. Print configuration in Printer Maintenance.
4. Print configuration in Store Settings.

The Print Designer tool overrides configuration in Printer Maintenance and Store Settings; however, 
this does not mean configuration in these areas is overlooked. You must still configure all applicable 
options in Store Settings and Printer Maintenance to enable a printing feature to print with the Print 
Designer tool. 

Here are some print hierarchy scenarios: 

Tip
If you add an element to your Print Designer layout but do not also configure a required option 
elsewhere in the system, the information does not print on the chit or guest check.

Setup Result

Configure print options in Store Settings.
Do not configure Print Designer. 

The system prints in accordance to the configuration in 
Store Settings.

Configure print options in Store Settings.
Configure print options in Printer Maintenance.
Do not configure Print Designer.

The system prints in accordance to the configuration in 
Store Settings, but is overridden by any print 
configuration in Printer Maintenance for that specific 
printer.

Do not configure print options in Store Settings.
Configure Print Designer.

The system does not print any Print Designer elements 
that have a required configuration in Store Settings. 

Do no configure print options in Printer 
Maintenance.
Configure Print Designer.

The system does not print any Print Designer elements 
that have a required configuration in Printer 
Maintenance. 

Configure print options in Item Maintenance.
Configure Print Designer.

The system prints in accordance to the configuration in 
Print Designer, but is overridden by any print 
configuration in Item Maintenance. 
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To help visualize this, the following examples depict how to add the ‘Guest count’ element to a chit. 
In the first example, the default chit for Aloha Quick Service and Table Service does not contain an 
entry to print the number of guests for a table/order. 

Figure 3  Default Chit Print for Aloha Quick Serivce (Left) and Table Service (Right)

Configure a layout in Print Designer for expo 
chits. 
Do not configure a layout in Print Designer for 
kitchen chits.
Configure print options in Store Settings.

The system prints at the expo printer in accordance to 
the configuration in Print Designer and prints at the 
kitchen printer in accordance to the configuration in 
Store Settings. 

********************************* *********************************

3/16/2013 3/16/2013

Susie 2:03 PM 2:03 PM

Table 10 1 of 1 1 of 1

Type: Dine In Type: Dine In

Roast Beef 3.00 Roast Beef 3.00

Double w/Chz 3.00 Double w/Chz 3.00

Gr Chk Breast 3.00 Gr Chk Breast 3.00

----------------------------------------------- ----------------------------------------------

Setup Result
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Access Maintenance > Business > Store > Store Settings tab and select ‘Show guest count’ under the 
‘Chit Content’ group bar to enable the system to print the guest count in a fixed location, flush left 
and beneath the Order Mode (Type) field. 

Figure 4  Chit Print When Guest Counts are Enabled in Store Settings

********************************* *********************************

3/16/2013 3/16/2013

Susie 2:03 PM 2:03 PM

Table 10 1 of 1 1 of 1

Type: Dine In Type: Dine In

Guests: 3 Guest: 3

Roast Beef 3.00 Roast Beef 3.00

Double w/Chz 3.00 Double w/Chz 3.00

Gr Chk Breast 3.00 Gr Chk Breast 3.00

----------------------------------------------- ----------------------------------------------
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Once the guest count is enabled to print in Store Settings, you can add the ‘Guest count’ element to 
the layout for a chit, using Print Designer. 

Figure 5  Chit Print with Guest Count Element Added in Print Designer

In the last example, not only did we add the ‘Guest count’ element, but we also did the following: 

● Moved the guest count flush right on the chit. 
● Moved the current date flush left on the chit and aligned with the current time, using a custom 

line.
● Moved the order mode (type) flush right on the chit and above the guest count.
● Moved the ‘Number of number’ element to print in the center on the chit. 

********************************* *********************************

3/16/2013 2:03 PM 3/16/2013 2:03 PM

Susie Type: Dine In Type: Dine In

Table 10 Guests: 3 Guests: 3

1 of 1 1 of 1

Roast Beef 3.00 Roast Beef 3.00

Double w/Chz 3.00 Double w/Chz 3.00

Gr Chk Breast 3.00 Gr Chk Breast 3.00

----------------------------------------------- ----------------------------------------------
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Configuring Print Designer 

Configuring a layout from the default template
To create your own custom layout, we recommend you begin by copying and renaming the default 
template provided for you in the Aloha POS system. You can then remove, add, and organize 
elements as you see fit. This method saves you time and allows you to be functional more quickly, 
rather than creating a layout from scratch. 

It is up to you to remove elements from, or add elements to, your new layout, and to move elements 
up or down to change the order in which they appear. You can also combine certain elements so that 
they print on the same line in the layout, using the ‘Custom line’ element. For example, you can print 
the current date and time on the same line. 

Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task.

1. Create a layout from the default template. See page 12 to create a new, or edit an existing, layout.

2. Customize the print designer layout. Organize and assign attributes to the elements on the layout. to 
add, remove, rearrange, or format elements on a chit or guest check. See page 21. 

3. Associate a production chit layout with an order mode. See page 32

4. Activate the new layout using the Activate Layout Override and Disable Layout Override events in 
Event Schedule. See page 33 to activate or disable an operational event that determines the layout 
for a chit or guest check at any given time.

5. Refresh POS data. See page 34. 

Tip
The default templates are not intended for use as your production prints. Each one is protected, 
preventing you from making any changes to it; instead, use the “copy” command to copy a template 
to a new record and then modify the new record. 

Tip
If you include an element for a feature you do not have your system configured to use, the system 
allows you to add the element to the layout, but does not print anything on the chit. 
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For a default chit layout, the elements are the same for Aloha Quick Service and Table Service. The 
following example depicts the elements provided on the default chit template. 

Custom header top 

Promise time

Delivery info

Filled line

Linefeed

Linefeed

Linefeed

Modified Order info

Current date

Server name Current time

Order name Number of number

Print ordermode on check

Guest count

Check numbers

Custom header middle

Club members

Bar audit chit header

Terminal name

Training

<linefeed>

Membership

Table tent

Void

Linefeed

<linefeed>

Alerts

Ordermode header

<linefeed>

Custom header bottom



 Print Designer
Configuring Print Designer

14

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Figure 6  Default Chit Template 

Items

Custom trailer top

Void

Total

Recipes

Other menu

Ordermode trailer

<linefeed>

Chit tag totals

Custom trailer middle

<linefeed>

Split chit message

Linefeed

Linefeed

Filled line

<linefeed>

Promise time

<linefeed>

<linefeed>

Expo barcode

Custom trailer bottom

ATO bag sort number

Legend

Bold box Indicates elements containing internal leading and trailing linefeeds which you can 
suppress.

Double line box Indicates a ‘Custom line’ element was used to add up to three specific elements onto 
the same line. 
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For a default guest check template, we provide one for each environment, Aloha Quick Service and 
Aloha Table Service. The following examples depict the elements provided on the default Quick 
Service (Left) and Table Service (Right) guest check. 

Placeholder text (“Header Elements”) Placeholder text (“Header Elements”)

Bitmap Bitmap

<linefeed> <linefeed>

Header Header

<linefeed> <linefeed>

<linefeed>

Large check name

<linefeed>

Linefeed Linefeed

<linefeed> <linefeed>

Refund Refund

<linefeed> <linefeed>

Linefeed Linefeed

Server name Current date Server name Current date

Cashier name Cashier name

Order name Current time Order name Current time

Guest count Guest count

Order/Check number Order/Check number

Fiscal Quebec transaction ID/date Fiscal Quebec transaction ID/date

Duplicate Duplicate

Reprint Reprint

Order mode Order mode

Revenue center Revenue center

Menu name Menu name

Order attribute Order attribute

Survey banner text Survey banner text

Day part Day part

<linefeed> <linefeed>

Placeholder Element (“Body Elements”) Placeholder Element (“Body Elements”)



 Print Designer
Configuring Print Designer

16

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

<linefeed> <linefeed>

Items Items

<linefeed> <linefeed>

Placeholder Element (“Footer Elements”) Placeholder Element (“Footer Elements”)

Training Training

<linefeed>

Advance Order info

<linefeed>

PMS info PMS info

<linefeed> <linefeed>

PMS room PMS room

<linefeed> <linefeed>

Frequent Diner subtotal Frequent Diner subtotal

<linefeed> <linefeed>

Frequent Diner message Frequent Diner message

<linefeed> <linefeed>

Sales Category detail Sales Category detail

<linefeed> <linefeed>

Inclusive taxes breakout Inclusive taxes breakout

Exclusive taxes breakout Exclusive taxes breakout

Signature Signature

<linefeed> <linefeed>

<linefeed> <linefeed>

eFrequency check text eFrequency check text

<linefeed> <linefeed>

Guest Check messages Guest Check messages

<linefeed> <linefeed>

Gift Card Offline message Gift Card Offline messages

<linefeed> <linefeed>

<linefeed> <linefeed>

Delivery info Delivery info
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Figure 7  Default Guest Check Template for Quick Service (Left) and Table Service (Right) 

<linefeed> <linefeed>

<linefeed>

Advance Order footer

<linefeed>

Linefeed Linefeed

<linefeed> <linefeed>

Footer Footer

Linefeed Linefeed

<linefeed> <linefeed>

Barcode Barcode

Comp form Comp form

<linefeed>

<linefeed>

Two Part check

Quebec Fiscal info Quebec Fiscal info

Separate survey Separate survey

Legend

Bold box Indicates elements containing internal leading and trailing linefeeds which you can suppress. 

Double line 
box

Indicates a ‘Custom line’ element was used to add up to three specific elements onto the 
same line. 

Shaded box Indicates areas in the example to be ignored and are provided only to align the Quick 
Service and Table Service elements side by side. 
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To configure a custom layout starting with a template:

1. Select Maintenance > Hardware > Print Designer. 

2. Select either 9996 General Message, 9997 TS Guest Check, 9998 QS Guest Check, or 
9999 Default Kitchen Chit from the ‘Print Designer’ drop-down list. 

3. Click Copy in the Command panel to display the copy options. 

4. Type a name for the new layout, such as ‘Expo Chit’ for a chit or ‘Custom Check’ for a guest 
check. 

5. Accept the system assigned number or click the drop-down arrow next to ‘Copy to number’ to 
display the Number Assignment dialog box, from which you can choose an alternate number, 
and click OK.

Figure 8  Print Designer - Layout Tab

Figure 9  Make Copy of Dialog Box
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6. Select the Design tab.  

7. To design the layout, perform any of the following steps:

Figure 10  Print Designer - Design Tab

Reference
Refer to “Appendix A: Field definitions” on page 41 for a comprehensive list of field definitions 
for options available on this screen. 
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a. To add an element to the layout, click the Add drop-down arrow to display a list of available 
elements. 

Select the element to add from the ‘Type’ list box and click OK. The element appears at the 
bottom of the list of elements under the ‘Design’ group bar. Also, based on the element you 
select, additional options may appear under the ‘Print style settings’ group bar, which require 
you to complete the element. 

b. To remove an element from the design, select an element you do not need from the list of 
elements available under the ‘Design’ group bar and click Remove. A confirmation appears. 

Figure 11  Available Elements

Reference
For a comprehensive list of elements available to use, refer to “Appendix B: Production chit and 
order taker elements” on page 45, “Appendix C: Guest check elements” on page 60, or 
“Appendix D: General message elements” on page 74.

Figure 12  Print Designer - Remove Record Prompt
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Click Yes at the prompt to confirm the removal of the record from the layout.
c. To change the top-down order in which elements appear on the layout, select an element 

and click Move up or Move down. 

8. Repeat this procedure for other elements to include in the new layout until you are done adding, 
removing, or moving items in the list. 

9. Click Save and exit the Print Designer function. 

Customizing the Print Designer layout 
As you add elements to the Print Designer layout, you can customize them by changing the font size 
and style, width and height, and alignment as they appear on the custom print. Additionally, you can 
suppress any leading and trailing internal linefeeds to promote a ‘green’ environment and regulate 
the size of the chit or guest check. 

Grouping items by categories (production layout) 

Items on a production chit appear and print in the order in which you add them to the check, or by 
using a defined priority. For better organization, you can group and print items using general 
(non-sales) categories. For example, you can group items by:

● Courses, such as appetizers, entrees, and dessert.
● Stations, such as grilled, fried, and cold.
● Length of time to prepare, such as two minutes, three minutes, five minutes. 

To do this, assign items to general categories in the Categories function, and then use the Chit Item 
Category Grouping function to group the categories. We recommend putting an item in only one of 
these categories. Once grouped, all production chit layouts defined in the Print Designer function 
use that grouping. Any item not assigned to a category within the grouping prints independently. You 
can configure only one Chit Item Category Grouping record, per store. If you later decide you do not 
want the grouping, delete the Chit Item Category Grouping record. 

Tip
The Items and Training elements are required elements. If you do not select a required element, 
an error message appears prompting you to add the element to your layout. 

Figure 13  



 Print Designer
Configuring Print Designer

22

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

To assign items to a general category:

1. With Kitchen selected in the product panel, select Maintenance > Menu > Categories. 
2. Click the New drop-down arrow, select General, and click OK. 
3. Type a name for the category, such as ‘Apps.’
4. Select the Items tab. 
5. Select an item from the ‘Available’ list and click >> to move the item to the ‘Included’ list. 
6. Repeat step 5 to include each item in the category. 
7. Click Save. 
8. Repeat this procedure until you assign all necessary items to a category. 
9. Exit the Categories function. 

To assign categories for chit item category grouping:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Print Designer 
Configuration > Chit Item Category Grouping. The Chit Item Category Grouping function 
appears. 

2. Under the ‘Groupings’ group bar, click Add. 
3. Select a category to include in the production chit grouping from the ‘Category’ drop-down list. 
4. Type the name to identify the category in ‘Group Header,’ if different than the default text. The 

name of the category appears as the default text, but you can use an alternate name that is more 

Figure 14  Chit Item Category Grouping Function
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descriptive or friendly. To have more than one category appear as though it belongs to a single 
category, type the same group header for each applicable category. 

5. Repeat steps 2 through 4 until you group all the necessary categories. 
6. Click Save and exit the Chit Item Category Grouping function. 

Changing the size of an element (all layouts) 
You can control the size of an element layout by setting the size, width, and height attributes for each 
element to print. You can change the printing to preset relative sizes for the text.  

You can expand the width and height of an element.  

To customize the size of an element:

1. Select an element in the list, under the ‘Design’ group bar. 
2. Under the ‘Print style settings’ group bar that appears, select the relative size of printed text for 

the selected element from the ‘Size’ drop-down list. Your choices are ‘Large,’ ‘Medium,’ ‘Small,’ 
‘Very small,’ and ‘Very large.’ 

3. Select Expanded width, to stretch the printed element horizontally across the line.
4. Select Expanded height, to increase the height of the printed element.
5. Click Save in the Command panel. 

You can override the font and font sizes for an element defined in Print Designer when you use an 
Epson TM-88 printer with Windows printer drivers in the Printers function. These drivers have proven 
to print text and graphical images on a chit with more clarity. We recommend you use an Ethernet 
connection for your operations since an Epson TM-88 printer installed with Windows printer drivers 
may print slower in comparison to other printers. 

For example, if you select ‘Large’ as the font size for an element in Print Designer, you can stipulate 
the font size for large as being 15 points in the Windows printer definition. While there is no option 
in the Print Designer function to specify the font type, you can override the default font using ‘Font 
name’ in the Windows printer definition. 

Figure 15  Relative Size Examples for Elements

Figure 16  Expanded Examples for Elements
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To override the font and font sizes for an element using a Windows printer:

1. With Kitchen selected in the product panel, select Maintenance > Hardware > Printers. 
2. Click the New drop-down arrow, select Aloha Kitchen, and click OK.  

3. Type a name to identify the printer. 
4. Under the ‘Settings’ group bar, select Windows Printer from the ‘Mode’ drop-down list to 

expose the ‘Windows printer settings’ group bar. 
5. Select the terminal that uses the printer. 
6. Select the backup printer to use for the terminal. 
7. Under the ‘Windows printer sttings’ group bar, type a name to identify the printer in ‘Printer 

name.’ 
8. Select a font to use instead of the default font for chit printing from the ‘Font name’ drop-down 

list, if desired. 
9. Select a font size to use for very small printing from the ‘Font size (very small)’ drop-down list, if 

desired. The default is 5 points. This option overrides the default font size used for the ‘Very 
small’ choice for ‘Size’ on the Design tab in the Print Designer function. 

10. Select a font size to use for small printing from the ‘Font size (small)’ drop-down list, if desired. 
The default is 7 points. This option overrides the default font size used for the ‘Small’ choice for 
‘Size’ on the Design tab in the Print Designer function. 

Figure 17  Printers - Printers Tab



 Print Designer
Configuring Print Designer

25

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

11. Select a font size to use for medium printing from the ‘Font size (medium)’ drop-down list, if 
desired. The default is 10 points. This option overrides the default font size used for the ‘Medium’ 
choice for ‘Size’ on the Design tab in the Print Designer function.

12. Select a font size to use for large printing from the ‘Font size (large)’ drop-down list, if desired. 
The default is 13 points. This option overrides the default font size used for the ‘Large’ choice for 
‘Size’ on the Design tab in the Print Designer function. 

13. Select a font size to use for very large printing from the ‘Font size (very large) drop-down list, if 
desired. The default is 15 points. This option overrides the default font size used for the ‘Very 
large’ choice for ‘Size’ on the Design tab in the Print Designer function. 

14. Click Save. 
15. Repeat this procedure for any other printer using a Windows printer. 
16. Exit the Printers function. 

Changing the appearance of an element (production layout) 
You can configure basic text attributes for your production layout, such as bold and italics, and print 
the element in a color of your choice, by setting line attribute overrides for each element to print. This 
allows an element to stand out while other elements print normally. You cannot customize attributes 
for a specific item or modifier.  

To change the appearance of an element:

1. Select an element in the list, under the ‘Design’ group bar. 
2. Under the ‘Line attribute overrides’ group bar that appears, select Use line attributes to enable 

you to use additional basic text attributes, such as bold, italic, and underlined, and to print the 
element in a color of your choice. Selecting this option exposes the remaining options in the 
group bar. 

3. Select the color in which to print the text of the element from the ‘RGB color settings’ palette, as 
desired. The default is 0.0.0. You must use a color printer to print in color. 

4. Select Italic to print the text of the element in italic. 
5. Select Underlined to print the text of the element with an underline. 
6. Select Bold to print the text of the element in bold. 
7. Repeat steps 2 to 6 for any other element for which to override the standard printing. 
8. Click Save in the Command panel. 

Figure 18  Line Attributes Applied to Item and Modifier
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Changing the alignment of an element (all layouts) 
Each element has a default alignment; however, you can change the alignment to print flush left or 
right. 

To change the alignment of an element:

1. Select an element in the list, under the ‘Design’ group bar. 
2. Under the ‘Print style settings’ group bar, select the horizontal position of the element on the 

chit from the ‘Alignment’ drop-down list. Each element has a default alignment. You can override 
that default by selecting another alignment from the drop down list. Your choices are Left, Center, 
and Right. 

3. Click Save in the Command panel. 

Suppressing linefeeds (all layouts)
A linefeed is a blank line in the layout used for readability and sectioning. Reducing the number of 
blank linefeeds on your layout not only promotes a “green” environment, but also saves on the cost of 
expensive printer paper. 

Inserted linefeed elements

The copied chit or guest check template from which you create your new layout contains inserted 
linefeed elements. Remove these linefeed elements as you would for any element, if desired. 

Internal linefeeds

Some elements contain inherited leading or trailing linefeeds that appear on the layout to match the 
printing behavior of the element when you do not use Print Designer. For example, if you add the 
‘Day part’ element to the design, the element has an internal linefeed after the printing of the 
element. Where applicable, you can suppress any internal linefeeds of a particular element. If an 
element has more than one internal linefeed, regardless if they are leading or trailing, the system 
suppresses all linefeeds.

Figure 19  Internal Linefeed for Day Part is Suppressed 

Guest: 5 Guest: 5

Day part Day part

<linefeed>

Reference
Refer to Figure 6 and Figure 7 for a visual representation of the internal linefeeds that appear.
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To suppress the internal linefeeds of an element:

1. Select an element in the list, under the ‘Design’ group bar. 
2. Under the ‘Print style settings’ group bar, select Suppress leading line feed and/or Suppress 

trailing line feed to promote “green” printing by using less paper. 
3. Click Save in the Command panel. 

The following elements have suppressible internal linefeeds: 

Element Supported Layout Product Internal Linefeed

Advance Order info Guest Check QS Leading and Trailing

Advance Order footer Guest Check QS Leading and Trailing

Alerts Chit QS/TS Leading

Barcode Guest Check QS/TS Leading

Day part Guest Check QS/TS Trailing

Delivery info Guest Check QS/TS Leading and Trailing

eFrequency check text Guest Check QS/TS Trailing

Expo barcode Chit QS/TS Leading

Footer Guest Check QS/TS Leading

Frequent Diner message Guest Check QS/TS Trailing

Frequent Diner subtotal Guest Check QS/TS Trailing

Gift Card offline 
message

Guest Check QS/TS Leading and Trailing

Header Guest Check QS/TS Leading and Trailing

Items Guest Check QS/TS Leading and Trailing

Large Check name Guest Check QS Leading and Trailing

Ordermode header Chit QS/TS Trailing

Ordermode name Chit QS/TS Trailing

Ordermode trailer Chit QS/TS Trailing

PMS Info Guest Check QS/TS Trailing

PMS Room Guest Check QS/TS Trailing

Promise time Chit QS/TS Leading and Trailing

Refund Guest Check QS/TS Leading and Trailing

Sales Category detail Guest Check QS/TS Trailing

Signature Guest Check QS/TS (2) Trailing
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Linefeeds caused by unused elements

Obviously, you want to add only the elements for the features you are using. If you add an element to 
the design related to a feature you are not using, the system prints a blank line. For example, if you 
add the ‘Club member number’ element, and you are not interfacing with Membership, only a blank 
line prints. You should leverage the features you are actually using when adding elements to your 
design. 

Using a custom line element to position multiple elements (all layouts) 
Custom lines contain up to three elements that print together on one line. You can create up to three 
custom lines; however, there is a very specific list of elements from which you can choose. You must 
select ‘None’ when you want only two elements on a line.

Figure 20  Example of Three Custom Lines  

Single chit message Chit QS/TS Leading

Split Chit message Chit QS/TS Leading

Training Chit QS/TS Trailing

Two Part check Guest Check TS (2) Leading

Current date

Server name Current time

Order name Number of number

Tip
All three elements in a custom line use the print style settings for the grouped element ‘Custom line.’ 
For example, you cannot select only one ‘Custom line’ element to print in red ink and then have the 
others print in normal type, bold, or italics.

Reference
For a comprehensive list of elements available to use, refer to “Appendix B: Production chit and 
order taker elements” on page 45, “Appendix C: Guest check elements” on page 60, or 
“Appendix D: General message elements” on page 74.

Element Supported Layout Product Internal Linefeed
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To create a custom line:

1. Select Custom line under the ‘Design’ group bar.
2. Select an element from the ‘Left,’ ‘Center,’ and ‘Right’ drop-down lists under the ‘Custom line 

settings’ group bar. 

3. Click Save in the Command panel. 

Printing an image with a menu item (production layout)
You can designate an image to print to the left of a menu item on a production chit created in Print 
Designer. You may want to do this to promote signature items or identify generic items, such as an 
image of a drink for your drink items. You could also use an image to indicate the serving 
temperature recommended for items, such as HOT for a coffee, or use an image containing the first 
letter of an item, such as the letter B for a burrito. 

Tip
You must select three elements to print on a custom line. If you only want two elements on a 
line, select None for one of the three alignments.

Figure 21  Item with Image
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To designate an image to print to the left of a menu item on a production chit:

1. Select Maintenance > Menu > Items > Item tab. 

2. Under the ‘Settings’ group bar, select the image to print to the left of the menu item from the 
‘Kitchen chit item image’ drop-down list. The image prints to the left of the menu item on a 
kitchen chit, when using a production chit layout in Print Designer. You may want to do this to 
promote signature items or identify generic items, such as an image of a drink for your drink 
items. You could also use an image to indicate the serving temperature recommended for items, 
such as HOT for a coffee, or use an image containing the first letter of an item, such as the letter 
B for a burrito. We recommend using 22x22 as the dimensions for your image. Required 
Options: You must import the image using the Aloha Kitchen application type in the Media Files 
function to make the image available in the drop-down list. 

3. Click Save. 
4. Repeat this procedure for any other menu item for which to designate an image. 
5. Exit the Items function. 

Figure 22  Items - Items Tab
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Printing an image based on modifier code (production layout) 

You can designate an image to print to the left of a modifier code on a production chit created in 
Print Designer. You might use a plus sign for a modifier added to an item (Add), a minus sign for a 
modifier removed from an item (No), and others. You could also use an image with the word ADD or 
NO. You must import the image using the Aloha Kitchen application type in the Media Files function 
to make the image available in the drop-down list. 

To designate an image to print to the left of a modifier code on a production chit:

1. Select Maintenance > Menu > Modifier Codes.

2. Select a modifier code. 
3. Under the ‘Settings’ group bar, select the image to associate with the modifier code from the 

‘Kitchen modifier image’ drop-down list. The image prints to the left of a modifier code on a 
kitchen chit, when using a production chit layout in Print Designer. You may want to use a plus 
sign for a modifier added to an item (Add), a minus sign for a modifier removed from an item 

Figure 23  Modifier Code with Image

Figure 24  Modifier Codes Function
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(No), and others. You could also use an image with the word ADD or NO. We recommend using 
22x22 as the dimensions for your image. 

4. Click Save. 
5. Repeat this procedure for any other modifier code for which to designate an image. 
6. Exit the Modifier Code function. 

Associating a production chit layout with an order mode (production layout)
You can associate a production chit layout designed in Print Designer for use with a specific order 
mode. For example, to print a production chit layout specifically for takeout orders, attach the layout 
to the Takeout order mode. Aloha Kitchen uses the layout to print the chit each time you place a 
takeout order. This option overrides the default layout selected in the ‘Item chit layout’ drop-down list 
in Maintenance > Kitchen Configuration > Kitchen Settings. 

To associate a production chit layout with an order mode:

1. With Kitchen selected in the product window, select Maintenance > System Settings > Order 
Mode. 

2. Select the Kitchen tab. 
3. Select an order mode from the drop-down list. 

4. Select the layout from the ‘Print layout override’ drop-down list. When you apply this order 
mode, the system uses the production chit layout designed in Print Designer. 

5. Click Save. 

Figure 25  Order Modes - Kitchen Tab 
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6. Repeat this procedure for each order mode for which to print an override production chit. 
7. Exit the Order Mode function. 

Activating a layout using Event Schedule (all layouts)
You activate the customized layouts you create for your locations using Event Schedule. For each 
layout, you must assign an ‘Activate Layout Override’ event to notify the system to use the customized 
layout, and a ‘Disable Layout Override’ event to revert back to the default layout before the 
end-of-day, if necessary.

How you are using the Event Schedule function determines whether you add new events to an 
existing event schedule or add them to a new event schedule you create. For the purposes of this 
document, we assume you use one event schedule to which you add all events.

To activate a custom layout:

1. Select Maintenance > System Settings > Event Schedule.
2. Select an existing event schedule, if different than the active schedule.
3. Select the Events tab. 
4. Click the Add drop-down arrow, select Activate Layout Override, and click OK. 
5. Select the frequency of the event from the ‘Activation schedule’ drop-down list. Your choices 

are ‘None,’ ‘Always,’ ‘EOD,’ or ‘EOD Daily.’
6. Select whether you want to assign the layout to a type of chit or the guest check from the 

‘Override layout type’ drop-down list under the ‘Activate Layout Override’ group bar.
7. Select the desired layout from the ‘Override layout selection’ drop-down list.
8. If the layout needs to discontinue prior to the end-of-day, click the Add drop-down arrow again, 

select Disable Layout Override, and click OK.
9. Select the frequency of the event from the ‘Activation schedule’ drop-down list. Your choices 

are ‘None,’ ‘Always,’ ‘EOD,’ or ‘EOD Daily.’
10. Select the layout to disable from the ‘Override layout type’ drop-down list under the ‘Activate 

Layout Override’ group bar.
11. Select the same layout from the ‘Override layout selection’ drop-down list.
12. Click Save in the Command panel. 
13. Repeat this procedure for other layout overrides you want to activate or disable.
14. Click Close in the Command panel to exit the Event Schedule function. 
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Refreshing POS data
After all settings are in place in Aloha Manager, you must select Utilities > POS > Refresh POS & All 
Installed Products to transfer the new information to the FOH terminals, or wait for the End-of-Day 
(EOD) process to accomplish the data refresh for you. If you run the refresh prior to the EOD 
process, select ‘Automatically restart all POS terminals’ and click OK to continue. After the data 
refresh is complete, all new settings become operational across the Aloha network. 

Caution
Refresh data with caution and never during peak hours of operation. All FOH terminals reboot 
during a refresh and are down for a short period of time. 
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Viewing custom Print Designer layout examples
Once configured, the Print Designer feature is easy to take advantage of, requiring no additional 
attention from management or restaurant staff. When you direct an order to a printer, the system 
prints using the layout you specified. 

Production chits

The following is an example of the default chit for Aloha Quick Service and Table Service.  

Figure 26  Default Chit for Quick Service (Left) and Table Service (Right)

********************************
*

********************************
*

3/16/2013 3/16/2013

2:03 PM Susie 2:03 PM

1 of 1 Table 10 1 of 1

Type: Dine In Type: Dine In

Roast Beef 3.00 Roast Beef 3.00

Double w/Chz 3.00 Double w/Chz 3.00

Gr Chk Breast 3.00 Gr Chk Breast 3.00

----------------------------------------------- ----------------------------------------------



 Print Designer
Viewing custom Print Designer layout examples

36

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

When using Print Designer to customize your layout, the system prints as designed, as in the 
following example. 

Figure 27  Customized Chit for Quick Service (Left) and Table Service (Right)

Guest checks

The following is an example of the default guest check for Aloha Quick Service and Table Service. 

======================== ========================

MAKE THIS ORDER MAKE THIS ORDER

1 of 1 1 of 1

3/16/2013 2:03 PM 3/16/2013 2:03 PM

Type: Dine In Check: 10000 Type: Dine In Check: 10000

Roast Beef 3.00 Roast Beef 3.00

Double w/Chz 3.00 Double w/Chz 3.00

Gr Chk Breast 3.00 Gr Chk Breast 3.00

========================- ==========================

DELIVER TO: DELIVER TO:

Suzie Table 10 Suzie

Aloha Cafe Aloha Restaurant

1234 Anywhere 1234 Anywhere

3/16/2013 Server: Suzie 3/16/2013

3:30 PM Table 12/1 3:30 PM

#20040 #20040

Order Type: Dine In Order Type: Dine In

Area: Counter Area: Dining
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Figure 28  Default Guest Check for Aloha Quick Service (Left) and Table Service (Right)

Roast Beef 3.00 Roast Beef 3.00

Double w/Chz 3.00 Double w/Chz 3.00

Gr Chk Breast 3.00 Gr Chk Breast 3.00

Subtotal 9.00 Subtotal 9.00

Food Tax 0.68 Food Tax 0.68

Total 9.68 Total 9.68

Cash $20.00 Cash $20.00

Change $10.32 Change $10.32

Thank You for Visiting Thank You for Visiting

Aloha Cafe Aloha Cafe

Have a nice day! Have a nice day!

---Check Closed---- ---Check Closed----
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When using Print Designer to customize your layout, the system prints as designed, as in the 
following example. 

Figure 29  Custom Guest Check with Print Designer for Quick Service (Left) and Table Service (Right)

Aloha Cafe 1234 Anywhere Aloha Cafe 1234 Anywhere

=================== ===================

Your Order Number was Your Server was 

20040 Suzie

3/16/2013 3:30 PM 3/16/2013 3:30 PM

#20040

Order Type: Dine In Area: Counter Order Type: Dine In Area: Counter

-------------------------------------- ------------------------------------------

You ordered: You ordered:

Roast Beef 3.00 Roast Beef 3.00

Double w/Chz 3.00 Double w/Chz 3.00

Gr Chk Breast 3.00 Gr Chk Breast 3.00

-------------------------------------- -----------------------------------------

Subtotal 9.00 Subtotal 9.00

Food Tax 0.68 Food Tax 0.68

Total 9.68 Total 9.68

Cash $20.00 Cash $20.00

Change $10.32 Change $10.32

---Check Closed---- ---Check Closed----

Thank You for Visiting Thank You for Visiting

Aloha Cafe Aloha Cafe

Have a nice day! Have a nice day!
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General message 

Figure 30  Print on Demand Offer
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Troubleshooting Print Designer
The following are troubleshooting tips provided for Print Designer:

Nothing Prints for an Element

If nothing prints for an element from your layout, this could be caused by several reasons. The Print 
Designer tool is only the ‘face’ of your printing configuration. It does not enable or disable features. 
If an element did not print before you implemented Print Designer, it will probably not print after 
implementing Print Designer. Try the following troubleshooting tips, if nothing prints for an element: 

● Ensure the element exists on the Print Designer layout in use.
● If the element has required options, ensure these are enabled, such as options located in Store 

Settings or Printer Maintenance. This is explained in detail in “Required configuration for Print 
Designer” on page 8. 

The Chit Runs Too Long

If the chit runs too long when printing, consider the following:

● Remove any unused elements from the layout. 
● Suppress any linefeeds that print as blank line entries on the layout. Refer to “Suppressing 

linefeeds (all layouts)” on page 26 for more information.

Reference
Refer to “Appendix B: Production chit and order taker elements” on page 45, “Appendix C: Guest 
check elements” on page 60, and “Appendix D: General message elements” on page 74 for a 
complete list and description for each available element.
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Appendix A: Field definitions
Layout tab 

When you create a new custom layout, you must select the type of layout you want to create. Select 
from the following types when you click the New drop-down to add a new layout:

Production chit provides the elements you need to design a custom chit to print in the kitchen, such 
as an expo chit, kitchen chit, and tray chit. You must include the Items and Training elements on a 
custom chit of this type to save the new layout.

Guest check provides the elements you need to design a custom guest check. You must include the 
Items and Training elements on a custom guest check to save the new layout.

General message provides the elements required to design a printed voucher for use with 
campaigns.

Order taker provides the same elements you need to design a custom chit to print in the kitchen 
(production chit) without the requirement of including the Items and Training elements. With this 
type, if you include one of the available elements in your design, you can save and use the new 
layout. 

Name — Identifies the layout. 

Design tab
Use the Design tab to choose the elements to include in the custom layout you are designing and to 
change how elements appear in the layout, such as font, alignment, and more.

Group bar: Design

Element — Indicates the elements already selected to include in the custom layout. To add an ele-
ment, click the Add drop-down arrow to display the Type list box and select from the list of available 
elements for the specific type of layout you are designing. For example, if you select ‘Guest check’ as 
the type of layout, only the elements available to add to a custom guest check layout appear in the 
Type list box. 

Group bar: Design > Print style settings

Size — Specifies the relative size of the printed text. Select from Large, Medium, Small, Very small, 
and Very large. 

Alignment — Specifies the horizontal position of the element on the layout. Select from Left, Center, 
and Right. 

Expanded width — Stretches the printed element horizontally across the line. 

Expanded height — Increases the height of the printed element. 
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Red — Prints the element in red. 

Suppress leading line feed — Does not precede the element with a leading blank line, if any. For 
example, when you add the ‘Alerts’ element, a blank line usually precedes the element on the printed 
artifact. When you select this option, the system does not precede the Alerts element with a blank 
line, which promotes a ‘green’ environment. 

Suppress trailing line feed — Does not follow the element with a trailing blank line, if any. For 
example, when you add the ‘Ordermode name’ element, a blank line usually follows the element on 
the printed artifact. When you select this option, the system does not follow the ‘Ordermode name’ 
element with a blank line, which promotes a ‘green’ environment. 

Group bar: Design > Line attribute overrides 

Allows you to add color, italic, underline, and bold to an element. Required Options: You must 
select ‘Production chit’ as the layout type to expose this group bar. 

Use line attribute overrides — Enables you to use additional basic text attributes, such as bold, 
italic, and underlined, and to print the element in a color of your choice. This allows an element to 
stand out while other elements print normally. Selecting this option exposes the remaining options in 
the group bar. Required Options: You must select ‘Production chit’ as the layout type to expose this 
option.

Color — Specifies the color in which to print the text of the element. The default is 0.0.0. You must 
use a color printer. Required Options: You must select ‘Production chit’ as the layout type to expose 
this option.

Italic — Prints the text of the element in italic. Required Options: You must select ‘Production chit’ 
as the layout type to expose this option.

Underlined — Prints the text of the element with an underline. Required Options: You must select 
‘Production chit’ as the layout type to expose this option.

Bold — Prints the text of the element in bold. Required Options: You must select ‘Production chit’ 
as the layout type to expose this option.

Group bar: Design > Bag label settings

Prints the current name, and the total number of bags, on the order label. Required Options: You 
must add the ‘Bag label sequence’ element to expose this group bar. 

Bag label text — Specifies the text to print on the left of a custom line. Required Options: You must 
add the ‘Bag label sequence’ element to a layout to expose this option.
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Group bar: Design > Custom line settings

Allows you combine up to three elements from a limited list on one line. Required Options: You 
must add the ‘Custom line’ or ‘Custom line for label printing’ element to expose this group bar. 

Left — Specifies the element to print on the left of a custom line. Select None to show the area as 
blank. Required Options: You must add the ‘Custom line’ or ‘Custom line for label printing’ element 
to expose this option.

Center — Specifies the element to print in the center of a custom line. Select None to show the areas 
as blank. Required Options: You must add the ‘Custom line’ or ‘Custom line for label printing’ ele-
ment to expose this option.

Right — Specifies the element to print on the right of a custom line. Select None to show the area as 
blank. Required Options: You must add the ‘Custom line’ or ‘Custom line for label printing’ element 
to expose this option.

Group bar: Design > Custom paid line settings

Allows you to define the text to appear on the chit when a check is tendered, such as ‘PAID OUT.’ 
Required Options: You must add the ‘Custom paid line text’ element to a layout to expose this group 
bar. 

Text — Specifies the text to use for the paid line. Required Options: You must add the ‘Custom paid 
line text’ element to a layout to expose this option.

Group bar: Design > Filled line settings

Allows you to print a line using the character you designate, such as *. Required Options: You must 
add the ‘Filled line’ element to a layout to expose this group bar. 

Text — Specifies the character to print across the line. Required Options: You must add the ‘Filled 
line’ element to a layout to expose this option.

Group bar: Design > Image settings

Allows you to add an image to the layout. Required Options: You must select the ‘Image’ element to 
expose this group bar. 

Select image — Specifies the image to add. Required Options: You must add the ‘Image’ element 
to a layout to expose this option. Related Requirement: You must upload the image using the Media 
Files function.

Group bar: Design > Label Print Sequence settings

Allows you to print the ‘x of y’ label sequence on the production chit. Required Options: You must 
add the ‘Label print sequence’ element to a ‘Production chit’ or “Order taker chit’ layout to expose 
this group bar.
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Label print text — Specifies the text to print for an ‘x of y’ printing sequence on the kitchen chit. The 
default is ‘Label print is {0} of {1},’ enclosed in braces, where {0} is the specific print number and {1} 
is the total number of prints. You can modify the free text to further customize the text that prints on 
the chit. Required Options: You must add the ‘Label print sequence’ element to a ‘Production chit’ 
or “Order taker chit’ layout to expose this option. Documented Version: v19.11. 

Group bar: Design > Loyalty customer name and image settings

Allows you to add the Loyalty name and image to a production layout. Required Options: You must 
add the ‘Loyalty customer name and image’ element to expose this group bar. 

Loyalty image — Specifies the image to add. Required Options: You must add the ‘Loyalty 
customer name and image’ element to expose this option. Required Requirement: You must upload 
the image using the Media Files function. 

Group bar: Design > Placeholder text settings 

Allows you to add free text to the layout. Required Options: You must add the ‘Placeholder Element’ 
or Placeholder Text element to a layout to expose this group bar.

Placeholder text settings — Allows you to define free-form, non-printing text to include in the lay-
out. This text serves as a label in the list of elements on a chit, such as **END OF HEADER** or 
**START OF TRAILER**. Required Options: You must add the ‘Placeholder Element’ or 
‘Placeholder Text’ element to a layout to expose this option.

Group bar: Design > Redemption period

Establishes the number of calendar days after printing a reward voucher an offer is valid. The system 
uses the number of days to determine and print the beginning and ending dates during which a 
guest can redeem a voucher for an earned reward. Required Options: You must add the 
‘Redemption Period’ element to expose this group bar. 

Redemption period (in days) — Specifies the number of days to allow the consumer to redeem a 
voucher for an earned reward. Default Alignment: Centered.Required Options: You must add the 
‘Redemption Period’ element to expose this option. 

Group bar: Design > User text settings

Allows you add free text to the layout. Required Options: You must add the ‘User text’ element to a 
layout to expose this group bar.

User text settings — Allows you to define free form text to include in the layout. Required Options: 
You must add the ‘User text’ element to a layout to expose this option. 

Reference
Refer to the Campaign Rulebook Feature Focus Guide - HKS324 for more information. 

https://docs.ncrvoyix.com/downloads/aloha-pos/QSTS_CampaignRulebookFFG-HKS324.pdf


 Print Designer
Appendix B: Production chit and order taker elements

45

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Appendix B: Production chit and order taker elements
The following is a comprehensive list of the elements available for use when you choose a layout type 
of ‘Production chit’ or ‘Order taker,’ listed in alphabetic order. The list includes the default alignment 
of the element as it appears on the generic chit layout and a brief description. Also included are 
related or required options you must select or clear when adding the element to a custom layout. 

Aggregator

Prints the name of the aggregator on the kitchen chit. Default Alignment: Center.

Alerts

Prints each alert for the order, followed by a line feed. Default Alignment: Center. 

ATO bag sort number

Prints the bag sort number received from Aloha Takeout. Aloha Takeout sends the bag number 
automatically, but you must add the element to the header or footer to include it on your custom chit. 
Default Alignment: Left.  

Bag label sequence 

Prints the current number, and the total number of bags, on the order label. Use this element to 
design an order label for an operation such as a production assembly line. Default Alignment: 
Center. 

Bar audit chit header  

Prints a header containing the text “***AUDIT CHIT***” on bar chits. Default Alignment: Center.

Reference
Refer to the Alerts Feature Focus Guide - HKS334 for more information on alerts. 

Reference
Refer to the Aloha Takeout documentation for more information on Aloha Takeout. 

Bag 1 of 1

Reference
Refer to the Production Assembly Line Feature Focus Guide - HKS1548 for more information on a 
production assembly line operation. 

***AUDIT CHIT***

https://docs.ncrvoyix.com/downloads/aloha-pos/QSTS_AlertsFFG-HKS334.pdf
https://docs.ncrvoyix.com/restaurant/aloha-takeout/overview
https://docs.ncrvoyix.com/downloads/aloha-kitchen/AK_ProductionAssemblyLineFFG-HKS1548.pdf
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Check numbers 

Prints one line for the check number, formatted as “Check: nnnnn.” Multiple entries print when you 
split a check. Default Alignment: Left. Required Options: You must select ‘Print check number’ in 
Maintenance > Business > Store > Store Settings tab > Chit Printing group > under the ‘Content’ 
group bar. 

Chit header text 

Prints up to five lines of custom text in the chit header. Default Alignment: Center. Required 
Options: You define the custom text in the five ‘Text line #’ options in Maintenance > Business > 
Store > Store Settings tab > Chit Printing group > under the ‘Order Taker Chits’ group bar. 

Chit tag totals 

Prints a consolidated summary of ingredient information on the bottom of the chit, as defined in 
ChitTag.cfg. You can use this feature to print some or all ingredients needed to prepare selected 
items on the chit, such as the total number of steaks or shrimp needed for the table. Default 
Alignment: Left.

You must configure each line in the ChitTag.cfg, using the following format:

<item_ID,><space><ingredient_label,><space><quantity>

Check: 0100

Check: 0101

Tip
The check number is also available using the ‘Custom line’ element, where you can combine the 
check number with three other elements in either the left, center, or right alignment. 

Order is Ready!

<available text>

<available text>

<available text>

<available text>

--------------------------------

20 oz Steak

20 Shrimp
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Item_ID refers to the item ID in Item Maintenance. Ingredient_Label refers to an alphanumeric field, 
up to 80 characters, listing the ingredient associated with the item. Quantity refers to a numeric field 
listing the weight or quantity of the ingredient. The quantities for like ingredients are always 
consolidated regardless of the chit consolidation options configured within the Aloha POS system. 

For example, in a Japanese steakhouse, the chef must know how much to prepare and load on a food 
cart to present to the guest. The Steak Dinner (ID 1001) contains 12 ounces of steak, the Shrimp 
Dinner (ID 1002) contains 12 pieces of shrimp, and the Steak and Shrimp Dinner (ID 1003) contains 
eight ounces of steak and eight pieces of shrimp. The ChitTag.cfg file would list the following entries 
in the format of:

1001, oz Steak, 12
1002, Shrimp, 12
1003, oz Steak, 8
1003, Shrimp, 8 

To configure ChitTag.cfg:

1. Create a new text file named ChitTag.cfg and place the file in the Data directory. 
2. Type the name of the item ID, ingredient, and quantity for which you want to print ingredient 

information, using the appropriate format. 
3. Select File > Save. 

Club members 

Prints one line per club member associated with the order. Line formatting is “Last name, First 
name.” This is a Table Service only element. Default Alignment: Center. Required Options: You 
must select ‘Print club member name’ in Maintenance > Business > Store > Store Settings tab > Chit 
Printing group > under the ‘Content’ group bar. 

Reference
Refer to Consolidated Kitchen Chit Ingredient Tags - HKS1749 for more information on configuring 
ChitTag.cfg. 

Smith, John

Harvey, Tom

Reference
Refer to the Interfacing with Memberships User Guide for more information on memberships. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1749


 Print Designer
Appendix B: Production chit and order taker elements

48

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Custom header top

Prints custom text at the top of the header section. Default Alignment: Left. Required Options: 
Define the custom text in ‘Kitchen chit header’ in Maintenance > System Settings > Order Modes > 
Order Mode tab under the Settings group bar.

Custom header middle

Prints custom text in the middle of the header section Default Alignment: Left. Required Options: 
Define the custom text in ‘Kitchen chit header’ in Maintenance > System Settings > Order Modes > 
Order Mode tab > under the Settings group bar.

Custom header bottom

Prints custom text at the bottom of the header section, immediately before printing the items section. 
Default Alignment: Left. Required Options: Define the custom text in ‘Kitchen chit header’ in 
Maintenance > System Settings > Order Modes > Order Mode tab > under the Settings group bar.

Custom line 

Allows you to print up to three elements on the same line, starting with left alignment, then center, 
then right. Add a custom line for each line. There is a very specific list of elements from which you 
can choose. See “Using a custom line element to position multiple elements (all layouts)” on 
page 28. Default Alignment: Left. 

Select from the following to complete your custom line:  

Custom line for label printing

Prints the order number in bold, and the item number on the same line, such as Order #25, (item 1 
of 2). This is used exclusively for printing a label for NCR Sticky Media™. Default Alignment: Left. 

3/16/2013

Susie Server 2:03 PM

Table 10 1 of 1

Cashier name Check number Current date

Current time Guest count Number of number, such as ‘x’ of 
‘y.’

Order name Order number Ordermode name

Pager number Pager Location Printer name

Server name Tent number Terminal name
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Custom paid line text

Allows you to define the text, such as ‘PAID OUT,’ to appear on the chit when a check is tendered. 
Use this element instead of the ‘Is paid’ element. Default Alignment: Center. Required Options: 
You must select ‘Show paid indicator’ in Maintenance > Hardware > Kitchen Screen under the 
‘Order display’ group bar. 

Custom trailer top

Prints custom text at the top of the footer (trailer) section, immediately after printing the items section. 
Default Alignment: Left. Required Options: Define the custom text in ‘Kitchen chit footer’ in 
Maintenance > System Settings > Order Modes > Order Mode tab under the Settings group bar.

Custom trailer middle

Prints custom text in the middle of the footer (trailer) section of the chit. Default Alignment: Left. 
Required Options: Define the custom text in ‘Kitchen chit footer’ in Maintenance > System Settings > 
Order Modes > Order Mode tab under the Settings group bar.

Custom trailer bottom

Prints custom text at the bottom of the footer (trailer) section of the chit. Default Alignment: Left. 
Required Options: Define the custom text in ‘Kitchen chit footer’ in Maintenance > System Settings > 
Order Modes > Order Mode tab under the Settings group bar.

Customer first name

Prints the first name of the consumer on the production chit. Default Alignment: Left. Required 
Requirements: You must access Maintenance > System Settings > Order Modes and select ‘Parse 
order name for customer name’ to use this option. 

Customer last name first initial

Prints the initial of the last name of the consumer on the production chit. Default Alignment: Left. 
Related Requirements: You must access Maintenance > System Settings > Order Mode > Kitchen 
tab and select ‘Parse order name for customer name’ for each order mode to use this option. 

Cut

Cuts the chit at the defined section. 
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Delivery info 

Prints available delivery information, based on the printer printing the chit. Default Alignment: Left 
for Phone and Name; all else is Center. Required Options: You must clear ‘Never print 
delivery/carryout information in Maintenance > Hardware > Printers > Options tab > under the ‘Chit 
printing’ group bar.  

Delivery partner name

Prints the name of the third-party delivery partner on the order label to assist the delivery partners in 
identifying their orders. Use this element to design an order label for an operation such as a 
production assembly line. Default Alignment: Center. 

Delivery partner order number

Prints the order number the third-party delivery partner uses on the order label to assist delivery 
partners in identifying their orders. Use this element to design an order label for an operation such as 
a production assembly line. Default Alignment: Center.

Phone: 555-5555

Name: Smith, John

Reference
Refer to the Delivery Area Feature Focus Guide - HKS351 for more information on delivery.

TAKE IT AWAY DELIVERY

Reference
Refer to the Production Assembly Line Feature Focus Guide - HKS1548 for more information on a 
production assembly line operation. 

Order Number 1234

Reference
Refer to the Production Assembly Line Feature Focus Guide - HKS1548 for more information on a 
production assembly line operation. 

https://docs.ncrvoyix.com/downloads/aloha-takeout/ATO_DeliveryAreaFFG-HKS351.pdf
https://docs.ncrvoyix.com/downloads/aloha-kitchen/AK_ProductionAssemblyLineFFG-HKS1548.pdf
https://docs.ncrvoyix.com/downloads/aloha-kitchen/AK_ProductionAssemblyLineFFG-HKS1548.pdf
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Expo barcode 

Prints a bar code for each check on the order, with a leading and trailing linefeed. Default 
Alignment: Left. Required Options: 1) You must select an ‘Expediter printer’ in Maintenance > 
Business > Store > Store Settings tab > Chit Printing group > under the Content group bar, and 2) 
You must select ‘Print barcode on Expediter’ in Maintenance > System Settings > Order Mode > 
under the ‘Printing’ group bar. 

Filled line 

Prints a line across the chit using the character you designate, such as * or =, in ‘Text’ under the 
‘Filled line settings’ group bar that appears when you select this element. Default Alignment: Left. 

Guest count 

Prints a line, formatted as “Guests: n”, where n is the guest count. Default Alignment: Left. 
Required Options: 1) You must select ‘Print guest count’ in Maintenance > Business > Store > Store 
Settings tab > Chit Printing group > under the ‘Content’ group bar. 2) You must clear ‘Allow a guest 
count of zero’ in Maintenance > Business > Store > Store Settings tab > Order Entry group > under 
the ‘Guest count’ group bar. 

Header

Prints the store name, address, and phone number, if defined. The header also includes an optional 
list of items configured in a guest check token file. Default Alignment: Center.

Image

Prints an image on the chit, such as your company logo, using the image you designate under the 
‘Image settings’ group bar that appears when you select this element. Related Requirements: You 

<line feed>

<bar code>

<line feed>

**********************************

Guests: 5

Tip
The guest count is also available using the ‘Custom line’ element, where you can combine the guest 
count with three other elements in either the left, center, or right alignment.
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must import images specific to the Aloha Kitchen application in Maintenance > System Settings > 
Media Files. Use this element for such things as printing your company logo on NCR Sticky Media™. 

Is paid 

Prints “Paid” above the order mode header on chits. Use this element to design an order label for an 
operation such as a production assembly line. Default Alignment: Center. Required Options: You 
must have Aloha Kitchen installed and select ‘Show paid indicator’ in Maintenance > Hardware > 
Kitchen Screen > under the ‘Order display’ group bar. 

Item chit counter

Prints item counts for orders that print single-item chits to multiple printers in the kitchen. All unique 
single-item chits print ‘Item x of y’ where ‘x’ is the sequence number of the item in the order and ‘y’ is 
the total number of items in the order. Default Alignment: Left. Related Options: You must 
configure your printers for single-item chit printing under the ‘Chit settings’ group bar in 
Maintenance > Hardware > Printers.

Items

Specifies where the main item section appears on the printed chit. The system considers items the 
main body of information on a chit and always positions items between the header and footer. This is 
a required element in your layout. Default Alignment: Left. 

Label print sequence

Prints the ‘x of y’ chit or label sequence on the kitchen chit, with respect to all printers involved in the 
order. For example, if you have four chits printing across two printers in use, the ‘x of y’ sequence 
includes both printers in the counter, ‘1 of 4’ to ‘4 of 4.’ Documented Version: v19.11.

Linefeed 

Inserts an empty line into the print design, to set elements apart from each other. Default Alignment: 
Left. 

Paid

Reference
Refer to the Production Assembly Line Feature Focus Guide - HKS1548 for more information on a 
production assembly line operation. 

<line feed>

https://docs.ncrvoyix.com/downloads/aloha-kitchen/AK_ProductionAssemblyLineFFG-HKS1548.pdf


 Print Designer
Appendix B: Production chit and order taker elements

53

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Loyalty customer name and image 

Prints the name of the Loyalty member, along with an image, on the order label. Use this element to 
identify bags you need to give special treatment, or to identify bags into which to insert a flyer 
encouraging non-loyalty members to join your Loyalty program. Use this element to design an order 
label for an operation such as a production assembly line. Default Alignment: Center. 

Membership 

Prints the item name associated with one of the three items you create for interfacing with 
Membership and selling in a dry county. These items indicate whether the guest is a new member, 
renewing member, or existing member. This is Table Service only. Default Alignment: Center. 
Required Options: You must specify a category from the ‘Require membership if items from this 
category are ordered’ drop-down list in Maintenance > Business > Store > Store Settings tab > Order 
Entry group > under the ‘Liquor Memberships’ group bar to use this feature. When you select a 
liquor category, prompts appear in the Front-of-House (FOH), requiring the selection of one of these 
items. 

Modified order info 

Prints a message indicating some items were previously ordered for this check when you modify an 
order after the first chit print. Default Alignment: Center. Required Options: You must select ‘Print 
all items on all kitchen chits’ in Maintenance > Business > Store > Store Settings tab > Chit Printing 
group > under the ‘Content’ group bar. 

Ordermode header 

Prints the header text designated for the specific order mode applied to the check, in the header of 
the chit. Default Alignment: Left. Required Options: You designate the header text for each order 
mode in ‘Kitchen chit header’ in Maintenance > System Settings > Order Mode > under the ‘Settings’ 
group bar. 

Reference
Refer to the Production Assembly Line Feature Focus Guide - HKS1548 for more information on a 
production assembly line operation. 

New Member

Some items were previously ordered

The following items are To Go:

https://docs.ncrvoyix.com/downloads/aloha-kitchen/AK_ProductionAssemblyLineFFG-HKS1548.pdf


 Print Designer
Appendix B: Production chit and order taker elements

54

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Ordermode name 

Prints the name of the order mode applied to the check, followed by a line feed. Default Alignment: 
Left. 

Ordermode trailer 

Prints the footer text designated for the specific order mode applied to the check, in the footer of the 
chit, followed by a line feed. Default Alignment: Left. Required Options: 1) You designate the 
footer text for each order mode in ‘Kitchen chit footer’ in Maintenance > System Settings > Order 
Mode > under the ‘Settings’ group bar. 2) To print the order mode footer text in red ink, select ‘Print 
order mode in red’ in Maintenance > Business > Store > Store Settings tab > Chit Printing group > 
‘Appearance’ group bar. 

Other menu 

Prints “* - Items from” followed by “MenuName menu” if you order items from an off-cycle menu, 
such as a breakfast menu item ordered during the hours normally scheduled for the lunch menu. 
Default Alignment: Left. 

Payment status 

Prints the payment status on the order label, depending on if the check is fully tendered. If the check 
is fully tendered, PAID prints on the label. If the check is not fully tendered, NOT PAID prints on the 
label. Use this element to quickly identify if the consumer has already paid for the order at the time 
the label was printed or if the order still requires payment. Use this element to design an order label 
for an operation such as a production assembly line. Default Alignment: Center. 

Dine In

<line feed>

The above items are To Go:

* - Items from Breakfast menu

*** NOT PAID ***

Reference
Refer to the Production Assembly Line Feature Focus Guide - HKS1548 for more information on a 
production assembly line operation. 

https://docs.ncrvoyix.com/downloads/aloha-kitchen/AK_ProductionAssemblyLineFFG-HKS1548.pdf
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Phone number 

Prints the phone number of the guest on the chit. Default Alignment: Left. Required Options: You 
must configure your Aloha Takeout phone number requirements under the ‘Settings’ group bar on 
the Phone Numbers tab in Maintenance > Takeout Configuration > Takeout Settings. 

Pickup instructions 

Prints the order destination, such as Curbside, on the order label and leverages the Source and 
Destination feature in Aloha Takeout. If the selected destination for the order is the default destination 
defined in the Source and Destination feature, the destination does not print. Any destination not 
selected as the default destination will print on the label. Use this element to design an order label for 
an operation such as a production assembly line. Default Alignment: Center. Required Options: 
You must select ‘Use ATO destination’ in Maintenance > Kitchen Configuration > Kitchen Settings to 
use this element. 

Placeholder Element 

Contains non-printing, optional text, to use as a label in your design, such as **END OF HEADER** 
or **START OF TRAILER**. Designate the label text in ‘Placeholder text’ under the ‘Placeholder text 
settings’ group bar that appears when you select this element. Default Alignment: Left. 

Print order mode on check 

Prints the order mode on the chit when you have the order mode designated to print on the guest 
check. If you do not select Large as the ‘Size’ under the ‘Print style settings’ group bar that appears 
when you select this element, the prefix ‘Type’ precedes the order mode name. Prints ‘None’ if 
printing of chit occurs prior to order mode assignment. Default Alignment: Left. Required Options: 
1) To stipulate you want to print the order mode on the guest check, select ‘Print Order Mode’ in 

123-456-7890

Pickup

Reference
Refer to the Production Assembly Line Feature Focus Guide - HKS1548 for more information on a 
production assembly line operation. 
Refer to the Source and Destination - HKS334 for more information on using the Source and 
Destination feature.

**END OF HEADER**

Dine In

https://docs.ncrvoyix.com/downloads/aloha-kitchen/AK_ProductionAssemblyLineFFG-HKS1548.pdf
https://docs.ncrvoyix.com/restaurant/aloha-takeout/implementing/source_and_destination/implementing_source_and_destination
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Maintenance > Business > Store > Store Settings tab > Check Printing group > under the ‘Guest 
Check Content’ group bar. 2) To print the order mode name in red ink, select ‘Print order mode in 
red’ in Maintenance > Business > Store > Store Settings tab > Chit Printing group > under the 
‘Appearance’ group bar. 

Promise time 

Inserts a line feed, followed by a line containing the promise time and another line feed. Default 
Alignment: Center. Required Options: You must clear ‘Never print delivery/carryout information’ in 
Maintenance > Hardware > Printers > Options tab > under the ‘Chit printing’ group bar. 

Recipes 

Prints the defined recipe for any item, every ‘n’ times the item prints. Default Alignment: Header, 
Center; all else, Left. Required Options: 1) You must select ‘Enable recipes’ in Maintenance > 
Business > Store > Store Settings tab > User Interface group > under the ‘Display’ group bar. 2) You 
define the recipe for the item in ‘Recipe text’ in Maintenance > Menu > Items > General Settings tab 
> under the ‘Recipe Information’ group bar. 3) You must set the value of ‘Print recipe frequency’ in 
Maintenance > Menu > Items > General Settings tab > under the ‘Recipe Information’ group bar to a 
number greater than 0 (zero). 

Reward member text

Prints the text to indicate the consumer is a Loyalty rewards member. You must assign the consumer 
to the check in the Aloha POS system to populate this element. Default Alignment: Center. Related 
Options: You can customize the text to print using ‘Reward member text’ in Maintenance > Kitchen 
Configuration > Kitchen Settings. 

<line feed>

12:47 PM

<line feed>

Chicken Quesadillas

2 Flour tortillas

1 cup Chicken

8 oz Cheese

8 oz Tomatoes

8 oz Onions

1 tbls Sour Cream
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Set print style 

Sets the print size and format for all following text, such as a change to the size, italics, and more. To 
change or return to the default print style, you must add another ‘Set print style’ element. Default 
Alignment: Left; however, the element is only a command and does not print on the chit. 

Single chit text 

Prints up to 30 characters of additional text on the chit. Default Alignment: Center. Required 
Options: 1) You must select ‘Single-item’ or ‘Both’ as the ‘Chit type’ in Maintenance > Business > 
Store > Store Settings tab > Chit Printing group > under the ‘Content’ group bar. 2) You define the 
text in ‘Additional text to print on single-item chits’ in Maintenance > Business > Store > Store 
Settings tab > Chit Printing group > under the ‘Content’ group bar. 3) You can suppress the message 
by clearing ‘Print message if order contains items routed to more than one order printer’ in 
Maintenance > Business > Store > Store Settings tab > Chit Printing group > under the ‘Content’ 
group bar. 

Split chit message 

When you route an order to more than one production station, inserts a line feed followed by the 
message “More Items @,” followed by a line feed and then the ‘PrinterName” followed by one line 
for every other printer name used to fill the order. Default Alignment: Left. Required Options: You 
must select ‘Print message if order contains items routed to more than one order printer’ in Mainte-
nance > Business > Store > Store Settings tab > Chit Printing group > under the ‘Content’ group bar. 

Table tent 

Prints the text associated with the table tent feature. Default Alignment: Left. Required Options: 
Define the text to print in ‘Chit text’ in Maintenance > Business > Store > Store Settings tab > Chit 
Printing group > under the ‘Table Tent’ group bar. 

This chit contains a single item. Look for more 
chits to complete the order.

<line feed>

More Items @ <printer name>

Table Tent #
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Terminal name 

Prints the name of the terminal from which the items were ordered, if selected in the printer 
configuration. Default Alignment: Center. Required Options: You must select ‘Print terminal name’ 
in Maintenance > Hardware > Printers > Options tab > under the ‘Chit printing’ group bar. 

Total 

Prints a ‘Total’ line for each check on the order, if selected in the printer configuration. Default 
Alignment: Center. Required Options: You must route the chit to a printer for which you select 
‘Print order total’ in Maintenance > Hardware > Printers > Options tab > under the ‘Chit printing’ 
group bar. 

Training 

Prints a header containing two lines of text, “****TRAINING****,” “*DO NOT PREPARE*,” 
followed by a line feed. This is a required element in the layout but it prints only when a training 
employee is clocked in. Default Alignment: Center. 

User text 

Prints the contents specified in ‘Text’ under the ‘User text settings’ group bar that appears when you 
select this element. Default Alignment: Left. 

Term 1

Tip
The terminal name is also available using the ‘Custom line’ element, where you can combine the 
terminal name with two other elements in either the left, center, or right alignment. 

Total

****TRAINING****

****DO NOT PREPARE****

<line feed>

This line is intentionally left blank.
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Void 

Prints “***VOID***” for a voided item using a large font. This element only prints when you void an 
item. If you specify a void reason, the system prints this text at the end of the chit header. Default 
Alignment: Center. 

Zone 

Prints the zone text on the chit, as configured in Aloha Kitchen. Default Alignment: Center. 

***VOID***

1
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Appendix C: Guest check elements
The following is a comprehensive list of the elements available for use when you customize a guest 
check layout, listed in alphabetic order. The list includes the default alignment of the element as it 
appears on the generic guest check layout and a brief description. Also included are related or 
required options you must select or clear when adding the element to a custom guest check layout. 

Account receivable

Prints accounts receivable information on the guest check. Default Alignment: Left. 

Additional charge

Prints the additional charge information on the guest check. Default Alignment: Left. Required 
Options: You define additional charges in Maintenance > Business > Store > Store Settings tab > 
‘Financials’ group > ‘Additional charges’ group bar. 

Advance Order Footer 

Prints “Unfilled” or “Do not pay” when the order is an advance or future order. Default Alignment: 
Left. 

Advance Order Info

Prints the name, phone number, date, time, and order mode on the guest check when the order is an 
advance or future order. This is a Quick Service only feature. Default Alignment: Left. 

Alerts

Prints each alert for the order, followed by a line feed. Default Alignment: Center. 

Reference
Refer to the Alerts Feature Focus Guide - HKS334 for more information on alerts. 

https://docs.ncrvoyix.com/downloads/aloha-pos/QSTS_AlertsFFG-HKS334.pdf
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Aloha Loyalty check text 

Prints the custom text defined in Aloha Insight on the guest check. Default Alignment: Left. 

Aloha Loyalty new price 

Prints the message defined in Aloha Insight for the new price promotion. Default Alignment: Left. 

Barcode

Prints the bar code on the guest check in the format of “999xxxxxxxx” where ‘x’ is the check number 
with leading zeros. For example, for check ID 10001, “99900010001” prints. Default Alignment: 
Left. 

Bitmap

Prints a custom bitmap on each printed guest check. Default Alignment: Left. Required Options: 
You must configure the ‘Printer bitmap,’ ‘Printer bitmap size,’ and ‘Printer bitmap justification’ 
options in Maintenance > Business > Store > Store Settings tab > Check Printing group > under the 
‘Guest Check Content’ group bar, 

Credit earned for current visit:

Business Person’s Lunch-12 points

Beer Tout-5.00 spent

Current balance:

Business Person’s Lunch-22.00

Beer Tour-43 points

Reference
Refer to the Aloha Loyalty User Guide for more information on configuring and using Aloha Loyalty. 

Congratulations! You earned a 50%
coupon on your next visit. 

Reference
Refer to Receipt Logos - HKS1750 for more information on adding a bitmap to the guest check. 

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1750
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Cashier 

Prints the name of the cashier on the guest check, when an employee is clocked in with a job code 
configured as a cashier: otherwise, the server name prints. Default Alignment: Left. Required 
Options: You must select ‘Cashier’ in Maintenance > Labor > Jobcodes > Order Entry tab > under 
the ‘Order entry’ group bar. 

Change item

Prints the changed item information on the guest check. Default Alignment: Left. 

Club member number 

Prints the ID number of the club member associated with the order on the guest check. This is a Table 
Service only element. Default Alignment: Center. Required Options: You must select ‘Print club 
member number on check’ in Maintenance > Business > Store > Store Settings tab > Check Printing 
group > under the ‘Guest Check Content’ group bar. 

Comp form

Prints the custom comp approval form on the guest check, according to the print requirements of the 
form. Default Alignment: Left. Required Options: You must select ‘Print custom comp chit’ in 
Maintenance > Business > Store > Store Settings tab > Check Printing group > under the ‘Comp 
Slips’ group bar. 

Cashier: Suzie

1524

Reference
Refer to the Interfacing with Memberships User Guide for more information on memberships.

Reference
Refer to the Comp Approval Forms Feature Focus Guide - HKS345 for complete information on 
configuring and using comp approval forms. 

https://docs.ncrvoyix.com/downloads/aloha-pos/QSTS_CompApprovalFormsFFG-HKS345.pdf
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Custom line 

Allows you to print up to three elements on the same line, starting with left alignment, then center, 
then right. Add a custom line for each line. There is a very specific list of elements from which you 
can choose. See “Using a custom line element to position multiple elements (all layouts)” on 
page 28. Default Alignment: Left. Select from the following to complete your custom line:  

Cut

Cuts the chit at the defined section. 

Day part 

Prints “DAY PART:” followed by the name of the day part in effect on the guest check. Default 
Alignment: Left. Required Options: You must select ‘Print Daypart’ in Maintenance > Business > 
Store > Store Settings tab > Check Printing group > under the ‘Guest Check Content’ group bar.

Delivery Info 

Prints delivery information, if the printer is configured to print this information. Default Alignment: 
Left. Required Options: 1) You must clear ‘Never print delivery/carryout information’ in 
Maintenance > Hardware > Printers > Options tab > under the ‘Chit printing’ group bar to allow 
delivery information to print. 2) You must interface with Aloha Takeout to use this feature. 

Disclaimer

Prints the training mode disclaimer on the guest check. Default Alignment: Left. 

3/16/2013

Susie Server 2:03 PM

Table 10 1 of 1

Cashier name Check number Current date

Current time Guest count Number of number

Order name Order number Ordermode name

Pager number Printer name Server name

Tent number Terminal name

DAY PART: 11-12 AM
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Duplicate 

Prints DUPLICATE, followed by the number of prints, when you reprint the check after it is closed. 
Default Alignment: Center. Required Options: You must select USEDUALREPRINTNUMBERING in 
Maintenance > Business > Store > Custom tab > under the ‘Name’ group bar to enable this option. 

Employee 

Prints the nickname of the employee on the guest check. The first and last name do not print on the 
guest check. Default Alignment: Left.

Exclusive Taxes Breakout 

Prints a list of each applied exclusive tax on the guest check. Default Alignment: Left. Required 
Options: You must select ‘Print exclusive tax breakout’ and ‘Print exclusive tax breakout section’ on 
guest check’ in Maintenance > Business > Store > Store Settings group > Check Printing group > 
under the ‘Tax Breakout’ group bar. 

Filled line 

Prints a line across the guest check using the character you designate, such as * or =, in ‘Text’ under 
the ‘Filled line settings’ group bar that appears when you select this element. Default Alignment: 
Left. 

Fiscal Quebec Transaction ID/Date 

Prints the transaction ID on the left of the guest check, and the transaction date on the right. Default 
Alignment: Left. Required Options: You must be using Fiscal Quebec to enable this element. 

DUPLICATE

Suzie

Exclusive Taxes

8% Base 6.00 IncTax 0.48

5% Base 5.00 IncTax 0.25

2% Base 14.98 IncTax 0.30

**********************************

123456 04/16/2013
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Footer 

Prints “---Check Closed---” in the footer of the guest check if it is closed. Default Alignment: Center. 

Frequent Diner Message

This element relates to the Delivery/Frequent Buyer program, which is obsolete. Default Alignment: 
Left. 

Frequent Diner Subtotal

This element relates to the Delivery/Frequent Buyer program, which is obsolete. Default Alignment: 
Left. 

Gift card international info

Prints the gift card International information on the guest check. Default Alignment: Left. 

Gift Card Offline Message

Prints a custom offline gift card message when the check contains gift card transactions occuring 
during offline mode. Default Alignment: Left. 

Gratuity

Prints the gratuity information on the guest check. Default Alignment: Left.

Guest Check Messages

Prints a guest check message. Default Alignment: Left. Required Options: You must access 
Maintenance > Messaging > Guest Check Messages and define a guest check message to print. 

Guest Count 

Prints the guest count on the guest check. If a refund is performed, the count is zero. Default 
Alignment: Left. 

---Check Closed---

Guest: 3
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Header 

Prints the store name, address, and phone number, if defined. The header also includes an optional 
list of items configured in a guest check token file. Default Alignment: Center.

Inclusive Taxes Breakout 

Prints a list of each applied inclusive tax on the guest check. Default Alignment: Left. Required 
Options: You must select ‘Print inclusive tax breakout’ and Print inclusive tax breakout section on 
guest check’ in Maintenance > Business > Store > Store Settings group > Check Printing group > 
under the ‘Tax Breakout’ group bar. 

Items 

Specifies where the main item section appears on the printed guest check. The system considers 
items the main body of information on a guest check and always positions items between the header 
and footer. This is a required element in a guest check layout. Default Alignment: Left. 

Large Check Name

Prints the check name in large font on the guest check. This is a Quick Service only feature. Default 
Alignment: Left. Required Options: You must select ‘Use large font for order name’ in Maintenance 
> Business > Store > Store Settings tab > Check Printing group > under the ‘Guest Check Style’ 
group bar. 

Linefeed 

Inserts an empty line into the print design for the guest check. Default Alignment: Left. 

Aloha Cafe #1234

111 Anywhere

555-555-5555

GST Taxes

8% Base 6.00 IncTax 0.48

5% Base 5.00 IncTax 0.25

2% Base 14.98 IncTax 0.30

<line feed>
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Menu Name 

Prints “Menu:” followed by the name of the current menu in use on the guest check. Default 
Alignment: Left. Required Options: You must select ‘Print Menu name’ in Maintenance > Business 
> Store > Store Settings tab > Check Printing group > under the ‘Guest Check Content’ group bar. 

Order / Check Number 

Prints the check or order number on the left side of the guest check. Default Alignment: Left. 
Related Options: 1) If you select ‘Do not print check number’ in Maintenance > Business > Store > 
Store Settings tab > Check Printing group > under the ‘Guest Check Content’ group bar, the check 
number prints on the right side. 2) To print the order number in bold font, select ‘Use bold font for 
check number’ in Maintenance > Business > Store > Store Settings tab > Check Printing group > 
under the ‘Guest Check Style’ group bar. This is a Table Service only option. 

Order Attribute 

Prints the name and ID of the order attribute (sales type) on the guest check. This is Table Service 
only. Default Alignment: Left. Required Options: You must select ‘Print sales type’ in Maintenance 
> Business > Store > Store Settings group > Check Printing group > under the ‘Guest Check 
Content’ group bar. 

Order Mode 

Prints the order mode applied to the order on the guest check. Default Alignment: Left. Required 
Options: You must select ‘Print order mode’ in Maintenance > Business > Store > Store Settings tab 
> Check Printing group > under the ‘Guest Check Content’ group bar. 

Order Mode Charge

Prints the order mode charge. Default Alignment: Left.

Paymentech agreement

Prints the Paymentech agreement message. Default Alignment. Left. 

Menu: Lunch

Order: 123456

Sales Type: Banquet

Order Type: Dine In
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Payment Information

Prints the general payment information, such as cash, credit card, authorization code, tip, and more. 
Default Alignment: Left. 

Phone Number

Prints the phone number of the guest on the chit. Default Alignment. Left. Required Options: You 
must configure your Aloha Takeout phone number requirements under the ‘Settings’ group bar on 
the Phone Numbers tab in Maintenance > Takeout Configuration > Takeout Settings. 

Placeholder Element 

Contains non-printing, optional text, to use as a label in your design, such as **END OF HEADER** 
or **START OF TRAILER**. Designate the label text in ‘Placeholder text’ under the ‘Placeholder text 
settings’ group bar that appears when you select this element. Default Alignment: Left. 

PMS Info 

Prints the PMS room number and name of the guest on the guest check, for checks closed to a tender 
used with PMS. The element also prints a signature line, if it was not previously printed. Default 
Alignment: Left. Required Options: You must select ‘Print room number and guest name lines’ in 
Maintenance > Business > Store > Store Settings tab > Guest Check group > under the ‘Guest Check 
Content’ group bar.

PMS Room 

Prints the name of the guest associated with the room on the guest check, for checks closed to a 
tender used with PMS. Default Alignment: Left. Required Options: You must select ‘Print Hotel 
PMS guest name’ in Maintenance > Business > Store > Store Settings tab > Guest Check group > 
under the ‘Guest Check Content’ group bar.

Quebec Fiscal Info

Prints the transaction ID on the left side of the guest check, and the transaction date on the right. 
Default Alignment: Left. Required Options: You must enable Revenu Quebec in Maintenance > 

**END OF HEADER**

Room: 21B

Guest: John Smith

x __________________________________

Guest: John Smith
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Business > Store > Store Settings tab > Check Printing group > ‘Guest Check Content > Fiscal 
printer’ group bar. 

Refund 

Prints “REFUND” on the guest check when you perform a refund on the check. Default Alignment: 
Center.

Reprint 

Prints REPRINT, followed by the number of prints, when you reprint the check after it is closed. 
Default Alignment: Center. Required Options: You must clear ‘USEDUALREPRINTNUMBERING’ in 
Maintenance > Business > Store > Custom tab > under the ‘Name’ group bar to enable this option.

Revenue Center 

Prints “Area:” followed by the name of the revenue center from which the check originated on the 
guest check. Default Alignment: Left. Required Options: You must select ‘Print Revenue Center’ in 
Maintenance > Business > Store > Store Settings tab > Check Printing group > under the ‘Guest 
check content’ group bar. 

Sales Category Detail 

Prints a subtotal and grand total line for each sales category from which an item was entered on the 
guest check. Default Alignment: Left. Required Options: You must select ‘Print sales category 
totals’ in Maintenance > Business > Store > Store Settings tab > Check Printing group > under the 
‘Guest check content’ group bar. 

Seat Total

Prints the total sales value for each seat (guest). Default Alignment: Left. 

REFUND

REPRINT

Area: Patio

Sales: $4.00

Retail: $0.90

Total: $ 4.90
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Separate Survey

Prints the customer survey message text on the guest check, based on the printing requirements of 
the survey. You must configure the survey to print independently and the survey prints after the guest 
check. Default Alignment: Left. Required Options: 1) You must select ‘Active’ and select ‘Print 
Survey separately’ in Maintenance > Messaging > Survey > Survey tab> under the ‘Settings’ group 
bar. 2) You must specify the message to print in ‘Message text 1’ through ‘Message text 20’ in 
Maintenance > Messaging > Survey > Message tab > under the ‘Message text’ group bar. 

Service Charge 

Prints the text defined for additional charges, along with the amount, on the guest check. Default 
Alignment: Left. Required Options: You must type the text for the additional charge in ‘Text’ in 
Maintenance > Business > Store > Store Settings tab > Financials group > under the ‘Additional 
charges’ group bar. 

Set Print Style 

Sets the print size and format for all following text, such as a change to the size, italics, and more. To 
change or return to the default print style, you must add another ‘Set print style’ element. Default 
Alignment: Left; however, the element is only a command and does not print. 

Signature 

Prints a Total, Tip, and Signature line on the guest check, when printed before closing the check. 
Default Alignment: Left. Required Options: You must select ‘Print total, tip and signature lines on 
all checks’ in Maintenance > Business > Store > Store Settings tab > Check Printing group > under 
the ‘Guest Check Content’ group bar. 

Reference
Refer to the Customer Survey Feature Focus Guide - HKS304 for complete information on 
configuring and using the customer survey feature. 

Additional Charge 2.00

Total: __________

Tip: __________

________________________

https://docs.ncrvoyix.com/downloads/aloha-pos/QSTS_CustomerSurveyFFG-HKS304.pdf
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Surcharge

Prints the surcharge information on the guest check. Default Alignment: Left. Required Options: 
You define surcharges in Maintenance > Business > Store > Store Settings > ‘Financials’ group > 
‘Surcharge’ group bar.

Survey Banner Text 

Prints the customer survey banner text on the guest check, based on the printing requirements of the 
survey. You must configure the survey to append to the guest check and not print separately to use 
this feature. Default Alignment: Left. Required Options: 1) You must select ‘Active’ and clear ‘Print 
Survey separately’ in Maintenance > Messaging > Survey > Survey tab > under the ‘Settings’ group 
bar. 2) You must specify the text to print in ‘Banner text 1’ through ‘Banner text 10’ in Maintenance > 
Messaging > Survey > Banner tab > under the ‘Text lines’ group bar. 

Survey Message

Prints the customer survey message text on the guest check based on the printing requirements of the 
survey. Default Alignment: Left. Required Options: 1) You must select ‘Active’ and select ‘Print 
Survey separately’ in Maintenance > Messaging > Survey > Survey tab > under the ‘Settings’ group 
bar. 2) You must specify the message to print in ‘Message text 1’ through ‘Message text 20’ in 
Maintenance > Messaging > Survey > Message tab > under the ‘Message text’ group bar. 

Table Name  

Prints the alphanumeric name associated with the table on the guest check. Default Alignment: Left.

Tax invoice information

Prints tax invoice information on the guest check. Default Alignment: Left. 

You have been selected for the 

Aloha Cafe’s guest poll!!

Reference
Refer to the Customer Survey Feature Focus Guide - HKS304 for complete information on 
configuring and using the customer survey feature. 

Table: 11

https://docs.ncrvoyix.com/downloads/aloha-pos/QSTS_CustomerSurveyFFG-HKS304.pdf
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Tender Signature

Prints a signature line on the guest check, based on the tender. Default Alignment: Left. Required 
Options: You must select ‘Print signature line’ in Maintenance > Payments > Tenders > Tender tab > 
under the ‘Settings’ group bar. 

Time 

Prints the current time on the guest check. Default Alignment: Right.

Total 

Prints the total guest check value preceded by the order mode. Default Alignment: Right. 

Total Tax

Prints the total tax value on the guest check. Default Alignment: Left. Required Options: You must 
select ‘Print total tax line’ in Maintenance > Business > Store > Store Settings tab > Check Printing 
group > under the ‘Guest Check Content’ group bar. 

Training 

Prints a header containing two lines of text, “****TRAINING****,” “*DO NOT PREPARE*,” 
followed by a line feed. This is a required element in the layout and only prints when a training 
employee is clocked in. Default Alignment: Center. 

Two Part Check 

Inserts a partial cut after the first check, then prints the check number, table name, time, and date on 
the second guest check. Default Alignment: Left. 

User Text 

Prints the contents specified in ‘Text’ in Print Designer > Design tab > ‘User text settings’ group bar 
that appears when you select this element. Default Alignment: Left. 

12:30 PM

Dine In Total $3.48

****TRAINING****

****DO NOT PREPARE****

<line feed>

This line is intentially left blank.
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VBO Text

Prints the VBO (ecard) message on the guest check. 
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Appendix D: General message elements
The following is a comprehensive list of the available elements when designing printed vouchers for 
use with campaigns to drive traffic back in to your restaurant. Use the Campaign Rulebook function to 
define the actual set of conditions under which a guest earns a voucher reward. The list includes the 
default alignment of the element as it appears on the printed vouchers and a brief description. Also 
included are related or required options you must select or clear when adding the element to a 
voucher.

Bitmap

Prints a custom bitmap on each printed guest check. Default Alignment: Left. Required Options: 
You must configure the ‘Printer bitmap,’ ‘Printer bitmap size,’ and ‘Printer bitmap justification’ 
options in Maintenance > Business > Store > Store Settings tab > Check Printing group > under the 
‘Guest Check Content’ group bar, 

Cashier 

Prints the name of the cashier on the guest check, when an employee is clocked in with a job code 
configured as a cashier: otherwise, the server name prints. Default Alignment: Left. Required 
Options: You must select ‘Cashier’ in Maintenance > Labor > Jobcodes > Order Entry tab > under 
the ‘Order entry’ group bar. 

Employee 

Prints the nickname of the server on the reward voucher. The first and last name do not print on the 
voucher. Default Alignment: Left.

Filled Line 

Prints a line across the reward voucher using the character you designate, such as * or =, in ‘Text’ 
under the ‘Filled line settings’ group bar that appears when you select this element. Default 
Alignment: Left. 

Reference
Refer to Receipt Logos -HKS1750 for more information on adding a bitmap to the guest check. 

Cashier: Suzie

Suzie

**********************************

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS1750


 Print Designer
Appendix D: General message elements

75

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Header

Prints the store name, address, and phone number, if defined. Default Alignment: Center.

Linefeed

Inserts a blank line between two lines of text. 

Placeholder Text  

Contains non-printing, optional text, to use as a label in your design, such as **END OF HEADER** 
or **START OF TRAILER**. Designate the label text in ‘Placeholder text’ under the ‘Placeholder text 
settings’ group bar that appears when you select this element. Default Alignment: Left. 

Redemption Period 

Establishes the number of calendar days after printing a reward voucher an offer is valid. The system 
uses the number of days to determine and print the beginning and ending dates during which a 
guest can redeem a voucher for an earned reward. Default Alignment: Left. 

Set Print Style 

Sets the print size and format for all following text, such as a change to the size, italics, and more. To 
change or return to the default print style, you must add another ‘Set print style’ element. Default 
Alignment: Left; however, the element is only a command and does not print. 

User Text 

Prints the contents specified in ‘Text’ under the ‘User text settings’ group bar that appears when you 
select this element. Default Alignment: Left. 

**END OF HEADER**

2:00 PM, Thu Jun 14, 2025

This line is intentionally left blank.
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Print Designer, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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