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About Item Modifier Counts  

Some restaurants offer items on their menu that allow, or require, the selection of multiple modifiers, 
or groupings of modifiers, to fulfill the item. The following are only a few scenarios to which you 
might apply the Item Modifier Counts feature, available in Aloha® Quick Service and Aloha Table 
Service: 

● Wings - Due to the small individual pieces of wings, most wing restaurants sell bulk orders of 
wings, such as ‘50 Wings,’ as the single parent item. Within the item, the guest can choose from 
a wide variety of sauces, such as hot, mild, sweet, and more, until the choices fulfill the number 
of wings required for the order. 

● Chicken Bucket - Because there are different parts of a chicken, a restaurant could sell a bulk 
order of chicken, such as a ‘Chicken Bucket,’ as the single parent item. Within the item, the guest 
can choose from each part of the chicken, such as breast, wing, drumstick, and more, until the 
choices fulfill the number of chicken pieces required for the order. 

● Dozen Doughnuts - Since doughnuts come in a variety of different types and flavors, a doughnut 
shop bases their business on selling doughnuts in bulk, such as a ‘Dozen Doughnuts.’ Within the 
item, the guest can choose from different types of doughnuts, such as glazed, chocolate, apple 
fritter, and more, until the choices fulfill the number of doughnuts required for the order. 

● Boxed Tacos - To satisfy a catering and delivery need, a restaurant could offer a bulk order of 
tacos, such as ‘Boxed Tacos,’ as the single parent item. Within the item, the guest can choose the 
different types of tacos, such as beef, chicken, chorizo, and more, until the choices fulfill the 
number of tacos required for the order. 

Item Modifier Counts at a Glance

Core Product Aloha® Quick Service, Aloha Table Service

Complementary Products

Separate License Required? No

Other References Aloha Quick Service Reference Guide, Aloha Quick Service 
Screen Designer Guide, Aloha Table Service Reference Guide, 
Aloha Table Service Screen Designer Guide

50 Wings Chicken Bucket Dozen Doughnuts Boxed Tacos

Hot (10) Breasts (1) Glazed (4) Beef (10)

Mild (20 Wings (2) Choc (4) Ckn (15)

Sweet (20) Thigh (3) Apple Fritter (4) Chorizo (25)
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The Aloha POS solution
Today, you can order multiple counts of item modifiers; however, you have to press the desired 
modifier several times to reach the desired number. When you use the generic quantity button on the 
Front-of-House (FOH), or singular quantity buttons available in Aloha Quick Service, the function 
applies to items only, not modifiers. Additionally, when you enter modifiers for an item, the system 
places them on the check as you enter them and does not group like modifiers together. This could 
impact your speed of service and increase your chances of entering the wrong type or the wrong 
number of modifiers. 

With the ‘Item Modifier Counts’ feature in either Aloha Quick Service or Aloha Table Service v12.3, 
you can create panels with specific button functions to help you better manage the ordering of 
multiple counts of modifiers. From these panels, you can perform all functions for managing the 
modifiers for the selected item, such as adding, deleting, and clearing modifiers, enforcing 
minimum, maximum, and free restrictions, as well as applying modifier codes. For Aloha Table 
Service, you use a custom panel that overlays the modifier button area of the hard-coded classic 
modifier screen. For Aloha Quick Service, you can use a regular panel. 

Figure 1  User-Defined Modifier Item Count Panel
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Item modifier count feature set support
The following describes each feature of Item Modifier Counts and its behavior in relation to Aloha 
Quick Service and Aloha Table Service. 

Feature Aloha Quick Service Aloha Table Service

Able to add a single-digit count of an item 
modifier.

Supported. Supported.

Able to clear the current modifier count. Supported. Supported.

Able to add double-digit counts of item 
modifiers.

Supported. Supported. 

Able to navigate to a specific submenu 
panel after fulfilling the item modifier 
count. 

Not available. Supported.

Able to enter a special message for the 
item using an on-screen keyboard.

Not supported. Supported.

Able to display the name of the modifier 
group from which you are working and the 
remaining count to meet the minimum for 
the modifier group. 

In Aloha Quick Service, you 
configure the ‘Required 
Modifier Countdown’ button 
on a panel. The name of the 
modifier group appears on 
the button and is read-only. 

In Aloha Table Service, this is 
supported on the hard-coded 
‘classic’ Modifier screen. The 
option, ‘Show required 
modifier countdown’ in 
Modifier Group Maintenance 
allows you to add a 
countdown indicator on the 
modifier group button. 

Able to display the count on the modifier 
button. 

Supported. Not supported.

Respects the minimum and maximum 
modifier group requirements.

In Aloha Quick Service, you 
can add modifiers from any 
modifier group attached to 
the item to fulfill the 
min/max requirements for a 
modifier group. The system 
validates each requirement 
at the time you fulfill the 
item. 

In Aloha Table Service, you 
must add modifiers to fulfill 
the min/max requirements 
for each modifier group, in 
succession only. 

Support for the hard-coded ‘classic’ 
Modifier screen.

In Aloha Quick Service, this 
feature disables the prompt 
for the ‘classic’ Modifier 
screen. 

In Aloha Table Service, this 
feature uses the ‘classic’ 
Modifier screen and overlays 
a portion of the screen with a 
custom Modifier panel. 
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Able to clear all modifiers from an item 
and start over on the count. 

In Aloha Quick Service, the 
system clears modifiers from 
ALL the modifier groups 
attached to the menu item. 

In Aloha Table Service, the 
system clears modifiers from 
ONLY the modifier group 
from which you are working. 
You must clear modifiers 
from one modifier group at a 
time. 

Feature Aloha Quick Service Aloha Table Service
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Configuring Item Modifier Counts
This section details the configuration requirements within Aloha Manager and Aloha Configuration 
Center (CFC) for Item Modifier Counts. If you are an experienced user, refer to Procedures at a 
Glance for abbreviated steps. If you prefer more detail, continue reading this document.  

Creating items and modifiers
Configure items and modifiers in Item Maintenance as you would any item or modifier. You will 
return to Item Maintenance to attach the modifier groups to your items. 

To create items and modifiers:

1. Select Maintenance > Menu > Items. 
2. Click the New drop-down arrow, select Standard as the type, and click OK. 
3. Accept the system assigned number or click the ellipses (...) next to ‘Number’ to display the 

Number Assignment dialog box, from which you can choose an alternate number. 
4. Type a short name, chit name, and long name for the item. 
5. Select a tax to define for the item. 
6. Complete the remaining options as you would any other item or modifier. 
7. Click Save. 
8. Exit the Items function. 

Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Access Maintenance > Menu > Items and configure your items and modifiers as you would any 
item or modifier. See page 8. 

2. Access Maintenance > Menu > Modifier Groups and add each modifier to a modifier group. See 
page 9. 

3. Access Maintenance > Menu > Items and attach modifier groups to your items. See page 11. 

4. For Aloha Quick Service, access Maintenance > Business > Store > Store Settings tab > User 
Interface group and enable the modifier count to appear on each modifier button. See page 11. 

5. Access Screen Designer and create your panels to manage the ordering of item modifier counts. 
For Quick Service, create a panel as a regular panel type. For Table Service, you create a custom 
modifier panel and replace the modifier button area with that panel. See page 12. 
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Creating a modifier group
After you create your modifiers in Item Maintenance, attach the modifiers to a modifier group. For 
example, if all wings have the same choices of different flavors, include them in the modifier group. 
If there is a difference between the minimum and maximum requirements, you must create separate 
modifier groups to reflect this. For example, for a ‘50 Wings’ item, the minimum and maximum is 
50; however for a ‘12 Wings’ item, the minimum and maximum is 12. 

For Table Service operations, you will return to Modifier Group Maintenance to attach a modifier 
panel to the modifier group. 

To create a modifier group:

1. Select Maintenance > Menu > Modifier Groups. 
2. Click the New drop-down arrow, select Standard as the type, and click OK. 
3. Accept the system assigned number or click the ellipses (...) next to ‘Number’ to display the 

Number Assignment dialog box, from which you can choose an alternate number. 

4. Type a short name and long name for the modifier group. 
5. Type the minimum number of modifiers you must select from the modifier group to fulfill the 

item. For example, for a ‘50 Wings’ item, type 50. 
6. Type the maximum number of modifiers you can select from the modifier group. For example, 

for a ‘Dozen Doughnuts’ item, you can only type 12. 

Figure 2  Modifier Groups - Modifier Tab
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7. For Quick Service operations, select Suppress classic modifier screen to prevent the system 
from displaying the hard-coded classic modifier screen when the modifier group has one or more 
minimum required modifiers, as defined in ‘Minimum.’ You must clear ‘Screen flow required’ to 
enable this option. 

8. For Aloha Table Service operations, optionally select Remove special message button to 
prevent the Typewriter button from appearing in the bottom left corner of the hard-coded classic 
modifier screen when making selections for this modifier group. Do this to remove the ability to 
type user-defined text for the item. 

9. For Aloha Table Service operations, optionally select Show required modifier countdown to 
display a countdown in red text in the upper left corner of the modifier group button, indicating 
the remaining number of modifiers a guest must choose to fulfill the modifier requirements for 
the modifier group. The countdown defaults to the value in ‘Minimum’ and lowers as you enter 
guest selections. If ‘Minimum’ is set to 0 (zero), the countdown indicator does not appear on the 
modifier group button. Note: This is the equivalent to the ‘Required Modifier Countdown’ button 
function available in Quick Service Screen Designer. See “Designing the interface to manage 
item modifier counts” on page 12.

10. Select the Layout tab. 
11. Select a button from the grid. The location of the button on the grid does not matter because you 

determine the button placement in Screen Designer for both Aloha Quick Service and Table 
Service. 

12. Select the modifier from the ‘Item’ drop-down list. 
13. Repeat steps 11 and 12 until you add all modifiers to the modifier group. 
14. Click Save. 
15. Repeat this procedure until you create all necessary modifier groups. 
16. Exit the Modifier Groups function. 
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Attaching a modifier group to an item
After you add modifiers to a modifier group, you attach the modifier group to each applicable item. 
For example, for the ‘50 Wings’ item, you attach the modifier group with your flavors for the ‘50 
Wings’ item. 

To attach a modifier group to an item:

1. Select Maintenance > Menu > Items. 
2. Select the item to which you want to attach a modifier group from the drop-down list. 
3. Select the Modifier tab. 
4. Select the modifier group from one of the ‘Modifier’ drop-down lists. 
5. Repeat step 4 if you have any other modifier groups you need to attach to the item. 
6. Click Save. 
7. Repeat this procedure for each item you wan to attach a modifier group. 
8. Exit the Items function. 

Configuring the current count to appear on modifier button (QS)
In Aloha Quick Service, you can enable the system to display the item modifier count on all modifier 
buttons when you apply a count. This allows you to quickly see the count of a specific modifier you 
added to the item. 

To display the item modifier count on the modifier button:

1. Select Maintenance > Business > Store. 
2. Select the Store Settings tab. 

Figure 3  Count on Modifier Button
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3. Select the User Interface group from the bottom of the screen. 

4. Under the ‘Display’ group bar, select Display count on modifier buttons to enable the system 
to display the modifier count on each button for which you apply an item modifier count. 

5. Click Save and exit the Store function. 

Designing the interface to manage item modifier counts
You manage the ordering of item modifier counts from a panel you create in Screen Designer. The 
procedure is different depending on if you use Aloha Quick Service or Table Service. 

Aloha Quick Service
For Aloha Quick Service, you use the same panel type as you would for any other buttons in Aloha 
Quick Service. 

To design the interface to manage item modifier counts in Quick Service:

● Create an ‘item modifier count’ panel.
● Add buttons to the ‘item modifier count’ panel.

Figure 4  Store Settings - User Interface Group
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Creating an item modifier count panel
You must first create an ‘item modifier count’ panel on which to place your buttons or you can use an 
existing panel; however, due to the real estate needed, creating a new panel is preferable. To access 
the panel in the FOH once you create it, you can:

● Configure a script for your item buttons, such as ‘50 Wings,’ that includes ordering the item and 
displaying your ‘item modifier count’ panel. 

● Configure your ‘item modifier item count’ panel as a context panel so that it appears each time 
you enter an item, such as ‘50 Wings.’ This is the preferred method.

To create a panel in Quick Service:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer. The Quick 
Service Screen Designer dialog box appears. 

2. Select Work with Panels. The Properties dialog box appears along with a blank workspace. 
3. Select Panel > New Panel. A new panel appears. 
4. Size and relocate the panel, as needed. 
5. Under the ‘Identification’ group bar of the Properties dialog box, type a name and a description 

for the panel. 
6. Under the ‘Appearance’ group bar, set the remaining optional attributes the same as you would 

any other panel. 
7. If this is a context panel, set Context to True to make the panel a context panel. 
8. Continue to the next procedure. 

Reference:  Refer to the Context Panels Feature Focus Guide for information on how to config-
ure and use context panels.
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Adding buttons to an item modifier count panel
You can add up to 50 buttons to an ‘item modifier count’ panel, either one button at a time or 
multiple buttons using a grid. While adding buttons, you must select the appropriate function from 
the ‘Action’ drop-down list in the Properties dialog box, one button at a time. Design the layout of the 
panel to fit your needs, but we recommend you design the count buttons in the form of a keypad. 

The following example depicts a Quick Service panel for a ‘50 Wings’ item. When you access the 
panel, you can do such things as display the current count of modifiers, a user-defined numeric 
keypad with incremental quantities, modifiers, and modifier codes. 

Figure 5  Sample Custom Modifier Panel

display current count 
button 

clear modifiers but-
ton 

clear current count 
button 

modifier code 
buttons 
order modifier 
buttons

single-digit count buttons 

double-digit count 
buttons 

required modifier 
countdown button
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To add a button to an ‘item modifier count’ panel: 

1. With the ‘item modifier count’ panel open, select Panel > New Button. 

2. Under the ‘Function’ group bar of the Properties dialog box, select one of the following button 
functions from the ‘Action’ drop-down list. 

Figure 6  Properties Dialog Box for a Count Button Function 
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To add a ‘Required Modifier Countdown’ button, select Required Modifier Countdown from 
the ‘Action’ drop-down list and select the modifier group number, in relation to the order of the 
modifier groups you have defined for the item in Maintenance > Menu > Items > Modifier tab. 
The button displays the name of the modifier group and a countdown of the minimum number of 
modifiers left to fulfill the item. This is a read-only button and you can add as many Required 
Modifier Countdown buttons for each modifier group attached to the item as needed. Note: This 
is the equivalent to the ‘Show required modifier countdown’ option available in Maintenance > 
Menu > Modifier Groups in Table Service. See “Creating a modifier group” on page 9. 

To add a ‘Clear Modifiers’ button, select Clear Modifiers from the ‘Action’ drop-down list to 
remove all modifiers added to an unordered item and revert the menu item back to a single-entry 
state. Use this button function when you have a large number of modifiers added to an item and 
you want to remove them. You cannot use this function within a script. 
To add a ‘Double-Digit Count’ button that enables you to enter double-digit quantities of the 
modifier item, select Count from the ‘Action’ drop-down list and select Apply Count from the 
‘Count Type’ drop-down list. Then set ‘Append’ to True. For example, you can enter a quantity of 
12 for a modifier item by touching the 1 and then the 2 count buttons before touching the 
modifier item. 

To add a ‘Modifier Code’ button, select Modifier Code from the ‘Action’ drop-down list and 
select a modifier code from the ‘Modifier Codes’ drop-down list. This allows you to designate a 
preceding preparation code for a modifier, such as No, Extra, and Side. You must touch this 
button before selecting a modifier item. 

Figure 7  Required Modifier Count Button Function

Figure 8  Count (Double-Digit) Button Function

Figure 9  Modifier Code Button Function
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To add an ‘Order Modifier’ button, select Order Modifier from the ‘Action’ drop-down list and 
select a modifier from the ‘Modifier Item’ drop-down list. This allows you to add a modifier to the 
selected menu item or the last item ordered, if there is an association between the modifier and 
the item. 

To allow the order modifier button to fill the remaining count, set Fill remaining count to True to 
use the remaining minimum count with the modifier item to the menu item based on the 
remaining quantity of modifiers needed to fulfill the minimum required for the modifier group. 
For example, if the modifier group requires you to select a minimum of 10 modifiers, and you 
have already selected five, the system adds the selected modifier to the check using a quantity of 
five. If you select a count prior to selecting the modifier, the system ignores ‘Fill remaining count’ 
and adds the modifier based on the selected count. 
To add a ‘Display Current Count’ button, select Count from the ‘Action’ drop-down list and select 
Display current count from the ‘Count Type’ drop-down list. This displays the currently selected 
count of the modifier item on the modifier panel. If the count is zero, the button is blank. 

To add a ‘Single-Digit Count’ button, select Count from the ‘Action’ drop-down list and select 
Apply Count from the ‘Count Type’ drop-down list. Then specify the quantity, from 1 to 999, of 
the modifier item to apply when you touch this button. This applies the next modifier item you 
select to the menu item using the number stipulated for this button in ‘Count.’ For example, for 
the ‘10 Wings’ menu item, if you touch a button defined with a ‘Count’ of 5 and then touch the 
‘Hot’ modifier item, the system indicates the customer wants five of the ten wings modified with 
the ‘Hot’ modifier item. 

Figure 10  Order Modifier Button Function

Figure 11  Count (Display Current Count) Button Function

Figure 12  Count (Single-Digit) Button Function
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To add a ‘Clear Current Count’ button, select Count from the ‘Action’ drop-down list and select 
Clear current count from the ‘Count Type’ drop-down list. This resets the current count of the 
modifier item back to 0 (zero). 

3. Repeat Steps 1 and 2 until you add all the necessary buttons to the ‘item modifier count’ panel. 
4. Select Panel > Save Panel. 
5. Select File > Exit to exit Quick Service Screen Designer. 

Aloha Table Service
For Aloha Table Service, you must create a custom panel of the Modifier Panel type using Screen 
Designer to replace the hard-coded classic modifier screen. You cannot use the classic modifier 
screen to manage item modifier counts. 

To manage item modifier counts in Table Service:

● Create a custom ‘item modifier count’ panel of the Modifier Panel type. 
● Add buttons to the custom ‘item modifier count’ panel.
● Replace the modifier button area with the ‘item modifier count’ panel. 

Figure 13  Count (Clear Current Count) Button Function

Figure 14  Classic Modifier Screen

‘classic’ modifier 
screen

custom modifier 
panel

modifier button 
area 



 Item Modifier Counts
Configuring Item Modifier Counts

19

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Creating a custom item modifier count panel
You must create a custom panel of the Modifier Panel type to manage item modifier counts. The 
panel is in a fixed position and replaces the modifier button area on the ‘classic’ modifier screen. You 
cannot chain to another custom modifier panel so you must add all necessary modifiers to this panel. 

To create an ‘item modifier count’ panel in Table Service:

1. Select Maintenance > Screen Designer > Table Service Screen Designer. The Table 
Service Screen Designer dialog box appears. 

2. Select Work with Panels. The Properties dialog box appears along with a blank workspace. 
3. Select Panel > New Modifier Panel. 

A new modifier panel appears in a fixed position on the right side of the workspace. 

Figure 15  Panel Drop-Down Menu

Figure 16  Screen Designer Workspace with a Modifier Panel
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4. Under the ‘Identification’ group bar of the Properties dialog box, type a name and a description 
for the ‘item modifier count’ panel. 

5. Under the ‘Appearance’ group bar, set the remaining optional attributes the same as you would 
any other panel.

6. Continue to the next procedure. 

Adding buttons to an item modifier count panel
You can add up to 50 buttons to an ‘item modifier count’ panel, either one button at a time or 
multiple buttons using a grid. While adding buttons, it is necessary to select the appropriate function 
from the ‘Action’ drop-down list in the Properties dialog box, one button at a time. Design the layout 
of the panel to your needs, but we recommend you design the count buttons in the form of a keypad. 

The following example depicts a custom ‘item modifier count’ panel for a ‘50 Wings’ item. When you 
access the panel, you can do such things as display the current count of modifiers, a user-defined 
numeric keypad with incremental quantities, modifiers, modifier codes, and buttons allowing you to 
navigate to a specific submenu. 

Figure 17  Sample Custom Item Modifier Count Panel
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To add a button to an ‘item modifier count’ panel: 

1. With the custom ‘item modifier count’ panel open, select Panel > New Button.  

2. Under the ‘Function’ group bar of the Properties dialog box, select a button function from the 
‘Action’ drop-down list. 
To add a ‘Display Current Count’ button, select Count from the ‘Action’ drop-down list and select 
Display current count from the ‘Count Type’ drop-down list. This displays the currently selected 
count of the modifier item on the modifier panel. If the count is zero, the button is blank. 
To add a ‘Clear Modifiers’ button, select Clear Modifiers from the ‘Action’ drop-down list to 
remove all modifiers added to an unordered item and revert the menu item back to a single-entry 
state. Use this button function when you have a large number of modifiers added to an item and 
you want to remove them. You cannot use this function within a script. 
To add a ‘Clear Current Count’ button, select Count from the ‘Action’ drop-down list and select 
Clear current count from the ‘Count Type’ drop-down list. This resets the current count of the 
modifier item back to 0 (zero). 

To add a ‘Modifier Code’ button, select Modifier Code from the ‘Action’ drop-down list and 
select a modifier code from the ‘Modifier Codes’ drop-down list. This allows you to designate a 

Figure 18  Properties Dialog Box for a Button on a Modifier Panel

Figure 19  Count (Clear Current Count) Button Function
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preceding preparation code for a modifier, such as No, Extra, and Side. You must touch this 
button before selecting a modifier item. 

To add an ‘Order Modifier’ button, select Order Modifier from the ‘Action’ drop-down list and 
select a modifier from the ‘Modifier Item’ drop-down list. This allows you to add a modifier to the 
selected menu item or the last item ordered, if there is an association between the modifier and 
the item. 

To allow the order modifier button to fill the remaining count, set Fill remaining count to True to 
add the modifier item to the menu item based on the remaining quantity of modifiers needed to 
fulfill the minimum required for the modifier group. For example, if the modifier group requires 
you to select a minimum of 10 modifiers, and you have already selected five, the system adds the 
selected modifier to the check using a quantity of five. If you select a count prior to selecting the 
modifier, the system ignores ‘Fill remaining count’ and adds the modifier based on the selected 
count. 
To add a ‘Special Message’ button, select Special Message from the ‘Action’ drop-down list to 
display the Special Message screen so you can enter a free text description. This button function 
is equivalent to the ‘typewriter’ button on the ‘classic’ modifier screen. 
To add a ‘Single-Digit Count’ button, select Count from the ‘Action’ drop-down list and select 
Apply Count from the ‘Count Type’ drop-down list. Then specify the quantity, from 1 to 999, of 
the modifier item to apply when you touch this button. This applies the next modifier item you 
select to the menu item using the number stipulated for this button in ‘Count.’ For example, for 
the ‘10 Wings’ menu item, if you touch a button defined with a ‘Count’ of 5 and then touch the 

Figure 20  Modifier Code Button Function

Figure 21  Order Modifier Button Function
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‘Hot’ modifier item, the system indicates the customer wants five of the ten wings modified with 
the ‘Hot’ modifier item. 

To add a ‘Double-Digit Count’ button that enables you to enter double-digit quantities of the 
modifier item, select Count from the ‘Action’ drop-down list and select Apply Count from the 
‘Count Type’ drop-down list. Then set ‘Append’ to True. For example, you can enter a quantity of 
12 for a modifier item by touching the 1 and then the 2 count buttons before touching the 
modifier item. 

To add a link to a ‘submenu’ button, select Submenu from the ‘Action’ drop-down list and select 
a submenu from the ‘Submenu’ drop-down list. This allows you to navigate to a specific 
submenu. If you have not fulfilled all modifier group requirements, such as minimum, the system 
prompts you to complete the requirements first before navigating to the submenu. An additional 
option appears when you select the Submenu button function. 

3. Repeat Steps 1 and 2 until you add all the necessary buttons to the modifier panel. 
4. Select Panel > Save Panel. 
5. Select File > Exit to exit Table Service Screen Designer. 

Figure 22  Count (Single-Digit) Button Function

Figure 23  Count (Double-Digit) Button Function

Figure 24  Submenu Button Function
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Replacing classic modifier screen with custom ‘item modifier count’ panel (TS 
only)

In Table Service, after you create a custom ‘item modifier count’ panel, you must tell the system which 
panel to use for replacing the ‘classic’ modifier screen. 

To replace the ‘classic’ modifier screen with a custom ‘item modifier count’ panel:

1. Select Maintenance > Menu > Modifier Groups.
2. Select a modifier group from the drop-down list. 

3. Under the ‘Settings’ group bar, select the custom item modifier count panel to overlay the 
hard-coded classic modifier screen when displaying this modifier group from the ‘Modifier 
panels’ drop-down list. 

4. Click Save. 
5. Repeat this procedure for each modifier group for which you want to use a custom ‘item 

modifier count’ panel instead of the hard-coded classic modifier screen. 
6. Exit the Modifier Groups function. 

Figure 25  Modifier Groups Function
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Alternate Table Service configuration with submenu panels
The button functions discussed in the previous Table Service section enhance your order entry 
experience with regard to adding modifiers to an item. You can also use some of these item modifier 
count button functions on a submenu panel, allowing you to completely order an item and its 
modifiers from the same submenu panel without navigating to a modifier screen. This configuration is 
not supported with ‘classic’ submenus. 

You can add the following button functions to a submenu panel:

● Count
● Order Modifier
● Modifier Code

To add a Count, Order Modifier, and Modifier Code button function to a submenu panel: 

1. Select Maintenance > Screen Designer > Table Service Screen Designer.
2. Select Work with Panels.
3. Select Panels > Open Panels, select a submenu panel, and click OK. 
4. With the submenu panel open, select Panel > New Button. 
5. Under the ‘Function’ group bar of the Properties dialog box, select a button function from the 

‘Action’ drop-down list.

Figure 26  Sample Custom Submenu Panel
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6. Repeat Steps 4 and 5 until you add all the necessary buttons to the submenu panel. 
7. Select Panel > Save Panel. 
8. Select File > Exit to exit the Table Service Screen Designer. 

To replace a ‘classic’ submenu with a custom submenu panel:

1. Select Maintenance > Menu > Submenus.
2. Select a submenu from the drop-down list. 
3. Under the ‘Settings’ group bar, select the submenu panel from the ‘Submenu panels’ drop-down 

list. 
4. Click Save. 
5. Repeat this procedure for each submenu for which to use a custom submenu panel instead of 

the hard-coded classic submenu screen. 
6. Exit the Submenus function.
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Using Item Modifier Counts
With item modifier counts, you can use the panel to manage the ordering of large quantities of 
modifiers without having to press a modifier button numerous times. The count of modifiers appears 
in parenthesis after the modifier in the guest check window.  

Aloha Table Service
In Aloha Table Service, you can enter single or double-digit counts of modifiers that appear on a 
‘current count’ button, as well as clear the count on demand. Additionally, you can use a typewriter 
button to enter a special message for the item. 

To use item modifier counts in Aloha Table Service:

1. Start a table.
2. Touch an item that requires an item modifier count selection, such as ‘50 Wings.’ The ‘item 

modifier count’ screen appears on the right side of the screen. Note: You can also touch the 
Modify button to access the ‘item modifier count’ screen. 

3. Modify ‘50 Wings’ by doing the following:

50 Wings Chicken Bucket Dozen Doughnuts Boxed Tacos

Hot (10) Breasts (1) Glazed (4) Beef (10)

Mild (20 Wings (2) Choc (4) Ckn (15)

Sweet (20) Thigh (3) Apple Fritter (4) Chorizo (25)

Figure 27  Item Modifier Count in Aloha Table Service
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To add a specific count of a modifier, use the numeric keypad to type the number, or select a 
bulk count button (10, 20, 30, or 40), then touch the appropriate modifier. The modifier 
appears under the item with the selected quantity, such as Sweet BBQ (5).
To complete the item with a single modifier that fills the remaining count based on the minimum 
required modifiers, touch a modifier without first selecting a count button. 
To add a modifier code, such as No, touch the appropriate modifier code and select the 
modifier.
To remove all the modifiers and their counts you entered for the item, touch Clear Mods.
To clear the count from the current modifier on which you are working, touch Clear Count. 
Note: This operates as a CE key on a calculator. 
To enter a special message to notify the kitchen of specific preparation, touch the typewriter 
button and then use the alpha-numeric keypad to type the message. 
To access a specific submenu, touch a submenu button, located at the bottom of the modifier 
panel in this example. 

4. Touch OK to complete the item or Cancel to not order the ‘50 Wings.’
5. Touch Done to exit to the floating logo screen. 
6. Tender and close the check when finished. 

Note:  A message appears if you attempt to navigate away from the modifier screen before you 
fulfill the minimum and maximum modifier requirements for a modifier group.



 Item Modifier Counts
Using Item Modifier Counts

29

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Aloha Quick Service
In Aloha Quick Service, you can enter single or double-digit counts of modifiers that appear on a 
‘current count’ button, as well as clear the count on demand. Additionally, you have a countdown 
indicator on the button itself to help you gauge how many modifiers are needed to fulfill the minimum 
required count for the item. 

To use item modifier counts in Aloha Quick Service:

1. Start a check.
2. Touch an item that requires a modifier selection, such as ‘12 Class Combo.’ 

3. If the modifier panel does not automatically appear, navigate to the panel that manages your item 
modifier counts. 

4. Modify ‘12 Class Combo’ by doing the following:
To add a specific count of a modifier, use the numeric keypad to type the number, or select a 
bulk count button (10, 20, 30, or 40), then touch the appropriate modifier. The modifier 
appears under the item with the selected quantity, such as Atomic (4). 
To complete the item with a single modifier that fills the remaining count based on the minimum 
required modifiers, touch a modifier without first selecting a count button. 
To add a modifier code, such as No, touch the appropriate modifier code then select a 
modifier.
To remove all the modifiers and their counts you entered for the item, touch Clear Mods.

Figure 28  Item Modifier Count in Aloha Quick Service
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To clear the count from the current modifier on which you are working, touch Clear Count. 
Note: This operates as a CE key on a calculator. 

5. Tender the check when finished. 

Tip:  In all cases, the remaining count, based on the minimum required number for the specific 
modifier code, appears in red in the upper left corner of the Required Modifier Countdown but-
ton. Additionally, the current count for the modifier appears in the top right corner of the modi-
fier button. 

Note:  A message appears if you attempt to navigate away from the modifier screen before you 
fulfill the minimum and maximum modifier requirements for a modifier group.
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Item Modifier Counts, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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