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Revision Record 

Date Description

Prior to 
01/24/2023

Implemented Included Modifiers in POS v6.4.

Created the Included Modifiers Feature Focus Guide.

01/24/2023 Converted the document to use new template.

09/08/2023 Added ‘Configuring advanced features in QS’ section. 

12/12/2023 Updated document to reflect NCR Voyix branding.

04/09/2024 Changed the ‘Automatically printing included modifiers in the kitchen’ procedure to clear 
‘Print in kitchen’ in Store > Store Settings > User Interface group > ‘Display > POS Order 
Entry Check’ group bar. 
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About Included Modifiers  

A modifier is an item used to extend, alter, or further define a menu item. Modifiers are collected into 
modifier groups and then associated with as many menu items as needed. For example, lettuce, 
tomatoes, onions, and pickles are common modifier items used for a Hamburger menu item, or 
french fries and cole slaw are common with a Fish Basket. When the consumer modifies the menu 
item, you can select one or more modifiers to communicate information to the kitchen when printers 
and remote display systems are in use. 

An included modifier is a modifier that comes standard with an item without modifications and is 
usually assumed, unless stipulated otherwise. For example, a Hamburger menu item includes 
mustard, lettuce, tomatoes, and onions; however, the consumer can add bacon or pickles to the 
Hamburger. The consumer can also omit an included modifier, if desired. 

The Included Modifiers feature in the Aloha® POS system provides counter employees and servers 
with a visual indication of the default modifiers to avoid redundancy and the sending of confusing 
and incorrect orders to the kitchen. They also quickly answer the question from the consumer of what 
comes standard with the item. 

Included Modifiers at a Glance

Core Product Aloha Quick Service, Aloha Table Service

Complementary Products No

Separate License Required? No

Other References Aloha Quick Service Reference Guide, Aloha Table Service 
Reference Guide

Figure 1  Included modifiers illustration
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The first section of this guide addresses the Included Modifiers functionality available in both Aloha 
Quick Service (QS) and Aloha Table Service (TS). The second section applies to Aloha Quick Service 
only and builds upon the configuration in the first section to take fast food order entry to the next 
level. For example, you can assign blank buttons to populate with included modifiers, configure 
groups of included modifiers, define rules for substituting an included modifier for a non-included 
modifier, and more. 

Configuration prerequisites 
This document assumes you have the following configured and operating. We build upon these 
prerequisites for configuring included modifiers. 

● Menu items and modifier items in Maintenance > Menu > Items.
● Modifier codes in Maintenance > Menu > Modifier Codes.
● Modifier groups in Maintenance > Menu > Modifier Groups.
● Context panels in Maintenance > Screen Designer for advanced features in Aloha Quick 

Service operations.

Configuring included modifiers for use with pizza 
Included modifiers play an important role in pizza operations with regard to order taking and 
inventory. 

Reference
Refer to the Advanced Pizza in QS or Advanced Pizza in TS Feature Focus Guides for information 
on configuring included modifiers with the Pizza Topping Depletion Inventory Matrix.
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Configuring basic Included Modifiers for QS and TS
This section details the configuration requirements within Aloha Manager and Aloha Configuration 
Center (CFC) for Included Modifiers in Aloha Quick Service and Aloha Table Service. If you are an 
experienced user, refer to Procedures at a Glance for abbreviated steps. If you prefer more detail, 
continue reading this document. 

Included Modifiers Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Access Maintenance > Business > Store > Store Settings tab to activate the included modifier 
functionality. See page 7. 

2. Access Maintenance > Menu > Items > Dynamic Modifiers tab to define which modifiers in a 
modifier group are included with an item. See page 8. 

3. Access Maintenance > System Settings > Media Files to make an image for an included modifier 
available for use. See page 9. 

4. Access Maintenance > Menu > Modifier Codes to attach a bitmap or color to an included 
modifier button. See page 9. 

5. Select Utilities > Refresh POS & All Products to refresh the data. See page 14. 



 Included Modifiers
Configuring basic Included Modifiers for QS and TS

7

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Activating the Included Modifiers feature
You must activate the Included Modifiers feature in the Store function to use included modifiers and 
insert the necessary logic into the Aloha POS system. 

To activate the Included Modifiers feature:

1. Select Maintenance > Business > Store > Store Settings tab.
2. Select the User Interface group located at the bottom of the screen. 

3. Under the ‘Display > POS Order Entry Check’ group bar, select Use included modifiers. 
4. Click Save and exit the Store function.

Figure 2  User Interface Group - POS Order Entry Check
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Designating the included modifiers for an item
As normal, you attach the appropriate modifier groups to an item in the Items function. To configure 
a modifier from one of these modifier groups to be included with an item, you must take an 
additional step and designate which modifiers come standard with the item on the Dynamic Modifiers 
tab. 

To designate the included modifiers for an item:

1. Select Maintenance > Menu > Items.
2. Select a menu item for which to designate the included modifiers, such as ‘Hamburger,’ from 

the drop-down list.
3. Select the Modifier tab. 
4. Ensure the included modifiers you want to add to the item reside in at least one of the modifier 

groups associated from the ‘Modifier’ drop-down list. If not, select the applicable modifier 
group from one of the drop-down lists. 

5. Select the Dynamic Modifiers tab. 

6. Click Add. The modifier groups added to the Modifier tab appear for selection under the 
‘Modifier group’ drop-down list. 

Figure 3  Items - Dynamic Modifiers tab
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7. Select the modifier group that contains the included modifier from the ‘Modifier group’ 
drop-down list. 

8. Select a modifier to include with the menu item from the ‘Modifier Item’ drop-down list.
9. Select Included to indicate the modifier behaves as an included modifier. 
10. Repeat steps 6 through 9 for each modifier to include with the item. 
11. Click Save.
12. Repeat this procedure for each menu item for which to add included modifiers. 
13. Exit the Items function.

Configuring visual indicators to appear for included modifiers 

Modifier codes play an important role with included modifiers and you can designate a single image, 
color, or both, with a modifier code as a visual representation of the different states of the modifier, 
in relation to the present order. The visual indicator appears on any modifier designated as 
‘Included,’ or applied with the modifier code, when the modifier appears on the Front-of-House 
(FOH).

The following are the common modifier codes, their purpose, and the suggested image to use. You 
can use any image or color that is visually appealing to your color scheme and concept. Be aware 
that, with the exception of modifier code 202, you can also create a copy of a modifier code for use 
on your menu. If you do this, you must configure the visual indicators for the copies of these modifier 
codes. 

Included (modifier code 202) - Appears on the FOH for all included modifiers configured for the 
selected item so the employee can easily identify the modifiers that come standard with the menu 
item. The visual indicator appears by default prior to selecting a modifier code. Suggested Image: 
Check mark. 

No (modifier code 2) - Appears on the FOH when you remove an included modifier indicating it 
should not be prepared with the menu item. You must first select the No modifier code and then the 
modifier item to which it applies. Suggested Image: A red ‘X,’ 

Figure 4  Visual indicator examples

Tip
In Aloha POS v12.3 and earlier, you select the modifier image for indicating an included modifier in 
Maintenance > Business > Store > Store Settings tab > User Interface group. 
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Add (modifier code 19) - Appears on the FOH when you add a non-included modifier to an item by 
itself, or when you substitute an included modifier for a non-included modifier. You must first select 
the Add modifier code and then the modifier item to which it applies. Suggested Image: A plus 
sign. 

Extra (modifier code 3) - Appears on the FOH when you apply an extra amount of a modifier to an 
item. You must first select the Extra modifier code and then the modifier item to which it applies. 
Suggested Image: Two plus signs. 

Heavy (modifier code 15) - Appears on the FOH when you add a heavier amount of a modifier to an 
item. You must first select the Heavy modifier code and then the modifier item to which it applies. 
This modifier code is supported in Aloha Quick Service only. Suggested Image: None. 

Light (modifier code 14) - Appears on the FOH when you apply a lighter amount of a modifier to an 
item. You must first select the Light modifier code and then the modifier item to which it applies. This 
modifier code is supported in Aloha Quick Service only. Suggested Image: None. 

Half (modifier code 17) - Appears on the FOH when you apply a half portion of the modifier to an 
item. You must first select the Half modifier code and then the modifier item to which it applies. This 
modifier code is supported in Aloha Quick Service only. Suggested Image: None. 

Quarter (modifier code 18) Appears on the FOH when you apply a quarter portion of the modifier to 
an item. You must first select the Quarter modifier code and then the modifier item to which it 
applies. This modifier code is supported in Aloha Quick Service only. Suggested Image: None. 

To make an image available for use with included modifiers:

To make an image file available for use in the system, you must save the file as a supported file type 
in the Bmp folder and then upload the image using the Media Files function. You can search the 
Internet for clip art, if you do not have images available. We recommend you size your images to 48 
x 48 pixels; however, you may need to change the pixel size of the image to fit correctly on your 
configured buttons. 

1. Select Maintenance > System Settings > Media Files.
2. Click the New drop-down arrow, select Aloha Point-of-Sale, and click OK.
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3. Accept the system assigned number or click the ellipsis (...) next to ‘Number’ to display the 
Number Assignment dialog box, from which you can choose an alternate number. 

4. Type a name, such as ‘Green Check Mark,’ to help you identify the image file. 
5. Select the file type, such as ‘BMP,’ from the drop-down list. 
6. Click the ellipsis (...) to browse to and select the image file for the included modifier from the 

directory in which you have it saved. The system defaults to the BMP directory.

Figure 5  System Settings - Media Files
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7. Select the Preview tab to preview the image, if necessary.

8. Click Save.
9. Repeat this procedure for each image file to add as a media file. 
10. Exit the Media Files function.

Figure 6  Media Files - Preview tab
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To configure an image and color to use with included modifiers:

Once you make images available for use in the Media Files function, attach them to the applicable 
modifier code. Some sites only use the Included Modifier code, which is hard-coded to use ID 202, 
and the No modifier code, but you might also want to use other modifier codes, such as Extra, Light. 
or Heavy. You can also assign a color to appear on the button when the modifier code is applied. 

1. Select Maintenance > Menu > Modifier Codes.
2. Select a modifier code, such as ‘202 Included,’ from the drop-down list.

3. To attach an image, select the bitmap to associate with the modifier code, such as ‘Green Check 
Mark,’ from the ‘Display graphical modifier image’ drop-down list.

4. To assign a color, select Use graphical modifier color and select a color from the ‘Custom 
graphical modifier color’ drop-down list.

5. Click Save. 
6. Repeat this procedure to add an image or color to other modifier codes, such as ‘No.’ 
7. Click Save and exit the Modifier Codes function. 

Figure 7  Modifier Codes function
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Refreshing data
After all settings are in place in Aloha Manager, it is necessary to select Utilities > POS > Refresh All 
POS Data to transfer the new information to the FOH terminals, or wait for the End-of-Day (EOD) 
process to accomplish the data refresh for you. If you run the refresh prior to the EOD process, select 
‘Automatically restart all POS terminals’ and click OK to continue. After the data refresh is complete, 
all new settings become operational across the Aloha network. 

Caution
Refresh data with caution and never during peak hours of operation. All FOH terminals reboot 
during a refresh and are down for a short period of time.
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Using basic Included Modifiers
You can use the basic configuration for included modifiers in Aloha Quick Service and Aloha Table 
Service. Included modifiers appear with a visual indication, such as an image or color, on modifier 
screens. 

SCENARIO: The consumer orders a Single No Chz; however, does not want pickles, which is an
included modifier. 

Aloha Quick Service

Aloha Quick Service offers two types of modifier screens that contain modifier buttons. The most 
common type is a user defined panel that can appear anywhere on the screen during the ordering 
process. The other type is the classic modifier screen where the modifier buttons are in a uniform and 
consistent location. This screen is invoked when you press the Modify button. 

1. Start a check.
2. Touch Hamburger. The included modifiers appear with the image designated for included 

modifiers, typically a green check mark.   

Figure 8  Included modifiers on user defined panel in Quick Service
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3. Touch No and then touch Pickle. The Pickle button changes color and a red ‘X’ appears.  

Figure 9  Included modifiers on classic modifier screen in Quick Service

Figure 10  No pickles on user defined panel in Quick Service
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4. Complete the check, as normal. 

Table Service

Aloha Table Service offers the classic modifier screen where the modifier buttons are in a uniform 
and consistent location; however, depending on your configuration, the area that holds modifier 
buttons could have a user defined panel. The user defined panel has modifiers at any size and 
location within the modifier area. 

1. Start a check.
2. Touch Single No Chz. 

Figure 11  No pickles on classic modifier screen in Quick Service
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3. If the system does not automatically navigate to the Modify screen, touch Modify at the bottom of 
the screen. The Modify screen appears with the included modifiers marked with the included 
modifier image.  

Figure 12  Table Service Modify screen 

Figure 13  Table Service Modify screen with a user defined modifier panel 
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4. Touch No and then Pickle. An ‘X’ appears on the Pickle modifier. 

5. Touch OK to return to the Main screen. ‘NO Pickle’ appears on the guest check. 

Figure 14  Remove included modifier - classic modifier screen 

Figure 15  Remove included modifier - User defined modifier panel in TS
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Configuring advanced Included Modifiers for QS
This section details the configuration requirements within Aloha Manager and Aloha Configuration 
Center (CFC) for advanced Included Modifiers features in Aloha Quick Service. You must use context 
panels to use all of the features in this section. 

You can configure the following advanced features: 

● Toggling between Add and No modifier codes. 
● Substituting included modifiers for a non-included modifier. 
● Configuring substitution rules for included modifiers. 
● Adjusting the price of an included modifier based on modifier code.
● Configuring a group of included modifiers.
● Configuring visual indicators on chain button functions. 
● Supporting dynamic included modifiers. 
● Automatically printing included modifiers in the kitchen. 

Toggling between Add and No modifier codes 
Normally, when you need to switch an included modifier with a regular modifier, such as Mayo with 
Mustard, you must touch No and Mayo to remove Mayo from the item and ‘No Mayo’ appears in the 
guest check window. You must then touch Add and Mustard to add Mustard to the item and ‘Mustard’ 
appears in the guest check window. To save time, configure the ‘modifier toggle’ functionality to 
reduce the number of screen touches required. 

When you touch an included modifier without a preceding modifier code, the system assumes you 
want to remove the included modifier from the item. The system toggles the visual indicator on the 
button from ‘Included’ to ‘No.’ The included modifier appears preceded with ‘NO’ in the guest check 
window. Touch the included modifier again to revert back to the ‘Included’ state. 

When you touch a non-included modifier without a preceding modifier code, the system assumes you 
want to add the modifier to the item. The system toggles the button to the ‘Add’ state and displays the 
‘Add’ visual indicator. The modifier appears in the guest check window as normal. Touch the 
non-included modifier again to revert back to its original state. 

Reference
Refer to the Context Panels Feature Focus Guide for more information on configuring context 
panels. 

Tip
Other features in this section leverage the modifier toggling functionality. 
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To configure toggling between Add and No modifier codes:

1. Select Maintenance > Menu > Modifier Groups. 
2. Select a modifier group from the drop-down list. 

3. Under the ‘Settings’ group bar, select Modifier toggle configuration. 
4. Click Save. 
5. Repeat this procedure for each modifier group requiring modifier toggle configuration. 
6. Click Close to exit the Modifier Groups function. 

Figure 16  Modifier Groups - Modifier toggle configuration
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Substituting included modifiers for a non-included modifier 
Most consumers consider an included modifier as part of the item and there should be little or no 
consequence for removing the modifier. It is also common to allow the consumer to substitute an 
included modifier for a non-included modifier.

By default, included modifiers do not appear in the guest check window. Given that, included 
modifiers do not count against the minimum/maximum requirements for the modifier group; 
however, if you specify a preceding modifier code for an included modifier, the included modifier 
now appears in the guest check window and counts toward the min/max requirements of the modifier 
group. For example, if you substitute cucumbers for the included modifier lettuce, the system counts 
the addition of cucumbers and the removal of lettuce as a total of two toward the min/max modifier 
group requirements. The desired behavior is to not count included modifier substitutions against the 
min/max modifier group requirements. 

To avoid doubling the modifier selections against the min/max modifier group requirements, you can 
perform a seamless substitution between included and non-included modifiers in a single touch. The 
action counts as one modifier selection. 

You must remember these rules: 

● You must add all included modifiers and non-included modifiers for which you want to allow 
substitution to the same modifier group. If you attempt to substitute an included modifier for a 
non-included modifier not in the same modifier group, substitution does not occur and the 
non-included modifier is added to the check in an ‘add’ state. 

● If you attempt to substitute an included modifier with a non-included modifier using a modifier 
code, such as Add, substitution does not occur and the non-included modifier is added to the 
check in an ‘add’ state. 

Automatically substituting all included modifiers for a non-included modifier
When you configure modifier groups based on types of items, you can more easily control and limit 
the modifiers that modify an item. For example, you can have a separate modifier group for cheeses, 
another for breads, and another for meats. Each of these modifier groups could have a different 
min/max requirement, and the same item can be in more than one modifier group. 

Tip
This section assumes you have enabled the modifier toggle functionality as discussed in “Toggling 
between Add and No modifier codes” on page 20 

Reference
For a min1/max1 modifier configuration, refer to “Substituting with min1/max1 modifier group 
configuration” on page 28. 
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Most likely, each of these modifier groups has one or more included modifier to serve as the default 
selection. When you select a non-included modifier to substitute for the included modifiers, the 
system substitutes all included modifiers with the non-included modifier. 

For example, in a Bread modifier group, Wheat is configured as an included modifier. When you 
substitute with Rye, the system automatically adds Rye to the order and removes Wheat. In a modifier 
group that has more than one included modifier, such as Ham and Turkey in a Meat modifier group, 
and you substitute Roast Beef, the system adds Roast Beef to the order and removes Ham and Turkey. 

To automatically substitute an included modifier for a non-included modifier:

1. Select Maintenance > Menu > Modifier Groups.
2. Select a modifier group from the drop-down list. 

3. Select Automatically replaces included modifiers.
4. Click Save.

Tip
Remember, the included and non-included modifiers must reside in the same modifier group, and 
you cannot use a preceding modifier code when performing the substitution. 

Figure 17  Modifier Groups - Automatically replaces included modifiers
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5. Repeat this procedure for other modifier groups for which you want to automatically substitute 
an included modifier for an item in a modifier group.

6. Click Close and exit the Modifier Groups function. 

Apply the following scenarios:

SCENARIO: Substituting an included modifier with a non-included modifier where only one included
modifier is defined.

The Cheese modifier group has a minimum zero and maximum three requirement and contains 
American, Pepper Jack, Swiss, and Asiago as modifiers. American Cheese is an included modifier 
for Burger. 

1. Touch Burger to add it to the order.  

2. Touch Pepper Jack. As shown in the following example, American appears in a ‘no’ state with a 
preceding No. Pepper Jack appears in an implicit ‘with’ state. The visual indicators on the buttons 
toggle to No for American and Add for Pepper Jack.  

Conversely, if you then touch American, both ‘No American’ and ‘Pepper Jack’ are removed from 
the guest check window, returning the guest check to its original state. Remember, by default, 
included modifiers do not appear in the guest check window. The visual indicators on the 
modifier buttons return to their original state. 

Burger

Burger

Pepper Jack

No American
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SCENARIO: Substituting an included modifier with a non-included modifier where more than one
included modifiers are defined.

The Cheese modifier group has a minimum zero and maximum three requirement and contains 
American, Pepper Jack, Swiss, and Asiago as modifiers. American and Asiago are included 
modifiers for Burger. 

1. Touch Burger to add it to the order.  

2. Touch Pepper Jack. As shown in the following example American and Asiago appear in a ‘no’ 
state with a preceding No. Pepper Jack appears in an implicit ‘with’ state. The visual indicators on 
the buttons toggle to No for American and Asiago and Add for Pepper Jack. 

Conversely, if you then touch American, ‘No American’ is removed from the item. If you touch 
American and Asiago, all three modifiers are removed from the guest check window, returning 
the guest check to its original state. Remember, by default, included modifiers do not appear in 
the guest check window. The visual indicators on the modifier buttons return to their original 
state. 

SCENARIO: Substituting an included modifier with a non-included modifier entered using a modifier
code

The Cheese modifier group has a minimum zero and maximum three requirement and contains 
American, Pepper Jack, Swiss, and Asiago as modifiers. American is an included modifier for 
Burger. 

1. Touch Burger to add it to the order. 

2. Touch Add and Pepper Jack. As shown in the following example, American remains as an 
included modifier and is not substituted by Pepper Jack because a modifier code was used to add 
Pepper Jack. ‘Add Pepper Jack’ appears in an ‘add’ state. The visual indicators on the Pepper Jack 
button toggle to Add.  

Burger

Burger

Pepper Jack

No American

No Asiago

Burger

Burger

Add Pepper Jack
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Conversely, if you touch Pepper Jack again, Pepper Jack is removed from the guest check 
window, returning the guest check to its original state. Remember, by default, included modifiers 
do not appear in the guest check window. The visual indicators on the Pepper Jack button return 
to their original state.

SCENARIO: Substituting an included modifier with a non-included modifier defined with a different
weight 

The Cheese modifier group has a minimum zero and maximum three requirement and contains 
American, Pepper Jack, Swiss, and Cheese Mix as modifiers. American, with a weight of one, is an 
included modifier for Burger. Cheese Mix has a weight of two. 

1. Touch Burger to add it to the order. 

2. Touch Cheese Mix. 

The system allows the substitution because you have not exceeded the maximum three 
requirement of the modifier group, 
○ If the Cheese modifier group has a minimum zero and maximum two requirement, the 

substitution causes the system to exceed the modifier group requirements and an error 
message appears on the screen. Dismiss the error, touch American (included modifier) to 
remove it from the guest check, and touch Cheese Mix (non-included modifier) to allow the 
substitution. 

○ If the Cheese modifier group has a minimum two and maximum three requirement, and 
Cheese Mix is the included modifier and American is not, when you attempt to substitute 
American, the minimum requirements are no longer met, The system navigates to the classic 
modifier screen for additional modifier selections.

Burger

Burger

Cheese Mix

No American
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SCENARIO: Adding another instance of an included modifier 

The Cheese modifier group has a minimum zero and maximum three requirement and contains 
American, Pepper Jack, Swiss, and Asiago as modifiers. American is an included modifier for 
Burger. The consumer requests another slice of American Cheese. 

1. Touch Burger to add it to the order. 

2. Touch Extra and American. As shown in the following example, American appears in an ‘extra’ 
state with a preceding XT. The visual indicators on the American button toggle to Extra for 
American. 

Conversely, if you touch American again, XT American is removed from the guest check window 
and is still assumed as an included modifier, Remember, by default, included modifiers do not 
appear in the guest check window. The visual indicators on the American button return to the 
‘included’ state. 

Burger

Burger

XT American
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Substituting with min1/max1 modifier group configuration
A min1/max1 one configuration for a modifier group requires you to select one, and only one, 
modifier. You can substitute an included modifier with a non-included modifier in a single touch, 
when setting the minimum to one and the maximum to one. This counts as one and complies with the 
min/max modifier group requirements. No other configuration is required for this enhancement. 

To substitute an included modifier with min1/max1 modifier group requirements:

1. Select an item that has included modifiers. The included modifier appears with a check mark on 
the context panel.  

Figure 18  Included modifier on a context panel 
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2. Touch a non-included modifier to substitute for the included modifier. The included modifier 
appears with a ‘No’ visual indicator and the ‘Add’ modifier code visual indicator appears with the 
non-included modifier. 

Figure 19  Non-included modifier switched for an included modifier 
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Configuring substitution rules for included modifiers 
When you perform a substitution with included and non-included modifiers, you can enforce 
substitution rules on how you want to substitute included modifiers in the Aloha POS system and if 
you want the substitution to count against the min/max requirement of the modifier group. You can 
configure any of the following substitution rules for included modifiers: 

● Designate a non-included modifier as ineligible for substitution for an included modifier. 
● Allow the substitution at no charge even if there is a price associated. 
● Allow the substitution and the system calculates and charges the difference in price, if any. 
● Not allow the substitution at all and count against the modifier group rules. 

Designating a non-included modifier as ineligible for substitution for an included modifier
If a non-included modifier is absolutely not permitted for substitution for an included modifier, you 
can designate the non-included modifier as ineligible for substitution. The Aloha POS system does 
not perform the substitution. The non-included modifier is added to the guest check at full price, and 
counts against the min/max requirements. 

To designate a non-included modifier as ineligible for substitution for an included modifier:

1. Select Maintenance > Menu > Modifier Groups. 
2. Select a modifier group containing the non-included modifier from the drop-down list. 
3. Select the Layout tab. 
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4. Select the non-included modifier from the grid. 

5. Under the ‘Modifier item’ group bar, select Not eligible for substitution to specify this modifier 
cannot be substituted for an included modifier. 

6. Repeat steps 4 and 5 to set other modifiers in this modifier group as not eligible for substitution. 
7. Click Save. 
8. Repeat this procedure for other non-included modifiers for which you do not allow substitution. 
9. Exit the Modifier Groups function. 

Figure 20  Modifier Group - Layout tab



 Included Modifiers
Configuring advanced Included Modifiers for QS

32

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Configuring substitution rules for an included modifier
You can configure rules for substituting an included modifier for a non-included modifier, such as 
allowing the substitution at no price or the difference in price, or not to allow the substitution at all. 

To configure substitution rules for an included modifier:

1. Select Maintenance > Menu > Items.
2. Select the item with a defined included modifier from the drop-down list.
3. Select the Dynamic Modifiers tab. 
4. Under the ‘Dynamic Modifiers’ group bar, select the modifier configured as an included 

modifier for the item. 

Figure 21  Items - Dynamic Modifiers tab
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5. Select one of the following substitution options from the ‘Substitution charge’ drop-down list:

None — Specifies this included modifier cannot be substituted for a non-included modifier 
from the same modifier group. This is the default selection and counts against the mini-
mum/maximum/free requirement for the modifier group only when you add the included 
modifier to the check. 

No Charge — Specifies this included modifier can be substituted for a non-included modifier 
from the same modifier group at no charge. The included modifier and non-included modi-
fier do not count against the minimum/maximum/free requirement for the modifier group. 
The Aloha POS system does not make the substitution if you use a modifier configured as 
‘Not Eligible for Substitution’ in Maintenance > Menu > Modifier Groups > Layout tab. 

Change Difference — Specifies this included modifier can be substituted for a non-included 
modifier from the same modifier group and charged the difference between the two modifi-
ers. If the price of the included modifier is greater than the non-included modifier, the system 
prices the substitution at $0.00, instead of pricing a negative amount. The included modifier 
and non-included modifier do not count against the minimum/maximum/free requirement for 
the modifier group. The Aloha POS system does not make the substitution if you use a modi-
fier configured as ‘Not Eligible for Substitution’ in Maintenance > Menu > Modifier Groups > 
Layout tab.

6. Repeat steps 3 to 5 to configure substitution rules for other included modifiers for the item. 
7. Click Save.
8. Repeat this procedure for each item for which to configure substitution rules for an included 

modifier.
9. Exit the Items function. 

Using Included Modifier Substitution 
Once you define your substitution rules for an included modifier, you can successfully substitute an 
included modifier for a non-included modifier. You can:

● Not charge for the substitution.
● Charge and calculate the price difference between the modifiers you are substituting.
● Charge full price for the replacement item. 

Use the following scenario as a basis for each setup: 
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SCENARIO: Super Burger comes with Shredded Cheese, normally priced at $0.40 when ordered a
la carte. The guest wants to replace Shredded Cheese with Swiss Sauce, normally priced at $0.60. 

To substitute an included modifier with a non-included modifier at no charge:

1. Touch Super Burger to add the item in the guest check window. 
2. Touch Shred Chz from the context panel. ‘No Shred Chz’ appears in the guest check window. 

Figure 22  Super Burger and context panels
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3. Touch Swiss Sauce. The system finds Shred Chz and Swiss Sauce are in the same modifier 
group and Shred Chz is substitutable at no charge. Swiss Sauce appears in the guest check 
window at no charge.  

To substitute an included modifier with a non-included modifier for a charge difference:

1. Touch Super Burger to add the item in the guest check window. 
2. Touch Shred Chz from the context panel. ‘No Shred Chz’ appears in the guest check window.
3. Touch Swiss Sauce. The system finds Shred Chz and Swiss Sauce are in the same modifier 

group and Shred Chz is substitutable, but with a charge difference. Since Shred Chz is normally 
$0.40, and Swiss Sauce is normally $0.60, Swiss Sauce appears in the guest check window at 

Figure 23  Swiss cheese added at no charge
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$0.20. If Shred Chz was priced higher than Swiss Sauce, the system would not charge for Swiss 
Sauce. 

Figure 24  Swiss cheese added for a charge
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To substitute an included modifier with a non-included modifier not eligible for substitution:

1. Touch Super Burger to add the item in the guest check window (Figure 103). 
2. Touch Shred Chz from the context panel. ‘No Shred Chz’ appears in the guest check window.
3. Touch Swiss Sauce. The system finds Shred Chz and Swiss Sauce are in the same modifier 

group and Shred Chz is substitutable; however, Swiss Sauce is not eligible for substitution. Swiss 
Sauce appears in the guest check window at full price of $0.60.  

Figure 25  Swiss cheese not eligible for substitution
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Adjusting the price of an included modifier based on modifier code
You can configure a percentage adjustment to the base item price when you add a modifier item to 
the check using a modifier code. You can charge more for ‘Extra’ and less for ‘Light’ without affecting 
the defined base price of any given item. 

This feature is not specific to included modifiers; however, you can configure the system to 
differentiate between ‘included items’ and ‘added items’ for the menu item. For example, if a Meat 
Lover’s pizza already has pepperoni, you can charge less to add extra pepperoni than you would to 
add mushrooms, which do not come standard on a Meat Lover’s pizza. For a sandwich operation, 
you can charge less to add more bacon to a BLT instead of charging the full price. 

To configure a modifier code to adjust the modifier price:

1. Select Maintenance > Menu > Modifier Codes.  

2. Select a modifier code other than ‘No’ or ‘Included’ from the ‘Modifier Code’ drop-down list.
3. Under the ‘Pricing’ group bar, select Affects pricing. 

Figure 26  Modifier code pricing
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4. Type the percentage, from 0 to 9999 with 100% being the default to use when calculating the 
price of a modifier already included as part of the standard item in ‘Charge X percent if 
included.’ 

5. Click Save. 
6. Repeat this procedure for other modifier codes requiring price adjustments. 
7. Exit the Modifier Codes function. 

As with most modifier codes, you must select the code first and then the modifier to determine the 
price of the modifier. If the modifier does not contain a base price, the system does not make an 
adjustment, even if the modifier code is configured to affect the pricing. Use the following scenarios 
to help you configure your included modifier pricing: 

SCENARIO: Price decreased for an included modifier 

A BLT is priced at $3.00. Bacon is priced at $1.00 and is an included modifier for the BLT. The 
Heavy modifier code is set to 60% for included modifiers. You order the BLT and select Heavy 
Bacon. The system charges the BLT as $3.00 + ($1.00 x 60%) = $3.60.

SCENARIO: Price not charged for an included modifier 

Figure 27  Price decreased for an included modifier

Figure 28  Price not charged for an included modifier
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A BLT is priced at $3.00. Bacon is priced at $1.00 and is an included modifier for the BLT. The Light 
modifier code is set to 0% for included modifiers. You order the BLT and select Light Bacon. The 
system charges the BLT as $3.00 + ($1.00 x 0%) = $3.00.

SCENARIO: Price for an included modifier substituted for a non-included modifier 

A BLT is priced at $3.00. Bacon is priced at $1.00 and is an included modifier for the BLT, as well as 
configured to charge for the difference for included modifier substitutions. Avocado is priced at 
$1.00 and is not an included modifier for the BLT. The Heavy modifier code is set to 120% for 
non-included modifiers. You order the BLT and select No Bacon and Heavy Avocado. The system 
charges the BLT as $3.00 + ($1.00 x 120% - $1.00) = $3.20.

Figure 29  Price for included modifier substituted for non-included modifier
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Configuring a group of included modifiers
Some operations have a standard set of included modifiers called build groups that are used to build 
an item. 

SCENARIO: Gene's Sub Shop offers Italian Sub, Grilled Chicken Sub, and Gene’s Special Sub. The
Italian Sub has lettuce, red onions, and oil and vinegar sauce on flat bread. Grilled Chicken Sub has
lettuce, tomatoes, red onions, and mayonnaise on sourdough bread. Gene’s Special Sub has mayo,
deli mustard, lettuce, tomatoes, jalapeños, and onions. The consumer orders a Grilled Chicken Sub,
but wants the Italian Sub modifiers instead of the Grilled Chicken modifiers. Creating build groups
allows you to use a one-touch substitution to easily switch out one group of modifiers for another. If
further modifications are needed, the employee can remove or add modifiers based on the active
build. 

You can use a mixture of Standard and Build item types to create a Build modifier group that allows 
you to easily accomplish the task of swapping out a group of modifiers with one button touch. 
Without a Build modifier group, you have to remove and add each modifier one at a time. If further 
modification is needed, you can add or remove a modifier from the active build modifier group. 

The visual indicators continue to appear and change as you switch from one Build item in a Build 
modifier group to another Build item. For example, when you select the Burger Build item, the visual 
indicators for the included modifiers appear as normal and update when you select the Chicken Build 
item, 

Configuring build groups of included modifiers
Configuring a Build modifier group requires you to toggle back and forth between Item Maintenance 
and Modifier Group Maintenance, due to the dependencies that exist between items and modifier 
groups. It also requires the use of the Build item type and Build modifier group types. 

● The Build item type represents a grouping of included, zero-priced modifiers that you can use as 
a base to prepare one or more menu items. For example, you could group oil and vinegar sauce, 
lettuce, red onions, and flat bread into one Build item, group lettuce, tomato, red onions, 
mayonnaise, and sourdough bread into another, and so on.

● The Build modifier group type represents a grouping of the Build item types from which a 
consumer can choose to modify a menu item. 

Tip
For the best result, use zero-priced included modifiers in the build modifier group with the min/max 
requirement set to zero for the modifier group.
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Configuring a Build item type

The first step is to create each group of included modifiers using the Build item type in Item 
Maintenance. 

1. Select Maintenance > Menu > Items. 
2. Click the New drop-down arrow, select Build from the Type list box, and click OK. 
3. Type a name for the Build item, such as ‘Chicken Build,’ ‘Burger Build,’ and others. 
4. Select the Modifier tab. 

5. Under the ‘Modified by’ group bar, select a modifier group, such as ‘Condiments,’ from one of 
the ‘Modifier’ drop-down lists.

Figure 30  Attaching the modifier to the Build item 
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6. Select the Dynamic Modifiers tab. 

7. Under the ‘Dynamic Modifiers’ group bar, click Add. 
8. Select the modifier group that contains the items, such as condiments, from the ‘Modifier 

Group’ drop-down list. 
9. Select a modifier to include in the Build from the ‘Modifier Item’ drop-down list. 
10. Repeat steps 7 through 9 for each modifier that makes up the Build.
11. Click Save.
12. Repeat this procedure for each Build item you want to create.
13. Exit the Items function.

Figure 31  Adding the dynamic modifiers 
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Configuring a Build modifier group

You then create a Build modifier group and attach the Build items to the group. Attach each Build 
item you can use for modifying an item assigned to this modifier group. Generally, if you are 
switching builds across like menu items, only one Build modifier group is needed. 

1. Select Maintenance > Menu > Modifier Groups.
2. Click the New drop-down arrow, select Build from the ‘New modifier group’ list box, and click 

OK. 
3. Type a name, such as ‘Build,’ for the Build modifier group. 
4. Select the Layout tab.
5. Select a button from the grid. Additional options appear under the ‘Modifier item’ group bar.
6. Select a Build item from the ‘Item’ drop-down list, such as ‘Chicken Build.’ 

7. Repeat steps 5 through 6 to add other Build items to the Build modifier group.
8. Click Save. 
9. Repeat this procedure to create other Build modifier groups. 
10. Exit the Modifier Groups function.

Figure 32  Modifier group for a build 
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Attaching a Build modifier group to a menu item

As with any modifier group, you attach the Build modifier group to the necessary menu item and 
configure it as an included modifier. 

1. Select Maintenance > Menu > Items.
2. Select the menu item from the drop-down list to which you want to attach a Build modifier group, 

such as ‘Burger,’ ‘Chicken Sandwich,’ and more. 
3. Select the Modifier tab.
4. Attach the Build modifier group to one of the ‘Modifier’ drop-down lists. 
5. Select the Dynamic Modifiers tab.
6. Under the ‘Dynamic Modifiers’ group bar, click Add. 

7. Select the Build modifier group from the ‘Modifier Group’ drop-down list.
8. Select the Build modifier from the ‘Modifier Item’ drop-down list.
9. Select Included. 
10. Repeat steps 6 through 9 for each modifier that makes up the Build.
11. Click Save.

Figure 33  Items - Dynamic Modifiers tab 
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12. Repeat this procedure for each item to which you want to attach a Build modifier group.
13. Exit the Items function.

Adding Build items and Undo Modifications button to a panel

Once all the Build associations between items and modifiers are in place, you add the Build items to 
the necessary context panels for order entry. Also, you add the Undo Modifications button function to 
the same panel or to a non-context panel containing your function buttons. The Undo Modifications 
button allows you to dismiss all changes you made to included modifiers associated with the build 
item you are modifying and reset them to their original state. 

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.
3. Select Panel > Open Panel, and select a context panel containing your modifier buttons. 
4. Select Panel > New Button. 

5. In the Properties window and under the ‘Function’ group bar, select Order Modifier from the 
‘Action’ drop-down list. 

6. Select the Build item from the ‘Modifier Item’ drop-down list, such as ‘Burger Build.’ 

Note
The Undo Modifications button function only applies to an item configured as a Build item type. 

Figure 34  Properties window - Order Modifier (left) and Undo Modifications (right)
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7. Under the ‘Appearance’ group bar, type a name for the button, such as ‘Burger Build.’ To display 
text on multiple lines, insert ‘\n’ without spaces for line breaks, such as ‘Burger\nBuild.’ 

8. Configure the remaining options as you would for any other button function.
9. Repeat steps 4 through 8 to add other Build items to the panel. 
10. Select Panel > Save Panel.
11. While still in Panel Editor, select Panel > Open Panel, and select a panel to which you want to 

add the ‘Undo Modifications’ button.
12. Select Panel > New Button. 
13. In the Properties window and under the ‘Function’ group bar, select Undo Modifications from 

the ‘Action’ drop-down list to allow you to remove any modifications made to a Build item, before 
the item is ordered and revert back to it original state. 

14. Under the ‘Appearance’ group bar, type a name for the button, such as ‘Undo Mods.’ To display 
text on multiple lines, insert ‘\n’ without spaces for line breaks, such as ‘Undo\nMods.’ 

15. Configure the remaining options as you would for any other button function.
16. Select Panel > Save Panel.
17. Select File > Exit to exit Quick Service Screen Designer.

Using Build modifier groups 
Use Build modifier groups to switch out a complete group of included modifiers for an item, such as 
a hamburger with a Burger build to a hamburger with a Chicken build. Once the included modifiers 
are switched, and the consumer wants additional modifications, you can further alter the included 
modifiers individually. For example, if you switch from a Burger build to a Chicken build, and the 
consumer wants the tomatoes from a Burger build, you can easily add tomatoes to the menu item with 
the new Chicken build. 

Veteran employees who know the restaurant menu well could also determine if switching a build is 
more efficient to enter the order instead of adding and deleting individual included modifiers. 

If you perform major modifications to the Build item, and make a mistake or decide to start over, 
press the Undo Modifications button to undo all changes and return the Build item to its original state. 
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Configuring visual indicators on chain button functions
In “Configuring visual indicators to appear for included modifiers” on page 9, we discussed adding 
an image or color to a modifier code as a visual indicator on a button. In a more complex Quick 
Service screen design using context panels, an included modifier could be located on a panel 
hidden beneath other panels and is not readily visible when you add the menu item to the check. The 
designer often segregates common modifiers, such as cheeses or protein choices, and uses chain 
buttons to access the context panel on which they reside. For example, one panel is dedicated to 
bread choices, while another could contain only cheese choices, or meat choices. An included 
modifier found on these panels is not visible when you add the menu item to the check. You must first 
touch the ‘chain’ button to navigate to the modifier panel before you can determine which modifiers 
on that panel, if any, are included with the item. 

To easily identify which hidden panel contains at least one included modifier, you can also display the 
same visual indicator on the chain button that navigates to a panel that has an included modifier. For 
example, a chain button named ‘Cheese Menu’ appears for the item you are currently entering and 
the ‘cheese panel’ to which the ‘cheese menu’ button navigates contains the included modifier 
Cheddar Cheese. The same visual indicator appears on both Cheddar Cheese and the ‘cheese menu’ 
chain button. 

Figure 35  Visual indicator on chain buttons
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To display the visual indicator on a button that chains to a modifier panel containing included 
modifiers, you must specify the image or color to use in the chain button function definition. 

To configure a visual indicator to display on a chain button function:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.
3. Select Panel > Open Panel, then select a panel to use, and click OK.
4. Add a button, or select an existing button. 
5. In the Properties window and under the ‘Function’ group bar, select Chain from the ‘Action’ 

drop-down list. 

6. Select a panel from the ‘Panel to display’ drop-down list. 
7. To add an image to a chain button, select an image from the ‘Use graphical modifier image’ 

drop-down list.

Tip
A script button function often includes a chain function as part of a multi-function action. To use 
visual indicators on a chain button function, you must place the chain function as the first action 
defined in the script. 

Figure 36  Chain button function
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8. To add a color to a chain button, select Use graphical modifier color and a color from the 
‘Custom graphical modifier color’ drop-down list. 

9. Select Panel > Save Panel.
10. Repeat this procedure to specify an image or color for another chain button. 
11. Select File > Exit to exit Quick Service Screen Designer. 
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Supporting dynamic included modifiers
Dynamic included modifiers is a design feature that reserves a set or row of buttons on a context 
panel to be automatically populated with included modifiers when an item is added to the guest 
check window. Dynamic included modifiers also inherit the visual indicators configured with an 
included modifier. 

You may want to implement this if included modifiers are not visible at the same time on the screen 
and are hidden within underlying panels, such as panels specific to bread, cheese, or condiment 
choices. The employee must navigate through these chaining panels to view each included modifier 
that comes standard with the item. By reserving an area for dynamic included modifier buttons, the 
employee can view a complete list of the included modifiers for an item and quickly respond to any 
inquiries the consumer may have. 

In the following example, the context panel has the top two rows reserved for dynamic included 
modifiers. When you add an item, such as Super Burger, to the guest check, the system automatically 
populates the top two rows of the panel, starting with the top-left button and across, with the included 
modifiers defined for the item. 

Note
The visual indicators continue to appear everywhere the included modifier is found. 

Figure 37  Dynamic included modifiers for Super Burger
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When you select another item, such as Crsp Ckn Filet, the system updates the buttons with the 
included modifiers defined for the new item.  

To configure dynamic included modifiers, you must first set up your included modifiers, as normal, 
then add the dynamic included modifier buttons to a context panel. For readability, place the buttons 

Figure 38  Dynamic included modifiers for Crsp Ckn Filet
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in a specific area, separate from the other functions on the context panel. The buttons will appear 
blank until you select a menu item with included modifiers.  

To add dynamic included modifiers to a context panel:

1. Select Maintenance > Screen Designer > Quick Service Screen Designer. 
2. Select Work with Panels. 
3. Select Panel > Open Panel. The Open Panels screen appears. 
4. Select a panel configured as a context panel from the list and click OK. You cannot add a 

dynamic included modifier button to a panel that is not a context panel. 

Figure 39  Reserved area for dynamic included modifiers

Tip
The number of dynamic included modifier buttons needed is at your discretion. As a best 
practice, evaluate the maximum number of included modifiers needed for your items. The sys-
tem populates the dynamic included modifier buttons with the included modifiers based on the 
order in which they are configured in Items > Dynamic Modifiers tab. If you add only four 
dynamic included modifier buttons to the context panel, and the item has five included modifiers 
configured, the fifth included modifier does not appear. In this example, we added 10 dynamic 
included modifier buttons to accommodate menu items with a high usage of included modifiers. 



 Included Modifiers
Configuring advanced Included Modifiers for QS

54

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

5. Select Panel > New Button. A new button is added to the context panel and the Properties 
dialog box appears. 

6. Under the ‘Function’ group bar, select Dynamic Included Modifier from the ‘Action’ drop-down 
list.

7. Complete the remaining background options for the button, as desired. Since the system 
generates the text and content on the button, you cannot configure the text, or font options on a 
Dynamic Included Modifier button, nor can you add an image to the button since that comes from 
the image defined for the Included Modifier modifier code. 

8. Repeat steps 5 through 7 for each of the remaining buttons to use for dynamic included 
modifiers. 

9. Select Panel > Save Panel. 
10. Repeat this procedure for each context panel requiring a set of Dynamic Included Modifier 

buttons. 
11. Exit Quick Service Screen Designer. 

Figure 40  Dynamic Included Modifier properties window
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Automatically printing included modifiers in the kitchen
By default, included modifiers do not appear in the guest check window and are not sent to the 
kitchen or printed on the kitchen chit. You can configure one or all included modifiers to print on the 
kitchen chit for the kitchen staff to use when preparing an item. You can also leverage the item 
priority feature in Maintenance > Menu > Item Routing to configure the included modifiers to print in 
the order in which your ingredients are laid out on a ‘make table.’ 

To configure included modifiers to automatically print on the kitchen chit, you must disable ‘Print in 
kitchen’ in Store Settings and then specify the included modifiers to print in the kitchen when you 
order the menu item. 

To disable kitchen printing in Store Settings:

1. Select Maintenance > Store > Store Settings.
2. Under the ‘Display > POS Order Entry Check’ group bar, select the User Interface group at the 

bottom of the screen (Figure 2). 
3. Clear Print in kitchen. 
4. Click Save and exit the Store function. 

To configure an included modifier to print on a kitchen chit:

1. Select Maintenance > Menu > Items.
2. Select the item with a defined included modifier from the drop-down list.
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3. Select the Dynamic Modifiers tab. 

4. Under the ‘Dynamic Modifiers’ group bar, select the modifier configured as an included 
modifier for the item.

5. Select Print in kitchen.
6. Repeat this procedure for each included modifier to print on a kitchen. 
7. Exit the Items function. 

Figure 41  Items - Dynamic Modifiers tab
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Included Modifiers, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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