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 EMV Moneris
About EMV Moneris

4

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

About EMV Moneris  

EMV (Europay, MasterCard, and Visa), offered with Aloha® Quick Service and Table Service, is a 
technical standard for a chip-based payment technology where consumers use payment cards 
embedded with a smart ‘chip’ to connect to an EMV-enabled device, such as the Ingenico iPP320, 
and execute payment using dynamic authentication. Because the data is dynamic, not static like 
traditional magnetic stripe cards, duplicating one of these credit or debit cards is very difficult, 
reducing data security fraud around the world. 

Consumers either insert their card (contact) into or tap their card (contactless) on an EMV-enabled 
device and then enter a personal identification number (PIN) or provide a signature for authorization. 
These cards also come equipped with the traditional embossed number and magnetic stripe for use 
as a fallback in the event the EMV-enabled device fails to read the chip. NCR Voyix is working 

EMV Moneris at a Glance

Core Product Aloha® Quick Service, Aloha Table Service, Aloha EDC

Complementary Products? Yes, the Ingenico iPP320 PIN Pad Device v2.10.

Separate License Required? No

Other References Aloha Quick Service Manager Guide, Aloha Quick Service 
Reference Guide, Aloha Table Service Manager Guide, Aloha 
Table Service Reference Guide

Figure 1  Chip/Smart Card Example

Embedded chip in credit 
card
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directly with the major processors to implement a multi-payment type solution that supports EMV as 
well as the traditional magnetic stripe.

The support of EMV is mandatory for sites in Canada, and, we currently support EMV only for use in 
Canada. Effective with Aloha Electronic Draft Capture (EDC) v14.2, you can directly process EMV 
cards in Canada through the Moneris processor. Moneris, the largest processor in Canada, supports 
the following EMV card types on the Ingenico iPP320 PIN pad device using the Moneris solution:

● Visa®
● MasterCard®
● American Express®
● JCB
● Interac®

The Aloha POS terminals also offer redundancy, but only as a backup method with the required POS 
access level. You can slide or manually enter the following cards on the POS terminal:

● Visa 
● MasterCard
● American Express
● Discover®
● JCB

Figure 2  Inserting the Chip Card
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For example, if the device cannot read the chip, the employee with the appropriate POS access level 
can slide the card using the magnetic stripe reader (MSR). If the MSR fails to read the magnetic 
stripe, the employee has the ability to manually enter the card number. 

How does the use of EMV improve payment security?
EMV-chip-based solutions have been successful in reducing data security fraud around the world. 
Traditional magnetic stripe cards contain static data on the back of each card. This static data can 
easily be duplicated using low cost equipment that is readily available for purchase on the Internet. 
Once duplicated, a criminal can use the copied card to commit fraud anywhere in the world that 
accepts the specific brand of credit card. EMV differs as it uses a program in the chip on the card. 
The program allows for dynamic information to pass through with each payment transaction. Because 
the data is dynamic and not static, duplication of any one card is very difficult. Strong encryption and 
other security measures have made EMV much more secure; however, if a merchant has a properly 
configured POS solution and is meeting or exceeding PCI DSS requirements, the added security of 
EMV will only provide a marginal improvement in the overall security of your payment data.

Software requirements
You must use Aloha Configuration Center (CFC) or Aloha Manager v15.1 or later and Aloha EDC 
v14.2 or later, to take advantage of EMV technology. You must also use Aloha Table Service v15.1 or 
later, or Aloha Quick Service v15.1 or later. Use the proper steps to upgrade CFC or Aloha Manager 
and EDC, including settling all outstanding batches prior to upgrading and performing the necessary 
configuration. 

Hardware requirements
Aloha EDC supports the Ingenico iPP320 PIN pad device v2.10, which is a tethered PIN pad device 
connected to the Aloha point of sale (POS) terminals using a universal serial bus (USB) cable. The 
Ingenico iPP320 PIN pad device supports EMV requirements through the Moneris solution. 

Aloha Table Service and Aloha Quick Service support up to two PIN pad devices per Aloha POS 
terminal; providing a faster way to process EMV transactions.

You must develop a plan to deploy the Ingenico iPP320 PIN pad devices. Determine how many 
Ingenico iPP320 PIN pad devices with the Moneris solution to install. If you are using only one PIN 

Note
As of this writing, the Ingenico iPP320 PIN pad device does not support gift card payments; 
Discover EMV is also not supported.
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pad device per POS terminal, you can use a serial cable. If you are using two PIN pad devices per 
POS terminal, you must use a USB converter cable. 

Contact Moneris to:

● Set up EMV on your merchant account.
● Request the Ingenico iPP320 v2.10 PIN pad devices.
● Obtain unique terminal IDs (TIDs) for each PIN pad device, each POS terminal, and one for the 

Aloha EDC Back-of-House (BOH).

Figure 3  USB Converter Cable
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Card brand mandates
Due to card brand mandates, to use Moneris, you must have a terminal ID for the Back-of-House 
(BOH), terminal, and PIN pad device.  

For example, the Aloha Café decides to support EMV using Moneris. The restaurant has four POS 
terminals and obtains eight Ingenico iPP320 PIN pad devices installed with the Moneris solution; two 
for each POS terminal. The Aloha Café must obtain a total of 13 terminal ID numbers.

Internet service
Aloha EDC defaults to secure socket layer (SSL) as the primary communication method with Moneris; 
however EDC also supports a dial-up connection with the processor as a redundancy feature. You can 
use a dial-up connection as the primary connection, if necessary. If you configure both SSL and 
dial-up, EDC uses SSL to communicate with Moneris; if this connection fails, EDC uses dial-up.

Partial approvals
You can partially approve pre-paid cards, and the remaining balance prints on the customer copy 
voucher.

Pre-paid cards
Moneris supports pre-paid cards. When a guest uses a pre-paid card, any remaining balance appears 
on the Front-of-House (FOH). 

Real-time reversals
Moneris supports real-time reversals for both timeouts and voids.

Figure 4  Terminal ID Example
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Supporting cardholder verification
Moneris supports cardholder verification through address verification (AVS) using the ZIP code of the 
cardholder, and the card validation of the three-digit security code located on the back of the 
payment card. AVS response codes are available in the Appendix of this document. 
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Configuring Ingenico iPP320 PIN pad devices
Configuring an Ingenico iPP320 PIN pad device is a multi-step process. First, you must install the 
Ingenico iPP350 USB driver; then attach the devices to the POS terminal. You must also initialize the 
Ingenico iPP320 PIN pad devices prior to first use. 

Installing the Ingenico iPP320 device driver
You must install the drivers on each terminal to which you attach an Ingenico iPP320 PIN pad device. 

To install the drivers:

1. Open and log in to the web site: https://www.radiantupdate.com. 

2. Click Download Install CD on the menu.

Figure 5  HSR Hospitality Updates
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3. Select PIN Pad from the ‘Application Suite’ drop-down list. 

4. Select Ingenico iPP350 USB Driver from the ‘Major Version’ drop-down list. 
5. Click Download Now to download the Ingenico iPP350 UsbDrvInstall.zip file. This driver works 

for both the iPP320 and iPP350 PIN pad devices.

Figure 6  Application Suite

Figure 7  Selecting PIN Pad Device
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When the download is complete, the following screen appears:

6. Double-click UsbDrvInstall.exe to open the file. 

7. Click Yes on the ‘User Account Control’ dialog box to begin installing the USB driver. 

Figure 8  WinZip Exe File

Figure 9  User Account Control Dialog Box
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8. Click Next. 

9. Click Browse to select a different folder in which to install the driver, or click Next to accept the 
current folder location.

Figure 10  UsbDrvInstall Setup Wizard

Figure 11  Designating Folder Location
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10. Click Install to continue with the installation. Click Back if you want to review or change any 
settings. 

11. Select Force COM Port Feature enabled. (Required)
12. Type the Product ID, available on the back of the device. (Required)
13. Type the Virtual COM Port. (Required) The system defaults to ‘8.’ 
14. Repeat steps 12 and 13 if you have two PIN pad devices attached to one terminal. 

Figure 12  Ready to Install

Figure 13  USB Driver Parameters



 EMV Moneris
Configuring Ingenico iPP320 PIN pad devices

15

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

15. Select Uninstall Microsoft Usbser drivers(s) and click Next. (Recommended) 

16. Select a Start Menu folder into which to create the program’s shortcuts, or leave the current 
selection as the default location.

17. Click Install.

Figure 14  Advance Parameters

Figure 15  Choose Start Menu Folder
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18. Click Finish to exit the Setup wizard.

Attaching the Ingenico iPP320 PIN pad device to a terminal
Attach the Ingenico iPP320 PIN Pad Device to the terminal. 

If you are using only one PIN pad device per POS terminal, you can use a serial cable. If you are 
using two PIN pad devices per POS terminal, you must use a USB converter cable.

Figure 16  Setup Complete

Figure 17  Attaching the PIN Pad Device to a Terminal
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Locating Ingenico iPP320 serial numbers 

The Ingenico iPP320 serial numbers are located on the back of each PIN pad device.  

Initializing the Ingenico iPP320 device
Moneris requires an initialization event of every PIN pad. The event occurs on the first transaction 
only.

● If using two PIN pad devices per terminal, the POS terminal allows both initializations at the same 
time. 

● The initialization process lasts two to four minutes.
● The initialization process must run while in ‘online mode,’ as it requires a response code from 

Moneris. 

Figure 18  Serial Numbers

Figure 19  Ingenico iPP320 PIN Pad Device



 EMV Moneris
Configuring EMV Moneris

18

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Configuring EMV Moneris
To configure EMV, access either Aloha Manager or Aloha Configuration Center (CFC) and perform 
several functions, such as configure the Moneris processor in EDC, enable Chip and Pin 
functionality, and more.

This section details the configuration requirements within Aloha EDC and Aloha POS for EMV 
Moneris. If you are an experienced user, refer to Procedures at a Glance for abbreviated steps. If you 
prefer more detail, continue reading this document. 

EMV Moneris Procedures at a Glance:

If you are viewing this document using Adobe Acrobat Reader, click each link for detailed information 
regarding the task. 

1. Access Maintenance > Electronic Draft Capture > Processor and configure the Moneris 
processor, complete with unique merchant ID numbers and a BOH terminal ID number. See page 19.

2. Access Maintenance > Electronic Draft Capture > Cards to assign the appropriate payment cards 
to the Moneris processor. See page 22.

3. Access Maintenance > Business > Store > Store Settings tab > Credit Card group > EDC 
Setup group bar to enable the Chip and PIN feature for EDC and designate Moneris as the ‘EMV 
processor’ to force chip-enabled cards to be read using a PIN pad device. See page 23.

4. Access Maintenance > Business > Store > Store Settings tab > Credit Card group > Voucher 
print settings group bar to configure the voucher requirements for Moneris. You can also combine 
the first voucher with the guest check, to save paper. See page 25.

5. Access Maintenance > Payments > Tenders to create a tender for each PIN pad device. See 
page 26.

6. Access Maintenance > Screen Designer > Quick Service Screen Designer to create tender 
buttons, such as ‘PIN Pad1’ and ‘PIN Pad 2.’ (Required for Quick Service only) See page 28.

7. Clear ‘Wait for credit authorization’ in Maintenance > System Settings > Revenue Center to 
allow you to start a new guest check without waiting for authorization for the current guest check. See 
page 30.

8. Access Maintenance > Hardware > Terminals to assign up to two PIN pad devices to a FOH 
terminal. See page 31.

9. Access Maintenance > Labor > Pos Access Levels to provide the ability to slide an EMV-enabled 
card on the POS terminal MSR. (Optional). See page 33.

10. Access Utilities > POS > Refresh POS & All Installed Products to refresh your POS system and 
stop and start EDC processing. See page 34.
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Configuring the Moneris processor 
As of this writing, Elavon and Moneris are the only processors supporting the EMV payment 
technology, and it is only supported in Canada. To accept the Moneris type of payment card, you 
must reach out to Moneris and obtain a unique terminal ID for the BOH file server and each Ingenico 
iPP320 PIN pad device in the network.

To configure the Moneris processor:

1. Select Maintenance > Electronic Draft Capture > Processor. 
2. Select Moneris from the drop-down list, or click the New drop-down arrow, select Moneris as 

the owner, and click OK. 

3. If this is a new processor, accept the system assigned number or click the ellipsis button (...) 
next to ‘Number’ to display the Number Assignment dialog box, from which you can choose an 
alternate number. 

4. Under the ‘Moneris’ group bar, type the unique merchant ID provided by the processor. 
5. Type the unique terminal ID provided by the processor for your BOH file server in ‘BOH 

terminal ID.’ This step is mandatory. 
6. Under the ‘SSL’ group bar, type the URL provided by the processor. For example, 

‘ipgt.moneris.com.’
7. Select the Options tab. 

Figure 20  Processor Tab
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8. Under the ‘EMV’ group bar, select Process EMV transactions. 
9. Under the ‘Options’ group bar, select Disable adjustments to prevent an employee from 

adjusting a credit card payment, once the payment has processed. Use this feature in conjunction 
with Maintenance > Business > Store > Store Settings tab > Credit Card group > EDC 
Setup group bar > Disable credit card adjustments to prevent adjustments.
If you select both ‘Disable adjustments’ in EDC and ‘Disable credit card adjustments’ in the POS, 
the system prevents an employee from adjusting a processed credit card payment.
If you select ‘Disable adjustments’ in EDC and clear ‘Disable credit card adjustments’ in the POS, 
the employee can adjust the processed credit card payment; however, EDC stops the transaction 
and an ‘Adjustments were disabled at the time of this transaction’ error message appears.
If you clear ‘Disable adjustments’ in EDC and select ‘Disable credit card adjustments’ in the POS, 
the FOH prevents the employee from adjusting the processed credit card payment. 

Figure 21  Options Tab



 EMV Moneris
Configuring EMV Moneris

21

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

10. Select the Dialing tab. 

11. Under the ‘Phone Numbers’ group bar, type the phone number used for authorizations.
12. Type the phone number used for settlements.
13. Click Save and exit the Processor function.

Figure 22  Dialing Tab
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Configuring payment cards for use with Moneris
You must also assign the appropriate payments cards to the Moneris processor.

1. Select Maintenance > Electronic Draft Capture > Cards. 

2. Under the ‘Common Credit Cards’ group bar, select Moneris for each credit card type that will 
use the Moneris processor.

3. Under the ‘Debit Cards’ group bar, select Moneris from the ‘Canadian Debit’ drop-down list. 
Note: Selecting ‘Moneris’ as the Canadian Debit processor disables the US Debit option.

4. Under the ‘Other Cards’ group bar, select Moneris from the ‘Chip ‘N Pin’ drop-down list.
5. Click Save and exit the Cards function. 

Figure 23  Configuring Cards to Use with Moneris
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Enabling Chip and PIN 
You must enable Chip and PIN in the Aloha POS system to use chip-based technology so you can 
accept credit cards using EMV Moneris. 

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the Credit Card group located at the bottom of the screen. 

4. Under the ‘EDC Setup’ group bar, select Use Chip N Pin to enable the Chip and PIN 
functionality for Aloha EDC.

5. Select Moneris from the ‘EMV processor’ drop-down list to force employees and guests to insert 
or slide chip-enabled cards into the PIN pad device to complete a transaction. When you select 
Moneris as the EMV processor, additional options appear. 

6. Select Allow standard credit card processing on POS terminals to allow employees and 
guests to slide a chip-enabled card on a magnetic stripe reader (MSR) or enter the card number 
manually on the FOH only as a backup method. Selecting this option may impede EMV 
functionality; however, if you do, you have the choice of having the FOH display an EMV liability 
warning message. 

7. Select Display EMV liability warning to enable the alert, ‘Processing credit cards at this POS 
terminal could result in liabilities and fees due to EMV requirements. Would you like to 
proceed?’ on the FOH. (Recommended)

8. Select Disable credit card adjustments to prevent credit card adjustments after the payment 
has processed. An error message appears if there is an attempt to adjust the payment, and the 

Figure 24  Store Settings Tab - Credit Card Group
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Adjust and Adjust Tips buttons are not available on the Tender screen. Use this feature in 
conjunction with Maintenance > Electronic Draft Capture > Processor > Options tab > 
Options group bar > Disable adjustments. 
If you select both ‘Disable credit card adjustments’ in the POS and ‘Disable adjustments’ in EDC, 
the system prevents an employee from adjusting a processed credit card payment.
If you select ‘Disable credit card adjustments’ in the POS and clear ‘Disable adjustments’ in EDC, 
the FOH prevents the employee from adjusting the processed credit card payment.
If you clear ‘Disable credit card adjustments’ in the POS and select ‘Disable adjustments’ in EDC, 
the employee can adjust the processed credit card payment; however, EDC stops the transaction 
and an ‘Adjustments were disabled at the time of this transaction’ error message appears in EDC.

9. Click Save and continue to the next procedure. 

Enabling voucher requirements for Moneris
Moneris has specific requirements that must appear on the voucher. This procedure is mandatory.

1. Select Maintenance > Business > Store. 
2. Select the Store Settings tab.
3. Select the Credit Card group located at the bottom of the screen. 

4. Under the ‘Voucher print settings’ group bar, select Moneris from the ‘Print mandatory 
processor vouchers’ drop-down list. 

Figure 25  Voucher Print Settings Group Bar
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5. Select Print first voucher with guest check to combine the customer voucher with the guest 
check, saving paper. (Optional) 

6. Click Save and exit the Store function.

Creating a tender for each PIN pad device 
The Ingenico PIN pad device can read a chip-enabled card, a magnetic stripe card, and a contactless 
card, and has the ability to detect the card type for you. In a fast-paced environment, it is possible to 
connect two of these devices to a single POS terminal and use the ‘slide and go’ environment to 
process a payment from one guest on the first PIN pad device while processing a payment from 
another guest on the second PIN pad device. Instead of the cashier touching a specific tender type 
on the Tender screen, such as MasterCard or Visa, you display two buttons on the Tender screen, one 
for each PIN pad device. The cashier alternately selects between the two buttons based on the PIN 
pad device that is available for processing a payment. 

SCENARIO: You work as a cashier in a fast-paced environment in which you have a line of guests
waiting to pay. Enter the first order and touch PIN Pad #1 on the Tender screen to initiate payment on
the primary PIN pad device. While the first guest is responding to the prompts, enter the next order
and touch PIN Pad #2 on the Tender screen to initiate payment on the secondary PIN pad device. 

1. Select Maintenance > Payments > Tenders.
2. Click the New drop-down arrow, select Credit Card and click OK. 

3. Under the ‘Settings’ group bar, accept the system assigned number or click the ellipsis button 
(...) next to ‘Number’ to display the Number Assignment dialog box, from which you can choose 
an alternate number. 

Figure 26  Tenders - Tenders Tab



 EMV Moneris
Configuring EMV Moneris

26

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

4. Type a name for the primary PIN pad device, such as ‘PIN Pad #1.’ 
5. If using Table Service, click the ellipsis (...) to display the ‘Select New Button Position’ dialog 

box and select an available position for the PIN pad device on the Tender screen, or select First 
available button position to assign the device to the first available button on the screen. For 
Quick Service, access Quick Service Screen Designer to add a button for each PIN pad device to 
the panel currently used for tendering. See “Creating a tender button for each PIN pad device 
(QS only)” on page 28.

6. Select Can refund. (Required)
7. Under the ‘Tips’ group bar, select Allow tips if you allow tips for this tender. 
8. Configure the remaining options as normal.
9. Select the Type tab. 

10. Under the ‘Type settings’ group bar, select Not Applicable as the credit card provider. 
(Required) A ‘Not Applicable’ tender alerts EDC to handle the transaction outside the normal 
process, send the amount due to the PIN pad device, and prompt the guest through the payment 
process. 

11. Select Primary PIN pad from the ‘Prompt for payment using the following PIN pad’ drop-down 
list. 

Figure 27  Tenders - Type Tab
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12. Select the Authorization tab. 

13. Select Require authorization to display additional options and to allow use with the Ingenico 
iPP320 PIN pad device. (Required) 

14. Select Print on check to print the authorization code on the guest check. (Required)
15. Select Authorize using EDC to use Aloha EDC for credit card authorization. (Required)
16. Select Allow pre-auth with EDC to use Aloha EDC for credit card pre-authorization. (Required)
17. Click Save.
18. If using a second PIN pad device, repeat this procedure. When configuring the Type tab, select 

Secondary PIN pad from the ‘Prompt for payment using the following PIN pad’ drop-down list.
19. Exit the Tenders function. 

Creating a tender button for each PIN pad device (QS only) 
For Aloha Quick Service operations, you must add a button to the Tender screen for each PIN pad 
device. For Table Service operations, the system adds the button for you based on the button 
configuration of the PIN pad device in the Tenders function.

1. Select Maintenance > Screen Designer > Quick Service Screen Designer.
2. Select Work with Panels.
3. Select Panel > Open Panel, select a panel to edit, such as the Tender panel, and click OK.

Figure 28  Tenders - Authorization Tab

Reference
Refer to the Credit Card Lookup in Quick Service Feature Focus Guide - HKS336 for more 
information on ‘Slide and Go’ and more.

https://okm.ncrvoyix.com/infocenter/index?page=content&id=HKS336
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4. Select an available button or create a new button. The Properties dialog box appears. 

5. Under the ‘Function’ group bar, select Tender from the ‘Action’ drop-down list.
6. Select the primary PIN pad from the ‘Tender’ drop-down list.
7. Select True or False from the ‘Open Drawer’ drop-down list, depending on your business needs.
8. Under the ‘Appearance’ group bar, type a name for the button, such as PIN Pad\n#1.’ To display 

text on multiple lines, insert ‘\n’ without spaces for line breaks.
9. Configure the remaining options as you would for any other button.
10. Repeat this procedure for a second PIN pad tender button, if you have a second iPP320 PIN 

Pad device attached to the terminal.
11. Select Panel > Save Panel.
12. Select File > Exit to exit Quick Service Screen Designer.

Figure 29  Properties Dialog Box
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Bypassing the wait time for PIN pad authorization in Quick Service 
In a fast-paced environment, it is possible to connect two PIN pad devices to a single POS terminal 
and use the ‘slide and go’ environment to process a payment from on guest on the first PIN pad 
device while processing a payment from another guest on the second PIN pad device. In order to 
bypass the wait time for one PIN pad device to provide authorization and complete the transaction, 
clear the ‘Wait for credit authorization’ feature found in Revenue Center. 

To bypass the wait time for PIN pad authorization in Quick Service: 

1. Select Maintenance > System Settings > Revenue Center.
2. Select the revenue center from the drop-down list. 

3. Clear Wait for credit card authorization to continue to the next transaction.
4. Click Save and exit Revenue Center.

Figure 30  Revenue Center
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Assigning a PIN pad device to a POS terminal
1. Select Maintenance > Hardware > Terminals.
2. Select the POS terminal to which to assign a PIN pad device from the ‘Terminal’ drop-down list.
3. Select the Output Devices tab. 

4. Under the ‘PIN pad’ group bar, select Ingenico IPP320. Additional options appear.
5. Select the COM port to which you attached the first PIN pad device from the ‘Port’ drop-down 

list. For example, ‘COM1.’
6. Type the unique terminal ID to assign to the first PIN pad device. This is mandatory. Contact the 

processor for the unique terminal ID.
7. Select Ingenico IPP320 from the ‘Secondary PIN pad’ drop-down list, if using two PIN pad 

devices per POS terminal. Additional options appear.
8. Select the COM port to which you attached the second PIN pad device from the ‘Secondary 

port’ drop-down list. For example, ‘COM2.’
9. Type the unique terminal ID to assign to the second PIN pad device. This is mandatory. Contact 

the processor for the unique terminal ID. 

Figure 31  Terminals - Output Devices Tab
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10. Click the EDC Settings tab. 

11. Click Add.
12. Select Moneris from the ‘Processor’ drop-down list.
13. Type the unique terminal ID obtained from the processor for this POS terminal. 
14. Select another processor from the ‘Processor’ drop-down list, if necessary. Note: You cannot 

select Moneris for the secondary processor.
15. Type the unique terminal ID either provided by the processor or assigned by you. 
16. Click Save and exit the Terminals function.

Figure 32  Terminals - EDC Settings Tab
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Overriding EMV verifications
The POS offers a POS access level to allow merchants to slide EMV-enabled cards through an MSR 
on the POS terminal, but only as a backup and optional solution. Enable this feature based on your 
business needs.

1. Select Maintenance > Labor > Pos Access Levels.
2. Select the access level from the POS Access Level drop-down list. 

3. Under the ‘Financial’ group bar, select Override EMV verifications to allow employees 
assigned this access level to slide the EMV-enabled card through an MSR on the FOH only as a 
backup and optional solution. 

4. Click Save.
5. Repeat this procedure for any other access level requiring the ability to slide an EMV-enabled 

card through the MSR on the POS terminal.
6. Exit the Pos Access Levels function.

Figure 33  POS Access Levels
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Refreshing the data
Once you configure the necessary features for EMV, you must refresh the Aloha POS system, then 
stop, and restart EDC Service (EDCSvr).  

Select Utilities > POS > Refresh POS & All Installed Products to transfer the new information to 
the FOH terminals, or wait for the End-of-Day (EOD) process to accomplish the data refresh for you. 
Note: If you run the refresh prior to the EOD process, select ‘Automatically restart all POS terminals’ 
and click OK to continue. After the data refresh is complete, all new settings become operational 
across the Aloha network.  

Go to Windows Services, select EDC Service to stop and then restart. PIN pads obtain 
proper configuration.

Tip
If you make any changes to the wireless PIN pad device settings, such as changing the IP address or 
adding an additional wireless PIN pad device, you must (1) refresh the Aloha POS and All Installed 
Products, and (2) stop the ‘POS processing’ in Aloha EDC, and then restart it.

Caution
Refresh data with caution and never during peak hours of operation. All FOH terminals reboot 
during a refresh and are down for a short period of time.
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Using Moneris and the PIN pad device
The magnetic stripe reader on a smart card stores data that allows the card to be read by the MSR or 
inserted for chip processing. The Ingenico iPP320 PIN pad device allows your guest to slide, tap or 
insert the chip-enabled card. 

Getting started 
As the guest makes selections, the Ingenico iPP320 PIN pad device auto-advances to the next screen.

1. Enter the items on the front-of-house (FOH) terminal.
2. Touch the PIN Pad #1 tender to initiate payment. 

The ‘Please wait for card entry on supported device’ message appears on the FOH. If you touch 
Cancel, the transaction cancels and the POS system returns to the on-screen guest check. 

Figure 34  Wait for Card Entry Message on FOH

Figure 35  Welcome Screen
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The PIN pad device initializes and the Welcome screen appears.

3. The guest inserts the payment card into the Ingenico iPP320. The PIN pad device confirms the 
brand of the card. The total purchase amount appears.

4. The guest presses OK to approve the purchase.

Figure 36  Amount Appears With Guest Instructions

Figure 37  Purchase Approval Screen
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5. If desired, using the keypad, the guest enters a tip amount, and presses OK. Note: The guest 
must include a tip while the card remains in the PIN pad device; card adjustments cannot be 
made once the card is removed. 

6. The guest presses OK to approve the total amount. 

7. The guest enters the PIN and presses OK. The ‘Please Wait, Do Not Remove Card’ message 
appears while the device sends the transaction.

Figure 38  Enter Tip Amount Screen

Figure 39  Enter Tip Screen
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‘Approved’ appears on the Ingenico iPP320 PIN pad device, and the device prompts the guest to
remove the card. 

8. The guest removes the card from the PIN pad device.

Adding a tip 
A guest can add a tip to the check using the PIN pad device during the prompts if the PIN pad tender 
is configured for tips.

Figure 40  Transaction Complete
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Explaining PIN pad voucher requirements
EMV and Moneris have specific requirements for vouchers. To meet these requirements, the voucher 
prints the required fields in English or French, based on the language code on the card being used. 
If a preferred language is not read by the device, the voucher prints in English. 

Information provided on the voucher differentiates between transactions performed on the Ingenico 
iPP320 PIN pad device (contact, contactless, MSR) and those allowed on the POS terminal (MSR and 
manual card entry). Transactions using the PIN pad device print the required EMV information on the 
voucher.

Vouchers for Ingenico iPP320 PIN pad devices

If the guest inserts, taps, or slides a chip-enabled card using the magnetic stripe reader (MSR) on the 
Ingenico iPP320 PIN pad, the voucher contains the required EMV tag lines. See the examples 
provided below.

If the PIN pad device reads the language code of the card as English, the voucher appears as: 

Figure 41  Purchase with Tip - English
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If the PIN pad device reads the language code of the card as French, the voucher appears as:

Figure 42  Purchase with Tip - French
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Vouchers for MSR on POS terminal 

If the PIN pad device fails to read the card chip and the magnetic stripe reader cannot read the 
magnetic stripe of the card, you can slide the card using the magnetic stripe reader on the POS 
terminal if you have the appropriate access level. Because the POS terminal reads the card, the 
vouchers do not contain the EMV tag lines. 

Examples provided below show vouchers in English and French. If the PIN pad device reads the 
language code of the card as English, the voucher appears as: 

Figure 43  Purchase with Tip - English
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If the PIN pad device reads the language code of the card as French, the voucher appears as: 

Figure 44  Purchase with Tip - French
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Reporting Moneris
Aloha EDC supplies four new indicators on the EDC Transaction and EDC Audit Transaction reports, 
including ‘fallback’ transactions. A fallback transaction occurs when a chip-enabled card is ultimately 
used by sliding the card on the MSR instead of inserting the card, or tapping the card on the PIN pad 
device.

The indicators appear to the right of the authorization code on the reports.

● ‘E’ appears if a guest inserts a chip-enabled card (contact transaction) into the iPP320 PIN pad 
device.

● ‘ET’ appears if a guest taps a chip-enabled card (contact-less transaction) on the iPP320 PIN pad 
device.

● ‘ES’ appears if a guest inserts a chip-enabled card, the PIN pad device is unable to read the chip, 
and you must slide the card using the MSR. 

● ‘EM’ appears if a guest inserts a chip-enabled card, the PIN pad device is unable to read the 
chip, and you must manually enter the card number on the Front-of-House (FOH). 

Figure 45  EDC Transaction Report Example
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Troubleshooting Moneris
The following are error messages and troubleshooting tips when using Moneris and the Ingenico 
iPP320 PIN pad device.

FOH guest check error message

If you attempt to use a chip-enabled payment card, the following error message, ‘Processor not 
configured,’ appears on the FOH screen when Moneris is not configured in Maintenance > 
Electronic Draft Capture > Cards. 

PIN pad does not initialize after touching PIN pad #1 or PIN pad #2

If you touch either PIN Pad #1 or PIN Pad #2 (as the ‘Not Applicable’ tender) and the PIN pad does 
not initialize, verify that ‘Use Chip N Pin’ under the ‘EDC Setup’ group bar in the ‘Credit Card’ group 
is selected in Maintenance > Business > Store > Store Settings tab. 

Transaction not approved

A ‘Transaction Not Approved’ error message appears on the voucher when you attempt a correction 
or void on a payment card that was not used originally. The guest must provide the same payment 
card originally authorized for purchase. 

Figure 46  Processor Not Configured Error Message
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No EMV devices are configured for this tender error message 

If ‘Prompt for payment using the following PIN pad’ is set to None under the ‘Type settings’ group 
bar, in Maintenance > Payments > Tenders > Type tab, the ‘No EMV devices are configured for this 
tender’ error message appears.

EMV devices not detected at this POS terminal 

If ‘Prompt for payment using the following PIN pad is set to PIN Pad #1 or PIN Pad #2 under the 
‘Type settings’ group bar in Maintenance > Payments > Tenders > Type tab and the PIN pad is 
disconnected from the POS terminal (not due to hardware issues or any other type of malfunction), 
the ‘EMV devices not detected at this POS terminal’ error message appears. 

If the PIN pad is connected and properly communicates with Aloha, the PIN pad prompts for 
payment and continues the transaction process. 

Figure 47  No EMV Devices Configure for This Tender Error Message

Figure 48  EMV Devices Not Detected At This POS Terminal Error Message
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EMV devices are not available at this time

If you touch a PIN pad tender and the PIN pad device is not available or in use, the ‘Please wait. EMV 
devices are not available at this time’ warning message appears. 

You and the guest must wait until the PIN pad device becomes available to continue the transaction 
process.

Payment card entry not supported at this terminal

If you attempt to slide the payment card on the MSR or manually enter the credit card data and the 
‘Payment card entry not supported at this terminal’ error message appears on the FOH, the guest 
must use the PIN pad device. 

The warning message appears if:

If you clear ‘Allow standard credit card processing on POS terminals’ under the ‘EDC Setup’ group 
bar in the Credit Card group on the Store Settings tab in Maintenance > Business > Store.

-OR-

If you select ‘Allow standard credit card processing on POS terminals’ under the ‘EDC Setup’ group 
bar of the Credit Card group on the Store Settings tab in Maintenance > Business > Store, but you 

Figure 49  Please Wait. EMV Devices Are Not Available... Error Message

Figure 50  Payment Card Entry Not Supported Error Message
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clear ‘Override EMV verifications’ for the employee under the ‘Financial’ group bar in Maintenance > 
Labor > Pos Access Levels

Processing credit cards at this POS terminal could result...

If you select ‘Allow standard credit card processing on POS terminals’ and ‘Display EMV liability 
warning’ under the ‘EDC Setup’ group bar of the Credit Card group on the Store Settings tab in 
Maintenance > Business > Store > Store Settings tab, and you select the ‘Override EMV verifications’ 
access level, the ‘Processing credit cards at this POS terminal could result in liabilities and fees due 
to EMV requirements. Would you like to proceed?’ warning message appears. 

To allow sliding the card or manually entering the card number, touch OK. The POS system prompts 
for the cardholder verification process, such as entering a ZIP code and/or the three-digit security 
code located on the back of the payment card, if properly configured.

If you touch cancel, the FOH returns to the guest check. 

No EMV devices are configured for this POS terminal 

If you touch a PIN pad tender and the ‘No EMV devices are configured for this POS terminal’ error 
message appears on the FOH screen, you must configure a PIN pad device for the terminal.

Figure 51  Processing Credit Cards At This Terminal... Error Message

Figure 52  No EMV Devices are Configured for This POS Terminal
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Please wait for card entry on supported device

If you touch the PIN pad tender, enter the amount, and touch OK, the ‘Please wait for card entry on 
supported device’ alert message appears. 

The PIN pad must initialize, display the amount due, and then start the EMV prompts for the guest. If 
you touch Cancel, the screen returns to the guest check.

Moneris and offline transactions

Moneris does not allow offline transactions. 

Figure 53  Please Wait for Card Entry on Supported Device Alert Message
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Appendix
This section provides detailed information regarding Address Verification System (AVS) and Card 
Validation response codes.

AVS response codes
To use the Address Verification feature, using the appropriate credit card tender, select ‘Enter 
address verification code’ and complete the options under the ‘Address’ group bar on the Security 
Verification tab in Maintenance > Payments > Tenders. 

MasterCard Responses

Value Description

A Address matches, postal code does not.

N Neither address nor postal code match.

R Retry, system unable to process.

S AVS not currently supported.

U No data from issuer/authorization system.

W For U.S. addresses, nine-digit postal code and addresses matches; for addresses outside the 
U.S., postal code matches, address does not.

X For U.S. addresses, nine-digit postal code and addresses matches; for addresses outside the 
U.S., postal code and address match.

Y For U.S. addresses, five-digit postal code and address matches.

Z For U.S. addresses, five-digit postal code matches, address does not.

AmEx/JCB Card Responses

Value Description

Y Billing address and postal code both match.

N Billing address and postal code do not match.

A Billing address matches, postal code does not.

Z Postal code matches, billing address does not.

U Information is unavailable.

S AVS not currently supported.

R System unavailable, retry.

L CM name and postal code match.
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M CM name, billing address, and postal code match.

O CM name and billing address match.

K CM name matches.

D CM name incorrect, postal code matches.

E CM name incorrect, billing address and postal code match.

F CM name incorrect, billing address matches.

W CM name, billing address, and postal code are all correct.

Visa Card Responses

Value Description Domestic International

A The street address matches but the postal/ZIP code does not, or 
the request does not include the postal/ZIP code.

X X

B Street address matches, but postal code not verified due to 
incompatible formats. (Acquirer sent both street address and 
postal code.)

X X

C Street address and postal code not verified due to incompatible 
formats. (Acquirer sent both street address and postal code.)

X X

D Street address and postal code match. X

G Address information not verified for international transaction. X

I Address information not verified. X

M Street address and postal code match. X

N No match. Acquirer sent postal/ZIP code only, or street address 
only, or both postal code and street address.

X X

P Postal code match. Acquirer sent both postal code and street 
address, but street address was not verified due to incompatible 
formats.

X X

R Retry, system was unavailable or timed out. Issuer ordinarily 
performs its own AVS but was unavailable. Available for U.S. 
issuers only.

X

S Not applicable. If present, replaced with G (for international) or 
U (for domestic) by V.I.P. Available for U.S. issuers only.

X

AmEx/JCB Card Responses

Value Description
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U Address not verified for domestic transaction. Visa check failed 
because: no AVS information was available on record; issuer is 
not an AVS participant; or AVS data was present in the request 
but issuer did not return an AVS result.

X

W Not applicable. If present, replaced with Z by V.I.P. Available for 
U.S. issuers only.

X

X Not applicable. If present, replaced with Y by V.I.P. Available for 
U.S. issuers only.

X

Y Street address and postal code match. X

Z Postal/ZIP matches, but street address does not match, or was 
not included in request.

X X

Discover Card Responses

Value Description

X Address matches, nine-digit postal code matches.

A Address matches, five-digit postal code matches.

Y Address matches, postal code does not.

T Nine-digit postal code matches, address does not.

Z Five-digit postal code matches, address does not.

N Nothing matches.

W No data from Issuer/Authorization system.

U Retry, system unable to process.

S AVS not supported at this time.

G Address information not verified for international transaction.

Visa Card Responses

Value Description Domestic International
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Card validation codes (CVC2, CVV2, CID)
The card validation codes are located on the back of the payment cards. The following are responses 
that you may receive for a transaction.  

Responses

Value Description

D Invalid security code for AMEX/JCB/Discover (CID).

M CVV2 match.

N No match for CVV2 or for CID.

P Not processed.

S CVV2 should be on the card, but the merchant has indicated that CVV2 is not present.

U Uncertified issuer (issuer not a CVV2 participant CID was not checked).

Y Match for AMEX/JCB/Discover (CID).
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EMV Moneris, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com

	EMV Moneris
	Contents
	About EMV Moneris
	Configuring Ingenico iPP320 PIN pad devices
	Installing the Ingenico iPP320 device driver
	Attaching the Ingenico iPP320 PIN pad device to a terminal
	Locating Ingenico iPP320 serial numbers
	Initializing the Ingenico iPP320 device

	Configuring EMV Moneris
	Configuring the Moneris processor
	Configuring payment cards for use with Moneris
	Enabling Chip and PIN
	Enabling voucher requirements for Moneris
	Creating a tender for each PIN pad device
	Creating a tender button for each PIN pad device (QS only)
	Bypassing the wait time for PIN pad authorization in Quick Service
	Assigning a PIN pad device to a POS terminal
	Overriding EMV verifications
	Refreshing the data

	Using Moneris and the PIN pad device
	Getting started

	Reporting Moneris
	Troubleshooting Moneris
	Appendix



