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Revision Record

Date Version # Description

Prior to 
12/15/2022

v7.0+ Implemented Custom FOH Reports using a manual method with an 
external .cfg file that you place in the Data directory. 

v12.3.31+ Enhanced the solution by adding the Custom FOH Report function in the 
configuration management tool. This allows you to build expressions for 
syntaxes in an easier manner. Additionally, we migrated the configuration 
of a custom report from an external .cfg file created with a text editor to 
creating the file with the new interface, and provided additional filters. 

v12.3.52+ Added the ‘Allow report to be run for multiple employees at a time’ option 
to provide the ability to select and generate data in the report for more 
than one employee at a time.

v15.1+ Added a new option for controlling how data sorts and appears in a 
custom FOH report. Also added a new option for viewing custom FOH 
reports in the FOH instead of automatically printing them to the local 
receipt printer.

v19.3.8+ Added the ability to use the current #GUESTS variable to show fractional 
guest count weights for menu items.

01/13/2023 Converted the document to use new templates. Updated the front cover 
and back page to use new NCR branding.

07/07/2023 v19.9 Added item count variables #Itemsxy|z and #TotalItemsxy|z. A use case for 
the variables is available in Appendix A. 

12/14/2023 Updated document to reflect NCR Voyix branding.
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About Custom FOH Reports   

Custom FOH Reports at a Glance

Core Product Aloha Quick Service, Aloha Table Service

Separate License Required? No

Other References Aloha Quick Service Manager Guide; Aloha Quick Service 
Reference Guide; Aloha Table Service Manager Guide; Aloha 
Table Service Reference Guide

Figure 1  Custom FOH Report 
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Use Custom Front-of-House (FOH) Reports to replace or extend the existing default FOH reports 
available in the Aloha® Point-of-Sale (POS) system. By creating your own reports, you have unlimited 
flexibility for reporting on any facet of your operation, such as comps and promotions, tipouts, and 
more. Additionally, you can filter the reporting data by one or many employees. 

Caution:  If you have Custom FOH reports in place and use Print Intercept to view a custom 
report on the screen versus automatically printing a report, upon upgrade to Aloha POS 
v15.1, you must select a new option called ‘Display custom reports on the FOH’ under the 
‘Report settings’ group bar under the Report Printing group located in Maintenance > 
Business > Store > Store Settings tab. If you do not, all custom FOH reports automatically 
print to the local receipt printer. 

If you configured custom FOH reports prior to Aloha POS v12.3 you did so by creating an 
external configuration file using MS Notepad® and then placing the file in the Data direc-
tory. While not required, we recommend you upgrade your custom FOH reports to use the 
configuration management tool, either Aloha Configuration Center or new Aloha Manager. 
See “Appendix B: Upgrading Custom FOH Reports” on page 43.
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Configuring Custom FOH Reports
This section details the configuration requirements for customizing a FOH report. If you are an 
experienced user, refer to Procedures at a Glance for abbreviated steps. If you prefer more detail, 
continue reading this document.  

Custom FOH Reports Procedures at a Glance:

If you are viewing this document using Adobe® Acrobat Reader, click each link for detailed information 
regarding the task. Click Previous View  to return to this location and proceed to the next step.

1. Access Maintenance > Labor > POS Access Levels and select ‘Custom Reports’ for each access 
level requiring the ability to run custom FOH reports. See page 7.

2. If you use an Aloha POS version earlier than v15.1, open PrtIncptr.ini using a text editor such as 
Notepad, and set FOHDOC_CUSTOMISABLE_REPORT to 1, to allow you to view a custom report 
on-screen instead of automatically sending it to a printer. You then have the choice to print the report, 
if desired. Effective with Aloha POS v15.1, you must access Maintenance > Business > Store > Store 
Settings tab > Report Printing group and select ‘Display custom reports on FOH’ under the ‘Report 
Settings’ group bar. See page 8.

3. Access Maintenance > Business > Custom FOH Reports and create a custom report using the 
Report Line Builder function. See page 10.

4. For Quick Service operations and floor plans used in Table Service, access Maintenance > Screen 
Designer and add a ‘Custom Report’ button to a panel for each report you use. See page 29.

5. For Table Service operations, use Notepad a CustRpt.ini file to design the buttons to appear on the FOH 
Custom Report screen. See page 30.

6. Access Utilities > POS > Refresh POS & All Installed Product Data to update the information on 
the FOH terminals, or wait for the End-of-Day (EOD) process to accomplish the data refresh for you. 
See page 32.
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Providing the ability to run custom FOH reports
To provide the ability for an employee to run custom FOH reports requires you to select ‘Custom 
Reports’ in the access level to which you assign the employee. If you clear this option, the employee 
accessing the report receives the manager approval screen and a manager with sufficient access must 
enter their password to allow the employee to continue.

To provide the ability for an employee to run custom FOH reports: 

1. Select Maintenance > Labor > Pos Access Levels.
2. Select an access level that requires the ability to run custom FOH reports. 

3. Under the ‘Reports’ group bar, select Custom Reports to enable all employees clocked in under 
this access level the ability to run custom reports from the FOH.

4. Click Save. 
5. Repeat this procedure for each access level requiring the ability to run custom FOH reports. 
6. Exit the Access Levels function. 

Figure 2  Pos Access Levels
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Enabling on-screen viewing of custom FOH reports
If you use an Aloha POS version earlier than v15.1, custom FOH reports print to the local printer by 
default. To view a custom report on-screen instead of automatically sending it to the printer, and print 
the report only when desired, requires you to enable the print intercept functionality. To enable print 
intercept, register and ensure PrtInter.dll resides in the Bin directory. You must also include the 
appropriate command lines in PrtIncptr.ini in the Data and Newdata directories. 

Effective with Aloha POS v15.1, PrtInter.dll is no longer required for viewing custom FOH reports 
on-screen. If you want custom reports to appear on the FOH instead of automatically printing, select 
‘Display custom reports on the FOH’ under the ‘Report settings’ group bar, in the ‘Report Printing’ 
group on the Store Settings tab in Maintenance > Business > Store. 

If using an Aloha POS version earlier than v15.1, to view custom FOH reports on-screen: 

1. If using Aloha POS version 6.7 or earlier, access Maintenance > Business > Store > Store 
Settings > System group > Interfaces tab and select Use FOH Com interface. For Aloha 
POS v12.3 and later, the COM interface is enabled by default. 

2. If you currently use print intercept to view standard reports on screen, locate and select 
PrtIncptr.ini in the Newdata directory and press Enter. The file opens in Notepad; otherwise, 
you need to create this file in Notepad and place it in the Newdata directory. 

3. Add the following command line:
FOHDOC_CUSTOMISABLE_REPORT=1

4. Select File > Save. 
5. Exit Notepad. 
6. If you currently use print intercept to view standard reports on screen, continue to step 7; 

otherwise, open a command prompt on each terminal, navigate to the Aloha\Bin folder on the 
Aloha POS system, and execute the following command:
regsvr32 PrtInter.dll

7. Refresh the system and start the FOH. 

Reference:  Refer to RKS ID 9552 Using Aloha Interceptor for detailed information on using the 
Print Intercept feature. 
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If using Aloha POS v15.1 or later, to view custom FOH reports on-screen:

1. Select Maintenance > Business > Store.
2. Select the Store Settings tab.
3. Select the Report Printing group located at the bottom of the screen. 

4. Under the ‘Report settings’ group bar, select Display custom reports on the FOH to allow all 
custom FOH reports to appear on the FOH screen when you touch the desired report button. You 
can also print the report at the local receipt printer if you touch ‘Print’ on the Report screen.

5. Click Save and exit the Store function. 

Figure 3  Report Settings Group Bar
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Creating a custom FOH report
You use the Custom FOH Reports function to create your report and the content within the report. 
Before you start, you need to be aware of the variables to use in the report and the rules to follow the 
correct syntax for the report. If you do not know these, the report may not operate correctly or will not 
generate data at all. Once you understand the variables and the configuration rules, you can use the 
expression builder inside the configuration tool to build your report. See “Creating a custom FOH 
report” on page 10 to build your report. 

Understanding configuration variables
The following table contains the variables you can use.   

Variable Description Type
Initial 
Version

RELATE TO COMPS:

#C Total count of all comps. Calculation

$C Total amount of all comps. Calculation

#Cnnnn Total count of comp nnnn, where nnnn is the ID of 
the comp.

Calculation

$Cnnnn Total amount of comp nnnn, where nnnn is the ID 
of the comp.

Calculation

Variable Description Type
Initial 
Version

RELATE TO DELIVERY:

#Delivery Total count of delivery orders. Calculation

$DelComm Total amount of delivery commissions. Calculation

StartMileage Starting mileage. String 

EndMileage Ending mileage. String

Variable Description Type
Initial 
Version

RELATE TO EMPLOYEES:

FirstName Employee first name. String

LastName Employee last name. String

NickName Employee nickname. String

EmployeeID Employee ID number String
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JobcodeID Job code ID under which the employee clocked 
in.

String

JobcodeName Name of the job code under which the employee 
clocked in.

String

ShiftNumber Shift number under which the employee worked 
for the checkout.

String

Variable Description Type
Initial 
Version

RELATE TO ENTREE COUNT:

#Entrees Total count of entrees sold. Calculation

Variable Description Type
Initial 
Version

RELATE TO GIFT CERTIFICATES:

#GC Total count of all gift certificates sold. Calculation

$GC Total amount of all gift certificates sold. Calculation

#GCnnnn Total count of gift certificate nnnn sold, where 
nnnn is the ID of the gift certificate.

Calculation

$GCnnnn Total amount of all gift certificates nnnn sold, 
where nnnn is the ID of the gift certificate.

Calculation

#GCC Total count of all gift certificate comps. Calculation

$GCC Total dollar amount of all gift certificate comps. Calculation

#GCCnnnn Total count of gift certificate nnnn sold, where 
nnnn is the ID of the gift certificate.

Calculation

$GCCnnnn Total dollar amount of gift certificate nnnn comps, 
where nnnn is the ID of the gift certificate. 

Calculation

#GCP Total count of all gift certificate promos. Calculation

$GCP Total dollar amount of all gift certificate promos. Calculation

#GCPnnnn Total count of gift certificate nnnn promos, where 
nnnn is the ID of the gift certificate.

Calculation

Variable Description Type
Initial 
Version
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$GCPnnnn Total dollar amount of gift certificate nnnn promos, 
where nnnn is the ID of the gift certificate.

Calculation

Variable Description Type
Initial 
Version

RELATE TO GRATUITIES:

$AutoGrat Total amount of all gratuity. Calculation

$AutoGratnnnn Total amount of gratuity of tender type nnnn, 
where nnnn is the ID of the comp.

Calculation

$AutoGratWage Total amount of all wage gratuity. A wage gratuity 
is gratuity with ‘Exclude from employee tip’ 
selected. 

Calculation POS v13.1

$AutoGratWagennnn Total amount of a wage gratuity, where nnnn is the 
ID number of the gratuity configured as a wage 
gratuity. A wage gratuity is gratuity with ‘Exclude 
from employee tip’ selected. 

Calculation POS v13.1

$EmpGrat Total dollar amount of non-distributed and 
non-team gratuity for the shift of an employee. This 
variable is used for a tip and sales distribution 
environment.

Calculation POS v14.1

$TeamGrat Total dollar amount of distributed gratuity from 
team checks. This variable is used for a tip and 
sales distribution environment.

Calculation POS v14.1

Variable Description Type
Initial 
Version

RELATE TO GUEST CHECKS:

#Checks Total count of all checks Calculation

#SplitChecks Total count of split checks for this server for this 
checkout.

Calculation

Variable Description Type
Initial 
Version
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Variable Description Type
Initial 
Version

RELATE TO GUEST COUNTS:

#Guests Total count of all guests.
To report fractional guest counts, use the same 
variable and define a fractional value in ‘Guest 
count weight’ under the ‘General’ group bar in 
Maintenance > Menu > Items > General Settings 
tab, and select ‘Reports use fractional guest 
counts’ on the Guest Count tab in Maintenance > 
Business > Store > Store Settings tab > Order 
Entry group.

Calculation

Variable Description Type
Initial 
Version

RELATE TO ITEM COUNT:

#Itemsxy|z The count of items sold from a specified category 
and one or more order modes where x indicates 
to include or exclude the listed order mode(s), y is 
the category ID, and z is the order mode IDs to 
include or exclude. If more than one order mode, 
separate the IDs with commas. For example, 
#ItemsInclusive3|4,5 represents a count of items 
from category ID 3 with order mode IDs 4 and 5. 
#ItemsExclusive11|20 represents a count of items 
from category ID 11 with all order modes except 
ID 20. Note: This variable is not supported for a 
custom checkout report.

Calculation POS v19.9
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#TotalItemsxy|z Total count of items sold from a specified category 
and one or more order modes where x indicates 
to include or exclude the listed order mode(s), y is 
the category ID, and z is the order mode IDs to 
include or exclude. If more than one order mode, 
separate the IDs with commas. For example, 
#TotalItemsInclusive3|4,5 represents a total count 
of items from category ID 3 with order mode IDs 4 
and 5. #TotalItemsExclusive11|20 represents a 
total count of items from category ID 11 with all 
order modes except ID 20. When paired with the 
#Itemsxy|z, variable, ensure both have the same 
category and order mode requirements. Note: 
This variable is not supported for a custom 
checkout report.

Calculation POS v19.9

Variable Description Type
Initial 
Version

RELATE TO ITEMS:

#ClearItems Total count of all cleared items. Calculation POS v6.8

$ClearItems Total amount from all cleared items. Calculation POS v6.8

Variable Description Type
Initial 
Version

RELATE TO ORDER MODE CHARGES:

#OMCnnnn Total count of order mode charges for ordermode 
nnnn, where nnnn is the ID of the order mode.

Calculation

$OMCnnnn Total amount of order mode charges for order 
mode nnnn, where nnnn is the ID of the order 
mode.

Calculation

Variable Description Type
Initial 
Version

RELATE TO PETTY CASH ACCOUNTS:

Variable Description Type
Initial 
Version
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$ACCTD Total amount of petty cash accounts. Calculation

#ACCTD Total count of petty cash accounts. Calculation

#ACCTnnnn Total count of transactions for cash account nnnn, 
where nnnn is the ID of the petty cash account.

Calculation

$ACCTnnnn Total amount of transactions for cash account 
nnnn, where nnnn is the ID of the petty cash 
account.

Calculation

Variable Description Type
Initial 
Version

RELATE TO PROMOTIONS:

#P Total count of all promos. Calculation

$P Total amount of all promos. Calculation

#Pnnnn Total count of promo nnnn, where nnnn is the ID 
of the promotion.

Calculation

$Pnnnn Total amount of promo nnnn, where nnnn is the ID 
of the promotion.

Calculation

Variable Description Type
Initial 
Version

RELATE TO REFUNDS:

#R Total count of all refunds. Calculation POS v7.0

$R Total amount of all refunds. Calculation POS v7.0

Variable Description Type
Initial 
Version

RELATE TO REVENUE ITEMS:

#Rev Total number of revenue items sold. Calculation

$Rev Total amount of all revenue items sold. Calculation

Variable Description Type
Initial 
Version
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Variable Description Type
Initial 
Version

RELATE TO ROUNDING:

$Rounding Total amount of rounding adjusted total, if using 
the ‘round check to nickel’ option.

Calculation

Variable Description Type
Initial 
Version

RELATE TO SALES:

#EmpSls Total dollar amount of non-distributed and 
non-team sales for the shift of an employee. The 
sales amount is for net sales based on sales - 
inclusive tax - comps - promos, irregardless of the 
‘NetHasComps’ and ‘NetHasPromos’ variable. 
This variable is used for a tip and sales distribution 
environment.

Calculation POS v14.1

#S Total count from all sales categories. Calculation

$S Total amount from all sales categories. Calculation

#Snnnn Total count from sales category nnnn, where nnnn 
is the ID of the sales category.

Calculation

$Snnnn Total amount from sales category nnnn, where 
nnnn is the ID of the sales category.

Calculation

#NoSales Total count of No Sale (open drawer) operations 
performed (Quick Service only).

Calculation

$Cash Total amount of calculated cash, based on the 
following calculation: sales + taxes + gift 
certificates sold - tenders - comps - promos + not 
redeemed + tip reduction + mode charges.

Calculation

$DeclCash Total amount of declared cash (Table Service 
only).

Calculation

$Net Total dollar amount of net sales from all 
categories.

Calculation

$Netnnnn Total dollar amount of net sales from category 
nnnn, where nnnn is the ID of the category.

Calculation
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$TeamSls Total dollar amount of distributed sales from team 
checks. The sales amount is for net sales based on 
sales - inclusive tax - comps - promos, irregardless 
of the ‘NetHasComps’ and ‘NetHasPromos’ 
variable. This variable is used for a tip and sales 
distribution environment. 

Calculation POS v14.1

$TipSale Tippable sales for the check. Note: This variable 
is only supported on a Guest Check Message. 

Calculation POS v6.4

Variable Description Type
Initial 
Version

RELATE TO STORE INFORMATION:

RestUnitNumber Restaurant ID number. String

RestUnitName Restaurant unit name. String

RestAddressOne First line of restaurant address. String

RestAddressTwo Second line of restaurant address. String

StoreNumber SuperSite store ID. String

StoreName SuperSite store name. String

Variable Description Type
Initial 
Version

RELATE TO SERVICE CHARGES:

#SVC Total count of service charges. Calculation

$SVC Total amount of service charges. Calculation

Variable Description Type
Initial 
Version

RELATE TO SURCHARGES:

$Sur Total amount of all surcharges. Calculation

$SURnnnn Total amount of surcharge nnnn, where nnnn is the 
ID of the surcharge. 

Calculation

Variable Description Type
Initial 
Version
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Variable Description Type
Initial 
Version

RELATE TO SYSTEM:

SystemDate Date at the time of printing. String

PrintTime Time when the printing occurs. String

DOB Date of business. String

RptFirstName The first name of the employee who ran the 
report.

String POS v14.2

RptLastName The last name of the employee who ran the report. String POS v14.2

RptEmployeeID The ID of the employee who ran the report. String POS v14.2

RptJobCodeID The ID of the job code of the employee who ran 
the report.

String POS v14.2

RptJobCodeName The job code of the employee who ran the report. String POS v14.2

RptShiftNumber The shift number of the employee who ran the 
report. 

String POS v14.2

Variable Description Type
Initial 
Version

RELATE TO TAXES:

#GST Total count of GST taxes. Calculation

$GST Total amount of GST taxes. Calculation

$X Total amount of all taxes. Calculation

$Xnnnn Total amount of tax nnnn, where nnnn is the ID of 
the tax.

Calculation

$XI Total amount of inclusive taxes. Calculation

$XE Total amount of exclusive taxes. Calculation

#TaxExempt Total count of tax exempt transactions. Calculation

$TaxExempt Total amount of tax exempt transactions. Calculation
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Variable Description Type
Initial 
Version

RELATE TO TENDERS:

#CCGROREQxxx@nnn Total count of all credit card transactions greater 
than a specified amount, where xxx is the 
specified threshold and nnn is the tender ID. For 
example, to count the number of transactions 
above $25.00 with a Visa (tender ID 1), type 
#CCGROREQ25@001.

Calculation POS v12.3

$CCGROREQxxx@nnn Total amount from all credit card transactions 
greater than a specified amount, where xxx is the 
specified threshold and nnn is the tender ID. For 
example, to obtain the total amount of sales from 
Master Card (tender ID 2), which were over 
$50.00, type $CCGROREQ50@002.

Calculation POS v12.3

#T Total amount of all tenders. Calculation

$T Total dollar amount of all tenders (includes 
gratuity, voluntary tips, and non-redeemed 
payments).

Calculation

#Tnnnn Total count of tender nnnn, where nnnn is the ID of 
the tender.

Calculation

$Tnnnn Total amount of tender nnnn, where nnnn is the ID 
of the tender.

Calculation

$TNRnnnn Total amount of tender nnnn not redeemed 
(overpayment without charge to guest), where 
nnnn is the ID of the tender.

Calculation

TFCnnnn Total amount of foreign currency tender nnnn in 
foreign currency, not base currency, where nnnn 
is the ID of the tender.

Calculation

Variable Description Type
Initial 
Version

RELATE TO TIPS:

$EmpCCTips Total dollar amount of non-distributed and 
non-team charge tips for the shift of an employee. 
This variable is used for a tip and sales distribution 
environment.

Calculation POS v14.1
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$TeamCCTips Total dollar amount of all distributed charge tips 
from team checks. This variable is used for a tip 
and sales distribution environment. 

Calculation POS v14.1

$Tips Total amount of all tips on noncash tenders. Wage 
gratuities are excluded from this amount. 

Calculation

$Tipsnnnn Total amount of tips for tender nnnn, where nnnn 
is the ID of the tender. Wage gratuities are 
excluded from this amount. 

Calculation

$TipsCollected Total dollar amount of tips collected. Wage 
gratuities are excluded from this amount.

Calculation

$TipsOwed Total dollar amount of tips owed. Wage gratuities 
are excluded from this amount.

Calculation

$TipRedux Total amount of tip reduction. Wage gratuities are 
excluded from this amount.

Calculation

Variable Description Type
Initial 
Version

RELATE TO TIPSHARE:

$EmpTipsharePaid Total dollar amount of non-distributed and 
non-team contributed tipshare for the shift of an 
employee. This variable is used for a tip and sales 
distribution environment.

Calculation POS v14.1

$TeamTipsharePaid Total dollar amount of contributed tipshare based 
on distributed sales from team checks. This 
variable is used for a tip and sales distribution 
environment.

Calculation POS v14.1

$TipsharePaid Total amount of tipshare paid Calculation

Variable Description Type
Initial 
Version

RELATE TO VOIDS:

#V Total count of all voids. Calculation POS v7.0

$V Total amount of all voids. Calculation POS v7.0

Variable Description Type
Initial 
Version
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Understanding configuration rules
It is necessary to follow certain rules when creating your configuration file. 

Print for all employees or by job code

Use a header to tell the system to print the custom information. You must dedicate the first line to a 
header; otherwise, anything placed before the header does not print. If the custom information is to 
print for all employees, use [Default]. If the custom information is to print for a specific job code, or 
job codes, use a ‘jobcode’ header. The information prints until you insert another header to tell the 
system to print differently.  

Fill a line with a single character

For readability and dividing sections, you can insert a line composed entirely of a single character. 
You must use the ‘Fill’ command, enclosed inside greater and less than brackets. Common characters 
are -, *, or =. 

Insert free text

You can insert free text for such things as section headings, labels for calculations, and more. Do not 
use closing and ending greater and less than brackets (<>) around any free text. These characters are 
reserved for a dynamic calculation or string. 

Header Examples

[Default] Prints custom information for all employees.

[Jobcode:1,5,41] Prints custom information for employees who clocked in under job code IDs 1,5, and 
41 only.

[Jobcode:40] Prints custom information only for employees who clocked in under job code ID 40. 

Tip:  The first line of your custom information must be a header.

Fill Command Result Printed on the Report

<Fill(*)> **************************************
**

Free Text Result Printed on the Report

Sales Section Sales Section
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Insert blank lines

Each line in the custom configuration file equals to a line printed for your custom information. If you 
want a blank line to print, insert a blank line in the configuration file. A line for a header is ignored. 

Insert dynamic calculations and strings

Dynamic calculations and strings are the main components of your custom information. A calculation 
is a count or equation of a value on which you want to report, such as the number of all comps, or the 
calculated total of all comp amounts. A string is the name of a supported variable pulled from within 
the system, such as the last name of an employee, or the date of business. 

To configure, you must include three required elements, all inside of beginning and closing greater 
and less than brackets, as shown in the following: 

<Val(width:formula)>

Val - Indicates the result will be a dynamic calculation or string. 

Width - Specifies the number of spaces to use for the value, depending on if you are inserting a 
dynamic calculation or a string. 

Lines in Checkout.cfg Result Printed on the Report

[Default]

<Val(1:DOB)> 01/01/2011

<Fill(=)> ================================

Width Used with a Calculation Width Used with a String

Enter a number, from 1 to 6, to indicate the number 
of digits for a calculated value, such as 00.00. The 
value is always flush right and the decimal point is 
not considered in the width. You must ensure you 
indicate the correct number of spaces for the given 
value to avoid truncating. For example, if you 
specify a width of 3, and the result is 1234, the 1 
does not print on the report. 

Always enter a width of 1 when using a string. The 
system pulls in the string no matter the length of 
characters within the string. 
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Formula - Specifies the equation of the calculation or the name of the string. 

Align text and values on a line

Whether you use free text, a dynamic calculation, or a string, you can align all or individual attributes 
on a line. Each line is left aligned, by default, but you can change the positioning with the <Center> 
and <Right> commands. Given this, there is no need to use a <Left> command for a line. The 
attributes start left aligned again on the following line. 

Designing a custom FOH report
Once you become familiar with the variables and configuration rules, you can design your FOH 
report. You can format and use as many variables as needed, while designing the report. 

Width Used with a Calculation Width Used with a String

Enter the formula for the calculated value. 
● You can use supported algebraic operators, such 

as (), =,/,+,-, and more. Multiplication and 
division operators have a higherprecedence over 
addition and subtraction. 

● You must enter the entire equation within the same 
formula, such as <Val(4:#Guest/#Checks)>. You 
cannot use a formula to operate with another 
formula, such as 
<Val(4:#Guest>/<Val(4:#Checks)>.

● An equation results in a numeric value with no 
label. If you want a label with your calculation, you 
must use free text as a label, or a string, such as 
Total Comps: <Val(4:#C)>.

● The result from an equation uses constant 
numbers, such as 1 or 2.5. Fractions are never 
displayed. 

Always enter a supported string, such as 
<Val(1:LastName)> or <Val(1:DOB)>. The system 
pulls in and prints the string on the report. 

Alignment Examples Result Printed on the Report

<Center> Guests and Checks Guests and Checks

Liquor: <Right> <Val(7:$S0003)> Liquor 1234.56

Guests: <Center> <Val(4#Guests)> <Right> 
<Val(4:$S/#Guests)>

Guests: 200 7.21

Tip:  Custom FOH reports were initially supported in Aloha POS v7.0 using a manual method. If 
you created a custom FOH report this way, you can still use the report. Refer to “Appendix B: 
Upgrading Custom FOH Reports” on page 43.
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For ease of creating a custom FOH report, use the Report Line Builder dialog box to insert any 
dynamic calculations and strings in the report. For each line that contains a dynamic calculation, you 
must click the ellipses (...) for the corresponding variable line in the report to access the dialog box. 
You can also type the dynamic calculations and strings manually into the ‘Report line’ column without 
using the Report Line Builder, if desired. 

To create a custom FOH report: 

1. Select Maintenance > Business > Custom FOH Reports. 

2. Click New. The configuration management tool, either Aloha Manager (AM) or Aloha 
Configuration Center (CFC), creates a configuration file named CustomFOHReportNumberx, 
where x is the sequential number of the report, in the NewData directory.

3. Under the ‘Identification’ group bar, type a name to identify the report. 
4. Select Allow report to be run for multiple employees at a time to enable you to select and 

generate data in the report on more than one employee at a time. If you clear this option and 
select more than one employee, the report appears blank and with no data. 

5. Under the ‘Display options’ group bar, select how you wish to sort and display the data from 
the ‘Report format’ drop-down list. Your choices are: 
Standard – Displays values for the entire day for the line item. This is the default behavior.

Figure 4  Custom FOH Report Function
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Sort data in 15 minute increments – Displays the total value of each line item in 15 minute 
increments, for the entire day. Zero (0) appears for time increments for which data is not present. 
Sort data in 30 minute increments – Displays the total value of each line item in 30 minute 
increments, for the entire day. Zero (0) appears for time increments for which data is not present. 
Sort data in 60 minute increments – Displays the total value of each line item in 60 minute 
increments, for the entire day. Zero (0) appears for time increments for which data is not present. 
Sort by Day Part – Displays the total value for each line item for each configured day part. Zero 
(0) appears for day parts for which data is not present.
Sort by Revenue Center – Displays the total value for each line item for each configured revenue 
center. Zero (0) appears for revenue centers for which data is not present. 

6. If you want to report on a specific job code, or group of job codes, select a job code from the 
‘Available’ list and click >> to move the job code to the ‘Filter by’ list. 

7. Select the Design tab. 
8. Click Add.  

To insert free text, type text directly in ‘Report lines.’ 
To insert a blank line, leave the line as blank. 
To insert a line of characters to indicate a separation in text, type the line of characters. 

Figure 5  Custom FOH Report - Design Tab 
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To insert a dynamic calculation, click the ellipses (...) to display the Report Line Builder dialog 
box. Using the help text, example, and report line as a guide, build the specific line of the report, 
and click Insert. 

9. Click OK to return to the Custom FOH Reports function. 
10. Repeat steps 6 and 7 until you complete the content of the custom FOH report. 
11. Click Save.
12. Repeat this procedure for any other custom FOH report you want to configure. 
13. Click Close to exit the Custom FOH Report function. 

A sample configuration file and the resulting report is as follows: 

Figure 6  Report Line Builder

Line Configuration File Result Displayed on the Report

1. [Default] <no line prints>

2. <Center> ***FLASH REPORT*** ***FLASH REPORT***

3. <Fill(=)> ===========================

4. <Center>***<Val(1:RestUnitName)>*** ***Aloha Cafe***

5.

6. Print Date:<Val(1:SystemDate)><Right> Print 
Time:<Val(1:PrintTime)>

01/01/2012 12:00 AM

7. DOB:<Val(1:DOB)> DOB: 01/01/2012
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8. <Fill(=)> ==========================

9. <Center>***SALES*** ***SALES***

10. <Fill(=)> ===========================

11. TOTAL SALES:<Right><Val7:$S)> TOTAL SALES: 500.00

12. <Fill(=)> ==========================

13.

14. <Center>***COMPS*** ***COMPS***

15. <Val(7:#C0001)> Entertain: 
<Right><Val(7:$C0001)>

02 
Entertain:

10.00

16. <Val(7:#C0002)> Staff Disc 15% 
<Right><Val(7:$C0002)>

03 Staff Disc 15% 15.00

17. <Val(7:#C0003)> MGR Comp 100% 
<Right><Val(7:$C0003)>

01 MGR Comp 100% 5.00

18. TOTAL COMPS: <Right><Val(7:$C)> TOTAL COMPS: 30.00

19. <Fill(=)> ==========================

20. GROSS SALES: <Right> <Val(7:$S-$C)> GROSS SALES: 470.00

21.

22. <Center> ***PROMOS*** ***PROMOS***

23. <Val(3:#P1000)> Disc 5%: <Right> 
<Val(7:$P1000)>

00 Disc 5% 0.00

24. <Val(3:#P1001)> Disc 10%: <Right> 
<Val(7:$P1001)

04 Disc 10% 20.00

25. <Val(3:#P1002)> Staff Disc 15% <Right> 
<Val(7:$P1002)>

01 Staff Disc 15% 2.00

27. TOTAL PROMOTIONS: <Right> <Val(7:$P)> TOTAL PROMOTIONS: 22.00

28. <Fill(=)> ==========================

29. NET SALES: <Right> <Val(7:$S-$C-$P)> NET SALES: 448.00

30. <Fill(=)> ==========================

31.

32. <Center> ***PAYMENTS*** ***PAYMENTS***

33. <Val(3:#T0001)> Cash: <Right> 
<Val(7:$T0001+$T0002+$T0003+$T0004)>

20 Cash: 200.00

Line Configuration File Result Displayed on the Report
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34. <Val(3:#T0008)> Visa: <Right> 
<Val(7:$T0008)>

05 Visa: 100.00

35. <Val(3:#T0009)> Mastercard: <Right> 
<Val(7:$T0009)

05 Mastercard: 100.00

36. <Val(3:#T0010)> Amex <Right> 
<Val(7:$T0010)>

01 Amex: 10.00

37. <Val(3:#T0011)> Diners <Right> 
<Val(7:$T0010)>

01 Diners: 10.00

38. <Fill(=)> =========================

39. TOTAL PAYMENTS: <Right> <Val(7:$T)> TOTAL PAYMENTS 420.00

40. <Fill(=)> ==========================

41. OUTSTANDING: <Right> <Val(7:$S-$P-$C-$T)> OUTSTANDING: 28.00

42. <Fill(=)> ==========================

43.

44. <Center> ***VOIDS*** ***VOIDS***

45. <Val(3:$V)> VOIDS: <Right> <Val(7:$V)> 03 VOIDS: 20.00

46. <Fill(=)> ===========================

47.

48. <Center> GUESTS AND CHECKS GUESTS AND CHECKS

49. Number of Guests: <Right> <Val(4:#Guests)> Number of Guests: 200

50. Number of Checks: <Right> <Val(4:#Checks)> Number of Checks: 50

51. Guests per Check: <Right> 
<Val(4:#Guests/#Checks)>

Guests per Check: 4

52.

53. <Center> ***END OF REPORT*** ***END OF REPORT***

Line Configuration File Result Displayed on the Report



 Custom FOH Reports
Configuring Custom FOH Reports

29

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

Adding a custom report button to a panel
For Aloha Quick Service operations, you must add a button to a panel for each customized report you 
create. You must also do this in Aloha Table Service, if you want to add a custom report button to a 
floor plan in use. If you want the report button to appear in a relative location as your other 
hard-coded reports in Table Service, refer to “Designing the FOH Select a Report screen in Table 
Service” on page 30.

To add a custom report button to a panel:

1. Select Maintenance > Screen Designer > Quick Service (or Table Service) Screen 
Designer.

2. Select Work with Panels.
3. Select Panel > Open Panel. The Open Panels dialog box appears. 
4. Select a panel to edit, such as Manager Reports, and click OK. The panel appears. 
5. Select Panel > New Button. The Properties dialog box appears.  

6. Under the ‘Function’ group bar, select Custom Report from the ‘Action’ drop-down list to add a 
custom report button to the ‘Select Report’ screen on the FOH. 

7. Select True or False in the ‘Select Employees’ drop-down list, to allow you to select specific 
employees to include in the report at runtime. If set to False, the system generates data for all 
employees who worked during the time frame selected for the report. 

Figure 7  Custom Report Button Properties (Custom FOH Reports Defined)
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8. Select Custom FOH Reports defined to indicate this button calls a custom FOH report created 
using the Custom FOH Report function. 

9. Select the report to link to this button in ‘Custom FOH Report.’ 
10. Type the text to identify the specific report you want to generate in ‘Name.’ The text appears on 

the button. 
11. Complete the remaining options for the button, such as font, background color, and text 

alignment. 
12. Repeat this procedure for each custom report you want to add to the panel. 
13. Select Panel > Save Panel and exit the Screen Designer function. 

Designing the FOH Select a Report screen in Table Service
For Table Service operations that are not accessing reports from a floor plan screen, you must select 
your custom report buttons from the FOH Select Reports screen. The screen appears blank until you 
design the buttons to appear on the screen using a CustRpt.ini file, which is placed in the Data and 
Newdata directories. The file defines where to place a button using an internal grid, the text to 
appear on the button, the title to use for the report, and the custom report configuration file you are 
accessing. As an added feature, you can configure whether to generate data for the entire store or 
select specific job codes to include in the report data. The format of CustRpt.ini is as follows: 

Tip:  The other option, ‘Externally defined,’ is used only for a custom FOH report you manually 
created using MS Notepad. Refer to “Appendix B: Upgrading Custom FOH Reports” on 
page 43. 

CustRpt.ini Example

[BUTTON0]

Position=0

Select_Employees=1

Label=All Statistics

File=AllStats.cfg

[BUTTON1]

Position=1

Select_Employees=1

Label=Tipouts & Credit

File=Tipouts&Credit.cfg
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[ButtonX] — Specifies the section header for each button you are adding to the CustRpt.ini file, 
such as ‘Button2.’ Use the x value to identify the location of the button in relation to the screen. 

Select_Employees — Determines how you want to generate the data, using the values of 0 or 1. 
Assign a value of 0 to Select_Employees, to use data for the entire store, or assign a value of 1, to 
enable an additional screen to appear from which you can select specific employees to include in the 
report data. 

Position — Indicates the positioning on the screen where you want to place the button, using an 
internal grid. Position ‘0’ indicates the first button on the top upper left, and the numbering continues 
across the screen. 

Label — Indicates the name of the report to appear on the button. Use ‘\n’ with no spaces between 
words, to display the text on multiple lines. 

File — Specifies the name of the report configuration (.cfg) file to link to the custom button. 

[BUTTON2]

Position=2

Select_Employees=1

Label=Promo & Payment\nBreakdown

File=Promo&Pmt.cfg

[BUTTON3]

Position=3

Select_Employees=1

Label=Flash

File=Flash.cfg

CustRpt.ini Example
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Refreshing the data
After all settings are in place in Aloha Manager, you must select Utilities > POS > Refresh POS & All 
Installed Products to transfer the new information to the FOH terminals, or wait for the End-of-Day 
(EOD) process to accomplish the data refresh for you. After the data refresh is complete, all new 
settings become operational across the Aloha network. 

Caution:  Refresh data with caution and never during peak hours of operation. All FOH ter-
minals reboot during a refresh and are down for a short period of time. 
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Using Custom FOH Reports
To use custom FOH reports, select the appropriate report button and the report appears in the FOH. 
The generated data is up-to-the-minute for the current day. If available for this report, the Select One 
or More Employees screen appears, allowing you to select the employees to include in the report 
data. 

To run a custom FOH report in Aloha Table Service:

1. From the FOH Working with Tables/Tabs screen, touch Functions. The FOH Special Functions 
screen appears. 

2. Touch Reports. The Reports screen appears.  

Figure 8  FOH Reports Screen
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3. Touch Custom Reports. The Select Report screen appears.  

4. Select the button corresponding to the custom report you wish to run. If available, the ‘Select 
one or more Employees’ screen appears, allowing you to choose the employees to include in the 
report data. 

Figure 9  FOH Select Report Screen

Figure 10  Select One or More Employees Screen
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5. Select the employees to include in the report, or select (All) to generate data for all employees. 
The report appears on the screen, if available, and you can print it, if desired, or it prints to the 
designated printer. 

To run a custom FOH report in Aloha Quick Service: 

1. Navigate to the panel containing your reports. 
2. Select the button corresponding to the custom report you wish to run. If available, the ‘Select 

one or more Employees’ screen appears, allowing you to choose the employees to include in the 
report data. 

3. Select the employee to include in the report, or select (All) to generate data for all employees. 
The report appears on the screen, if available, and you can print it, if desired, or it prints to the 
designated printer. 

Viewing a custom FOH report
1. When you run a custom FOH report, a screen stating ‘Please wait. System is generating report’ 

appears.  

Figure 11  Wait Message
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Once the system dismisses the message, the report appears. 

2. Touch Two Cols to view the report with two columns. 

Figure 12  Custom FOH Report Example - 1 Column

Figure 13  Custom FOH Report Example - 1 Column
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3. Touch Print to print the report to a local printer. 

4. Touch Done when finished. 

Figure 14  Sample Custom FOH Report
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Troubleshooting Custom FOH Reports
The following tips provide troubleshooting for custom FOH reports:

Report does not display or print

If a report does not print, ensure the appropriate file, with a .cfg extension, resides in the Data and 
NewData directories. Additionally, you must link the .cfg file to the corresponding Custom Report 
button on a panel. See “Adding a custom report button to a panel” on page 29 and “Designing the 
FOH Select a Report screen in Table Service” on page 30. 

Calculation or string does not appear

If a calculation or string does not appear in a custom section of a custom FOH report, ensure the 
following: 

● You typed the correct syntax for the formula, such as <Val(3:#Guests/#Checks)>
● You used the correct algebraic operators.
● You used a variable which is supported with your Aloha POS version. 

See “Creating a custom FOH report” on page 10. 

Report appears blank with no data

This usually occurs when you select more than one employee for which to generate data in the report. 
The configuration management tool is unable to resolve the multiple selection. If you intend to select 
more than one employee, or all, you must select ‘Allow report to be run for multiple employees at a 
time’ in Maintenance > Business > Custom FOH Reports. See “Creating a custom FOH report” on 
page 10. 
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Appendix A: Use Case for Item Count Variables
This section details a use case example for using the Item Count variables. Use the #Itemsxy|z and 
#TotalItemsxy|z variables to track the count of items sold by category and order mode. Each variable 
definition requires you to configure a parameter that stipulates whether to include or exclude order 
modes. The intent is to use variables with identical selections together for a new standalone custom 
report that relies on time increments for parsing the data; however, you can integrate them with an 
existing custom report.

SCENARIO: Managers find the number of times an item is sold during increments of the day a valu-
able analytical asset for projections and forecasting. They want to track the number of donuts sold
from the dine-in order mode for each hour of the day.  

Figure 15  Custom FOH Report with Item Counts Variables

#ItemsInclusive4|2,3 
variable

#TotalItemsInclusive4|2,3 
variable
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To add item count variables to a custom FOH report:

1. Select Maintenance > Business > Custom FOH Reports.
2. Click New. 

3. Type a name for the report, such as ‘Donut Count.’ 
4. Select Allow report to be run by multiple employees at a time. 
5. Select a time increment from the ‘Report format’ drop-down list, such as ‘Sort data in 60 minute 

increments.’ 
6. Select the Design tab. 
7. Under the ‘Design’ group bar, click Add. A new line of the report appears. 

Figure 16  Custom FOH Report Tab
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8. Click the ellipses (...) to display the Report Line Builder dialog box. Using the help text, example 
and report line as a guide, build the specific line of the report and click Insert. 

9. Select Item Count from the ‘Categories’ list. The variables for ‘item count’ populate in the 
‘Elements’ list and the ‘Order modes’ selection list become available. 

10. Select Count of items sold for the specified category and order mode from the ‘Elements’ 
list. 

11. Select one sales or one general category from which to report from the ‘Specific records’ list. 
12. Select one or more order modes from which to report from the ‘Order modes’ list. 

a. To include all order modes, select the check box above the list of order modes. 
b. To include specific order modes, select Inclusive and then each order mode to include in 

the report from the list of order modes. 
c. To exclude specific order modes, select Exclusive and then each order mode to exclude 

from the report from the list of order modes. 

13. Click OK to return to the Design tab. 
14. Repeat steps 7 through 13 to add the Total count of items sold for the specific category 

and order mode variable to the report. 

Figure 17  Report Line Builder - Item Count
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15. Add any other design elements to customize the report, such as inserting free text, blank lines, 
or a line with a single character. Use the example shown below as a guide. 

16. Click Save and exit the Custom FOH Reports function.

Figure 18  FOH Custom Reports - Design Tab
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Appendix B: Upgrading Custom FOH Reports
We introduced custom FOH reports in Aloha POS v7.0 as an external configuration file that you 
create using MS Notepad and then place it in the Data directory. When you tie the file to a button 
function, the system uses the file to generate the report in the FOH. Since the configuration file is 
external, the data is not housed in either Aloha Configuration Center or Aloha Manager. To 
compound the problem, in a hosted multi-store environment, you had to send the external 
configuration files to your stores separately. Additionally, creating the configuration file manually 
required a certain level of programming knowledge that increased the margin of error when typing a 
syntax string. 

In Aloha POS v12.3, we added the Custom FOH Report function in Aloha Configuration Center and 
Aloha Manager to alleviate these issues. Using the configuration management tool, you create an ID 
record for each custom FOH report so you do not need separate external configuration files and store 
the data in the database. Additionally, we provide a user interface for building the syntax strings 
when creating your report. 

If you implemented custom FOH reports prior to Aloha POS v12.3, you can upgrade the reports to 
the configuration management tool or choose to keep your current implementation. As the preferred 
solution, we recommend you upgrade your custom FOH reports to use the configuration 
management tool, either Aloha Configuration Center or Aloha Manager. Provided you already 
followed the steps depicted in the body of this guide, you need to modify a couple of areas in your 
configuration.

If you created custom FOH reports prior to Aloha POS v15.1 and configured Print Intercept to view a 
custom report on-screen versus automatically printing a report, when you upgrade to Aloha POS 
v15.1, you must select a new option called ‘Display custom reports on the FOH’ under the ‘Report 
settings’ group bar in the Report Printing group on the Store Settings tab in Maintenance > Business 
> Store to continue this behavior. If you do not, all custom FOH reports automatically print to the local 
receipt printer by default.

Upgrading your custom FOH report to the configuration management tool
The first step is to enter the content of your existing report into the Custom FOH Report function so 
the report is housed in the database. Instead of retyping each line into the function, you simply need 
to create a Custom FOH Report record and manually copy and paste each line in the ‘Report line’ text 
boxes. Refer to “Creating a custom FOH report” on page 10 for additional information. 

To enter the content of your existing report into the Custom FOH Report function: 

1. Select Maintenance > Business > Custom FOH Reports (Figure 4). 
2. Click New. 
3. Type a name to identify the report. You can use the same name as the external configuration file 

you are replacing. 



 Custom FOH Reports
Appendix B: Upgrading Custom FOH Reports

44

© 2024 NCR Voyix. All rights reserved. NCR Voyix — Confidential
Use and Disclose Solely Pursuant to Company Instructions

4. If you want to report on a specific job code, or group of job codes, select a job code from the 
‘Available’ list and click >> to move the job code to the ‘Filter by’ list. 

5. Select the Design tab. 
6. Click Add.  

7. Copy a line of text from the external configuration file and paste it into the ‘Report line’ text box. 

8. Repeat step 7 until you paste each line into the Custom FOH Reports function. 
9. Click OK to return to the Custom FOH Reports function. 
10. Click Save.
11. Repeat this procedure for any other custom FOH report you want to upgrade. 
12. Click Close to exit the Custom FOH Reports function. 

The second step is tying the FOH button to the custom FOH report that is now housed in your 
configuration management tool. To do this, please follow the instructions provided in “Adding a 
custom report button to a panel” on page 29.

Figure 19  Custom FOH Report - Design Tab 

Note:  You can use this opportunity to adapt or change the content to your specific needs relat-
ing to the report.
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Keeping your current custom FOH report implementation
If you want to keep your current custom FOH report implementation, using external configuration 
files, the system performs the upgrade path for you. The button function configuration for each report 
changes to point to an externally defined report. If you notice a problem with your report, you can 
verify this configuration in Screen Designer. Note: This is not the preferred solution and we 
recommend you upgrade your custom FOH reports to the configuration management tool. 

To verify your button configuration points to an external custom FOH report:

1. Select Maintenance > Screen Designer > Quick Service (or Table Service) Screen 
Designer. 

2. Select Work with Panels. 
3. Select Panel > Open Panel. The open Panels dialog box appears. 
4. Select a panel to edit, such as ‘Manager Reports,’ and click OK. The panel appears. 
5. Select Panel > New Button. The Properties dialog box appears. 
6. Under the ‘Function’ group bar, select Custom Report from the ‘Action’ drop-down list.
7. Select Externally defined to indicate the system uses a manually created external configuration 

file. 

8. Type the name of the configuration file (with a .cfg extension), located in the Data directory, to 
link to this button. If you do not link the button to a report configuration file, the button does not 
generate a report. 

Figure 20  Custom Report Button Properties (Externally Defined)
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9. Type the text to identify the specific report you want to generate in ‘Name.’ The text appears on 
the button. 

10. Complete the remaining options for the button, such as font, background color, and text 
alignment. 

11. Repeat this procedure for each custom report you want to add to the panel. 
12. Select Panel > Save Panel and exit the Screen Designer function. 
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Custom FOH Reports, Feature Focus Guide

NCR Voyix welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email address: 
Documentation.HSR@NCRVoyix.com

mailto:documentation.hsr@ncrvoyix.com
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