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Preface
Aloha Kitchen provides an innovative solution to streamline restaurant kitchen operations. 
The addition of the kitchen module incorporates the tools needed to facilitate orders 
prepared in the kitchen and delivered to the guest. With Aloha Kitchen extending Aloha’s 
feature-rich Quick Service and Table Service applications, your kitchen staff can now focus 
on smooth restaurant operations and superior guest service 

We discuss the following topics: 

● Benefits

● Key Features

● Integrating Aloha Kitchen with Other Aloha Products

● Touch Screen vs. Bump Bar

● Aloha Kitchen Screen Components

● Aloha Kitchen Screen Components

● Aloha Kitchen Order Sequence

Benefits
Aloha Kitchen is an innovative and intuitive kitchen display system that drives efficiency 
within table service and quick service environments. Some benefits in using Aloha Kitchen 
include: 

Improved speed of service Aloha Kitchen greatly improves the speed of service at a restaurant 
by ensuring the operation prepares and delivers orders on time. 
Through delayed routing, you can time each item to be sent to the 
kitchen in a staggered order so all items on an order are ready at 
the same time. You can see crucial minutes drop off your table 
turns and service times. 

Timed alerts You can use alerts to notify employees when orders are late in 
starting and bumping. At a quick glance, you can visually monitor 
the ‘health’ of your kitchen at any given time. For example, if you 
see a large number of items in red, you know the kitchen is behind.

Higher food quality High food quality is a must in any restaurant. Aloha Kitchen can 
assist you in maintaining high food quality at optimal temperatures 
so cooked food remains hot and cold food remains cold, when the 
food reaches the customer.

Enhanced guest experience Through on-time deliveries, Aloha Kitchen enhances the experience 
of your guests and encourages them to return to your restaurant. 
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Key features
Aloha Kitchen has many features that benefit kitchen operations.

● Aloha Kitchen supports multiple screen configurations to manage kitchen orders in 
various locations of the Back of House (BOH). You can configure each kitchen terminal to 
a specific role for that station, whether it is at the beginning or end of the food 
production process. Examples of these are:

Production screens to start or finalize food items. Aloha Kitchen supports production 
bins to manage items that are produced in quantity.

Expediter screens to manage, assemble, and deliver finalized orders to customers.

Fixed cell options for a traditional kitchen look and flow. 

The ability to toggle to other screens as needed when working. 

● Aloha Kitchen is flexible enough to address several operational models, from fast food 
to fine dining environments

● Display dynamic quote times based on several real-time productivity metrics. Quote 
times are communicated to other NCR Aloha applications, such as NCR Aloha Takeout 
and NCR Aloha Guest Manager, to provide customers up-to-the-minute information.

● Robust, purpose-built hardware for harsh kitchen environments that support touch or 
bump bar interfaces.

● Print kitchen chit automatically or on demand to reduce paper cost, while maintaining 
efficient food delivery.

● Items may be routed by video group, terminal, order mode, and other options to meet 
existing or improved methods. 

Increased productivity The cost of labor is a huge concern in most restaurants. Aloha 
Kitchen can decrease your labor cost by helping you determine 
when to cut labor. You will also increase productivity by employees 
being more attentive to orders. Communication among kitchen 
staff increases, reducing the number of meals that are comped due 
to mistakes.

Multi-lingual support Many restaurants staff their kitchen with employees from diverse 
backgrounds who speak different languages. Aloha Kitchen has the 
unique ability to allow an employee to easily switch the language 
on the screen to their native language, on demand.

Management and analysis Through Aloha Kitchen, you can implement and monitor real-time 
metrics that appear on specific kitchen screens, based on the 
system time of the POS. Averages are broken down by individual 
stations. Also, a full suite of BOH reports are available for additional 
analysis.
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● Screens may be load balanced to prevent overloading a kitchen station, while another 
station is under utilized. This allows maximum efficiency and improved speed of service.

● Bin management provides a consolidated at-a-glance view of bulk production items, 
such as fries or wings, that are currently needed to fulfill orders. Bin management may 
also be used to determine how many steaks, burger patties, or chicken breasts are 
ordered and should be cooking. This helps avoid miscounts and mistimed orders.

● Recipe Viewer allows you to use the system during non-business times to help with prep 
and other pre-opening tasks. During business hours, you can use the recipe viewer to 
provide plating and preparation reference.

● Zone placement of prepared items organizes the ‘window’ to efficiently tray and deliver 
orders. Aloha Kitchen automatically rotates the zones, informing you where to place 
prepared items.

● On-screen performance metrics eliminate manual tracking of cook times and provide 
real-time information to display service measurements. At-a-glance management allows 
you to view metrics and make staffing adjustments to meet company service standards 
and address customers with long service times.

● Aloha Kitchen provides robust historical reporting to track kitchen performance over 
time. You can use this information to adjust staffing during key business periods to 
balance customer experience with labor costs.

Integrating Aloha Kitchen with other Aloha products
To add high competitive value, Aloha Kitchen integrates with the NCR Aloha suite, including 
Aloha Table Service, Aloha Quick Service, Aloha Takeout, Aloha Guest Manager, and more. 

It is necessary to use a configuration management tool, either Aloha 
Configuration Center (CFC) or Aloha Manager, to configure Aloha Kitchen 
and have a working system prior to installing and configuring Aloha Kitchen. 
In CFC, you have full above-store management control over multiple sites. 
Aloha Manager is ideal for single-store operations. 

You must use a POS system, either Aloha Quick Service or Aloha Table 
Service to integrate with Aloha Kitchen. Crucial elements, such as item cook 
times, order modes, voids, customer and employee names, table transfers, 
and custom chit layouts, are transmitted to Aloha Kitchen for calculations and 
to appear on a kitchen screen. 

You can optionally override quote times and display customer information 
when you integrate with Aloha Takeout. 
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In addition to these NCR Aloha suite products, Aloha Kitchen can also interface with the 
Advanced Restaurant POS system. 

You can optionally display wait list information and wait quote times from 
Aloha Guest Manager and display them directly on the kitchen screen.

Note:  Contact your NCR Corporation representative for help determining the products 
that meet your operational needs.
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Expediter employee vs production employee
An expediter employee assembles the plated food for delivery by a server or food runner. 
During slow periods, an expediter could be sent home early, in which case, a server or 
kitchen employee would double as an expediter. Large kitchens sometimes employ an 
additional expediter or have an expediter dedicated to takeout orders. Regardless of the 
environment, an expediter is the final stop before delivering the food to a guest or table. 

In Aloha Kitchen, an expediter manages each order in its entirety, and gages the state of all 
orders in the kitchen. A production employee manages some or all items sent to their 
station and can instantly know the count of items they must prepare to fulfill all orders 
currently needed in the restaurant. After cooking the food, an employee places an item in a 
location for an expediter to retrieve. Depending on the size of a restaurant, there could be 
many production stations in a kitchen. Aloha Kitchen is designed to provide clear and 
concise information to kitchen employees to promote efficient production of orders.

Touch screen vs. bump bar
Whether to use a touch screen terminal or a bump bar to interact with the system is a 
personal preference. Aloha Kitchen ensures that you can perform your every day functions 
using just one, or a combination of both, methods. Given its harsh environment, a 
production station is well suited for using a bump bar, since replacing a stained bump bar is 
much less expensive than replacing a touch screen monitor. A touch screen monitor is ideal 
for a more gentle environment, such as an expo station. 

Aloha Kitchen offers many commands to assist you in navigating orders and items when 
using a bump bar, such as ‘Item Cursor Up,’ ‘Item Cursor Left,’ ‘Scroll Right,’ ‘Scroll First,’ and 
others. On a touch screen monitor, you simply need to locate and touch a particular cell. A 
flyout appears with logical options to touch base on the status of an order.

The following depicts two ways to navigate on the screen, using a bump bar.  

Note:  When you configure touch screen functionality on a terminal, the Commands bar 
appears at the bottom of a kitchen screen. This allows you to perform various functions by 
touch. Most of these commands have an equivalent function available on the bump bar.

Bump Bar Navigation Examples

In the left example, if you are on ‘Kid Pizza’ and 
you want to navigate to ‘Fried Mozz,’ press 
‘Item Cursor Up’ five times on the bump bar. 

In the right example, if you are on ‘Kid Pizza’ and 
you want to navigate to ‘Fried Mozz,’ press ‘Scroll 
First’ on the bump bar to select the first cell, 
then press ‘Item Cursor Down.’ 
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Aloha Kitchen hardware solutions
NCR Corporation provides two hardware solutions for use with Aloha Kitchen, the K1700 
and KC3. You can select a single hardware solution to use throughout your restaurant, or 
you can mix them together, depending on your needs. For example, you might use the 
K1700 solution for your expo stations, and use the KC3 controller solution for production 
stations to use with employees with gloved hands.  

K1700 Kitchen Production Terminal

An all-in-one solid state unit that is touch screen 
capable and does not require a bump bar to 
operate.

Open platform terminal that uses Windows 
Embedded Standard (WES) as a low-powered 
operating system.

Clutter-free - no need for multiple devices and 
power supplies.

Withstands harsh kitchen and food preparation 
environments.

Can be mounted in a variety of environments. The 
optional wall bracket, or VESA, protrudes less than 
four inches from the wall surface.

No air circulation fans or air vents to allow 
contaminants to damage interior components.
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KC3 Controller with Bump Bar

Consists of the kitchen controller, kitchen monitor, 
bump bar, and printer (optional).

Designed to relay information originating from the 
POS to the KC3 controller, where a bump bar is 
then used to perform different functions, such as 
bumping the order, viewing a recipe, or finishing 
instructions for an item.

Rugged enclosure offering protection from extreme 
temperature and humidity.

Small footprint, making it easy to install in even the 
smallest kitchen stations.

Bump bar is resistant to water and other solvents 
like cleaning agents.

Bump bar comes in 16-key and 19-key 
configurations. 
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Aloha Kitchen screen components
This section details the screen components of Aloha Kitchen. Throughout this guide, we 
discuss the two most commonly used screen for an expediter (Expo Order View) and for a 
production employee (Production Start and Cooking). Other screens alter the layout and 
behavior slightly, and are not discussed in this guide. Expo screen   

Figure Pref - 1  Expo Kitchen Screen Example

Number Description

1. Metrics bar displays configurable metrics used to help employees gauge their progress and 
facilitate their station. 

2. Kitchen screen name contains a descriptive name of a kitchen screen that identifies 
the location of a station within a kitchen. 

3. Order cell contains order-level information, per order, for a screen used by an 
expediter to quickly view the progress of items within an order. An order cell also 
includes any modifiers for an item and header and footer information to identify order. 
Aloha Kitchen uses colors to identify status of items and modifiers on the expo screen 
based on the production station interaction.

4. Commands bar contains functions primarily used for a touch screen terminal that allow you 
to perform certain tasks. 
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Production screen  

Figure Pref - 2  Production Kitchen Screen Example

Number Description

1. Metrics bar displays configurable metrics used to help employees gauge their 
progress and facilitate their station.

2. Kitchen screen name contains a descriptive name of a kitchen screen that identifies 
the location of a station within a kitchen.

3. Item cell contains item-level information, per item, for a screen used by a production 
employee to monitor the progress of an item. An item cell also includes any modifiers 
for the item.

4. Start queue represents the area where active items appear on a production screen to 
indicate you need to start an item. Select an item in the start queue and touch Start to 
indicate you have started cooking an item. The system moves started items to the 
cooking queue portion of the screen and updates the status of the item on all other 
screens.

5. Cooking queue represents the area where started items appear on a production 
screen. When you have completed cooking an item, select the item in the cooking area 
and touch ‘Bump to’ remove it from your screen.

6. Bin represents an area where bulk production item totals appear. Simple bins require 
no interaction and display a count that you should have cooking. Production bins are 
more complex and require you to interact with the bin and start a group of BIN items.

7. Commands bar contains functions primarily used with a touch screen terminal that 
allow you to perform certain tasks. 
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Aloha Kitchen order sequence
As items are ordered on the POS, they route to different stations and pass through several 
states until the expediter eventually finishes a complete order. The following diagram 
depicts the sequence of a typical Aloha Kitchen order, with the assumption that an 
expediter uses a touch screen terminal, and all production employees use a bump bar.  

Sequence of a Typical Aloha Kitchen Order

A guest orders a Single 
w/Chz, Lg Fries, and Gr 
Chk Brst.

Per routing rules, Single 
wChz and Gr Chk Brst 
route to the Grill station, 
Lg Fries route to the Fry 
station, and all items 

Expo Station
Grill Station

Fry Station
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Sequence of a Typical Aloha Kitchen Order (cont.)

As the items appear on-screen, based on delayed routing and activation times, the 
Grill and Fry station employees navigate with a bump bar and press ‘Start’ to move 
their respective items to the cooking area of the screen. Both employees then 
physically begin cooking their items.

Grill Station Fry Station

When the items are cooked, each production employees uses the bump bar to 
navigate and presses Bump to remove the items from their respective screens. 

Grill Station Fry Station

When all items of the order 
are ready, the expediter 
prepares the completed 
order, then touches the order 
to select and touches Bump 
Order from the fly-out menu 

Expo Station
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Progression states of an Aloha Kitchen order
As items and orders progress through the kitchen screens, they pass through several states. 
Each state has a default color; however, you can use skins to change the color for each state. 
The four states, listed in the order of occurrence, are:

1. Unstarted — Released items that are awaiting you to touch the start action appear in 
purple. After a defined amount of time in an unstarted state, an exclamation mark icon 
appears, alerting you to start the order or item.

2. Cooking — When you start or the system automatically starts an item, the system 
moves it to the cooking queue, and the item appears in blue. 

3. Prepared — When you bump an item, the system removes the item from the 
production screen, and the item appears in green on the expo screen.

4. Served — When you bump an item or order from the expo screen, the item and order 
appears as black. In most cases, this is not seen since the order no longer appears on 
the screen; however, you will see this state if you have more than one expediter and 
expo screen in use. 

Alert states of an Aloha Kitchen order
Within Aloha Kitchen, you can configure an alert that, when triggered, changes the color of 
the item or order cell. The two alert states, listed in the order of occurrence, are: 

● First Alert - When a first alert triggers, the header/footer color of the item or order cell 
changes to yellow, to indicate the order is running late.

● Second Alert - When a second alert triggers, the header/footer color of the item or 
order cell changes to red, to indicate the order is very late.

Tip:  Items may appear in gray on the expo screen, indicating the item is uninitialized and 
is not ready to appear on a production screen. This happens when you configure your sys-
tem for delayed routing, or if an item has a shorter cook time than another item within the 
same order.

Note:  We recommend you leave the default color scheme (Kitchen Skin) in place for trou-
bleshooting reasons.
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Is this guide for you?
The NCR Aloha Kitchen Implementation Guide is intended for anyone who uses NCR Aloha 
Kitchen to manage kitchen operations. 

This guide assumes you have the following knowledge:

● Basic understanding of restaurant terminology and concepts.

● Basic understanding of PCs and Microsoft Windows.

● Understanding of the operation of a computer mouse and keyboard.

● Basic understanding of how to work with Microsoft Windows based menu structures 
and basic application components, such as scroll bars, buttons, drop-down lists, text 
boxes, radio buttons, and check boxes.

How this guide is organized
This guide is designed to help you familiarize yourself quickly with Aloha Kitchen. It is 
organized as follows:

Chapter 1: Getting started
This chapter discusses installing and configuring E-Messenger for a corporate and a store 
location. 

Chapter 2: Customizing Aloha Kitchen
This chapter discusses sending and receiving e-mail, sending and processing packages, and 
defining macros. It also details automated package handling.

Third-party software prerequisites
The prerequisites you need for supporting Aloha Takeout are all available from the 
downloads section of the Microsoft Web site: 

All installations are wizard-based. Double-click each file to launch the installation wizard, 
and click ‘Next’ and ‘Finish’ until the process is complete.

● Install .NET v3.0 SP1 on the Aloha Back-of-House (BOH) file server and each terminal. 
The Aloha Takeout installation process validates the presence and the version of .Net 
installed, as it starts.

● Install Microsoft SQL Express 2005 SP2 on the Aloha BOH file server.

○ Select only the ‘Database Services’ for installation.

○ Select ‘Mixed mode authentication.’

http://www.microsoft.com/downloads

http://www.microsoft.com/downloads
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○ Select ‘Enable User Instances.’

○ Leave the ‘Named instance’ set at the default, ‘SQLEXPRESS.’

● Install Microsoft SQL Server Management Studio Express SP2 on the Aloha BOH file 
server. 

● Run Windows Update on the Aloha BOH file server and install critical updates. 

Tip:  Microsoft SQL Express 2005 SP2 is installed by the CMT. We recommend installing 
the CMT prior to installing Aloha Takeout.
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Preparing the system for Aloha Kitchen
You must perform several configuration steps to successfully integrate the Aloha POS with 
Aloha Kitchen. As you go through the process outlined in this chapter, you may find some 
requirements are already active in your current database, or may not be relevant to your 
site. 

The purpose of this chapter is mainly to discuss the configuration requirements within the 
Aloha POS; however, some requirements have a corresponding requirement in Aloha 
Kitchen. In this case, we discuss what you need to do in both products to complete the 
implementation of the requirement or feature.

Making Aloha Kitchen active
By default, Aloha Kitchen is not active. You must enable Aloha Kitchen, to make it available 
in the product panel and to expose the options available for Aloha Kitchen. Once active, you 
can use Aloha Configuration Center (CFC) or Aloha Manager to configure Aloha Kitchen, in 
accordance with your permission levels.

1. If using Aloha Manager, select Maintenance > Business > Installed Products. (Log in to 
Aloha Manager as a corporate user.)

— OR — 

If using Aloha Configuration Center, select Maintenance > Global Administration > 
Installed Products. (Log in to Aloha Configuration Center as a global user.)

2. Under the ‘Products installed’ group bar, select Uses Kitchen. 

3. Click Save in the Command panel and continue to the next procedure. 

Figure 1 - 1  Products Installed Group Bar
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Establishing communication between Aloha POS and Aloha Kitchen
Aloha Kitchen uses Aloha Connect to establish communication between the Aloha POS and 
Aloha Kitchen. In POS v12.3, or later, Aloha Connect is automatically enabled. If you are 
using POS v6.7, or lower, you must enable Aloha Connect. 

1. Select the TS or QS icon on the Product panel.

2. Select Maintenance > Business > Store > Store Settings tab.

3. Select the System tab at the bottom.

4. Under the ‘Interfaces’ group bar, select Enable FOH COM Interface.

5. Click the Enable Kitchen ellipsis to have CFC automatically populate the Aloha Kitchen 
intercept 

— OR — 

Type AlohaPOSKitchenInterface.AlohaPOSKitchenInterface in the first available 
‘External integrated software component’ text box. 

6. Click Save and continue to the next procedure.

Providing access to Aloha Kitchen functions 
You must have a sufficient security role to access and perform configuration changes for 
Aloha Kitchen. 

1. Select Maintenance > Labor > Security Roles. 

2. Select a security role from the drop-down list.

Figure 1 - 2  Interfaces Group Bar
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3. Select the Kitchen tab.

4. Select the appropriate View, Edit, Add, and Delete options for the applicable security 
role.

5. Click Save.

6. Repeat this procedure for other security roles you allow to change Aloha Kitchen 
configuration.

7. Select File > Log out to log out and then log back in. 

Using the Aloha Kitchen configuration wizard
This section discusses the basic requirements to quickly get Aloha Kitchen up and running, 
mainly through the Aloha Kitchen wizard. This allows you to see items appear on the various 
controllers and screens, and helps you visualize additional configuration needed to 
accommodate your site. 

Identifying your kitchen areas
Before you begin, we highly recommend you first determine where you will place each piece 
of hardware (terminals, kitchen screen, kitchen station, bump bars, and printers) in the 

Figure 1 - 3  Security Roles Function
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kitchen area. Do not proceed until you complete this analysis. Determine device names, 
hardware types, and station roles for each area.

In general, the configuration of your Aloha Kitchen devices uses a one-to-one relationship, 
meaning each device in your kitchen has a dedicated terminal, kitchen screen, kitchen 
station, bump bar, and printer, with the last two devices as being optional depending on 
your needs. For example, the grill area would have a grill terminal, a grill kitchen screen, a 
grill kitchen station, a grill bump bar, and a grill printer. In some cases, you can reuse 
configuration elements such as bump bar layouts and screens. 

You configure each of these hardware elements in the configuration management tool 
(Aloha Configuration Center or Aloha Manager); however, you cannot share a device for 
Aloha Kitchen that you use for the POS, such as terminals. You must define unique 
terminals and printers for use with each application.

Historically, Aloha Kitchen has used the numbering range of IDs 81-90 for Aloha Kitchen 
terminals and printers. As noted, terminals and printers are used by both Aloha Kitchen and 
Aloha POS; however, they must be used exclusively. You cannot use the same terminal or 
printer for both Aloha Kitchen and Aloha POS. This also eases the burden of troubleshooting 
by locating your Aloha Kitchen terminals and printers. You will be instructed to use the 
Aloha Kitchen wizard which uses the same numbering convention of IDs 81-90, where 
possible. If you already have POS devices that use the range of 81-90, use a different 
numbering range. 

Figure 1 - 4  One-to-One Relationship Diagram for Aloha Kitchen Hardware
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Running the Aloha Kitchen configuration wizard
Before you begin ANY configuration, we highly recommend you start your implementation 
using the Aloha Kitchen Configuration Wizard, which lays the foundation and creates initial 
ID records for your configuration. 

Before you run the Aloha Kitchen Configuration Wizard, you must know and answer the 
following questions: 

● Is the site a fast food (quick service) or casual dining (table service) site? 

● How many kitchen areas will you have, and the name of each area, such as an Expo 
station, Fry station, Grill station, and others? 

● Are you ordering by designed courses, such as Appetizers, Entrees, and others? If the 
answer is yes, you must know the name of each course and the correct order in which 
the courses occur.

Courses in Aloha Kitchen are driven by categories. You must have a category for each 
corresponding course you are using. 

If you use courses, you must have an item modifier created in POS, such as ‘AsApp.’ 

Caution:  You run the Aloha Kitchen Wizard only one time and on a fresh install. You can-
not run the wizard again unless you individually delete the records and the associations it 
creates.
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When you run the Aloha Kitchen Configuration Wizard, the application creates records 
based on the following: 

● A bump bar layout record in Bumpbar Layout Maintenance for each of the following:  

● A course record in Courses Maintenance for each course you enter into the wizard. If 
you do not use coursing, the system still creates a default course, which is required for 
Aloha Kitchen to run. 

● A kitchen screen record in Kitchen Screen Maintenance for each kitchen area you enter 
into the wizard. You attach each kitchen screen to the applicable terminal in Terminal 
Maintenance.

● A single kitchen setting record in Kitchen Setting Maintenance. 

● A kitchen station record in Kitchen Station Maintenance for each kitchen area you 
enter into the wizard. You attach each kitchen station to the applicable terminal in 
Terminal Maintenance.

Bump bar Layout Attached to...

A single generic expediter 
bump bar layout, populated 
with three bump bar 
commands.

...each applicable expediter terminal 
you enter into the wizard.

A single generic production 
bump bar layout with three 
bump bar commands.

...each applicable production 
terminal you enter into the wizard. 

A bump bar layout for each 
kitchen area you enter into the 
wizard, with no commands. You 
can use these instead of the 
generic expediter and 
production bump bar layouts.

...none. 

Reference:  For more information on bump bar layouts, refer to “Configuring a bump 
bar layout” on page 1-20.

Reference:  For more information on kitchen screens, refer to “Configuring kitchen 
screens” on page 1-26.

Reference:  For more information on kitchen stations, refer to “Configuring kitchen 
stations” on page 1-24.
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● A metric record in Metrics Maintenance for each of the following:  

● A single routing rulebook record in Routing Rulebook Maintenance. The rulebook uses 
a video group condition, and routes to each, and combination of, expediter and 
production station you enter into the wizard. 

● A terminal record for each kitchen area you enter into the wizard. Each terminal has 
the applicable kitchen station and kitchen screen attached. Additionally, each expediter 

Metric For each... Attached to...

Current time ...expediter and production 
area you enter into the 
wizard.

...each expediter and 
production kitchen 
screen.

Average order time ...expediter and production 
area you enter into the 
wizard.

...each expediter and 
production kitchen 
screen.

Orders on time 
percentage

...expediter and production 
area you enter into the 
wizard.

...each expediter and 
production kitchen 
screen.

Maximum order time ...expediter and production 
area you enter into the 
wizard. 

...none.

Total active orders ...expediter and production 
area you enter into the 
wizard.

...none.

Total delayed orders ...expediter area you enter 
into the wizard.

...none.

Total suspended 
orders

...expediter area you enter 
into the wizard.

...none.

Total active items ...production area you 
enter into the wizard.

...none.

Note:  For more information on metrics, refer to the Customizing Aloha Kitchen Guide.

Note:  For more information on routing rulebooks, refer to the Customizing Aloha 
Kitchen Guide. 
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terminal has the generic expediter bumpbar layout attached and each production 
terminal has the generic production bumpbar layout attached. 

● A video group record in Video Group Maintenance for each kitchen area you enter into 
the wizard. Additionally, a record for all combinations of a kitchen area. Each video 
group has the single video queue record, ‘Kitchen <store name>’ attached, which is 
created in Video Queue Maintenance. 

● A single video queue record in Video Queue Maintenance named ‘Kitchen <store 
name>.’ The video queue has each video group attached, which is created by the wizard. 

Note:  For more information on terminals, refer to “Configuring terminals” on 
page 1-29.

Note:  For more information on video groups and video queues, refer to “Assigning 
video groups to items for routing” on page 1-17.
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To run the Aloha Kitchen Wizard:

1. With the AK icon selected in the product panel, select Utilities > Kitchen > Run Wizard.  

The Welcome screen appears. 

Figure 1 - 5  

Figure 1 - 6  
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2. Click Next. 

3. Select whether the site is a Fast food or Table service/Fast casual environment and 
click Next. 

Figure 1 - 7  

Figure 1 - 8  



 NCR Aloha Kitchen v19.11, Implementation Guide
Chapter 1: Getting started

1-13

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

4. Enter the number of stations you will use in the kitchen and click Next. 

5. Type the name you want for each station, whether the station is for an expo or 
production station, and if the station will have touch screen capability. The number 
of stations you select on the previous screen determines the number of stations listed. 
When you are finished, click Next. 

6. You must determine if you are using courses, such as Appetizers, Entrees, Desserts, and 
more, in your installation. If you are not using courses, select No and click Next to 
advance to the next screen and bypass the course configuration. 

Figure 1 - 9  

Figure 1 - 10  
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7. If you are using courses, select Yes and click Next. 

8. Type the name of the first course, such as Appetizers.

9. Type the name of the first course as you want it to appear on the order header display. 
Include any asterisks or other distinguishing characters to alert the employee, such as 
*DESSERT*.

10. Select the category of items to which items should go to by default, from the 
drop-down list. 

11. Select the modifier that, when ordered, moves the item to the respective course. For 
example, for your Entree/Main course, this would be your ‘As Entree/Main’ item. 

12. Select ‘Count up from 0’ or ‘Count down to the target time’ to determine the direction 
you want items to count. 

13. Enter the number of seconds you want an item to remain unfinalized before the cell 
turns yellow. 

14. Enter the number of seconds you want an item to remain unfinalized before the cell 
turns red. 

15. Enter the number of minutes you want this course to remain at the table before 
starting the next sequential course. 

16. Select Yes or No if this course is dedicated for ‘to go’ orders. 

Figure 1 - 11  
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17. If you select Yes, additional options appear. 

18. Enter how much earlier (in seconds) you would like this course to send to the kitchen.

19. Select each order mode affected by the course from the list of order modes. When all 
information is in place, the confirmation screen appears. 

20. Click Next to process the kitchen data.  

Figure 1 - 12  

Note:  If you are using cook times, the system sends the order based on the longest 
cook time. If you are not using cook times, you may want to enter a value here.

Figure 1 - 13  
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21. When the Aloha Kitchen Configuration Wizard completes, a screen appears listing the 
new records added to the database.  

22. Click Next. A screen with additional information appears, instructing you to perform 
extra steps. 

23. Click Finish. The Aloha Kitchen Wizard exits.

Figure 1 - 14  

Figure 1 - 15  
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Assigning video groups to items for routing
Item routing determines on which kitchen station items appear, when ordered. Several 
methods for item routing are available; however, the Aloha Kitchen Configuration Wizard 
sets you up with the most common: item routing by video group. The video group method is 
also carried into the Routing Rulebook, also set up by the Aloha Kitchen Configuration 
Wizard. 

To properly configure item routing by video group, the system uses the following 
configuration: 

● Configure video groups and video queues (accomplished by the Aloha Kitchen 
Configuration Wizard).

● Assign video groups to items.

Configuring video groups and video queues
The Aloha Kitchen Configuration Wizard sets you up with a video group record for each 
kitchen area you enter into the wizard, as well as a record for a combination of areas. The 
wizard also configures a single video queue record with all of the system-generated video 
groups attached. Aloha Kitchen requires at least one video queue record to communicate 
order information to Aloha Kitchen. 

You can define additional video groups to account for combination items, where 
components of an item are prepared at different stations. For example, create a ‘PantryGrill’ 
video group to allow a grilled chicken salad to route to both the Pantry and Grill stations.

Use this section if you want to add more video groups or video queues. Keep in mind, Aloha 
Kitchen only uses the video queue ID, and its associated video groups, for communication. If 
you enter any values for the video group or video queues, they are overridden by values you 
establish in Aloha Kitchen. Aloha Kitchen uses the COM interface to pass this information 
between products. To simplify the configuration, we recommend you assign all video 
groups to a single video queue. 

To configure a video group:

1. Select Maintenance > Hardware > Video Groups.

2. Click New.

3. Type a name for the video group, such as “Grill.”

4. Select the Video Queues tab.

5. Select a video queue from the ‘Available’ list and click >> to move the video queue to the 
‘Included’ list.

Note:  You must select ‘Display video’ in Maintenance > Business > Additional Features 
> Options to display Video Groups and Video Queues in Maintenance > Hardware.
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6. Click Save.

7. Repeat this procedure for each video group you need to create. 

8. Click Close and exit the Video Groups function. 

To configure a video queue:

1. Select Maintenance > Hardware > Video Queues.

2. Click the New drop-down arrow, select Standard from the drop-down list, and click OK.

3. Type a name for the video queue, such as ‘Kitchen.’

4. Select the Video Groups tab.

5. Select all video groups from the ‘Available’ list box (left-click the mouse on the first item, 
hold down the Shift key, and left-click the last item) and click the right arrow to move 
the video queue to the ‘Included’ list box.

6. Click Save.

7. Click Close and exit the Video Queues function.

Assigning a video group to an item 
The Aloha Kitchen Configuration Wizard does not assign a video group to an item. You must 
designate the video group to which you want an item to route when the item is added to an 
order, using the Item Routing function. If you have items you do not want to route to the 
kitchen, such as beverages, do not assign a video group to the item. 

Figure 1 - 16  Video Queue Maintenance (Using System-Generated Video Queue)
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To assign a video group to an item:

1. Select Maintenance > Menu > Item Routing > Item Routing tab. The Item Routing 
function contains only one record to use.

2. Maximize the screen so you can access all columns in the Item Routing function.

3. Select an item from the ‘Available’ list box and click the right arrow to move the item to 
the ‘Included’ list box.

4. Select the video group to which to route the item from the drop-down list. 

5. Repeat steps 3 and 4 for each item requiring a video group.

6. Click Save and exit the Item Routing function.

Figure 1 - 17  Item Routing Function



 NCR Aloha Kitchen v19.11, Implementation Guide
Chapter 1: Getting started

1-20

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

Manually configuring Aloha Kitchen hardware
As noted, once you run the Aloha Kitchen Configuration Wizard, you cannot run the wizard 
again unless you delete the auto-generated records and their associations. If you need to 
add another kitchen area to your restaurant or configuration, you can manually configure 
extra kitchen areas inside Aloha Kitchen. You must keep a one-to-one relationship with each 
component within a kitchen area, and we highly recommend maintaining the ID numbering 
range for your terminals. 

You must configure the following components, in order:

● Bump bar layout

● Kitchen station

● Kitchen screen

● Printer (optional)

● Terminal

Configuring a bump bar layout 
Bump bar devices are used by employees to perform multiple functions as they relate to the 
Aloha Kitchen screens, such as navigating from one order to another, or the physical 
removal (bumping) of a finished order from the screen. There are two types of bump bar 
hardware devices: the 16-key bump bar, which is the bump bar ordered most often for use 
with Aloha Kitchen, and the 19-key bump bar. With a bump bar layout, you determine the 
functions to make available on the bump bars, and the order in which they exist on the 
bump bar. 

A typical restaurant has two layouts, one for expo and one for production. You can create 
multiple bump bar layouts, depending on the functions required for each screen, or you can 
design one bump bar layout and use it for every bump bar in the system. Whichever design 
you choose, keep common commands in the same position across all bump bars. This 
reduces the risk of pressing the wrong button on a bump bar at a different station. For 
example, if the ‘Bump’ command is assigned to the large button on the right of the bump 
bar layout, place the command in the same position for all your production bump bar 
layouts. This way, if the fry cook switches to the pantry station, they are accustomed to a 
command being in the same location.

You can use a second bump bar for instances when you need to leverage more commands 
than are available on the bump bar. Attach that bump bar to COM2 in Terminal 
Maintenance. 

Note:  The procedures in this section depict how to configure the 16-key bump bar for 
Aloha Kitchen. If you have the 19-key bump bar, adjust the configuration, as needed.
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To configure a bump bar layout:

1. Select Maintenance > Hardware > Bumpbar Layout.

2. Click the New drop-down arrow, select Radiant 16-Key, and click OK.

3. Type a descriptive name for the bump bar layout, such as ‘Expo’ or ‘Grill.’

4. Click the Design tab. See Figure 1 - 18 for a basic bump bar layout for an expo station 
and Figure 1 - 19 for a basic bump bar layout for a production station.  

Figure 1 - 18  Bumpbar Layout - Design Tab (Expo)

function 
buttons
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5. Click the leftmost function button on the bump bar layout. 

6. Select a command, such as ‘Start,’ from the ‘Command’ drop-down list. The system 
automatically populates the ‘Text,’ ‘Button color,’ and ‘Text color’ for the button based on 
your selection; however, you can change these attributes, as needed.

7. Moving clockwise, repeat steps 5 and 6 until you add each desired command to the 
bump bar layout. Refer to the following table for a list of the recommended commands, 
with the large outside buttons shown highlighted.  

Figure 1 - 19  Bumpbar Layout - Design Tab (Production)

Bump Bar Layout for a Basic Expo 
Station

Bump Bar Layout for a Basic 
Production Station

1 Bump 1 Start

2 Scroll Left 2 Scroll Left

3 Order Cursor Up 3 Start Cursor Up

4 Scroll Right 4 Scroll Right

5 Display (Toggle Display) 5 Display (Toggle Display

6 Tables 6 Language

7 Recall 7 Item Cursor Up

8 Item Cursor Up 8 Info

9 Print 9 Bump

10 Item Cursor Down 10 Item Cursor Right

function 
buttons
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8. Click Print in the Command panel to view a preview of a bump bar layout. This allows 
you to visually see the layout of your bump bar, which you can print and insert into a 
physical bump bar.  

9. Click the printer icon and select a printer from the Select Printer frame. 

10. Click Print to send to the printer. We recommend printing to a PDF printer and saving 
the file to a flash drive. Local office supply and print stores can print bump bar layouts 
on overhead transparency stock. This makes it easier to insert a bump bar layout into a 
bump bar.

11 Select Staff (Select Staff Level) 11 Item Cursor Down

12 Info 12 Item Cursor Left

13 All Day 13 All Day

14 Order Cursor Right 14 Start Cursor Right

15 Order Cursor Down 15 Start Cursor Down

16 Order Cursor Left 16 Start Cursor Left

Note:  As you assign a command to the bump bar layout, the drop-down list includes sev-
eral options for a particular command, such as Start; however, each have a different 
behavior. For example, as you scroll through the list, there are many ‘Start’ commands. 
Make sure you select the appropriate command for your needs.

Reference:  Refer to the Aloha Kitchen Reference Guide for a complete list of bump bar 
commands.

Figure 1 - 20  Bumpbar Print Preview

Bump Bar Layout for a Basic Expo 
Station

Bump Bar Layout for a Basic 
Production Station
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11. Click Save in the Command panel.

12. Repeat this procedure for each additional bump bar layout you need to create.

13. Click Close in the Command panel to exit the Bumpbar Layout function, or continue to 
the next procedure.

Configuring kitchen stations
Kitchen stations define the attributes and behavior you want for a particular area of your 
kitchen, such as printing and bumping functions. They are also defined within a routing 
rulebook as the destination for items. Kitchen stations also define printing and bumping 
functions.

You always select the ‘Expo’ kitchen station type for each expo area. For each production 
station, you typically select the ‘Production’ kitchen station type. You must create a kitchen 
station for each area of your kitchen to maintain a one-to-one relationship.

To configure a kitchen station:

1. Select Maintenance > Hardware > Kitchen Station.

2. Click the New drop-down arrow, select the appropriate kitchen station type from the 
drop-down list, and click OK.

Note:  Kitchen stations are used as the routing destination when you define your item 
routing. Refer to the Customizing Aloha Kitchen Guide for more information.
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3. Under the ‘Settings’ group bar, type a descriptive name for the kitchen station. 

4. For an Expo kitchen station, make the following suggested selections: 

○ Under the ‘Settings’ group bar, select Master bump. When you select Master bump, 
the ‘Master bump all stations’ option appears. Select this only if you want this station 
to bump orders from all stations in use.

○ Under the ‘Items’ group bar, select Combine independent modifiers with parent 
item.

○ Under the ‘Printing’ group bar, select Auto-print chit when prepared. 

5. Click Save in the Command panel.

6. Repeat this procedure for each kitchen area.

7. Click Close in the Command panel to exit the Kitchen Station function.

Figure 1 - 21  Kitchen Station - Station Tab (Expo)

Note:  A production kitchen station for a basic setup has all options cleared in the 
Kitchen Stations function. If you select any options, you must exercise caution when 
you select any ‘auto-start’ or ‘auto-prepare’ options, as these options do not allow a 
production employee to physically interact with the screen. For example, if you select 
‘Auto-start all items,’ the correct setup is to use a ‘Production cooking only’ screen in 
the Kitchen Screens function; otherwise, items will never start. Refer to the Customiz-
ing Aloha Kitchen Guide for more information on kitchen screens.
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Configuring kitchen screens
Use the Kitchen Screen function to create a kitchen screen for each terminal in the kitchen 
area of the restaurant. There are several types of kitchen screens available for 
configuration, ‘Expo order view’ and ‘Production start and cooking’ being the two most 
common. Using this function, you define the attributes, colors, sorting, and display options 
for each kitchen screen. You also define the metrics and commands to appear on the 
kitchen screen. Later in the configuration, you will assign a kitchen screen to each terminal. 

To configure a kitchen screen for use on an expo terminal:

1. Select Maintenance > Hardware > Kitchen Screen.

2. Click the New drop-down arrow, select Expo order view from the drop-down list, and 
click OK.

3. Type a name, such as ‘Expo,’ for the kitchen screen.

4. For a basic Expo kitchen screen, we recommend the following selections:

○ Under the ‘Display options’ group bar, choose Selected routed items from the 
‘Manual print type’ drop-down list.

○ Under the ‘Order display options’ group bar, select Sort orders by target time.

○ Select Ignore prepared status for order sorting.

○ Under the ‘Item display options’ group bar, select Show order name.

Figure 1 - 22  Kitchen Screen - Screen (Expo)
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○ Select Show timer text.

○ Select Course text, available if you are using coursing.

5. Click Save.

6. Repeat this procedure for other expo kitchen screens, if necessary.

7. Click Close and exit the Kitchen Screens function, or continue to the next procedure to 
configure a kitchen screen for production.

To configure a kitchen screen for use on a Production terminal:

1. Select Maintenance > Hardware > Kitchen Screens.

2. Click the New drop-down arrow, select Production start and cooking from the 
drop-down list, and click OK.

3. Type a name, such as ‘Grill Production,’ for the kitchen screen.

4. For a basic Production kitchen screen, we recommend the following selections:

a. Under the ‘Display options’ group bar, type 30 in ‘Start queue percentage.’

b. Type 2 in ‘Start queue columns.’

c. Select Left from the ‘Start queue position’ drop-down list. 

d. Under the ‘Item display options’ group bar, select Show order name.

Figure 1 - 23  Kitchen Screen - Screen (Production)
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e. Select Show timer text.

f. Select Show parent item with independent modifiers.

g. Select Sort production cooking items by target time. 

5. Click Save.

6. Repeat this procedure for other kitchen screens for which you want a production 
kitchen screen.

7. Click Close and exit the Kitchen Screens function.

Configuring printers (optional)
If desired, you can configure your system so that Aloha Kitchen controls the printing of the 
kitchen chit rather than the POS. You can print to a POS printer, or you can use a dedicated 
printer for Aloha Kitchen. If you do not want Aloha Kitchen to control the printing of the 
kitchen chit, you can omit this procedure.

The application type of the printer is determined by the physical piece of hardware to which 
the printer is connected (whether physically or Ethernet-based). Aloha Kitchen can print to a 
printer that is physically connected to a POS terminal.

To configure a printer:

1. Select Maintenance > Hardware > Printers.

2. Click the New drop-down arrow, select Aloha Kitchen from the drop-down list, and 
click OK. 

3. Under the ‘Settings’ group bar, type a name for the printer.   

Figure 1 - 24  Printer - Printer Tab (Ethernet)
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4. Select a model to use for the printer from the drop-down list. If you want to use 
Ethernet printing, you must use an Epson printer.

5. Clear Use native network interface to use a local printer attached to a COM port on 
the kitchen terminal.

a. Select the terminal to which the printer is attached.

b. Select the port for the printer to use.

— OR — 

Enable Use native network interface to use an Ethernet printer.

c. Type the network address of the printer.

d. Accept the default network port of 9100, unless you need to change this to match 
your network configuration.

6. Select a backup printer from the drop-down list, in the event this printer is 
malfunctioning.

7. Click Save.

8. Repeat this procedure for other Aloha Kitchen printers connected to a terminal.

9. Click Close to exit the Printers function.

Configuring terminals
Once you configure your kitchen stations, kitchen screens, bump bars, and printers, you 
must assign them to a dedicated Aloha Kitchen terminal. Make sure you keep a one to one 
relationship. 

Figure 1 - 25  Printer - Printer Tab (Local)

Tip:  If the file server ever fails, the lowest-numbered Aloha Kitchen terminal takes over 
duties with the Aloha Kitchen service. For this reason, it is particularly important to assign 
the lowest ID number to your most robust terminal, such as ID number 81.
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At this point, you can enable touch screen functionality for the terminal, if supported. The 
secondary display for an additional monitor is used only if you are using the K1700 
controller and have a monitor connected to the video out connection on the K1700. 

To configure an Aloha Kitchen terminal:

1. Select Maintenance > Hardware > Terminals. 

2. Click New. The system creates a new terminal record with the next sequential ID 
number.

3. Under the ‘Identification’ group bar, choose an ID number from the drop-down list, such 
as ID 81.

4. Type a descriptive name for the terminal, such as ‘Expo’ or ‘Grill.’

5. Under the ‘Applications’ group bar, clear POS. The system removes all unnecessary 
group bars and tabs.

Figure 1 - 26  Terminal Configuration Diagram

Figure 1 - 27  Terminals - Terminal Tab 
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6. Select Aloha Kitchen. An additional Kitchen tab appears. 

7. Select the Kitchen tab.   

8. Select the kitchen station, kitchen screen, bump bar, and printer from the applicable 
drop-down lists.

9. When you attach a bump bar layout, specify the port to use for the bump bar device. 

Figure 1 - 28  Terminals - Kitchen Tab (Expo)

Figure 1 - 29  Terminals - Kitchen Tab (Production)
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10. Select Enable touch to enable the touch screen functionality, if supported by the kitchen 
device.

11. Click Save.

12. Repeat this procedure for all other Aloha Kitchen terminals.

13. Click Close and exit the Terminals function.

Refreshing data
After all settings are in place in your configuration management tool, you must select 
Utilities > POS > Refresh POS & All Installed Products to transfer the new information to 
the FOH terminals, or wait for the End-of-Day (EOD) process to accomplish the data refresh 
for you. If you run the refresh prior to the EOD process, select ‘Automatically restart all POS 
terminals’ and click OK to continue.After the data refresh is complete, all new settings 
become operational across the Aloha network. 

Caution:  Refresh data with caution and never during peak hours of operation. All FOH ter-
minals reboot during a refresh and are down for a short period of time.
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Configuring an Aloha Kitchen terminal environment
After you configure the requirements mentioned in this guide, and perform a refresh, you 
must configure an Aloha Kitchen terminal environment. This syncs Aloha Kitchen with the 
POS and launches Aloha Kitchen at the appropriate time. You must have all the 
requirements in this chapter complete, particularly the Aloha Kitchen terminal, before you 
can configure an Aloha Kitchen terminal environment. 

You can configure the terminal environment either manually, or using Radiant Application 
Loader (RAL) v14.1, or later. This is supported with all versions of Aloha Kitchen, and is 
recommended. All OS requirements on the device are the same as the POS terminal and 
Aloha Kitchen is required on the BOH server machine. RAL finds the AlohaKitchen.xml file in 
the Aloha Kitchen\Data folder to automatically configure the RAL interface with kitchen 
devices. Additionally, RAL creates an AKStart.bat file needed to launch Aloha Kitchen. 

Manually configuring an Aloha Kitchen terminal environment
If you want to manually configure an Aloha Kitchen environment, you must configure a 
batch file called ‘AKStart.bat’ to launch the terminals. 

To manually configure an Aloha Kitchen terminal environment:

1. Ensure the time zone of each terminal is set correctly to match the POS server.

2. Set Computer Name:

The networking setup should be similar to the Aloha POS terminals. The machine name is not 
important, but for ease of troubleshooting, we recommend you set the machine name to 
AKCONTROLLERx, where “x” is the device ID (for example AKCONTROLLER1, AKCONTROLLER2, 
etc.).

3. Set WORKGROUP.

Use the WORKGROUP the Aloha BOH file server uses (typically IBERTECH).

4. Set the IP Address.

Set the IP address compatible to the Aloha BOH file server and POS terminals.

5. Copy the Aloha Kitchen folder and its contents from the Aloha BOH file server to the 
Bootdrv folder on the AK Terminal.

6. Edit the StartAK.bat batch file and place a shortcut of it in the startup folder of the 
device. You need four startup parameters for the Aloha Kitchen executable: TERM, 
TERMSTR, KITCHENFOLDER, and SERVER and IBERROOT (if applicable), and IBERDIR, if 
using the temporary Command Center installation.

Reference:  Refer to the RAL v14.1 documentation for instructions on how to create an 
Aloha Kitchen terminal environment.
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a. TERM is the identifier of the terminal as set in Configuration Center. Example: 
TERM=81

b. TERMSTR should be set to the same value used by the POS system, i.e. the same 
TERMSTR you have set on your Aloha BOH file server and POS terminals. This setting 
is used to determine which terminal messages the Aloha Kitchen system should act 
on.

c. KITCHENFOLDER is the local AlohaKitchen folder on the device and is the path for 
config and storing logs. Example: KITCHENFOLDER=C:\BOOTDRV\ALOHAKITCHEN.

d. SERVER is the computer name of the file server.

e. If the POS is installed in an ALOHA folder, you do not need to set the IBERROOT 
variable, but if it is installed elsewhere (ex. ALOHAQS), set the IBERROOT variable.

7. Repeat this procedure for each Aloha Kitchen terminal.

An example batch file:
:: ---- SET ENVIRONMENT ----
:: ---- These are required ----
:: (Determines which Term Id this is and MUST be the term ID in CFC – Also used for 
temp CMC Install)
SET TERM=81
:: (Filters POS transactions and connection, only transactions from this TERMSTR will 
be used - MUST be the POS TERMSTR)
SET TERMSTR=ALOHATERMS
:: (Path for config and storing log - must point to local kitchen folder)
SET KITCHENFOLDER=C:\BOOTDRV\ALOHAKITCHEN
:: (SERVER variable must match the computer name of your POS and AK file server - 
Also used for temporary CMC install)
SET SERVER=ALOHABOH
:: (Used for temporary CMC Install - should match your KITCHENFOLDER variable)
SET IBERDIR=C:\BOOTDRV\ALOHAKITCHEN
:: (Override default of 'ALOHA' - needed to read DOB from BOH, should be IBERROOT at 
BOH)
:: SET IBERROOT=ALOHAQS
:: -----------------------------
:: ---- Optional Settings ----
:: (Use to dump local machines ENVIROMENT and startup args into debout)
SET SHOWKITCHENENVIRONMENT=TRUE
:: -----------------------------
:: ---- Load Aloha Kitchen and Loop ----
:RESTART
::
:: ---- Sync time with server ----
:: (Use to sync local time - make sure WINDOWS Time Zone settings match, this is a 
temporary workaround)
NET TIME \\%SERVER% /SET /Y
::
:: ---- copy local NEWBIN files to local BIN
COPY %KITCHENFOLDER%\NEWBIN\*.* %KITCHENFOLDER%\BIN\ /Y
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DEL %KITCHENFOLDER%\NEWBIN\*.* /Q
::
:: ---- Start a Aloha Kitchen instance ----
:: (switch '/TOUCH' will turn on the CommandBar even if a Bumpbar is defined for 
controller)
START /WAIT %KITCHENFOLDER%\BIN\ALOHAKITCHEN.EXE /CONTROLLER %TERM% /TOUCH
::
:: ---- Loop to restart ----
GOTO RESTART
EXIT
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Troubleshooting your terminal environment
Use the following helpful tips to troubleshoot your Aloha Kitchen terminal environment: 

Aloha Kitchen device does not start up and is in a continuous loop.
Check the Aloha Kitchen terminal debout for the following lines and ensure the IP address 
(in parenthesis) is your internal POS network or an external network IP address:

10:53:04, Detected instance AlohaKitchen_9999 on network (10.100.9.2)

10:53:04, Detected instance AlohaKitchenService_9098 on network (10.100.9.2) 

If the IP address is the external network, change the binder order.

1. Right-click My Network Places and select Properties.

2. Click Advanced and select Advanced Settings. 

3. Using the arrows on the right, change the binding order so your POS network is listed 
first. 

4. Click OK and exit the Advanced Properties dialog box.

5. Reboot the file server. You must reboot the file server for these changes to take effect.

6. If the debout is referencing the correct network, verify you have the correct ports open 
on your firewall for the server. 

‘NO POS’ message appears in the upper-right of the screen.
The POS terminal install usually requires only a refresh once AK has been installed on the 
server. Updating AK on the server adds the proper files to the Bin directory. If this does not 
happen, verify the following.

● If using the POS SynchInclusionList feature, ensure Aloha.ini has a CLSID entry for the AK 
POS interface, such as ‘ActivityCLSID1=Aloha 
POSKitchenInterface.AlohaPOSKitchenInterface.’ 

● If the CLSID entry is correct, then check the POS terminal debout. If the line, 
‘AlohaActivity: Failed to create CLSIDAlohaPOSKitchenInterface.AlohaPOsKitchen 
Interface’ appears, the interface did not automatically register. You must manually 
register the interface on each POS terminal (and also the server, if you are running an 
instance of Iber on the file server).

Tip:  It is necessary to add this setting in Configuration Center or Aloha Manager v7.0, 
or higher. Do not place it directly into Aloha.ini.
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To manually register the interface on each POS terminal. 

1. Open a Command prompt on the terminal and navigate to the POS Bin folder. 

2. Type %windir%\Microsoft.Net\Framework\v2.0.50727\Regasm.exe /Verbose 
%LocalDir%\Bin\AlohaPOSKitchenInterface.dll /Codebase, where %LocalDir% is the 
actual path of your LocalDir, if your LocalDir is not defined in your environment variables 
on the POS terminal. 

3. Reboot the terminal after registering the command. 
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About this chapter
This chapter discusses how you can use other functions and isolated features to customize 
your Aloha Kitchen installation. These are not required for getting Aloha Kitchen started and 
running; however, when configured, they add exceptional value to your overall operation 
and allow you to conform to your operational needs and specific environment.

Remember you must always refresh data after configuring any of these features.
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Understanding Kitchen settings
Before you begin to implement additional features which are not provided by the Aloha 
Kitchen wizard, it is helpful to understand the Kitchen Settings function. This function 
provides options relating to the whole kitchen, instead of an individual section of a kitchen. 
If your configuration tool is CFC, you can have a Kitchen Settings record for each store or 
you can use the same Kitchen Settings record for multiple stores. If your configuration tool 
is Aloha Manager, you only have a single Kitchen Settings record. Once you are familiar with 
the Kitchen Settings function, you will be instructed to return the function to make 
configuration changes. 

To access Kitchen Settings:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings. 

2. Click Close to exit the Kitchen Settings function.

Figure 2 - 1  Kitchen Settings Function
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The Kitchen Settings function contains a number of group bars whereby you configure your 
system at the store level.

Group Bar: Defaults 

Use the Defaults group bar to configure default behavior for certain elements of the 
program. The system uses these defaults at all times for the whole store, unless overridden. 

● To configure your default course, refer to “Configuring item activation” on page 29. The 
Aloha Kitchen wizard defines a default course for you. 

● To configure your default routing rulebook, refer to “Configuring item routing” on 
page 17. The Aloha Kitchen wizard defines a default routing rulebook for you.

● To configure your default staff level, refer to “Configuring staff levels to change item 
routing” on page 62.

● To configure your default quote time table, refer to “Configuring quote times for 
adjustments in Aloha Takeout” on page 65.

Group Bar: Items 

Use the Items group bar to configure features related to items.

● To configure the routing method, refer to “Configuring item timing” on page 7.

● To configure the method to use for items with zero cook times, refer to “Configuring 
item timing” on page 7.

● To configure minutes to automatically bump an item, refer to “Automating Aloha 
Kitchen” on page 39. 

Group Bar: Orders 

Use the Orders group bar to configure features related to orders.

To configure zoning, refer to “Configuring zoning” on page 42.

Group Bar: Timers 

Use the Timers group bar to configure when an item timer begins for orders.

Group Bar: User Interface 

Use the User Interface group bar to configure attributes for the graphical user interface.

Group Bar: Delay Routing 

Use the Delay Routing group bar to configure the delayed routing functionality.

To configure delay routing, refer to “Configuring item timing” on page 7.

Group Bar: Chit Printing 

Use the Chit Printing group bar to activate and configure attributes related to the printing of 
your chits. 
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To configure a print layout for chits, refer to “Customizing the print layout for production 
chits” on page 86.

Group Bar: Quote Times 

Use the Quote Times group bar to configure the rounding and override requirements for 
changing the quote time used in the Aloha Takeout product. 

To configure quote times, refer to “Configuring quote times for adjustments in Aloha 
Takeout” on page 65.

Group Bar: Customer order display options 

Use the Customer Order Display Options group bar to define the behavior for all customer 
order view kitchen screens. 

Note: Refer to the Customer Order Display Feature Focus Guide for complete information 
on configuring and using a customer order display. 

Group Bar: System 

Use the System group bar to configure internal elements of Aloha Kitchen, such as 
requirements to hold diagnostic data, debugging a bump bar, defining the kitchen server 
remoting port, and more. You should use caution with this group bar as many of these 
options should rarely be changed.
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Configuring item timing 
By default, all routed items display (activated) on their respective kitchen screens at the 
same time. You can configure the timing of items in Aloha Kitchen to allow items to display 
on a kitchen screen at staggered times (delayed routing) so you can synchronize the 
completion of the order at the same time. This ensures hot food is served hot and cold food 
is served cold. The item with a longest cook time displays first, then other items within the 
order with a shorter cook time displays at the appropriate times. There are several item 
timing methods you can use. Some methods you can use in conjunction with another timing 
method, and some override a method. 

For example, the guest orders a grilled chicken entrée with an eight minute cook time and a 
fried shrimp entree with a two minute cook time. The grilled chicken entree appears on the 
‘Grill’ screen for six minutes before the fried shrimp entrée appears on the ‘Fry’ screen. 

In order to stagger the delay of your items, you must activate delay routing and add cook 
times to your items. 

Activating delay routing
To stagger the times when items appear on-screen, you must activate the delay routing 
function in Kitchen Settings. 

To activate delay routing:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings. 

2. Under the ‘Delay Routing’ group bar, select Enable delay routing. 

3. Click Save and exit the Kitchen Settings function. 

Adding cook times for items
Adding cook times to your routed items is the very basic requirement for timing your items. 
The item with the longest cook time displays on-screen first, then all subsequent items 
within the order display when their cook times arrive. You need only add a cook time to 
items you are routing. 
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To add cook times for items:

1. Select Maintenance > Menu > Item Cook Times. 

2. Click New to create a new item cook time record.

3. Select an item from the ‘Available’ list box and click >> to move the item to the ‘Included’ 
list box. To select a range of items, select the first item in the range, hold down the Shift 
key, and select the last item. To select non-consecutive items, select an item, hold down 
the Ctrl key, and select each additional item.

4. Type the number of seconds it takes to prepare the item in ‘Cook time.’ To enter the 
same cook time for a range of items, select the first item in the range, hold down the 
Shift key, and select the last item. To enter the same cook time for non-consecutive 
items, select an item, hold down the Ctrl key, and select each additional item.

5. Repeat Steps 3 and 4 until you configure the cook times for each item.

6. Click Save.

7. Click Close to exit the Item Cook Time function or continue to the next procedure.

Adjusting an item cook time based on a modifier 
You can adjust the cook time of an item when you order the item with a specific modifier, 
using the Standard Modifiers tab. Typically, you adjust a cook time for temperature 
modifiers, such as ‘Well Done,’ or ‘Rare.’ You can increase or decrease the time, based on a 
percentage or a fixed amount of seconds. You must place the modifier in a modifier group 
and associate that modifier group to the applicable item, as you would for any other 
modifier group configuration. 

Figure 2 - 2  Item Cook Times - Item Cook Times Tab
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Note: Be aware the options you configure on the Standard Modifiers tab affects the cook 
times you configure on the Item Cook Time tab. Furthermore, the modifier configured here 
equally affects the timing of any item to which you apply this modifier. For example, using a 
‘Well Done’ modifier on a hamburger, a bacon cheeseburger, or a mushroom Swiss burger 
affects the cook time by the same amount. 

To adjust an item cook time based on a modifier:

1. Select Maintenance > Menu > Item Cook Times > Standard Modifiers tab.  

2. Select a modifier from the ‘Available’ list box and click the right arrow to add the 
modifier to the ‘Included’ list box. The modifier you choose must reside in a modifier 
group and must be attached to the applicable item. Do not select a menu item or a 
modifier that does not apply. 

3. To adjust the cook time by a percentage, type a percentage in the ‘+/- Percent’ column. 
Precede the percentage with a minus sign if you want to reduce the original cook time.

-OR-

To adjust the cook time by a fixed number of seconds, type an amount, in seconds, in 
the ‘+/- Seconds’ column. Precede the amount with a minus sign if you want to reduce 
the original cook time. 

4. Repeat Steps 2 through 4 for each modifier you want to adjust the original item cook 
time you order the item with the modifier. 

5. Click Save.

6. Click Close to exit the Item Cook Times function or continue to the next procedure. 

Figure 2 - 3  Item Cook Times - Standard Modifiers Tab
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Overriding an item cook time using an item/modifier pairing
You can override an item cook time, and item cook time adjustment, with a specific pairing 
of an item and a modifier, using the Advanced Modifiers tab. Typically, you would use this 
when a cook time adjustment is already in place or you want to use a pairing at all times. For 
example, if you already have a ‘Well Done’ modifier to increase the cook time of an item by 
50%, but when you order a NY Strip steak takes 100%, you would pair NY Strip steak and 
Well Done together to create a different cook time amount. You must place the modifier in a 
modifier group and associate that modifier group to the applicable item, as you would for 
any other modifier group configuration. 

To override an item cook time using an item/modifier pairing:

1. Select Maintenance > Menu > Item Cook Times > Advanced Modifiers tab.  

2. Click Add. The system adds a blank row under the ‘Cook Time Assignments’ group bar.

3. Select an item from the ‘Item’ drop-down list.

4. Select a modifier from the ‘Modifier’ drop-down list. Only modifiers associated with the 
item appear.

5. Type the total number of seconds it takes to cook the item when used with this 
modifier in ‘Combined cook time.’

Caution:  Be aware the options you configure for a specific pairing on the Advanced 
Modifiers tab override the options on the Item Cook Time and Standard Modifiers 
tabs.

Figure 2 - 4  Item Cook Times - Advanced Modifiers Tab
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6. Repeat Steps 2 through 5 until you add all advanced modifiers you need.

7. Click Close to exit the Item Cook Times function.

Overriding item cook times
Use the Item Cook Time Overrides function to override the entire set of item cook times 
with a new set during abnormal times or special events. You can use the function to 
increase or decrease the cook time of an item, such as when the number of items ordered, 
exceeds the capacity of a piece of kitchen equipment during busy meal periods or additional 
schedule staff increases productivity. If necessary, create one or more item cook time 
overrides to account for different business and production levels that affect the cook time 
of various items. After you configure a new set of cook time values, you must access 
Maintenance > System Settings > Activation Schedule and Event Schedule to activate or 
deactivate the override.

To configure item cook time overrides:

1. Select Maintenance > Menu > Item Cook Time Overrides. 

2. Click New.

3. Under the ‘Settings’ group bar, type a name for the item cook time override.

4. Select one or more items from the ‘Available’ list box and click the right arrow to move 
the items to the ‘Included’ list box.

Figure 2 - 5  Item Cook Time Overrides
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5. Use the Standard Modifiers and Advanced Modifiers tabs to configure cook time 
overrides for those functions. See “Configuring item timing” on page 7.

6. Click Save.

7. Click Close and exit the Item Cook Time Override function.

To create an activation schedule for a cook time override:

1. Select either the TS or QS icon.

2. Select Maintenance > System Settings > Activation Schedules.

3. Click the New drop-down arrow, select a type of cook time override from the drop-down 
list, and click OK.

Note1: If you select Weekly, Monthly, or Specific Date from the New drop-down list, you 
must select additional configuration from the ‘Options’ group bar.

4. Type a name for the activation schedule.

5. Under the ‘Time’ group bar, clear Start of day unless the cook time override applies to 
an entire day.

6. Type a Specific start time for the activation schedule.

7. Click Save and exit the Activation Schedule function.

To create an event schedule for a cook time override:

1. Select Maintenance > System Settings > Event Schedule.

2. Select an existing Event Schedule from the ‘Event Schedule’ drop-down list, or click New 
to add a new event schedule.

3. Select the Events tab.

4. Click the Add drop-down list and select Activate Item Cook Time Override.

5. Under ‘Activation Schedule,’ select the activation schedule.

6. Select a start date and end date from the drop down calendar. 

7. Under the ‘Activate Item Cook Time Override’ group bar, select the item cook time 
override from the drop-down list.

8. Select the Active check box.

9. Click Save and exit the Event Schedule function.

Note1: To deactivate a cook time override, repeat steps 4 - 9. In step 8 clear the ‘Active’ check 
box. 
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Determining the method to use for items with zero cook time
When you have a zero cook time assigned to an item, and you are using delay routing, the 
routed item appears on-screen with no delay. The system then uses the timing 
requirements of the course, even if you have only the default course. You can configure zero 
cook time items to appear on-screen in Kitchen Settings, based on when a course 
completes, starts, or by the ‘Duration in minutes’ option in Course Maintenance. 

To determine the method to use for items with zero cook time:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings.

2. Under the ‘Items’ group bar, select one of the following from the ‘Item with zero cook 
time option’ drop-down list.

a. Select Activate item at course completion to activate items when a course is 
complete. 

b. Select Activate item at course start to activate items based on the start of the 
course.

c. Select Use default item time as defined in course configuration to activate items 
based on the ‘Default cook time for zero cook time item (in seconds)’ value in 
Maintenance > Kitchen Configuration > Course for the active course.

3. Click Save.

Configuring delay routing
Delay routing options enable staggered activation based on item cook time, course timing, 
or when using the future order functionality in Aloha Takeout. If delayed routing is cleared, 
items are activated all at once. If delayed routing is cleared and the order has multiple 
courses, all items appear at once with each course appearing in separate cells with their 
respective items.

To configure delay routing:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings.

2. Under the ‘Delay Routing’ group bar, configure the following:

a. Select Enable delay routing to activate delay routing. If cleared, all items route 
normally and become active immediately.

b. Clear Always activate delayed items on same order together to stagger the 
activation of items. Enable this option if you want to activate all items in a delay 
group at the same time. Use this option if you use an Aloha Kitchen expo station, but 
use kitchen chit printing instead of production displays.
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c. Type the number of minutes before the target time that Aloha Kitchen forces 
activation of a delayed item in ‘Minimum activation time in minutes,’ if it has not been 
activated by other methods. Recommended: Set this to the shortest cook time item 
for all courses.

d. Type the number of minutes before the target time that you allow Aloha Kitchen to 
activate delayed item in ‘Maximum activation time in minutes’ to prevent items from 
being released too early. Type ‘0’ to indicate no limit. Recommended: Set this to the 
cook time of the item that takes the longest time to prepare.

e. Type the number of seconds to add to the activation time in ‘Additional activation 
seconds’ for counting, battering, breading, or other preparation you require before 
cooking items.

f. Select Enable manual activation for delayed orders if you activate orders, as 
opposed to Aloha Kitchen automatically activating a delayed order. Recommended: 
Cleared.

g. Select Enable manual activation for delayed items if you activate items, as 
opposed to Aloha Kitchen automatically activating a delayed item. Recommended: 
Cleared.

h. Select Add production factor to activation time to calculate the activation time of 
items.

i. Select Activate relative to first item actual start time to time the activation of 
items within a course based on when the first item is activated and the cook time of 
each item. This option ignores the course target time and sets a new target time for 
all course items, based on the start of the first item on a course and the cook time of 
that item. Required Options: It is necessary to set a maximum time to wait for the 
first item in seconds.

j. Specify the Maximum time to wait for first item in seconds to define the seconds 
other items on a course must wait before the activation of the beginning of a course. 
This prevents an entire order from being late if you forget to start the first item. 
Required options: You must select ‘Activate relative to first item actual start time’ to 
enable this option. 

k. Select a behavior from the ‘Auto suspend course behavior’ drop-down list to 
determine the automatic suspension of courses.

l. Select Disable in a quick service, quick casual, and casual table service environments 
to allow Aloha Kitchen to time and automatically fire all courses.

Note:  Selecting ‘0’ delays shorter cook time items indefinitely until the item with the 
longest cook time is started.
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m. Select Suspend all courses in fine dining to release each course for a table manually, 
including the first course.

n. Select Autofire first course and suspend all subsequent courses in fine dining to 
automatically fire the first course, then require you to release each remaining course 
for a table, when necessary.

o. Select Auto fire suspended course minutes to specify the number of minutes, from 
0 to 999, to wait before automatically firing a course that has been suspended. The 
default is 500 minutes (8 hours 20 minutes). Lower the number Sgtpeof minutes to 
fire a suspended course in case you forget to fire a course.

3. Click Save and exit the Kitchen Settings function.

Configuring item routing method for items
In the POS, an item is sent to the kitchen in a variety of ways, all of which are with the 
inclusion of the ‘Send’ function. You can either touch a stand-alone ‘Send’ button, include 
the send function within a script, apply an order mode with the send function, and more. 
You can use Aloha Kitchen to determine at what state of the ordering process in the POS 
that items appear on the kitchen screen. 

To determine when items appear from the POS:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings.  

2. Under the ‘Items’ group bar, configure one of the following options from the ‘Routing 
method’ drop-down list:

Figure 2 - 6  Kitchen Settings - Items Group Bar
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a. Select When finalized to send an item to the kitchen when you order the item on the 
POS. 

b. Select One behind to send an item to the kitchen only after you enter the next item 
in the POS.

c. Select Route when POS order is closed to send an item to the kitchen when you 
close the check on the POS. 

d. Select Immediate to send an item to the kitchen as you enter the item, as 
unordered, on the POS. This is useful for fast quick-service environments. 

3. Click Save. 
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Configuring item routing
Item routing determines on which Aloha Kitchen station items appear. Several methods for 
item routing are available, depending on your operations. Most restaurants take the 
granular approach, meaning each item is routed to an appropriate kitchen station using 
video groups. A less granular approach would be to send an entire order to a kitchen screen, 
such as by order mode. 

What the Aloha Kitchen wizard does?

When you run the Aloha Kitchen wizard, the system automatically creates a ‘My Routing 
Rulebook’ record in Routing Rulebook Maintenance, configured for video group routing to 
each kitchen station created by the wizard. The system attaches the generated routing 
rulebook as the default rulebook in Kitchen Settings. 

Visit the Routing Rulebook function to do the following: 

● Adjust the system-generated routing rulebook by changing or adding additional 
conditions.

● Create another routing rulebook to use during non-peak times of the day. 

● Create another routing rulebook with a different routing method, such as category, to 
use instead of routing by video groups. 

Before configuring item routing, you need to understand the concept of a “routing 
rulebook.” Regardless of the method of item routing you choose, you must have at least one 
rulebook to use as the default rulebook. This rulebook should cover your routing needs 
when your restaurant is at its normal staffing level, and is the default rulebook, active at the 
start of each day. Then create additional rulebooks, if desired, to cover the routing 
requirements when you either increase or decrease your staff. You can easily change the 
active rulebook using the Set Staff Levels command from the Command bar on a touch 
screen terminal or a bump bar. For example, base the first (default) rulebook on the normal 
staffing level of five. Later, when you close the extra station, use the Set Staff Levels 
command to switch to the rulebook based on a lower staffing level. 
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Note: Refer to “Configuring staff levels to change item routing” on page 62 for information 
on how to implement and use the Set Staff Levels command. 

The method you choose for routing items determines the configuration steps you are 
required to perform. Since routing by video group is the most common method chosen, and 
is a common migration path from the legacy Aloha KPS to Aloha Kitchen, the following 
instructions are specific to that method. If you need to route items using a method other 
than by video groups, contact your NCR representative for help.

Configuring a rule for a routing rulebook
Once you designate the appropriate video group for each routed item, you must create a 
routing rulebook. When you create a routing rulebook, configure the conditions of the rule 
using the Rules tab. When you configure multiple rules for a rulebook, the system routes 
items based on a ‘top-down’ approach. When an item satisfies a routing rule, the system 
does not continue to the next rule in the list. To prioritize a rule, click the Move Up and Move 
Down arrows. To delete an element from the routing rule, click Remove.

To configure a rule for a routing rulebook:

1. Select Maintenance > Kitchen Configuration > Routing Rulebook > Settings tab. 

2. Click New.

3. Under the ‘Settings’ group bar, accept the default number or click the ellipsis (...) 
button to select another number.

Figure 2 - 7  Routing Rulebook - Settings Tab

This example depicts a video group routing type that sends 
items to Grill Station 2. When you close the station, use 
another routing rulebook to exclude Grill Station 2 and send 
items to other stations. 

This example depicts an order mode routing type that sends 
the order to the Takeout Production Station. When you close 
the Takeout Production station, use another routing rulebook 
to exclude the Takeout Production Station and send orders to 
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4. Type a name for the routing rulebook.

5. Under the ‘Modifiers’ group bar, select Regular modifiers always follow the parent 
item. This is typically selected; otherwise, modifiers do not appear on the kitchen 
screen.

6. Click the Rules tab. 

7. Under the ‘Routing Rules’ group bar, click Add. The system creates a rule without a 
condition or routing specified. 

8. Select the Conditions tab to the right of the ‘Routing Rules’ group bar.

9. Under the ‘Routing Conditions’ group bar, select Video group from the Add drop-down 
list, and click OK. 

The routing condition appears under the ‘Routing Conditions’ group bar. If more 
information is needed for the selected routing condition, an additional group bar 
appears below. In this example, a ‘Video Group Condition’ group bar appears so you can 
specify the video group you want to use for routing.

10. Under the Video Group Condition group bar, click Add. The systems adds a blank row 
under the ‘Video Group Condition’ group bar. 

Figure 2 - 8  Routing Rulebook - Rules Tab

Note:  Use ‘Not’ when a condition is defined in a later rule.
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11. Select a video group from the drop-down list. 

12. If you want to include more than one video group, repeat step 10 and select another 
video group. 

If you want to add additional routing conditions to the rule, repeat steps 9 and 10 and 
select another routing condition type. 

When you finish configuring the routing conditions, the system updates the 
sentence-formatted rule under the ‘Routing Rules’ group bar.

13. Select the Routing tab to define the destination of the routing.

14. Click Add. The system adds a blank row to the ‘Route To Stations’ group bar.

Figure 3  Routing Rulebook - Rules Tab (Conditions Configured)

Routing Condition Examples

‘Not’ Option Cleared ‘Not’ Option Selected

Multiple Conditions Configured Multiple Video Groups Configured
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15. Select a kitchen station to which to route from the drop-down list.  

If you want to include additional kitchen stations to which to route items, for this rule, 
repeat steps 12 and 13 and select additional kitchen stations.

When you finish configuring the destination of the routing, the system updates the 
sentence-formatted rule under the Routing Rules group bar. 

Figure 2 - 1  Routing Rulebook - Rules Tab (Routing Completed)

Note:  In most cases, include the expo station in each routing rule along with a produc-
tion station, for items to appear on the expo kitchen screen.

Routing Examples

Single Station Routing Multiple Station Routing
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16. If you want to add more routing rules for the routing rulebook record, repeat steps 6 to 
13.  

17. Review that your rules are in the order that the system will apply them, from top to 
bottom. If necessary, select a rule and click Move up or Move down to organize them in 
‘top-down’ order.

18. Click Save.

19. Repeat this procedure for other routing rulebooks you want to configure.

20. Click Close in the Command panel to exit the Routing Rulebook function. 

Attaching the default routing rulebook to Kitchen Settings
If you created a rulebook that you want to use as your default, you must access Kitchen 
Settings and replace the system-generated rulebook defined in Kitchen Settings. If the 
rulebook is not your default rulebook, you use the Staff Levels function to change to a 
particular rulebook, on demand. 

Figure 2 - 2  Routing Rulebook With Multiple Rules

Reference:  You can use staff levels to change the routing rulebook on demand from the 
kitchen screen. Refer to See “Configuring staff levels to change item routing” on page 62.
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To attach the default routing rulebook to Kitchen Settings:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings. 

2. Under the ‘Defaults’ group bar, select the routing rulebook from the ‘Default routing 
rulebook’ drop-down list.

3. Click Save and to exit the Kitchen Settings function.
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Configuring metrics
Located at the top of each kitchen screen is a Metrics bar. Metrics help employees gauge 
their progress and facilitate their station. You configure the metrics that appear on the 
metrics bar using the Metrics function. There is no limit to the number of metrics you can 
add; however, once the Metrics bar is full for a particular kitchen screen, all additional 
metrics do not appear on the bar. The screen resolution you set for the kitchen device also 
factors in. In most cases, Aloha Kitchen can display a maximum of five metrics per kitchen 
screen before they exceed the metric area and cannot be viewed. 

What the Aloha Kitchen wizard does?

When you run the Aloha Kitchen wizard, the system automatically creates a ‘Current Time,’ 
‘Maximum Order Time,’ ‘Orders on Time Percentage,’ ‘Total Active Times,’ ‘Total Delayed 
Orders,’ and ‘Total Suspended Orders’ metric. The system attaches the first three of these 
metrics to each expo and production kitchen screen created by the wizard. The remaining 
metrics are unattached. 

Visit the Metrics function to do the following:

● Change the system-generated metric.

● Add new metrics to attach to a kitchen screen. 

Some examples of metrics you can configure include monitoring the number of active 
orders waiting to be cooked, or the percentage of orders prepared on time. Metrics usually 
calculate by day part; however, if you do not stipulate a day part, the statistics calculate for 
the entire day. Another important note is a metric begins calculating only at the time it is 
actually activated for a specific kitchen screen.

To calculate a metric for more than one kitchen screen, create a duplicate of the metric, and 
change the name and label to coordinate with each kitchen screen. For example, if you want 
to see the total active items on the kitchen screen for both the fry station and expo station, 
create two ‘Total active item’ metrics, one for each station. Change the name and label to 
match the corresponding kitchen screen. You can type ‘\n’ between words in the label to 
display up to three lines of descriptive text for the metric. (e.g. ‘Total\nItems\nExpo, 
‘Total\nItems\nFry). 

Some metrics only apply logically to certain kitchen screens. For example, item-level 
information does not appear on an expo kitchen screen, so a metric such as ‘Items on time 

Figure 2 - 3  Sample Metric Bar on a Kitchen Screen
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percentage’ would not be applicable. The following table depicts each available metric type 
and the recommended kitchen screen to which you might assign the metric.  

Recommended Metrics Per Kitchen Screen Type
Expo 
Screen

Production 
Order View 
Screen

All Other 
Production 
Screens

Average item time X

Average order time X X

Bin X X X

Current staff level X

Current time * X X X

Guest Manager wait quote X

Items on time percentage X

Maximum item time X

Maximum order time * X X

Orders on time percentage * X

Quote time X

Total active and bumped items X

Total active and bumped orders X X

Total active items X X

Total active orders * X X

Total delayed items * X

Total delayed orders X

Total over quote X

Total suspended orders * X

*Metrics automatically created by the Aloha Kitchen wizard. 

Reference:  Refer to the Aloha Kitchen Reference Guide for metric definitions.



 NCR Aloha Kitchen v19.11, Implementation Guide
Chapter 2: Customizing Aloha Kitchen

2-26

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

To configure a metric:

1. Select Maintenance > Kitchen Configuration > Metrics.

2. Click the New drop-down arrow, select a metric from the drop-down list, and click OK.

3. Under the ‘Settings’ group bar, type a name for the metric. This name appears in the 
drop-down lists of other functions within Aloha Kitchen.  

4. Type a label for the metric, such as ‘Total\nActive\nOrders,’ as you want to appear on 
the metric bar. (Use “\n” to denote a new line)

5. Click Save.

6. Repeat this procedure for other metrics needed for any of your kitchen screens. 

7. Click Close and exit the Metrics function.

Figure 2 - 4  Metric Function (Total Active Orders)
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Placing restrictions on metrics
For some metrics, you can limit counts and calculations of the metric, based on other 
attributes of the system. 

Adding metrics to a kitchen screen
After you configure a metric, you must add the metric to a kitchen screen. Use the Design 
tab in Kitchen Screen Maintenance to define which of the metrics you created appear on the 
kitchen screen. 

To add a metric to a kitchen screen:

1. Select Maintenance > Hardware > Kitchen Screen. 

2. Select a kitchen screen from the drop-down list that you want to add a metric. 

3. Select the Design tab. Additional tabs appear with the Metrics subtab as the active tab.

Restriction Behavior

Station When configured, the metric uses orders from the selected station only. For 
example, if you select the Grill station, and have a Grill station and a Chicken 
station, the metric only calculates items routed to the Grill station, and not the 
Chicken station. 

Order mode When configured, the metric uses orders from orders applied with the selected 
order mode only. For example, if you select ‘Dine In,’ and have a Dine In order 
mode and a To Go order mode, the metric only calculates orders applied with 
the Dine In order mode. 

Course When configured, the metric uses orders from this course only. For example, if 
you select Appetizer, and have an Appetizer course and an entrée course, the 
metric only calculates orders used for the Appetizer course. 

Current day part The metric calculates using the active day part in use, as configured in the POS. 
When a day part lapses, the metric resets and begins calculating using the next 
active day part. 
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4. Click Add. The system adds a blank row under the ‘Metrics’ group bar. 

5. Under ‘Metric,’ select a metric, such as ‘Current\nTime,’ from the drop-down list.

6. Select Highlight to have the metric appear in bold on the Metrics bar. 

7. Repeat steps 5 and 6 to add other metrics to the Metrics bar on the kitchen screen.

8. Click Save. 

9. Repeat this procedure for each kitchen screen you want to add a metric. 

10. Click Close to exit the Kitchen Screens function. 

Figure 2 - 5  Kitchen Screens - Design Tab - Metric Tab (Expo)

Reference:  Refer to the “Recommended Metrics Per Kitchen Screen Type” on 
page 2-25 table to determine the common metrics to add to the applicable screen 
type.

Click Add to add a 
metric.

Click Remove to 
remove a selected 
metric you added. 

Click Move up and 
Move down to 
arrange the metrics 
left to right on the 
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Configuring item activation
Item activation, or when items appear on a kitchen screen depends on several options 
within your Aloha Kitchen configuration. Courses, cook times, modifiers, and delayed orders 
all play a role in when an item or order is activated and appears on Aloha Kitchen.

Course — A course determines the order in which items are delivered to a customer. All 
operations must have at least one course. Single course operations deliver all items on an 
order to a customer all at once. More complex operations have multiple courses to deliver 
items throughout a customer’s dining experience. See “Configuring full coursing” on 
page 30..

Item cook times — Specifies the number of minutes a menu item takes to cook. This 
allows Aloha Kitchen to stagger the activation of each item to allow your kitchen staff to fin-
ish all items on the order at the same time. This provides all customers on an order the abil-
ity to enjoy a freshly prepared dish. See “Adding cook times for items” on page 7.

Modifier adjustments — Standard and advanced modifier adjustments provide a way of 
increasing or decreasing the cook time of an item based on a temperature preference of the 
customer or the method of preparation. For example rare and fried items decrease the cook 
time of an item, where as, well done and baked items increase the cook time of an item. 
Advanced modifier adjustments tie a modifier to a specific item to provide a more granular 
way of adjusting item cook times. See “Adjusting an item cook time based on a modifier” on 
page 8 and “Overriding an item cook time using an item/modifier pairing” on page 10

Cook time overrides — Cook time overrides allow you to increase or decrease the cook 
time of an item, a standard modifier adjustment, or an advanced modifier adjustment 
during unusual business periods. This may be due to high volume business, or and increase 
or decrease in production capacity due to equipment or staffing. See “Overriding item cook 
times” on page 11.

Delayed orders — Aloha Takeout and Aloha Online support the ability to delay an order for 
same day or another day in the future. Aloha Kitchen uses the quote time of an order as the 
target time and delays activation of items within an order, until the required time. 
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Configuring full coursing
Course ordering refers to a sequence of food deliveries to the table to complete a 
multi-course meal experience. You can configure course ordering in Aloha Kitchen to 
activate items based on a course. Coursing items are divided into individual courses which 
you can fire automatically or manually, to time the dining experience. You can also limit 
coursing to specific order modes or a kitchen station.

What the Aloha Kitchen wizard does?

When you run the Aloha Kitchen wizard, the system automatically creates a Default Course 
record, and also creates a record for each course you defined in the wizard, if any. The 
system attaches the default course in the ‘Default course’ drop-down list in Kitchen Settings. 
If you opted to use full coursing, the system uses the first defined course from the wizard, as 
the default course in Kitchen Settings. 

Visit the Courses function to do the following: 

● Adjust the system-generated default course. This is generally not necessary since the 
default course is used only as a placeholder. 

● Adjust the system-generated courses defined in the wizard, if configured. If you ran the 
wizard without adding any courses, and now want to configure coursing, you must 
follow the procedures in this section. 

● Create another course. 

Note:  The courses configured in Aloha Kitchen are not tied to the course ordering feature 
configured in the POS.
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Configuring a course
You must configure each course you support, such as appetizers, salads, entrées, cheese 
plates, desserts, and more. The ID numbering of courses is important, as the system uses 
this order to send orders to the kitchen. For example, if ‘Appetizer’ is your first course of the 
meal, the course ID must be lower than any subsequent course. For this reason, we 
recommend you number your courses in increments of 5, such as course ID 5 for 
appetizers, course ID 10 for entrées, and so on. This ensures you have room for future 
course expansion and to avoid the need for extensive changes to your database. 

   

Table 1: Course Timing Examples

Course ID Name
Duration in 
minutes

Course Target 
Time

5 Appetizer 12 00:00

10 Salad/Soup 5 12:00

15 Entrée 15 17:00

20 Dessert 0 32:00

Note:  The system sets the target time for the first course based on a course’s longest cook 
time item, not the duration. The longest cook time item on the first course releases imme-
diately. Unless ‘Activate relative to first item actual start time’ is enabled, all other first 
course items are activated based on their individual cook times relative to this target time. 
The system activates subsequent course items based a target time for that course. With 
the exception of the first course (defined above), the target time of a course is the sum of 
the ‘Duration in minutes’ for all prior courses.
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To configure a course:

1. Select Maintenance > Kitchen Configuration > Course > Course tab.

2. Click New. 

3. Type a name for the course.

4. Under the ‘Settings’ group bar, configure the options, as needed:

a. Type the number of minutes in Duration in minutes. See “Course Timing Examples” 
on page 2-31. 

b. Select Use countdown.

Note:  Define the ‘Duration in minutes’ of the first course based on the longest cook time 
item in the category, plus time to allow a customer to finish this course. For example, if 
wings take eight minutes to prepare, the wings activate immediately. Based on a first 
(appetizer) course ‘Duration in minutes’ of 12 minutes, this allows a table to enjoy a wing 
appetizer for four minutes before the second (salad/soup) course arrives.

Note:  Define the ‘Duration in minutes’ for subsequent courses to set the target time 
based on the service standards for your operation. In the table above, the target time for 
when the entrée course is prepared is 17 minutes, based on a 12 minute appetizer course, 
plus a five minute salad/soup course.

Figure 2 - 6  Course - Course Tab
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c. Select Use countdown alerts.

d. Type ‘120’ in First alert seconds.

e. Type ‘0’ in Second alert seconds.

5. Click Save.

6. Repeat this procedure for each course in your operations.

7. Click Close and exit the Course function.

Note:  Courses are activated in numerical order. Number the course IDs appropriately.
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Configuring categories for coursing
You must configure a category that contains the items for each course.

To configure a category for a course:

1. Select Maintenance > Menu > Categories.

2. Click the New drop-down arrow, select a category type, and click OK.

3. Type a name for the category, such as ‘Appetizer course.’

4. Select the Items tab.

5. Select items in the ‘Available’ list box and click the right arrow to move the items to the 
‘Included’ list box.

6. Repeat this procedure to create a category for the Entrée course.

7. Click Save and exit the Categories function.

To define the appetizer and entrée course in Kitchen Settings:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings > Kitchen tab.

2. Under the ‘Items’ group bar, select the appetizer category from the ‘Appetizer category’ 
drop-down list.

3. Select the entrée category from the ‘Entree category’ drop-down list.

4. Click Save.

Overriding a course by order mode
You can override a course by order mode. This is typically used for a takeout course. If you 
are using this feature, you should select ‘Order mode override supersedes modifier 
override’ on the Course tab. You should also clear ‘Enable kitchen chit printing’ in 
Maintenance > Kitchen Configuration > Kitchen Settings.

To override a course by order mode:

1. Select Maintenance > Kitchen Configuration > Course.

2. Select a Course from the ‘Course’ drop-down list. 

Note:  Although you could use order modes for coursing, we recommend using categories 
for optimal flexibility.
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3. Select the Order Mode Overrides tab.  

4. Select the order mode from the ‘Available’ list box and click the right arrow to move the 
order mode to the ‘Included’ list box.

5. Click Save.

6. Repeat this procedure for other courses.

7. Click Close and exit the Courses function. 

Overriding a course by modifier
You can override the coursing of an item using a modifier. For example, a customer may 
want to order an appetizer as an entree. You can accommodate the request of a customer 
by configuring an appetizer with an ‘As Entree’ modifier. You can also configure your system 
so that you can order entree items as appetizers by attaching an ‘As Entree’ modifier to an 
appetizer. To configure your system to accommodate the wishes of a customer, it is 
necessary to create an ‘As Entree’ and ‘As App’ item, attach the items to a modifier group, 
and define the items as course overrides.

To create a course override modifier:

1. Select Maintenance > Menu > Items.

2. Create an item, such as ‘As Entrée.’

3. Complete the remaining item maintenance options, as normal.

Figure 2 - 7  Course - Order Mode Overrides Tab
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4. Click Save.

5. Repeat this procedure to create an ‘As App’ item.

To attach the course override item to a modifier:

1. Select Maintenance > Menu > Modifier Groups.

2. Select the modifier group for an appetizer item from the ‘Modifier Groups’ drop-down 
list.

3. Select the Layout tab.

4. Select an available button on the layout screen.

5. Under the ‘Modifier item’ group bar, select the item from the drop-down list. In this 
example, use either ‘As Entree’ or ‘As App.’

6. Click Save.

7. Repeat this procedure for any other modifier groups that require a course override 
item.

To define the course override items in Kitchen Settings.

1. Select the Kitchen icon on the Product panel.

2. Select Maintenance > Kitchen Configuration > Kitchen Settings > Kitchen tab.

3. Under the ‘Items’ group bar, select ‘As App’ from the ‘As-appetizer item modifier’ 
drop-down list.

4. Select ‘As Entrée’ from the ‘As-entree item modifier’ drop-down list.

5. Click Save.
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Limiting courses by a kitchen station
You can limit a course by a kitchen station. This is typically used if you have two expo 
stations and you want a course to display on one station, and not the other. For example, 
Expo Station A would handle appetizers and Expo Station B would handle entrées.

To limit courses by a kitchen station:

1. Select Maintenance > Hardware > Kitchen Station.

2. Select a kitchen station from the ‘Kitchen Station’ drop-down list. 

3. Select the Limit To Courses tab.  

4. Select a course from the ‘Available’ list box and click the right arrow to move the course 
to the ‘Included’ list box. 

5. Click Save.

6. Repeat this procedure for other kitchen screens for which you want to limit coursing.

7. Click Close and exit the Courses function.

Figure 2 - 8  Kitchen Station - Limit to Courses Tab
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Suspending a course automatically by table
You can automatically suspend a course by table number. Use this feature for a table, or 
sets of tables, that you want to fire individual courses manually. Use this if your operation 
has both fine dining and casual dining service.

SCENARIO: A server rings in all items for all meal courses. The appetizer course is fired. When the
table is ready, the server informs the kitchen to fire the entrée course. A kitchen employee touches
‘Fire’ to activate items on the entrée course. Items on the entrée course activate based on your con-
figuration.

To suspend a course automatically by table:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings > Auto Suspend 
Course By Table tab. 

2. Under the ‘Auto suspend course’ group bar, select Auto suspend course by table. The 
system adds the ‘Auto suspend course category’ group bar.

3. Select a table from the ‘Available’ list box and click the right arrow to move the table to 
the ‘Included’ list box. 

4. Click Save.

5. Repeat this procedure for each table you want to suspend a course.

6. Click Close and exit the Kitchen Settings function.

Figure 2 - 9  Kitchen Settings - Auto Suspend Course By Table Tab
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Automating Aloha Kitchen
You can automate functions in Aloha Kitchen so you do not have to perform the function 
manually. Most of the options are in the Kitchen Station and Kitchen Settings functions. 
These include starting, preparing, and bumping items automatically. You can automate the 
starting of items by kitchen station. 

To automate the starting of items by kitchen station:

1. Select Maintenance > Hardware > Kitchen Station.

2. Select a station from the ‘Kitchen Station’ drop-down list.

3. Under the ‘Items’ group bar, select Auto-start all items to automatically start all items 
that are routed to this station. Use this option if you are using a Production Cooking Only 
kitchen screen type and there is not a corresponding Production Start Only kitchen 
screen.

4. Under the ‘Orders’ group bar, select Auto-start production order view cell to 
automatically start all items on an order when an order is activated. This feature only 
affects a ‘Production Order view’ kitchen screen. 

5. Click Save. 

6. Repeat this procedure for other kitchen stations, as needed.

7. Click Close and exit the Kitchen Stations function.

To automate the preparing of items:

You can automatically prepare items by Kitchen Station. Use the following procedure when 
there is not a ‘Production cooking only’ station to bump prepared items.

1. Select Maintenance > Hardware > Kitchen Stations.

2. Select a station from the drop-down list.

3. Under the ‘Items’ group bar, select Auto-prepare all items to automatically prepare all 
items that are routed to this station.

4. Click Save.

Note:  You must be careful when automatically starting an item. When configured, all 
items routed to the station automatically start and are not subject to any timing you have 
for the items. 

Note:  You must be careful when automatically preparing an item. When configured, all 
items routed to the station automatically progresses to a prepared state and are not sub-
ject to any timing you have for the item.
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5. Repeat this procedure for other kitchen stations, as needed.

6. Click Close and exit the Kitchen Stations function.

To automatically bump items from other stations:

You can configure a station to bump the items within an order from all other production 
stations. In Kitchen Settings, you can define a threshold of minutes before the system 
bumps an item from all kitchen screens.

1. Select Maintenance > Hardware > Kitchen Stations.

2. Select a station from the Kitchen Station drop-down list.

3. Under the ‘Settings’ group bar, select Master bump to specify whether items and orders 
that are bumped from this station are automatically activated, started, and bumped 
from other production stations defined on the Master Bump Stations tab.

4. Select the Master Bump Stations tab, select stations in the ‘Available’ list box, and click 
the right arrow to move them to the ‘Included’ list box.

5. Select Master bump all stations to specify whether a bump on the selected station 
items and orders can activate, start, and bump from all other production stations. This 
option does not require stations are defined on the Master Bump Stations tab.

6. Click Save in the Command panel.

7. Repeat this procedure for other kitchen stations, as needed.

8. Click Close in the Command panel to exit the Kitchen Stations function.

To automatically bump stale orders:

Aloha Kitchen allows you to configure the number of minutes when an order is considered 
stale and should no longer appear on kitchen screens, even through it has not been 
manually bumped by an employee.

1. Select Maintenance > Kitchen Configuration > Kitchen Settings > Items group bar.

2. Type the number of minutes, from 0-9999, in Auto bump minutes, before the system 
automatically bumps an order from all kitchen stations, whether the order is prepared 
or not.

3. Click Close in the Command panel to exit the Kitchen Settings function.

To automate the printing in Aloha Kitchen: 

You can automatically print a chit in Aloha Kitchen, by kitchen station, when an order 
reaches a certain state.
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1. Select Maintenance > Hardware > Kitchen Station.

2. Select a station from the Kitchen Station drop-down list.

3. Under the ‘Printing’ group bar, select an auto-print method:

○ Auto-print when bumped automatically prints a chit to the local printer when you 
bump an order from this station.

○ Auto-print when prepared automatically prints a chit to the local printer when an 
item is prepared.

○ Auto-print on first item prepared automatically prints a chit to the local printer 
when the first item of an order is prepared to allow employees to organize for 
subsequent items as they are prepared.

○ Auto-print expo chit on order displayed automatically prints an expo chit to the 
printer attached to the kitchen station when an order appears on this screen. 

○ Auto-print expo chit on order prepared automatically prints an expo chit to the 
printer attached to the kitchen station when an order is bumped from the 
production station. 

4. Click Save.

5. Repeat this procedure for other kitchen stations, as needed.

6. Click Close and exit the Kitchen Stations function.
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Configuring zoning
The use of zones in the restaurant industry is a way to control in which prep area you 
allocate items to help with the coordination of orders. Often times, these zoning areas are 
marked off to assist the expediter in organizing and quickly plating orders on trays. In a 
quick service environment, a ‘burger shoot’ would be an example of a zone. When activated, 
the system assigns each order to a zone, which appears in the cell on the kitchen screen. 
The zone element appears on the item cell on a kitchen screen; however, if you are using a 
custom header or footer, you must add the zone element to the custom header.  

You enable zoning in Kitchen Settings for the whole kitchen to use; however, it can be 
overridden by a zone group configuration. 

Figure 2 - 10  Zoning Illustration

Figure 2 - 11  Quick Service Burger Shoot

1 2 3 4 5
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To enable the default zoning:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings.  

2. Under the ‘Orders’ group bar, select Enable Zoning to activate the zoning feature.

3. Type the number of zones you have in your kitchen. For example, if your prep area has 
five zones, type 5. After the fifth order, the system starts the numbering over. Zone 
numbers do not display on bins.

4. Select Show zone icon to display the default ‘zone’ image on top of the zone number. If 
you want to replace the default zone icon, you must name the file Zone.xxx where xxx is 
the supported media file format.

5. Type the text, such as ‘ZN,’ to display for the zone in ‘Zone text.’ 

6. Select Release zone on order close to make a zone spot available when you bump the order. 
For example, if you configure your zones as 1-4, and you bump the order from zone 2, then zone 2 
becomes available for the next zone assignment. 

7. Click Save exit the Kitchen Settings function. 

Figure 2 - 12  Kitchen Settings - Zoning Options

Tip:  A Zone icon image must be imported into the media files as an Aloha Kitchen type 
before it appears in the browse list.
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To create a zone group:

You can override the zoning defined in Kitchen Settings with individual zone groups. You can 
also configure a zone group to use for the default in Kitchen Settings. 

1. Select Maintenance > Kitchen Configuration > Zone Group. 

2. Click New.  

3. Type a name for the zone group.

4. Type the number of zones you want in the zone group. 

5. Select one of the following methods to determine the zone assignment method to use 
for this zone: 

○ Alpha-numeric cyclical assigns a zone number in sequential order, based on the 
value in ‘Number of zones.’ For example, if the number of zones is four, the sequence 
is 1, 2, 3, 4, 1, 2, 3, 4. This is equivalent to the global method defined in Kitchen 
Settings.

○ Cyclical Assigns a zone number and alphabetical letter in sequential order, based on 
the value in ‘Number of zones.’ For example, if the number of zones is four, the 
sequence is 1a to 1z, 2a to 2z, 3a to 3z, and 4a to 4z. 

○ First available assigns a zone number in sequential order, based on the value in 
‘Number of zones.’ When you bump an order, the system uses the first available 

Figure 2 - 13  Zone Group



 NCR Aloha Kitchen v19.11, Implementation Guide
Chapter 2: Customizing Aloha Kitchen

2-45

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

missing number. For example, if the number of zones is four and the sequence is 1, 
2, 3, 4, when you bump the order assigned to number 3, the system assigns the next 
order to zone number 3.

6. Type the zone text in ‘Override zone text’ to use for this zone to override the zone text 
defined in Kitchen Settings. 

7. Click Save. 

8. Repeat this procedure for each zone group you want to define. 

9. Click Close to exit the Zone Group function. 

To add the zone element to a custom header or footer:

If you want the zone to appear on the order cell, you must add the ‘Zone’ element to a 
header or footer in use. 

1. Select Maintenance > Kitchen Configuration > Header and Footer Layout.

2. Select a header or footer layout from the drop-down list.

3. Select the Design tab.

4. Click the Add drop-down list, select the Zone element, and then click OK.

5. Under ‘Line number,’ type the line number in which you want the zone element to 
display.

6. Under ‘Location,’ select the justification in which you want the zone element to display. 

7. Under ‘Style,’ select the style to use for the zone element. 

8. Click Save.

Figure 2 - 14  Zone Element on the Kitchen Chit
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9. Repeat this procedure for other header or footer layouts in which you want to add the 
zone element. 

10. Click Close to exit the Header and Footer Layout function. 
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Configuring bins
Aloha Kitchen can display bulk production item counts, such as fries. You can set up a bin to 
track individual items or you can track like items using the Quick Count tracking item 
feature, both of which are defined in the POS. For example, if you have fries set up as a 
single item, you would simply count fries at the item level. If you have multiple items for the 
same item, such as fries with no charge and fries with an associated price, or if fries are 
included with many items, such as ala carte and fries with a burger, then you need to use 
tracking items to form a relationship between those multiple item IDs.

A bin can either be defined to display a single count of items needing to be prepared or 
display a quantitative number. For a quantitative number, the first number is the total count 
of items ordered but not yet prepared, that are needed in the next n minutes. The second 
number is the remaining count of items ordered, but not yet prepared.

You can configure three types of bins: simple, production, and forecast. Once you configure 
your bins, you must assign the bin to a kitchen screen, either as a metric on the Metrics bar, 
or to a bin area as part of the kitchen screen itself. 

Configuring a simple bin
A simple bin displays on the metrics bar, or can be used in the bin area of a kitchen screen. 
Aloha Kitchen automatically updates the simple bin state from pending to cooking and 
require no interaction. 

Simple bins go through the following states: 

○ Pending — A bin item count appears with the defined ‘Pending label’ from when an 
item is ordered until the system calculates the item should be cooking. This alerts 
you to stage or prepare a bin item for cooking. 

○ Cooking — The system changes a simple bin from pending to cooking based on the 
course target time for an order and the ‘Cook time threshold in seconds’ value. A 

Reference:  Refer to the Bins Feature Focus Guide for more information on configuring 
and using bins. 

Figure 2 - 15  Simple Bin Example
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simple bin appears in the cooking state for the duration of the ‘Cook time threshold 
in seconds’ defined for each bin. At the completion of the ‘Cook time,’ the cooking bin 
count is removed from the cooking state and are considered prepared.

To configure a simple bin:

1. Select Maintenance > Kitchen Configuration > Bin.

2. Click the New drop-down arrow, select either Item or Tracking Item as the type, and 
click OK. 

3. Type a name for the bin that identifies it with the tracking item.  

4. Select an item from the drop-down list. If you selected ‘Item’ as the Item type, then the 
system displays an Item drop-down list. If you selected ‘Tracking item,’ then the system 
displays a Tracking item drop-down list.

5. Select Simple bin from the ‘Bin type’ drop-down list.

6. Type the number of seconds, from 0-99999 seconds, in ‘Cook time threshold in 
seconds’ to define the cook time for the bin.

7. Type the number of decimal points, from 0 to 3, from the ‘Precision’ option to display 
for the bin. For example, select 2 is you want to the count to display as 0.00.

8. Click Save. 

9. Repeat this procedure for each simple bin you want to configure. 

Figure 2 - 16  Bins (Simple)
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10. Click Close to exit the Bin function. 

Add a simple bin to the metric bar
You can add a simple bin to the Metrics bar of a kitchen screen. Production bins are not 
supported on the Metrics bar. You must first configure a metric for the bin, then attach the 
bin to the kitchen screen. 

To configure a metric for a simple bin: 

1. Select Maintenance > Kitchen Configuration > Metrics > Metric tab.

2. Click the New drop-down arrow, select Bin, and click OK. 

3. Type a name for the metric that identifies it with the bin item. In most cases this should 
match the bin name.

4. Select the bin from the ‘Bin’ drop-down list. Only simple bins that are not already 
assigned to the bin area of a kitchen screen appear for selection.

5. Click Save.

6. Repeat this procedure for other bins you want to appear on the metrics bar.

7. Click Close to exit the Metrics function. 

To attach a bin metric to appear on the Metrics bar:

1. Select Maintenance > Hardware > Kitchen Screen.

2. Select a kitchen screen from the ‘Kitchen Screen’ drop-down list.

3. Select the Design tab.

4. Select the Metrics subtab.

5. Click Add. The system adds a blank row under the ‘Metrics’ group bar.

6. Under ‘Metric,’ select a bin you configured as a metric from the ‘Metric’ drop-down list. 

7. Repeat steps 5 and 6 to add other metrics to the Metrics bar.

8. Click Save.

9. Repeat this procedure if you have other kitchen screens to which you want to attach a 
bin metric. 

10. Click Close to exit the Kitchen Screens function.

Figure 2 - 17  Simple Bin Added to the Metric Bar
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Configuring a production bin
A production bin offers quantitative measurements for items and require interaction from 
the production employee in the same way as you start items using a production screen. 
These bins affect individual item status and give more detailed information than a simple 
bin. 

Production bins go through the following states: 

1. Pending — A bin item count appears with the defined ‘Pending label’ for the duration of 
the ‘Bin pending threshold.’ This alerts production employees to stage or prepare a bin 
item for cooking.

2. Start — A bin item count appears in the start bin area to alert a production employee to 
start cooking the indicated number of bin items. The start number includes any bin 
items within the ‘Cook time threshold’ plus any bin items within the defined ‘Combine 
time.’ An alert appears if a production employee has not started a bin within the 
‘Unstarted alert time’ seconds.

3. Cooking — A production employee selects the bin and touches ‘Start’ on a touch-screen 
or bump bar to inform the system the bin items, up to the defined ‘Maximum start 
quantity,’ are cooking. A bin item appears in the cooking state for the duration of the 
‘Cook time’ defined for each bin. At the completion of the ‘Cook time,’ the cooking bin 
count is removed from the cooking state and are considered prepared.

Figure 2 - 18  Production Bin Example
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Production bin timing 

● The target time of an item in a production bin is based on coursing rules, other items on 
the course, etc. In this timing example, we will use 8:00 minutes as the target time. 

● The system calculates when a bin item appears in the ‘Start’ portion based on the target 
time, less the ‘Cook time threshold’.

● The system calculates when a bin item appears in the ‘Pending’ portion based on the 
target time, less the ‘Cook time threshold,’ less the ‘Bin pending threshold.’

● If you select zero as the ‘Bin pending threshold,’ items show as pending immediately 
when a course is active.

To configure a production bin: 

1. Select Maintenance > Kitchen Configuration > Bins.

2. Click the New drop-down arrow, select either Item or Tracking Item as the type, and 
click OK. 

Figure 2 - 19  Production Bin Timing Diagram
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3. Type a name for the bin. 

4. Select an item from the drop-down list. If you selected ‘Item’ as the Item type, then the 
system displays an Item drop-down list. If you selected ‘Tracking item,’ then the system 
displays a Tracking item drop-down list.

5. Select Production bin from the ‘Bin’ drop-down list. The system adds additional fields to 
complete.

6. Type the number of seconds, from 0 - 99999, in ‘Cook time threshold in seconds’ to 
define the threshold to use as the cook time for the bin. The ‘Cook time threshold’ value 
should be greater than the ‘Cook time’ value to account for finishing other tasks, 
counting out the bin items, and placing them in kitchen equipment for cooking.

7. Type the text to display for the pending total for the bin cell, in ‘Pending label.’ The 
default text is “Pending.”

8. Type the text to display for the start total for the bin cell, in ‘Start label.’ The default 
text is “Start.”

9. Type the text to display for the cooking total for the bin cell, in ‘Cooking label.’ The 
default text is “Cooking.” 

10. Type the number of seconds, from 0 - 9999, in ‘Unstarted alert time,’ to alert a 
production employee when a bin has not been started.

11. Type the number of orders, from 0 - 9999, in ‘Maximum start quantity,’ that you can 
cook each time you touch the start action. This should equal the number of items you 
can fit and cook in a piece of kitchen equipment at one time. For example, if you can 
cook six orders of fries in a a fry basket at once, type ‘6’ in ‘Maximum start quantity.’

Figure 2 - 20  Bin (Production)
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12. Type the number of seconds, from 0 - 9999, beyond the target time for which you want 
to include additional bin items in the start count in ‘Combine item time.’ This improves 
the efficiency of any station by cooking the maximum number of bin items currently 
needed or needed in the near future. We recommend you base this time on the 
post-cooking hold time for each bin item. For example, if fries hold their temperature for 
60 seconds after cooking, set the ‘Combine item time’ value to 60 

13. Type the cook time, from 0 - 9999 seconds, in ‘Cook time,’ to display the item in the 
cooking area before marking the item as prepared and having the item disappear from 
the bin.

14. Click Save. 

15. Repeat this procedure for any other production bin you want to configure.

16. Click Close to exit the Bin function.

Adding a simple or production bin to a bin area
You can add a simple or production bin to a bin area configured on a kitchen screen; 
however, it is most used for production bins. You must first enable the bin area to show on 
a kitchen screen, then attach the bin to the kitchen screen, using the Design tab. 

The illustration of the bin area at 30 percent of the right side of the kitchen screen and 
shows the behavior of both a simple bin and a production bin. 

Figure 2 - 21  Simple and Production Bin Illustration
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The bottom magnified cell, a simple bin, displays a simple visual count of pending and 
cooking items. A simple bin requires no interaction. The pending label indicates upcoming 
bin items to allow you to prepare the items for cooking. The simple bin changes the status 
to cooking based on the cook time of the bin item and the target time of the course. The 
simple bin automatically decreases the cooking count at the end of the cook time for each 
bin item.

The top and middle magnified cells, production bins, display three counts. The pending 
count indicates the number of bin items you need in the foreseeable future, including items 
that are delayed and not yet started. The production bin changes the status to start, based 
on the cook time of the bin item, the cook time threshold, the combine time, and the course 
target time. A production bin requires you to interact with the bin, using the bump bar or 
touch screen. Select the production bin and press ‘Start bin.’ The ‘Maximum start quantity’ of 
items appears as ‘Cooking’ each time you press start.

To add a simple or production bin to a bin area: 

1. Select Maintenance > Hardware > Kitchen Screen.

2. Select a kitchen screen from the ‘Kitchen Screen’ drop-down list.

3. Under the ‘Display options’ group bar, configure the following:

a. Select Show Bin to display the bin area on the kitchen screen.

b. Select the position of the screen from the ‘Bin position’ drop-down list to define 
where you want the bin area to display. 

c. Type the percentage of the screen to use for the bin area. 

d. Type the number of rows you want to display for the bin area.

e. Type the number of columns you want to display for the bin area.

4. Select the Design tab. 
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5. Select the Bins subtab. 

6. Click Add. The system adds a blank row under the ‘Bins’ group bar.

7. Select a bin from the ‘Bin’ drop-down list.

8. Repeat Steps 5 and 6 until you add each bin to the bin area of the kitchen screen.

9. Click Move up or Move down to organize your bins from top to bottom, left to right in 
the bin area.

10. Click Save.

Figure 2 - 22  Kitchen Screen - Design Tab - Bin Tab
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11. Repeat this procedure for other kitchen screens you want to display a bin area.

12. Click Close to exit the Kitchen Screens function. Once you configure the bin area, and 
add a bin, the bin area displays in the location you configured for the kitchen screen. 

Providing the ability to select a bin on a kitchen screen
If you are using a touch screen terminal, you need only to touch a bin from the bin area; 
however, if you using a bump bar, you must add the appropriate commands to your bump 
bar layout. Refer to “Configuring Bump Bars” on page 2-8 for more information on a bump 
bar layout. 

To provide the ability to select a bin on a kitchen screen:

1. Select Maintenance > Hardware > Bump bar Layout. 

2. Select a bump bar layout associated with a station that contains bins from the 
‘Bumpbar Layout’ drop-down list.

3. Select the Design tab.

4. Select a command box from the design and select StartBin1. 

5. Repeat Step 4 until you add the remaining StartBin commands, as needed.

6. Click Save. 

7. Repeat this procedure for other bump bar layouts associated with kitchen stations that 
contain bins.

8. Click Close to exit the Bumpbar Layout function.

Figure 2 - 23  How Bin Appear with Multiple Columns
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Configuring a forecast bin
A forecast bin displays and uses default quantities based on the ordering history of up to 
four weeks of previous day-of-businesses and allows you to take a more proactive approach 
to bins, rather than being reactive. 

When Aloha Kitchen calculates the bin quantities, you can override these numbers by 
setting a minimum for any given time interval. The system also provides a visible forecast 
bin drop adjustment tool to allow you to change the bin quantities, on demand. 

Forecast bins allow you to: 

● Populate bin quantities based on historical sales data, instead of the current sales from 
the FOH. 

● Define the text to appear on the label of each cooking stage of the bin. 

● Display the forecast report to gauge upcoming bin quantities and analyze waste data, by 
variance. 

● Establish minimum bin quantities for cases when the projected total might fall below the 
amount necessary to run the bin. 

Figure 2 - 24  Forecast Bin Illustration
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How forecast bins work
Forecast bins read the sales information inside GndItem.dbf from four weeks of 
sub-directories. If you have less than four weeks, the numbers may not calculate correctly. 
Each week is 25% of the total forecasted bin quantity. The totals always round down.  

In the example given, the forecast bin queries the historical item sales of ‘wings’ from the 
last four Fridays, and for the each given 15 minute time interval. During the interval of 12:00 
p.m. to 12:15, you are expected to need 45 wings for the kitchen station, 85 wings between 
12:15 p.m. to 12:30 p.m., and so on. When the time for each interval arrives, the system 
populates the bin with the calculated bin quantity. If the quantity does not match the 
current day’s business you can adjust the bin quantity using a tool called forecast bin drop 
adjustment bar. When the next interval arrives the bin quantity starts over. 

Figure 2 - 25  Bin Quantity Calculation Example

Reference:  Refer to the Forecast Bins Feature Focus Guide for information on configuring 
and using a forecast bin. 
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Configuring specific kitchen environments
In the Aloha Kitchen Getting Started guide, you set up a typical kitchen environment where 
the expeditor uses the ‘Expo’ kitchen station type with the ‘Expo order view’ kitchen screen 
type and the production employee uses the ‘Production’ kitchen station type with the 
‘Production start and cooking’ kitchen screen type. The following are a few examples of 
other kitchen configurations.

Quick Service
The configuration in the Getting Started section can easily accomplish a Quick Service 
environment. In most cases, Quick Service environments have a single course with all items 
activating as entered.

Suggested settings for a Quick Service environment

Maintenance > Kitchen Configuration > Kitchen Settings:

○ On the Kitchen tab, under the ‘Items’ group bar, select ‘Immediate’ as the ‘Routing 
method.’ This exposes ‘Modifiers one behind.’

○ Select ‘Modifiers one behind.’

Maintenance > Hardware > Kitchen Screen:

○ On the Screen tab, under the ‘Settings’ group bar, select ‘Production order view’ as 
the type.

Pizza establishment with a conveyor belt oven 

A pizza establishment has an area at the beginning of a make table (slapper station), and an 
ending area where the pizza enters the oven. Pizza size and sauce appears on the beginning 
station to start a pizza, and toppings for each pizza appears on the ending station. To 
accomplish this, use a terminal with a ‘Production start only’ kitchen screen at the slapper 

Figure 2 - 26  Pizza Establishment with Conveyor Belt Oven

Beginning Terminal

Production Start only kitchen screen.

Ending Terminal

Production cooking only kitchen screen 
+ kitchen station with “Start on these 
stations when started on this station.”)
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station, and use a terminal with a ‘Production cooking only’ kitchen screen at the end of the 
make table. For the ending terminal, match the kitchen screen with a kitchen station with 
the ‘Start on these stations when started on this station’ selected.

Suggested settings for a pizza environment

Maintenance > Kitchen Configuration > Kitchen Settings:

○ On the Kitchen tab, under the ‘Items’ group bar, select ‘Immediate’ as the ‘Routing 
method.’ This exposes ‘Modifiers one behind.’ 

○ Select ‘Modifiers one behind.’

○ Type the number of minutes equal to the oven time in ‘Auto bump minutes.’

Maintenance > Hardware > Kitchen Screen:

○ Under the ‘Settings’ group bar, select ‘Production start only’ as the type for the make 
table, and ‘Production close only’ for the screen at the end of the make table.

Casual dining
A casual Table Service establishment typically has multiple areas, where food is cooked, 
based on the kitchen equipment within an area. Item routing is designed for only items 
prepared within an area to appear on that area’s kitchen station. Typically a full order does 
not appear in these areas. A full order appears on ‘Production order view’ and ‘Expo order 
view’ kitchen screens. An expediter assembles prepared items from each production station 
into an order to tray and deliver to a table.

Suggested settings for a casual dining environment

Maintenance > Kitchen Configuration > Kitchen Settings:

○ On the Kitchen tab, under the ‘Items’ group bar, select ‘When finalized’ as the Routing 
method.

Maintenance > Hardware > Kitchen Screen:

○ Configure kitchen screen types of ‘Production start and cooking,’ ‘Production order 
view,’ and ‘Expo order view.’

Maintenance > Kitchen Configuration > Bin: 

○ Use bins for bulk items such as fries, wings, shrimp, and fish fillets.
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Maintenance > Kitchen Configuration > Course:

○ Define at least two courses for appetizer and entrées. Add additional courses for 
Aloha Takeout, dessert, etc., as needed.
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Configuring staff levels to change item routing 
Use the Staff Level function to switch to different routing rulebooks on the fly in the kitchen, 
when you use multiple routing rulebooks. You must create a staff level for each routing 
rulebook you created. To implement, you must create a staff level, attach a default staff 
level to your kitchen settings, and add a ‘Set Staff Level’ command button to a kitchen 
screen.

To configure staff levels:

Create a staff level for each routing rulebook you use. You must attach a routing rulebook to 
a staff level for it to appear for selection on the Set Staff Level screen.

1. Select Maintenance > Kitchen Configuration > Staff Level. 

2. Click New.

3. Type a name for the staff level.

4. Select the routing rulebook to use for this staff level from the ‘Routing rulebook’ 
drop-down list.

5. Click Save.

6. Repeat this procedure for other staff levels you want to create.

7. Click Close and exit the Staff Level function. 

To assign a default staff level in kitchen settings:

You must attach a default staff in kitchen settings. This staff level is in use at all times for the 
whole store until you select another. 

1. Select Maintenance > Kitchen Configuration > Kitchen Settings > Kitchen tab.

2. Under the ‘Defaults’ group bar, select the staff level from the ‘Default staff level’ 
drop-down list. 

3. Click Save.

4. Click Close and exit the Kitchen Settings function.

Figure 2 - 27  Staff Level Function



 NCR Aloha Kitchen v19.11, Implementation Guide
Chapter 2: Customizing Aloha Kitchen

2-63

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

To provide the ability to change a routing rulebook:

You can provide access to view task information for an item by either adding the Set Staff 
Level command to a bump bar layout or adding the Set Staff Level command to a touch 
screen terminal. 

To add a Set Staff Level command to a bump bar layout:

1. Select Maintenance > Hardware > Bumpbar Layout.

2. Select a bump bar layout from the ‘Bumpbar Layout’ drop-down list.

3. Select the Design tab.

4. Select a function button from the design and select Set Staff Level from the 
‘Command’ drop-down list. 

5. Click Save.

6. Repeat this procedure for other bump bar layouts you want to change a routing 
rulebook. 

7. Click Close and exit the Bumpbar Layout function. 

To add a Set Staff Level command to a kitchen screen:

1. Select Maintenance > Hardware > Kitchen Screen. 

2. Select a kitchen screen from the ‘Kitchen Screen’ drop-down list. 

3. Select the Design tab.

4. Select the Commands subtab.

5. Click Add. The system adds a blank row under the ‘Commands’ group bar.

6. Select Set Staff Level from the ‘Commands’ drop-down list.

7. Click Save.

8. Repeat this procedure for other kitchen screens you want to change a routing rulebook.

9. Click Close and exit the Kitchen Screen function. 
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To use staff levels to change item routing:

Once you create your staff levels and add the staff level commands, you can change a 
routing rulebook on demand. 

1. Select the Set Staff Level command, using either a touch screen or bump bar. The 
Select Staff Level screen appears with all routing rulebooks configured with a staff level 
attached. 

2. Select a routing rulebook.

3. Exit the Select Staff Level screen by either clicking OK with a touch screen terminal, or 
pressing the Set Staff Level command again from the bump bar. 

Figure 2 - 28  Select Staff Level Screen
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Configuring quote times for adjustments in Aloha Takeout 
In Aloha Takeout, you can select and adjust a quote time on the Metric bar. When integrated 
with Aloha Kitchen, you can adjust the timing of the quote time, based on the number of 
items in the cooking in the kitchen. 

Figure 2 - 29  Quote Times on Aloha TakeOut Screen

Quote times dis-
played in Aloha 
Takeout.
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To configure a quote time:

1. Select Maintenance > Kitchen Configuration > Quote Time > Table tab. 

2. Click New. 

3. Type a name for the quote time.

4. Click the Thresholds Table tab. 

Figure 2 - 30  Quote Time - Table Tab

Figure 2 - 31  Quote Time - Thresholds Table
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5. Click Add to add a new threshold level. The system adds a blank row under the 
‘Thresholds Table’ group bar.

6. Type the number of items for the threshold. 

7. Type the number of minutes to quote the guest based on the number of items cooking.

8. Click Save.

9. Repeat this procedure for each quote time table. 

10. Click Close and exit the Quote Time function.

To attach a default quote time to Kitchen Settings:

You must attach a default quote time in kitchen settings. This quote time is in effect at all 
times for the whole store until you change it.

1. Select Maintenance > Kitchen Configuration > Kitchen Settings > Kitchen tab. 

2. Under the ‘Defaults’ group bar, select the quote time from the ‘Default quote time table’ 
drop-down list. 

3. Click Save. 

4. Click Close and exit the Kitchen Settings function.

Configuring the rounding and override requirements for employees
For quote times, you can configure such things as the rounding method to use, as well as 
employee and manager overrides. These options apply to all defined quote times.

To configure the rounding and overrides for quote times for employees:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings > Kitchen tab.

2. Under the ‘Quote times’ group bar, configure the following:

a. Type the number of minutes, from ‘0’ to ‘60’ and in multiples of five, to use for 
rounding quote times.

b. Select either Nearest, Up, or Down as the rounding method.

3. Under ‘Employee Overrides’ group bar, configure the following:

a. Type the number of minutes that an employee can manually add to the quote time, 
from 0 to 60, in ‘Maximum minutes to add.’ 

b. Type the number of minutes that an employee can subtract from the quote time, 
from 0 to 60, in ‘Maximum minutes to subtract.’

4. Click Save and exit the Kitchen Settings function.
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To configure the rounding and overrides for quote times for managers:

1. Select Maintenance > Kitchen Configuration > Kitchen Settings > Kitchen tab > 
Quote Times group bar.

2. Under the ‘Manager Overrides’ group bar, configure the following:

a. Type the minimum number of minutes that a manager can quote for an order, 
from ‘0’ to ‘999,’ in ‘Minimum quote time in minutes.’

b. Type the maximum number of minutes that a manager can quote for an order, 
from ‘0’ to ‘999,’ in ‘Maximum quote time in minutes.’

c. Type the maximum number of minutes that a manager can add to a quote time, 
from ‘0’ to ‘60,’ in ‘Maximum minutes to add.’

d. Type the maximum number of minutes that a manager can subtract from a quote 
time, from ‘0’ to ‘60,’ in ‘Maximum minutes to subtract.’

e. Type the number of minutes, from ‘0’ to ‘999,’, that a manager can place on a quote 
time before the time expires. 

f. Type the maximum number of minutes, from ‘0’ to ‘999,’ that a manager can place 
on a quote time. 

g. Type a password, from ‘0’ to ‘40,’ that a manager can use to override a quote time. 

3. Click Save and exit the Kitchen Settings function.

Using Aloha Kitchen to adjust quote times
Once you configure the quote times in Aloha Kitchen, the rounding, and override 
restrictions, you can use Aloha Kitchen to adjust the quote times displayed in Aloha Takeout. 

Note:  Once a password is entered, only employees, such as a manager, who know this 
password may override quote times. The employee settings in the first procedure are dis-
regarded.
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To override a quote time with Aloha Kitchen:

1. Select the Quote command button from the Commands bar. If a password is 
configured, the Enter Password screen appears.  

2. Enter the password and select OK. The Adjust Manual Quote Time screen appears. 

Figure 2 - 32  Enter Password Screen

Figure 2 - 33  Adjust Manual Quote Time Screen
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3. If you want to use the calculated quote time, select ‘Use calculated quote time.’

4. If you want to manually adjust the quote time, select ‘Use manual quote time,’ then use 
the up and down arrows to adjust the quote time in the increments, as defined in 
Kitchen Settings. You must make the adjustments within the expiration window you 
defined in Kitchen Settings. 

5. Select OK.

To sort orders by quote time for a kitchen screen:

1. Select Maintenance > Hardware > Kitchen Screen.

2. Under the ‘Order display options’ group bar, select Sort orders by quote time to 
configure orders on this kitchen screen to sort by quote time.

3. Click Save in the Command panel.

4. Click Close in the Command panel to exit the Kitchen Screen function.
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Configuring other languages
Aloha Kitchen allows you to translate the screens into several languages. Aloha Kitchen 
translation includes both on screen labels and the item information from the POS. When 
configured, you can toggle between languages at any time using a command on the 
touchscreen or bump bar.

Aloha Kitchen uses three files to translate the screens:

● AlohaKitchen.en.txt - Aloha Kitchen creates the file during install in AlohaKitchen\Bin. 
AlohaKitchen.en.txt contains all the default English translation for the Aloha Kitchen 
hard-coded strings. Use this as the base file to create a language translation file.

● AlohaKitchen.xx.override.txt - Create and use this file to override the base translation 
file with regional or store specific translations of Aloha Kitchen hard-coded strings. 
Replace the “xx” with a language abbreviation to create an override file for any language. 
Typically, the override file contains only a few entries and does not translate the entire 
user interface.

● DataTranslation.xx.txt - Use this file to translate custom strings in Aloha Kitchen, such 
as bin, metric, and screen names. DataTranslation.xx.txt also allows you to translate POS 
information, such as items and modifiers. Create this file using ConfigureAlohaKPS.exe, 
locate in AlohaKitchen\Newdata, and edit using Notepad.exe. .

Aloha Kitchen Translation Steps at a Glance

1. Select Maintenance > Kitchen Configuration > Language and add a language.

2. Select AlohaKitchen.en.txt in AlohaKitchen\Bin, copy, and rename to AlohaKitchen.xx.txt, 
where xx is the abbreviation for the language defined in the language function.

3. Edit and translate the AlohaKitchen.xx.txt for your language, as needed.

4. Create a new text file in AlohaKitchen\Bin and save as AlohaKitchen.xx.override.txt.

5. Copy strings from AlohaKitchen.en.txt to the override file and translate, as necessary.

6. Using ConfigureAlohaKPS.exe to create DataTranslation.en.txt .

7. Select DataTranslation.en.txt in AlohaKitchen\Newdata, copy, and rename to 
DataTranslation.xx.txt, where xx is the abbreviation for the language defined in the language 
function.

8. Edit and translate DataTranslation.xx.txt.

9. Select Maintenance > Kitchen Settings > Other tab and add a language.

10.Add a toggle language command to a screen or bump bar layout.

11.Refresh the system.
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The following sections on configuration are additional instructions on configuring language 
translation in Aloha Kitchen.
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Making a language available in Aloha Kitchen
You must select which languages are available in your Aloha Kitchen system. This function 
also provides the abbreviation you use to name your translation files. Currently, the 
function is read-only and you cannot change or add additional languages. You must also 
assign the language to a kitchen setting.

To make a language available in Aloha Kitchen: 

1. Select Maintenance > Kitchen Configuration > Language. 

2. Click the New drop-down arrow, select a language, and click OK. Take note of the 
abbreviation for the predefined language, as you will use it to rename your language 
translation files. 

3. Click Close and exit the Languages function.

Creating your base translation file
Aloha Kitchen reads from AlohaKitchen.xx.txt to translate the hard-coded values within 
Aloha Kitchen when you select a language. 

To create your base translation file:

1. Select the AlohaKitchen.en.txt file in AlohaKitchen\Bin, and copy and rename it to 
AlohaKitchen.xx.txt, where xx is the abbreviation of the language you noted earlier. 
For example, if you wanted to change the base translation file to spanish, rename the file 
to ‘AlohaKitchen.es.txt.’

2. Select AlohaKitchen.xx.txt and open with Notepad.exe.

Figure 2 - 34  Language Function
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3. Locate each string within the file and translate the string between the second quotation 
marks. 

4. Save and close AlohaKitchen.xx.txt.

Creating a translation override file
If necessary, create a translation override file to replace store or regional specific 
hard-coded language.

To create a translation override file:

1. Launch Notepad.exe. 

2. Create a new file.

3. Select AlohaKitchen.en.txt in AlohaKitchen\Bin and open with Notepad.exe.

4. Arrange the two files side by side. 

5. Copy a heading from AlohaKitchen.en.txt to the new file.

Figure 2 - 35  AlohaKitchen.xx.txt Translation Example
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6. Copy a string to translate from AlohaKitchen.en.txt to the new file. 

7. Translate the copied string, as necessary. 

8. Click File > Save As... and save the file to AlohaKitchen\Bin as 
AlohaKitchen.xx.override.txt, where xx is the language abbreviation noted earlier.

Translating POS and other Aloha Kitchen text
You can use the DataTranslation.xx.txt file to translate POS and Aloha Kitchen information 
that is not hard-coded on the screens.

To translate POS and other Aloha Kitchen text:

1. Select AlohaKitchen\Bin and double-click ConfigureAlohaKPS.exe to launch.

2. Select Configure > Update Data Translation File.

3. Select AlohaKitchen\Newdata, copy DataTranslation.en.txt, and rename the file 
DataTranslation.xx.txt, where xx is the language abbreviation.

4. Right-click DataTranslation.xx.txt, select Open with, and select Notepad.

Figure 2 - 36  AlohaKitchen.en.override.txt Example
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5. Translate each entry into the selected language. 

6. Save and close DataTranslation.xx.txt.

Assigning a language in Kitchen Settings
Kitchen Settings allows you to select the available languages for a store. Only the languages 
you selected in Maintenance > Kitchen Configuration > Languages appear for selection.

Figure 2 - 37  DataTranslation.xx.txt Example
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To assign a language in Kitchen Settings:

1. Select Maintenance > Kitchen Settings > Other tab. 

2. Select a kitchen setting from the drop-down list.

3. Under the ‘Languages’ group bar, click Add. The system adds a blank row under the 
‘Languages’ group bar.

4. Select the language from the ‘Language’ drop-down list.

5. Repeat Steps 3 and 4 until you add all available languages.

6. Click Save and exit the Kitchen Settings function.

Providing the ability to change to a language on kitchen screens
You can provide access to change to a language by either adding the Select Language 
command to a bump bar layout or adding the Select Language command to a touch screen 
terminal. 

To add a Select Language command to a bump bar layout:

1. Select Maintenance > Hardware > Bumpbar Layout.

2. Select a bump bar layout from the ‘Bumpbar Layout’ drop-down list.

3. Select the Design tab.

4. Select a function button from the design and choose Select Language from the 
‘Command’ drop-down list.

5. Click Save.

6. Repeat this procedure for other bump bar layouts you want to change the language. 

7. Click Close and exit the Bumpbar Layout function. 

Figure 2 - 38  Kitchen Settings - Other Tab - Languages Group Bar
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To add a Select Language command to a kitchen screen:

1. Select Maintenance > Kitchen Configuration > Kitchen Screen. 

2. Select a kitchen screen from the ‘Kitchen Screen’ drop-down list. 

3. Select the Design tab.

4. Select the Commands subtab.

5. Click Add. The system adds a blank row under the ‘Commands’ group bar.

6. Select Set Language from the ‘Commands’ drop-down list.

7. Click Save.

8. Repeat this procedure for other kitchen screens you want to add the Set Language 
command.

9. Click Close and exit the Kitchen Screen function.
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Configuring task information for an item
Use the Task Info function to provide cooking or prep instructions for individual items. By 
using on-screen electronic recipes, this eliminates the need to create, print, and bind recipe 
books, which reduces unnecessary cost. Additionally, this safeguards against sensitive 
patented recipes leaving with an employee.

All configuration is performed inside the Task Info function and you do not need to access 
the Item function. You can also include a graphic, which must be added in the Media Files 
function first. You can also create headings by typing a colon in the ‘Name’ field. For 
example, to group items under an App heading, begin the name of each task info ‘App:’ such 
as ‘App:Buffalo Wings.’

To configure task information for an item:

1. Select Maintenance > Kitchen Configuration > Task Info. 

2. Click New. 

3. Type a name for the task information.

4. Select the item from the ‘Item’ drop-down list for which you want to add task 
information. 

Figure 2 - 39  Task Info - Task Info Tab
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5. Select the Steps tab. 

6. Click Add. The system adds a blank row under the ‘Steps’ group bar.

7. Under ‘Heading,’ type a heading to use for the step or procedure. 

8. Under ‘Text’, select the drop-down arrow and type the instructional text to display with 
the item.

9. Under ‘Image,’ select an image to associate with the item from the ‘Image’ drop-down 
list, if needed. 

Figure 2 - 40  Task Info - Steps Tab
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10. Select the Videos tab. 

11. Click Add. The system adds a blank line under the ‘Video’ group bar.

12. Under ‘Heading,’ type a heading to use for the video. 

13. Under ‘Video,’ select a video to associate with the item.

14. Under ‘Custom video file name,’ type the filename of the video. 

Figure 2 - 41  Task Info - Videos Tab
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15. Select the Preview tab to view the task info for the item. 

16. Click Save in the Command panel.

17. Repeat this procedure for other items you want to include task information.

18. Click Close in the Command panel to exit the Task Info function. 

Providing the ability to view task information for an item 
You can provide access to view task information for an item by either adding the Select Task 
Info command to a bump bar layout or adding the Select Task Info command to a touch 
screen terminal. 

To add a Select Task Info command to a bump bar layout:

1. Select Maintenance > Hardware > Bumpbar Layout.

2. Select a bump bar layout from the ‘Bumpbar Layout’ drop-down list. 

3. Select the Design tab.

4. Select an function button from the design and select Select Task Info from the 
‘Command’ drop-down list. 

5. Click Save in the Command panel.

6. Repeat this procedure for other bump bar layouts you want to view task information. 

7. Click Close in the Command panel and exit the Bumpbar Layout function. 

Figure 2 - 42  Task Info - Preview Tab
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To add a Select Task Info command to a kitchen screen for a touch screen terminal:

1. Select Maintenance > Kitchen Configuration > Kitchen Screen. 

2. Select a kitchen screen from the ‘Kitchen Screen’ drop-down list. 

3. Select the Design tab.

4. Select the Commands subtab.

5. Click Add. The system adds a blank row under the ‘Commands’ group bar.

6. Select Select Task Info from the ‘Commands’ drop-down list.

7. Click Save in the Command panel.

8. Repeat this procedure for other kitchen screens you want to view task information.

9. Click Close in the Command panel to exit the Kitchen Screen function. 

Viewing task information for an item
When you complete your task information for an item, you can access the information on 
the corresponding kitchen screen, by selecting the Info command at the bottom of the 
screen. You only need a Select Task Info command to view a list of all configured items. You 
can always view task information when you order the item and task information is 
configured for the item. 
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To view task information for an item:

1. Access the Select Task screen either by selecting the Info button from the Commands 
bar for a touch screen terminal or selecting the Select Task Info command from the 
bump bar. 

2. Select an item either by touching the item or by pressing the Up and Down buttons 
and the large buttons on the end of a bump bar. 

3. If you select a heading, an additional screen appears with a list of items from which to 
choose under that heading. In this example, a list of entrées appears when you selected 
entrées. 

Figure 2 - 43  Select Task Screen

Figure 2 - 44  Select Task Screen Headings

Configured head-
ings appear on the 
screen.
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4. Once you select an item, the task information for the item appears. 

5. Exit the screen either by selecting the Close button or by pressing the Select Task Info 
command again on the bump bar. 

Figure 2 - 45  Task Information Screen Example (Coconut Shrimp)
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Customizing the print layout for production chits 
Use the Print Designer function to customize the design of your chits. You must include the 
Items and Training type to every print layout design you create. If you include an element 
that you are not using, the system allows you add the element, but does not display any 
output on the chit or guest check. The system has a default kitchen chit layout that is 
equipped with all possible elements for a production chit. Use this default chit to copy and 
simply remove the elements you do not use. 

Once you finish the print layout for an Aloha Kitchen installation, you must also attach the 
layout to kitchen settings to use the layout design. Aloha Kitchen has several types of chits 
from which to choose. 

To customize the print layout for production chits: 

1. Select Maintenance > Kitchen Configuration > Kitchen Settings > Kitchen tab.

2. Under the ‘Chit Printing’ group bar, select a print layout from any of the following 
options: 

○ Bag chit layout

○ Kitchen chit layout

○ Item label layout

○ Item chit layout

3. Click Save.

4. Click Close to exit the Kitchen Settings function. 

Reference:  Refer to the Print Designer Feature Focus Guide for information on how to 
configure and use the Print Designer function. 
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Customizing your kitchen screens 
You can customize the graphical display and behavior of your kitchen screens. 
Customization methods include screen type, fixed cell, split screen, skin colors, and headers 
and footers. Use screen customization to enhance an employees interaction with a kitchen 
terminal within a specific area of an operation.

Defining kitchen screen types
Aloha Kitchen provides a number of different screens for your kitchen staff to assist them in 
the preparation and production of items.  

Production order view

The ‘Production order view’ kitchen screen type 
displays order information with a start and a 
cooking queue; however, you can hide the start 
section when you set the percentage to 0. This 
screen is always used at the production station. 
Click the New drop-down arrow, select 
Production order view, and click OK to enable this 
screen.

Production start only

The ‘Production start only’ kitchen screen type 
displays item information with a start queue only. 
Production employees can only start items. This 
screen is always used at the production station. 
Click the New drop-down arrow, select 
Production start only, and click OK to enable this 
screen.
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Production line item

The ‘Production line item’ kitchen screen type 
displays item information with a cooking section 
only. This screen is always used at the production 
station and is the least used screen type. Click the 
New drop-down arrow, select Production line 
item, and click OK to enable this screen.

Production cooking only

The ‘Production cooking only’ kitchen screen type 
displays item information with a cooking section 
only. Production employees can bump items only. 
This screen is always used at the production 
station. When you create a new kitchen screen, 
Click the New drop-down arrow, select 
Production cooking only, and click OK to enable 
this screen.
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Enabling fixed cell orientation
Aloha Kitchen has the ability to display the cells on a kitchen screen with a static width and 
length. Fixed cell orientation is only supported for Expo Order View and Production Order 
View kitchen screen types. 

To enable fixed cell orientation:

1. Select Maintenance > Hardware > Kitchen Screen.

2. Select a screen from the ‘Kitchen Screen’ drop-down list.

3. Under the ‘Display options’ group bar, configure the following:

a. Select Enable Fixed Cell.

b. Type the number of rows to display in ‘Number of rows.’

c. Type the number of rows to display in the Start area in ‘Start queue rows.’

d. Type the number of columns to display in ‘Number of columns.’ 

e. Type the number of columns to display in the Start area in ‘Start queue columns.’ 

4. Click Save in the Command panel.

5. Repeat this procedure for other kitchen screens you want to support fixed cell 
orientation. 

6. Click Close in the Command panel to exit the Kitchen Screens function. 

Figure 2 - 46  Fixed Cell Orientation
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To provide the ability to navigate with fixed cell orientation:

If you are using a touch screen terminal, you simply need to touch the cell for selection; 
however, if you are using a bump bar, you must configure a different set of bump bar layout 
commands to support navigation with fixed cell orientation. Use this bump bar layout in 
place of the one described in the Aloha Kitchen Getting Started Guide. 

1. Select Maintenance > Hardware > Bumpbar Layout. 

2. Select a bump bar layout from the ‘Bump bar layout’ drop-down list.

3. Click the Design tab. 

4. Click the left function box of the bump bar layout. 

5. Select a function button from the ‘Command’ drop-down list, such as ‘Start.’ The system 
automatically populates the ‘Text,’ ‘Button color,’ and ‘Text color’ for the button based on 
the function you selected, however, you can change these attributes, as needed.

6. Click the next function button to the right and select another command. 

Figure 2 - 47  Bump Bar Layout - Design Tab (Fixed Cell)
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7. Repeat Step 6 to configure the following commands, depending on if you are using 
Aloha Quick Service or Aloha Table Service. 

8. Click Save in the Command panel.

9. Repeat this procedure for other bump bar layouts for fixed cell orientation, if needed.

10. Click Close in the Command panel to exit the Bumpbar Layout function. 

Bump Bar Layout Commands for a production station (starting 
with the large box on the left and moving clockwise)

QS and TS

Bump Selected

Bump Cell 1 Selected

Bump Cell 2 Selected

Bump Cell 3 Selected

Bump Cell 4 Selected

All Day Selected

Display (Toggle Display) Selected

Item Cursor Up Selected

Print Selected

Item Cursor Down Selected

Info Selected

Select Staff Selected

Bump Cell 8 Selected

Bump Cell 7 Selected

Bump Cell 6 Selected

Bump Cell 5 Selected
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Enabling split screen orientation
You can enable split screens in Aloha Kitchen. This is typically used at the expo station for an 
overall view of the kitchen. 

To enable split screen orientation:

1. Select Maintenance > Hardware > Terminals.

2. Select an Aloha Kitchen terminal from the ‘Terminal’ drop-down list. 

3. Select the Kitchen tab. 

4. Under the ‘Primary Display’ group bar, configure the following: 

a. Select Enable split screen to allow the terminal to use a split screen. The system 
adds additional options.

b. Select Horizontal or Vertical from the Split screen orientation to determine if the 
split screens will be side-by-side or one on top of the other. 

c. Select a kitchen station from the ‘Bottom (right) station’ drop-down list.

d. Select a kitchen screen from the ‘Bottom (right) screen’ drop-down list. 

5. If you are using a secondary display, configure the following under the ‘Secondary 
display’ group bar:

Figure 2 - 48  Terminals - Kitchen Tab
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a. Select Enable split screen to allow the secondary display on the terminal to use a 
split screen. The system adds additional options.

b. Select Horizontal or Vertical from the Split screen orientation to determine if the 
split screens on the secondary display will be side-by-side or one on top of the other.

c. Select a kitchen station from the ‘Bottom (right) station’ drop-down list.

d. Select a kitchen screen from the ‘Bottom (right) screen’ drop-down list. 

6. Click Save in the Command panel.

7. Repeat this procedure for other terminals you want to configure split screen 
functionality.

8. Click Close in the Command panel to exit the Terminals function. 

To provide the ability to access individual split screens:

If you are using a touch screen terminal, you simply need to touch the individual screens for 
selection; however, if you are using a bump bar, you must configure additional bump bar 
layouts for each split screen. Refer to the Aloha Kitchen Getting Started Guide for more 
information on configuring a bump bar layout.

1. Select Maintenance > Hardware > Bumpbar Layout > Design tab.

2. Select a bump bar layout from the ‘Bumpbar Layout’ drop-down list. 

3. Select a function button from the bump bar layout.

4. Under the ‘Settings’ group bar, select Top (left) or Bottom (right) to specify which split 
screen on which the button will function. 

5. Repeat steps 3 and 4 to until you configure the split screen for each function of the 
bump bar layout.

6. Click Save in the Command panel.

7. Repeat this procedure for each bump bar layout for each split screen. 

8. Click Close in the Command panel to exit the Bumpbar Layout function. 
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Creating a customer order display 
A customer order display screen is available to use with both Aloha Quick Service© and 
Aloha Table Service©, but is used primarily in a quick service counter environment. The 
screen uses a dedicated customer-facing terminal that allows the guest to monitor the 
status of their order, by name or order number. You can connect a bump bar and printer, as 
you do with any other terminal; however, it is more common to have customer orders 
automatically remove from the screen without user intervention, after a certain amount of 
time. 

Some benefits for using a customer order display are: 

● Keeps the guest informed of the status of their order and deters them from 
congregating around the counter and asking about the status of their order. 

● Allows you to customize the background and cell colors of the screen. 

● Allows you to add graphics or scrolling media files to the screen for promotional needs 
or branding of the restaurant. 

Figure 2 - 49  Customer Order Display Screen

Reference:  Refer to the Customer Order Display Feature Focus Guide for complete infor-
mation on configuring and using a customer order display screen. 
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Customizing your kitchen skins
A skin refers to the look and feel of the user interface, such as backgrounds, title bars, 
buttons, and other graphical displays. Each kitchen screen supports a Light view and 
Super-gradient skin in the Kitchen Screens function; however, you can configure your own 
skin for purposes such as branding your screens to the colors of your restaurant, and more. 

To customize your kitchen skins:

1. Select Maintenance > Kitchen Configuration > Kitchen Skin.

2. Click the New drop-down arrow.

3. Type a name for the skin. 

4. Make the changes, as appropriate.

5. Click Save in the Command panel.

6. Repeat this procedure for other skins you want to create.

7. Click Close in the Command panel to exit the Kitchen Skin function.

Figure 2 - 50  Kitchen Skin Function



 NCR Aloha Kitchen v19.11, Implementation Guide
Chapter 2: Customizing Aloha Kitchen

2-96

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

Customizing the display of your order and item cCells
You can customize the attributes that display on your order and item cells. Some options 
allow you to add individual elements, or for full control of the display of your order and item 
cells, you can design a header footer layout. 

Configure the display for order cells
These are some of the things you can display on the order cell.      

Show Item Line Numbers

You can display the items within an order on the 
order cell. Select ‘Show item line numbers’ in 
Maintenance > Hardware > Kitchen Screens to enable 
this option.

Show Terminal Number

You can display the terminal number from where the 
order was ordered on the order cell. Select ‘Show 
term number’ in Maintenance > Hardware > Kitchen 
Screens to enable this option. 

Show Paid Indicator

You can display a dollar sign on the order cell to 
indicate the order has been paid. Select ‘Show paid 
indicator’ in Maintenance > Hardware > Kitchen 
Screens to enable this option. 
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Configuring the display for item cells
These are some of the things you can display on the item cell.   

Show Course Text

You can display the name of the present course on 
the order cell. Select ‘Show course text’ in 
Maintenance > Hardware > Kitchen Screens to 
enable this option. 

Collapsible Order

You can enable an item cell to expand and 
collapse on demand when you select the up or 
down arrow. 

1. In the Kitchen Screens function, select Enable 
collapsible order.

2. Select ‘Hide all items; or ‘Hide only items not 
yet prepared.’ 

3. Select or clear ‘Default to collapse.’

Show Order Name

You can show the tab name or the name you call 
the order on the item cell. Select ‘Show order 
name’ in Maintenance > Hardware > Kitchen 
Screens to enable this option. 

Show Timer Text

You can show the timer text on the item cell. 
Select ‘Show timer text’ in Maintenance > 
Hardware > Kitchen Screens to enable this 
option.
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Show Cell Number

You can show the number of cell as it relates to 
the order display at the present time the item cell. 
Select ‘Show cell number’ in Maintenance > 
Hardware > Kitchen Screens to enable this 
option.
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Configuring a custom header or footer layout for cells 
Use the Header Footer Layout function to customize the design of your headers and footers 
that displays for your item or order cells on a kitchen screen. If you include an element that 
you are not using, the system allows you add the element, but does not display any output 
on the cell.

The system has four default header and footer layouts that are equipped with all common 
elements for the respective layout. Use these default layouts to copy and simply add or 
remove the elements you do not use. The default header and footer layouts are: 

● 9996 Default Order Header

● 9997 Default Order Footer

● 9998 Default Item Header

● 9999 Default Item Footer

Once you create a layout, you must attach the order header or footer to an expo kitchen 
screen and the item header or footer to a production kitchen screen. 

Tip:  Many of the elements you can configure on a custom header or footer layout are 
dependent on the activation of other options in Kitchen Screen Maintenance. For example, 
if you add Order Mode to your header or footer layout, you must select ‘Show Order 
Mode;’ otherwise, the system does not display the order mode. 
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Configuring a header or footer layout
You must configure a layout for a header or footer to apply to an order or an item cell. 

To configure a header or footer layout: 

1. Select Maintenance > Kitchen Configuration > Header and Footer Layout.

2. Select one of the default designs from the ‘Header Footer Layout’ drop-down list. 

3. Click Copy on the right side of the screen to duplicate the selected header or footer. The 
Copy Options screen appears.

4. Accept the default number or click the ellipsis (...) button to select another number, 
and click OK.

5. Type a name for the header or footer design.

6. Select Order header, Order footer, Item header, or Item footer from the ‘Type’ 
drop-down list to indicate the area and the type of cell you are designing.

Figure 2 - 51  Header Footer Layout - Layout Tab
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7. Select the Design tab. 

8. Click the Add drop-down arrow, select an element, and click OK. 

9. Under ‘Line number,’ type the line number in which you want the element to appear on 
the cell. 

10. Under ‘Location,’ select Left, Center, or Right to indicate the justification of the element 
to appear on the cell. 

11. Under ‘Style,’ select Normal, Bigger, or Smaller to indicate the font size, in relation to 
the default font, for the element to appear on the cell. 

12. Click Save in the Command panel. 

13. Repeat this procedure for other header footer layout designs you want to create.

14. Click Close in the Command panel to exit the Header Footer Layout function. 

Figure 2 - 52  Header Footer Layout - Design Tab
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Attaching a header and footer layout to a kitchen screen
You must attach a header or footer to a kitchen screen. You can only add an order header or 
footer to an ‘Expo Order View’ or ‘Production Order View’ kitchen screen and you can only 
add an item header or footer to one of the production kitchen screens. 

To attach a header and footer layout to a kitchen screen:

1. Select Maintenance > Hardware > Kitchen Screen.

2. Select a kitchen screen from the ‘Kitchen Screen’ drop-down list. 

3. For an Expo Order View or Production Order View kitchen screen, select the 
following under the ‘Headers and footers’ group bar: 

a. Select an order header from the ‘Order header layout’ drop-down list.

b. Select an order footer from the ‘Order footer layout’ drop-down list.

4. For a Production kitchen screen, configure the following from the ‘Headers and 
footers’ group bar:

a. Select an item header from the ‘Item header layout’ drop-down list.
b. Select an item footer from the ‘Item footer layout’ drop-down list. 

5. Click Save in the Command panel.

6. Repeat this procedure for any other kitchen screen you want to use a custom header or 
footer layout. 

7. Click Close in the Command panel to exit the Kitchen Screens function. 
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Configuring load balancing
Load balancing is a way for kitchens to operate two or more identical stations, or groups of 
stations, during high volume times. Aloha Kitchen uses new configuration to route items 
between two or more stations depending on the item load on the stations, or decides to 
route groups of items on an order depending on the order load on kitchen stations.

Load balancing is associated with routing rulebooks. A load balancing scheme may be 
enabled by the default routing rulebook. An active load balancing scheme may be adjusted 
at any time by using the staffing level function on a kitchen station based on it’s associated 
routing rulebook.

Load balancing requires:

● Creating a load balancing scheme by order or by item.

○ Assigning the balancing percentage breakout to 2 or more groups. 

○ Assigning kitchen stations to each group. 

● Assign the load balancing scheme to a routing rulebook.

● Assigning the routing rulebook to a staff level.

There are two load balancing types. In this section, we will go through the steps to create 
basic load balancing using the two load balancing types. 

● Load balance by order — Performs load balancing by the number of open and delayed 
orders for a station.

● Load balance by item — Performs load balancing depending on the item balance 
method: All items (started, unstarted, and delayed), Unstarted items, or Cooking items.

Load balancing by order

SCENARIO: On Friday and Saturday nights you have an additional expeditor to manage, tray, and
assemble items coming out of the kitchen. You split the orders 50/50 on those nights, between the
two expo stations to delivery orders faster.

In this scenario, it is necessary to configure load balancing between two expo stations (QS 
Expo Station and QS 2nd Expo Station). First, it is necessary to create a load balance group 
with the load balance type, ‘by order.’ In this scenario, assign Group A 50% and Group B 
50%. The sum total of the group percentages must equal 100%. The group percentages 
enable the system to determine what group to route an order, depending on the volume of 
the particular station. Group percentages are usually based on the staffing and equipment 
at a station compared to another load balancing station.
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To use load balancing by order:

1. Select Maintenance > Kitchen Configuration > Load Balancing > Settings tab. 

2. Click New. 

3. Type a name for the Load Balancing record. 

4. Select By order from the ‘Load balance method’ drop-down list. 

5. Type a percentage to use for Group A, such as ‘50.’

6. Type a percentage to use for Group B, such as ‘50.’

7. Select the Details tab.

Figure 2 - 53  Load Balancing by Order - Settings Tab
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8. Click Add. The system adds a blank row under the ‘Rows’ group bar. 

9. Type a description for the row, such as ‘Expo Balance.’

10. Select the Group A subtab, if it is not already displayed. Note that each subtab indicates 
the percentage you configured on the Settings tab. 

11. Select a station, such as ‘QS Expo Station’ from the ‘Available’ list box and click the right 
arrow to move the station to the ‘Included’ list box.

12. Select the Group B tab.

13. Select a station, such as ‘QS 2nd Expo Station’ from the ‘Available’ list box and click the 
right arrow to move the station to the ‘Included’ list box. 

Figure 2 - 54  Load Balancing - Details Tab
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If you want to include another row, repeat Steps 8 to 14. In this example, only an Expo 
Balance row is used.

14. Click Save in the command panel.

15. Repeat this procedure for other load balancing records you want to create.

16. Click Close and exit the Load Balancing function.

Note:  You may add additional rows to a load balancing ID if the ‘Load balance method’ 
and ‘Group percentages’ are the same. For example, you could also balance orders 
50/50 for dual grill stations.
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Load balancing by item

SCENARIO: During lunch and dinner rush you open the back line with an additional grill. The grill
is smaller than the front line grill. You determine you can send 60% of grill items to the front line
grill and 40% of grill items to the back line grill to address the additional grill items during those
times. At the beginning of lunch and dinner, you select the staff level associated with the dual grill
load balancing during those times. After lunch and dinner, you select the default staff level to
return the routing to normal.

In this scenario, it is necessary to configure order load balancing between two grill stations 
(Grill and Grill Back Line). First, create a load balance group with the load balance type, ‘by 
item,’ then specify the ‘item balance method.’ In this scenario, assign Group A 60% and 
Group B 40%. The sum total of the group percentages must equal 100%. The group 
percentages enable the system to determine what group to route an order, depending on 
the volume of the particular station. Group percentages are usually based on the staffing 
and equipment at a station compared to another load balancing station.

To use load balancing by item:

1. Select Maintenance > Kitchen Configuration > Load Balancing > Settings tab. 

2. Click New. 

Figure 2 - 55  Load Balancing by Item - Settings Tab
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3. Type a name for the Load Balancing record. 

4. Select By item from the ‘Load balance method’ drop-down list. The system adds the 
item balance method option.

5. Select an Item balance method to determine when to send an item to one station 
verses another.

a. Select ‘Unstarted items’ to load balance based only on the number of unstarted 
items in a load balancing group. Aloha Kitchen distributes new items routed to a 
station based on the ratio of unstarted items. For example, if there are six unstarted 
items in group A, and three unstarted items in group B, the next item would go to 
group B, since it is less than 40 percent.

b. Select ‘Cooking items’ to load balance based only on the number of items currently 
cooking and bumped for each station in a load balancing group. Aloha Kitchen 
distributes new items to the group with the lowest ration to it’s percentage. For 
example, if there are three items cooking in group A, and four cooking items in group 
B, the next item would route to group A, since it is less than 60%.

c. Select ‘All items’ to load balance based on the number of unstarted, cooking, and 
bumped items in a load balancing group. For example, if group A has six unstarted 
items and three cooking items, and group B has three unstarted items and four 
cooking items, the next item would route to group A since it is less that 60%. 

6. Type a percentage to use for Group A, such as ‘60.’

7. Type a percentage to use for Group B, such as ‘40.’

Target 
%

Unstart
ed 
items

Cook-
ing 
items

Total 
items

Group A 60% 6 67% 3 43% 9 56%

Group B 40% 3 33% 4 57% 7 44%

Total 9 7 16
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8. Select the Details tab.

9. Click Add. The system adds a blank row under the ‘Rows’ group bar. 

10. Type a description for the row, such as ‘Grill Balance.’

Note:  When you select ‘Cooking items’ or ‘All items,’ as the item balance method, all 
items route to the new station when you change the routing level until the number of 
bumped items balances. For example, if you run lunch with only group A, then change 
the routing to include group B, group B receives all the items until the items bumped 
on group A through the day are reached on group B.

The ‘Unstarted items’ item balance method does not include bumped items in the load 
balancing calculation.

We recommend you select ‘Unstarted items’ if your business changes routing levels, as 
in this scenario.

Figure 2 - 56  Load Balancing - Details Tab
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11. Select the Group A tab, if it is not already displayed. Note that each group indicates the 
percentage you configured on the Settings tab. 

12. Select a station, such as ‘Grill’ from the ‘Available’ list box and click the right arrow to 
move the station to the ‘Included’ list box.

13. Select the Group B tab.

14. Select a station, such as ‘Grill Back Line’ from the ‘Available’ list box and click the right 
arrow to move the station to the ‘Included’ list box. 

If you want to include another row, repeat Steps 8 to 14. In this example, only an Expo 
Balance row is used.

15. Click Save in the command panel.

16. Repeat this procedure for other load balancing records you want to create.

17. Click Close and exit the Load Balancing function.

Adding load balancing to routing rules
It is necessary to add load balancing to routing rules. You can have one (default) routing 
rulebook if you plan on using load balancing all the time. But, as in the previous scenarios, 
where using load balancing only at specific times, it is necessary to create a different routing 
rulebook and staff level, one with regular routing and the other with load balancing.  

Note:  You may add additional rows to a load balancing ID if the ‘Load balance method’ 
and ‘Group percentages’ are the same; otherwise, create another load balancing grid. 
For example, you could also balance orders 60/40 for dual fry stations.

Figure 2 - 57  Routing Rulebook - Load Balancing - Expo
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To add load balancing to routing rules:

1. Select Maintenance > Kitchen Configuration > Routing Rulebook > Settings tab. 

2. Select the default routing rulebook from the ‘Routing Rulebook’ drop-down list.

3. Click Copy in the command panel on the right side of the screen to duplicate the default 
routing rulebook. This copies all the rules in the default routing rule book to a new 
rulebook.

4. Click OK. The system creates a new routing rulebook.

5. Accept the default number or click the ellipsis (...) to select another number.

6. Type a name for the load balancing routing rulebook.

7. Select the Rules tab.

8. Under the ‘Routing Rules,’ group bar, select a rule for which you want to apply load 
balancing.

9. Select the Load Balancing tab.

10. Select a Load Balancing rule from the ‘Grid’ drop-down list.

11. Click the Row drop-down list and select a row from the load balancing rule selected in 
the previous step. This row should align with the routing rule currently selected. For 
example, select the Expo grid and row when the Expo routing rule is selected.

Figure 2 - 58  Routing Rulebook - Load Balancing - Grill

Figure 2 - 59  Routing Rulebook - Settings Tab



 NCR Aloha Kitchen v19.11, Implementation Guide
Chapter 2: Customizing Aloha Kitchen

2-112

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

12. Repeat Steps 7 - 11 for additional routing and load balancing rules. Example, select the 
grill routing rule and apply the grill load balancing grid and row.

13. Click Save.

Activating load balancing
In order to activate load balancing, you will need to associated a load balancing rulebook 
with a staff level and manually select the staff level when business and staffing dictate. 
When the lunch or dinner rush is over and you close the load balancing stations, you will 
once again access staff levels and set a staff level to one not associated with load balancing. 
See “To use staff levels to change item routing:” on page 64.



 NCR Aloha Kitchen v19.11, Implementation Guide
Index

Index-i

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

Index

Numerics
16-Key ........................................................... 1-21 19-Key ........................................................... 1-21

A
Activate item at course completion .......... 2-13
Activate item at course start ...................... 2-13
Activate relative to first item actual start time .

2-14
Activation Schedule .................................... 2-12
Additional activation seconds .................... 2-14
Adjust Manual Quote Time screen ........... 2-69
Advanced modifier adjustments ............... 2-29
Alerts ....................................... Pref-vii, Pref-xviii
All Day ........................................................... 2-91
Aloha Kitchen service ................................. 1-29
Aloha Online ................................................ 2-29
Aloha Takeout .............. Pref-ix, 2-29, 2-65, 2-68

Always activate delayed items on same order 
together .................................................... 2-13

ATO ........................................................... Pref-ix
Automatic Bumping ...................................... 2-5
Automatically suspend a course by table 2-38
Auto-prepare all items ................................ 2-39
Auto-print chit when prepared .................. 1-25
Auto-print expo chit on order .................... 2-41
Auto-print when bumped ........................... 2-41
Auto-print when prepared ......................... 2-41
Auto-start ..................................................... 1-25
Auto-start all items ...................................... 2-39
Auto-start production order view cell ....... 2-39
Available ....................................................... 1-19

B
Bag chit layout ............................................. 2-86
Bigger .......................................................... 2-101
Bin ................................................................. 2-47

production ............................................. 2-47
simple .................................................... 2-47

Bottom (right) .............................................. 2-93
Bottom (right) screen .................................. 2-92
Bottom (right) station ................................. 2-92
Bump (selected) .......................................... 2-91
Bump Bar ................................................. Pref-xi
Bump bar .............................................. 1-5, 1-29

buttons .................................................. 1-20
Bump bar layout ............................... 2-77, 2-82

change routing rulebook ..................... 2-63
design tab .............................................. 1-21
fixed cell ................................................. 2-90
function ................................................. 2-91

Bump Cell 1 .................................................. 2-91
Bump Cell 2 .................................................. 2-91
Bump Cell 3 .................................................. 2-91
Bump Cell 4 .................................................. 2-91
Bump Cell 5 .................................................. 2-91

Bump Cell 6 .................................................. 2-91
Bump Cell 7 .................................................. 2-91
Bump Cell 8 .................................................. 2-91
Bump, master .............................................. 2-40
Button

all day ..................................................... 2-91
bottom (right) ........................................ 2-93
bump (selected) .................................... 2-91
bump cell 1 ............................................ 2-91
bump cell 2 ............................................ 2-91
bump cell 3 ............................................ 2-91
bump cell 4 ............................................ 2-91
bump cell 5 ............................................ 2-91
bump cell 6 ............................................ 2-91
bump cell 7 ............................................ 2-91
bump cell 8 ............................................ 2-91
display (toggle display) ......................... 2-91
info ......................................................... 2-91
item cursor down ................................. 2-91
item cursor up ...................................... 2-91
print ........................................................ 2-91
select staff ............................................. 2-91



 NCR Aloha Kitchen v19.11, Implementation Guide
Index

Index-ii

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

select task info ................... 2-82, 2-83, 2-85 top (left) ................................................. 2-93

C
Center ......................................................... 2-101
Change staff levels ...................................... 2-91
COM port ...................................................... 1-29
Command .................................................... 1-22
Conditions tab ............................................. 2-19
Configure, video group ............................... 1-17
Configure, video queue .............................. 1-18
Cook time overrides ................................... 2-29

Cook times ................................................... 2-29
Cooking ................................................. Pref-xviii
Course ................................................ 2-27, 2-30

first ......................................................... 2-32
subsequent ........................................... 2-32

Course numbering ...................................... 2-31
Courses ......................................................... 2-29
Customer Order Display ............................... 2-6

D
Default course ............................................... 2-5
Default Item Footer .................................... 2-99
Default Item Header ................................... 2-99
Default Order Footer .................................. 2-99
Default Order Header ................................. 2-99
Default quote time table .............................. 2-5
Default routing rulebook .................... 2-5, 2-22
Default staff level ........................................ 2-62

Default to collapse ...................................... 2-97
Delay routing ....................................... 2-5, 2-13
Delayed orders ............................................ 2-29
Design tab .................................................... 2-27

bump bar layout ................................... 1-21
Display (Toggle Display) .............................. 2-91
Down ............................................................. 2-67
Duration in minutes .................................... 2-31

E
Element

print designer ....................................... 2-86
Elements

header and footer ................................ 2-99
Employee can manually add to the quote time

2-67
Employee can subtract from the quote time ...

2-67
Enable collapsible order ............................. 2-97
Enable delay routing ................................... 2-13
Enable Fixed Cell ......................................... 2-89
Enable kitchen chit printing ....................... 2-34

Enable manual activation for delayed items ...
2-14

Enable manual activation for delayed orders ..
2-14

Enable split screen ...................................... 2-92
Enable touch ................................................ 1-32
Enable Zoning .............................................. 2-43
Event Schedule ............................................ 2-12
Expo .................................................... 1-24, 2-59

routing ................................................... 2-21
Expo order view .............. 1-26, 2-59, 2-60, 2-89

F
First course .................................................. 2-32
Fixed cell ....................................................... 2-89

Food quality ............................................ Pref-vii
Footer ........................................................... 2-99

H
Hardware

printers .................................................. 1-28
terminal ................................................. 1-29

Header .......................................................... 2-99
Header Footer Layout ............ 2-45, 2-99, 2-101

Hide all items ............................................... 2-97
Hide only items not yet prepared ............. 2-97
Horizontal ..................................................... 2-92



 NCR Aloha Kitchen v19.11, Implementation Guide
Index

Index-iii

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

I
Ignore prepared status for order sorting 1-27
Image ............................................................ 2-80
Immediate .................................................... 2-16
Included ........................................................ 1-19
Independent modifiers .............................. 1-25
Info ................................................................ 2-91
Instructional text ......................................... 2-80
Item activation ............................................. 2-29
Item cell ........................................................ 2-97

Item chit layout ............................................ 2-86
Item cook time overrides ........................... 2-11
Item cook times ................................. 2-11, 2-29
Item Cursor Down ....................................... 2-91
Item Cursor Up ............................................ 2-91
Item footer ................................................. 2-100
Item header ............................................... 2-100
Item label layout .......................................... 2-86
Item routing . 1-17, 1-18, 1-20, 2-17, 2-18, 2-62

J
Justification .................................................. 2-45

K
K1700 ....................................................... Pref-xii
KC3 ........................................................... Pref-xii
Kitchen chit layout ...................................... 2-86
Kitchen screen ............................ 1-5, 1-26, 1-29

design tab .............................................. 2-27

Kitchen Settings ............................................. 2-4
Kitchen skin .................................................. 2-95
Kitchen station 1-5, 1-24, 1-25, 1-29, 2-27, 2-39

routing rulebook ................................... 2-21
type ........................................................ 1-24

L
Language ................................................ Pref-viii
Left .............................................................. 2-101
Limit To Courses tab ................................... 2-37

Line number ................................................. 2-45
header and footer .............................. 2-101

M
Manager can add to a quote time ............ 2-68
Manager can place on a quote time ......... 2-68
Manager can place on a quote time before the 

time expires .............................................. 2-68
Manager can quote for an order .............. 2-68
Manager can subtract from a quote time 2-68
Master bump ..................................... 1-25, 2-40
Master bump all stations ........................... 2-40

Maximum activation time in minutes ....... 2-14
Maximum time to wait for first item in 

seconds ..................................................... 2-14
Metrics ....................................... 2-24, 2-26, 2-28
Minimum activation time in minutes ........ 2-14
Modifier adjustment, standard ................. 2-29
Modifier adjustments, advanced ............... 2-29
Modifiers ...................................................... 2-29

N
Nearest ......................................................... 2-67
Normal ....................................................... 2-101
Number of columns .................................... 2-89
Number of columns to display .................. 2-89
Number of items for the threshold .......... 2-67

Number of minutes to quote ..................... 2-67
Number of rows .......................................... 2-89
Number of rows to display in the Start area ...

2-89
Numbering

course .................................................... 2-31

O
One behind .................................................. 2-16
Order footer .................................. 2-100, 2-102

Order header ................................. 2-100, 2-102
Order mode ................................................. 2-27



 NCR Aloha Kitchen v19.11, Implementation Guide
Index

Index-iv

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

course .................................................... 2-34 Order mode overrides tab ......................... 2-35

P
Password ............................................ 2-68, 2-69
Pizza establishment .................................... 2-59
Port ............................................................... 1-29
Prepared ............................................... Pref-xviii
Preview ......................................................... 2-82
Print .............................................................. 2-91
Print Designer .............................................. 2-86

element ................................................. 2-86
Printers ............................................... 1-28, 1-29

COM port ............................................... 1-29
Printing ................................................. 2-5, 2-41
Production ................................. 1-24, 1-27, 2-59
Production bin ............................................. 2-47
Production cooking only ................... 2-60, 2-88
Production line item ................................... 2-88
Production order view ............. 2-60, 2-87, 2-89
Production start and cooking .......... 1-26, 2-59
Production start only ........................ 2-59, 2-87

Q
Quote time ................................................... 2-67

Aloha Takeout ....................................... 2-65
Quote Times ........................................... 2-5, 2-6

R
Redundancy ................................................. 1-29
Regular modifiers always follow the parent 

item ........................................................... 2-19
Remove, routing rule .................................. 2-18
Reports ................................................... Pref-viii
Right ............................................................ 2-101
Rounding quote times ................................ 2-67
Routing

immediate ............................................. 2-16

one behind ............................................ 2-16
when finalized ....................................... 2-16

Routing conditions ...................................... 2-20
Routing method ............................................. 2-5
Routing rulebook ...................... 2-17, 2-22, 2-62

hierarchy ................................................ 2-18
Routing tab ................................................... 2-20
Rules tab ............................................. 2-18, 2-19

S
Screen

adjust manual quote time ................... 2-69
split ......................................................... 2-92

Screen type
production cooking only ...................... 2-88
production line item ............................ 2-88
production order view ......................... 2-87
production start only ........................... 2-87

Select Language .......................................... 2-77
Select Staff ................................................... 2-91
Select Task Info ......................... 2-82, 2-83, 2-85
Service, Aloha Kitchen ................................ 1-29
Set Language ............................................... 2-78
Show cell number ....................................... 2-98
Show course text ......................................... 2-97
Show item line numbers ............................ 2-96
Show order mode ....................................... 1-26

Show order name .............................. 1-28, 2-97
Show paid indicator .................................... 2-96
Show parent item info with... ..................... 1-28
Show term number ..................................... 2-96
Show timer text ........................................... 2-97
Simple bin .................................................... 2-47
Skin ................................................................ 2-95
Smaller ........................................................ 2-101
Sort orders by quote time .......................... 2-70
Sort orders by target time .......................... 1-27
Speed of service ..................................... Pref-vii
Split screen ................................................... 2-92
Staff level ............................................ 2-17, 2-62

default .................................................... 2-62
Standard modifier adjustment .................. 2-29
Start queue percentage .............................. 1-27
Station ........................................................... 2-27



 NCR Aloha Kitchen v19.11, Implementation Guide
Index

Index-v

Confidential and proprietary information of NCR.
Unauthorised use, reproduction and/or distribution is strictly prohibited.

Style .............................................................. 2-45 Subsequent course ..................................... 2-32

T
Target time ................................................... 2-31
Task Info ....................................................... 2-79

image ..................................................... 2-80
video ...................................................... 2-81

Terminal ................................................ 1-5, 1-29
Thresholds Table ......................................... 2-66

Timers ............................................................. 2-5
Timing ................................................... Pref-xviii
Top (left) ....................................................... 2-93
Touch Screen ........................................... Pref-xi
Touch screen ................................................ 1-30

U
Uninitialized .......................................... Pref-xviii
Up .................................................................. 2-67
Use calculated quote time ......................... 2-70

Use default item time as defined in course 
configuration ............................................ 2-13

Use manual quote time .............................. 2-70
User Interface ................................................ 2-5

V
Vertical .......................................................... 2-92
Video ............................................................. 2-81

Video group ........................................ 1-17, 2-17
Video queue ................................................. 1-18

W
When finalized ............................................. 2-16

Z
Zero cook time items .................................... 2-5
Zone .............................................................. 2-45
Zoning .................................................... 2-5, 2-42



Confidential and proprietary information of NCR.
Unauthorized use, reproduction and/or distribution is strictly prohibited.

NCR Aloha Kitchen v19.11, Implementation Guide

NCR welcomes your feedback on this document. Your comments can be of great value in 
helping us improve our information products. Please contact us using the following email 
address: Hospitality.HSR@ncr.com

mailto: Hospitality.HSR@ncr.com

	NCR Aloha Kitchen v19.11
	Contents
	Preface
	Benefits
	Key features
	Integrating Aloha Kitchen with other Aloha products
	Expediter employee vs production employee
	Touch screen vs. bump bar
	Aloha Kitchen hardware solutions
	Aloha Kitchen screen components
	Aloha Kitchen order sequence
	Is this guide for you?
	How this guide is organized
	Third-party software prerequisites

	Chapter 1: Getting started
	Preparing the system for Aloha Kitchen
	Making Aloha Kitchen active
	Establishing communication between Aloha POS and Aloha Kitchen
	Providing access to Aloha Kitchen functions

	Using the Aloha Kitchen configuration wizard
	Identifying your kitchen areas
	Running the Aloha Kitchen configuration wizard
	Assigning video groups to items for routing

	Manually configuring Aloha Kitchen hardware
	Configuring a bump bar layout
	Configuring kitchen stations
	Configuring kitchen screens
	Configuring printers (optional)
	Configuring terminals

	Refreshing data
	Configuring an Aloha Kitchen terminal environment
	Manually configuring an Aloha Kitchen terminal environment
	Troubleshooting your terminal environment


	Chapter 2: Customizing Aloha Kitchen
	About this chapter
	Understanding Kitchen settings
	Configuring item timing
	Activating delay routing
	Adding cook times for items
	Adjusting an item cook time based on a modifier
	Overriding an item cook time using an item/modifier pairing
	Overriding item cook times
	Determining the method to use for items with zero cook time
	Configuring delay routing
	Configuring item routing method for items

	Configuring item routing
	Configuring metrics
	Configuring item activation
	Configuring full coursing
	Configuring a course
	Configuring categories for coursing
	Overriding a course by order mode
	Overriding a course by modifier
	Limiting courses by a kitchen station
	Suspending a course automatically by table

	Automating Aloha Kitchen
	Configuring zoning
	Configuring bins
	Configuring a simple bin
	Configuring a production bin
	Configuring a forecast bin

	Configuring specific kitchen environments
	Configuring staff levels to change item routing
	Configuring quote times for adjustments in Aloha Takeout
	Configuring the rounding and override requirements for employees
	Using Aloha Kitchen to adjust quote times

	Configuring other languages
	Making a language available in Aloha Kitchen
	Creating your base translation file
	Creating a translation override file
	Translating POS and other Aloha Kitchen text
	Assigning a language in Kitchen Settings
	Providing the ability to change to a language on kitchen screens

	Configuring task information for an item
	Providing the ability to view task information for an item
	Viewing task information for an item

	Customizing the print layout for production chits
	Customizing your kitchen screens
	Defining kitchen screen types
	Enabling fixed cell orientation
	Enabling split screen orientation
	Creating a customer order display

	Customizing your kitchen skins
	Customizing the display of your order and item cCells
	Configure the display for order cells
	Configuring the display for item cells
	Configuring a custom header or footer layout for cells

	Configuring load balancing
	Load balancing by order
	Load balancing by item
	Adding load balancing to routing rules
	Activating load balancing


	Index



